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1 Check Configuration and Wiring 

To use NcStudio V10 glass cutting CNC system, checking configuration and wiring is 
required. 

1.1 Prerequisites 

In bus type configuration mode, please check the hardware configuration as 
following list: 

• Lambda 5M controller 

• Servo drives 

• Servo motors 

• PM95A control card 

• Host computer (with PCIE slot) 

• EX31A terminal board 

• Optional: handwheel 

In non-bus type configuration mode, please check the hardware configuration as 
following list: 

• Lambda 3S/3L/4S/5S/5E controller 

• Servo drives 

• Servo motors 

• PM95A control card 

• Host computer (with PCIE slot) 

• EX27A/EX31A terminal board (For Lambda 3L controller, a terminal board is 
not required.) 

• Optional: handwheel 

Lambda 3S/4S controller matches EX27A terminal board, and Lambda 5S/5E 
controller matches EX31A terminal board. 
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1.2 Steps 

To check configuration and wiring, do the following: 

1. Confirm space for installation 

2. Install control card 

3. Hardware wiring 

4. Wiring of I/O port 

1.2.1 Confirm Space for Installation 

To install the hardware device, please check the specification of the product and 
ensure that there is sufficient space for installation. 

Please refer to Related Dimensional Drawing for details. 

1.2.2 Install Control Card 

To install control card, do the following: 

1. Turn off the power supply of host computer, and open the case. 

2. Insert the motion control card into PCIE slot. 

3. Tighten the mounting screw, and close the case. 

4. Restart the computer. 
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1.2.3 Hardware Wiring 

This part introduces hardware wiring in bus type and non-bus type configurations. 

Taking PM95A control card as an example, connect as follows: 

In bus type configuration: 
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In non-bus type configuration: 
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1.2.4 Wiring of I/O Port 

This part introduces wiring of I/O port in bus type and non-bus type configurations. 

Connect the product as follows: 

In bus type configuration: 

• Wiring diagram of I/O port of Lambda 5M controller is as follows: 
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• Wiring diagram of I/O port of EX31A terminal board is as follows: 
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In non-bus type configuration: 

• Wiring diagram of I/O port of Lambda 4S controller is as follows: 
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• Wiring diagram of I/O port of EX27A terminal board is as follows: 
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• Wiring diagram of I/O port of Lambda 3L controller is as follows: 
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2 Install Software 

To use NcStudio V10 glass cutting CNC system, installing NcStudio software is 
required. 

2.1 Prerequisites 

Before installing NcStudio, please confirm the configuration of the computer meets 
the requirements in the table below: 

Name Requirement 

CPU Main frequency 1G or above 

Memory 512M or above 
Hard disk 20G or above 
Graphic card 1024*768 at least 
Display VGA 14" or above 
CD-ROM 4X or higher (optional) 
Mainboard expansion slot More than 1 PCIE slot (with PM95A control card) 

2.2 Steps 

To install NcStudio, do the following: 

1. Double click .  

2. Select the display language. 

3. Click OK to save parameters in the following dialog box: 
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– If it is your first time to install NcStudio, a dialog box will pop up to prompt 
that installation completes. 

– If it is not your first time to install NcStudio, a dialog box will pop up: 

   

  Select whether to save the configuration parameters according to actual 
situation. 

  Installation completes. 
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3 Interface Overview 

NcStudio V10 glass cutting software includes the following: 

• NcStudio 

• NcEditor 

After the system is started, two software interfaces pop up: 

• NcStudio interface: Used to control machining process, like starting the system, 
stopping the system, loading file, etc. 

• NcEditor interface: Used to edit tool path and post-process CAM. 

3.1 NcStudio Interface 

The interface of NcStudio is as follows: 
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1. Menu bar 

2. Tool bar 

3. CNC info bar 

It includes three kinds of CNC information: 

– Operation mode 

– Status 

– Status info 

4. Window switch buttons 

It is used to switch among Track window, Wizard window and Test window. 

5. Function window 

It includes three kinds of function windows: 

– Track 

– Wizard 

– Test 

6. Machine control area 

It shows the information of the machine, including coordinate, parameters, auto 
mode, manual mode, port, etc. 

7. Buttons for common operations 

It includes buttons for eleven common operations: 

–  Return to machine origin 

–  Set directly 

–  XY clear 

–  Homing 

–  Analog 

–  Optimize 
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–  Convey 

–  Start 

–  Pause 

–  Stop 

–  Reset 

3.2 NcEditor Interface 

The interface of NcEditor is as follows: 

 

  



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 15 / 80 

1. Menu bar 

2. Tool bar 

3. Drawing toolbar 

The tools in drawing toolbar correspond to instructions in the pull-down list 
below Draw in menu bar. 

4. Object list area 

It shows the objects that are displayed in edit window. 

5. Object attribute area 

It is used to set attribute of current selected object. 

6. Edit window 

It shows target object. 

7. Parameter attribute area 

It includes two parts: 

– Color area 

There are 16 colors with different numbers. Each color corresponds to one 
parameter. 
The objects with the same color shares the same parameters. 

– Parameter attribute area 

After selecting a color, the attribute of the parameter that corresponds to the 
color will be shown in parameter attribute area. 

  



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 16 / 80 

4 Quick Start 

This part introduces NcStudio V10 glass cutting system machining process. 

The machining process includes the following: 

1. Commission before returning to origin. 

2. Return to machine origin. 

3. Detect I/O port. 

4. Set speed and eccentricity. 

5. Import machining file. 

6. Set workpiece origin. 

7. Execute simulation and analog. 

8. Execute auto machining. 

4.1 Commission Before Returning to Origin 

To commission before returning to origin, do the following: 

1. Adjust pulse equivalent. 

2. Check axis direction of machine. 

3. Set workbench stroke. 

4.1.1 Adjust Pulse Equivalent 

The smaller pulse equivalent is, the higher the machining accuracy and surface 
quality will be. While the larger, the faster feedrate will be. 

Therefore, lower pulse equivalent should be set under the condition of meeting the 
demand of feedrate. 

To adjust pulse equivalent, do the following: 

1. Click Parameter. A dialog box named Parameter pops up. 

2. On Machine interface, click Manufacturer. Double click parameters 
N10010~10013 Axis Pulse Factor. An input box pops up. 

3. Enter the value of each parameter in the input box. 

4. Click F1 OK. 

The adjustment takes effect after the system is restarted. 
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4.1.2 Check Axis Direction of Machine 

Checking axis direction of machine is required before homing. 

Before checking axis direction of machine, set Pulse equivalent parameter to 
confirm that the direction of the axis is the same as actual situation. 

To check axis direction of machine, do the following: 

1. Click Parameter. A dialog box named Parameter pops up. 

2. On Machine interface, click Manufacturer. View the values of parameters 
N10000~10003 Axis Direction. 

3. In machine control area, click  to switch to Manual mode. 

 

4. To control the machine moves in the direction of the selected axis, do one of the 
following: 

– Select Jog mode: 

Select the axis direction in machine control area or on the keypad. 

If you press the direction button, the machine will move in the direction 
at jog feedrate until you release the button. 

If you click the direction key / / /  and  at the same 
time, the machine will move at rapid jog feedrate. 

– Select Handwheel mode: 

Decide axis direction and override on the handwheel, and rotate it. The 
machine will move in the direction. 
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– Select step length 0.01 mode or custom step length mode: 

Click the direction key. The machine will move the step length in the 
direction. 

5. Check if the actual direction of axis is the same as the set direction of 
parameters N10000~10003 Axis direction parameter: 

– Same: The axis direction is correct. 

– Opposite: Set the value of parameter N10000~10003 Axis direction to 
the opposite value. 

4.1.3 Set Workbench Stroke 

To use soft limit function in NcStudio V10, please set workbench stroke according to 
actual size of the machine. 

To set workbench stroke, do the following: 

1. Click Parameter. A dialog box named Parameter pops up. 

2. On Machine interface, click Manufacturer. 

3. Double click parameters N10020~10023 Workbench Lower Limit and 
N10030~10033 Workbench Upper Limit. 

4. Enter the value of each parameter according to actual size of the machine. 

5. Click F1 OK. 

The setting takes effect after the system is restarted. 

Note: If it is your first time to set the upper and lower limits of the workbench stroke, confirm the 
effective machining range of the machine. 
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4.2 Return to Machine Origin 

To confirm the machining position is correct, please execute returning to machine 
origin. 

The following functions can be used after executing returning to machine origin: 

• Enable soft limit 

• Set fixed point 

• Tool change 

To execute returning to machine origin, do the following: 

1. Click , a dialog box named BKRef pops up. 

2. In the dialog box, do one of the following according to actual situation: 

– Click All Axis. 

If it is X1X2 or Y1Y2 configuration, click Detect Y. REF before clicking 
All Axis. 

– Click Set Directly. 

Set current position as machine origin. 

– Click X-axis/Y-axis/A-axis. 

After returning to machine origin,  appears on operation panel. 
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4.3 Detect I/O Port 

Polarity of I/O port is determined by the type of the switch. For a normally closed 
switch, the polarity is N (Normally closed) by default; for a normally open switch, 
the polarity is P (Normally open) by default. 

To detect I/O port, do the following: 

1. Click Port. A dialog box named Diagnosis pops up: 

 

Current status of each I/O port displays in the dialog box. It is helpful for 
monitoring and troubleshooting. 

2. Select the target port, and click Alter Polar. A dialog box named NcStudio pops 
up. 

3. Click OK to restart the software. Modification takes effect. 

4. Select the target Input port, and click Port Attribute. A dialog box named Port 
Attributes pops up. 

5. Set Sampling Interval, check Filter and Port Enable and modify Port Name 
and Port Desc in the dialog box. 

6. Click OK. 

Note: If the port polarity is wrong, modify it; otherwise, alarm prompt or other failure will occur. 
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4.4 Set Speed and Eccentricity 

Setting speed parameters and eccentricity parameters are required before 
machining. 

4.4.1 Set Speed Parameters 

During auto machining, adjust current feed override to control feed speed. 

Calculation formula: 

Actual value of feed speed = Current feed override * Set value of feed speed 

To set speed parameters, do one of the following: 

• Click Setting. A dialog box name Common Setting pops up: 

 

Select Speed according to actual situation. 

• Click Parameter. A dialog box named Parameter pops up. 

Under Machine interface, click Manufacturer. Double click parameter N72001 
SPEED ASSIGN TYPE. Enter the value in the input box. Click F1 OK. 

Please refer to Set Parameters for details. 
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4.4.2 Set Eccentricity Parameters 

There exists relative offset distance between cutting tool (work point) and control 
point. To solve this problem, the distance is shown as fore-and-aft eccentricity 
parameter, and the system compensates toolpath automatically via eccentricity 
value. 

Side eccentricity refers to X-axis offset of the tool. Fore-and-aft eccentricity refers to 
Y-axis offset of the tool. 

Before setting eccentricity parameters, measurement is required. See following 
figures for eight kinds of eccentricities: 

No fore-and-
aft 
eccentricity 

Fig. (1)

As shown in Fig. (1), the side offset 

exists and its value is negative, 

while the  fore-and-aft eccentricity 

does not exist.

A

As shown in Fig. (2), the side offset exists. 

Its value is positive and equals ½  the 

length of line segment A. The  fore-and-aft 

eccentricity does not exist.

Fig. (2)

 

No side 
eccentricity 

Fig. (1)

As shown in Fig. (1), the side offset 

exists and i ts va lue is negative , 

while the  fore-and-aft eccentricity 

does not exist.

A

As shown in Fig. (2), the side offset exists. 

It s value is posit ive and equals ½  the 

length of line segment A. The  fore-and-aft 

eccentricity does not exist.

Fig. (2)
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Both fore-
and-aft 
eccentricity 
and side 
eccentricity 
exist 

Fig. (5) Fig. (6)

As shown in Fig. (5), both the side offset and fore-

and-aft eccentricity exist, and their values are both 

nega t i ve .  The  va lue  o f  fore-and-aft eccentricity 

equals the length of line segment A. The value of the 

side offset equals the length of line segment B minus 

the length of line segment A.

As shown in Fig. (6), both the side offset 

and fore-and-aft eccentricity exist. The 

value of side offset is positive and the 

value of  fore-and-al t  eccentr ic i ty  is 

negative. 

A

B

 

Fig. (7) Fig. (8)

As shown in Fig. (7),  both the side offset and fore-

and-aft eccentricity exist. The value of side offset is 

negative while the value of fore-and-aft eccentricity is 

positive. The value of fore-and-aft eccentricity equals 

½ the length of line segment A. The value of the side 

offset equals the length of line segment B minus the 

length of line A.

As shown in Fig. (8), both the side 

offset and fore-and-aft eccentricity 

exist, and their values are both 

positive.

B

A
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To set eccentricity parameters, do the following: 

1. Click Window → NcEditor to switch to NcEditor. Draw the following graphic: 

 

2. Click File → Save to save the graphic. 

3. In NcStudio, click . 

The graphic and the machining track will be displayed in Track window. 

4. Drag the ruler on the left and above sides of Track window. Decide eccentricity 
according to the ruler. 

5. Click Setting. A dialog box named Common Setting pops up. 

6. Enter eccentricity values in the dialog box. 

7. Click OK. 
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4.5 Import Machining File 

To import machining file, do one of the following: 

• Load machining file in NcStudio. 

• Import machining file in NcEditor. 

• Draw machining object in NcEditor. 

4.5.1 Load Machining File in NcStudio 

To load a machining file in NcStudio, do the following: 

1. To find the machining file, do one of the following: 

– Click File → Open and Load in menu bar. 

– Click Load in the toolbar. 

2. Select and Open the target file. 

Optional: Convert the file into a NCE file by setting parameter N65000. 

4.5.2 Import Machining File in NcEditor 

To import a machining file in NcEditor, do the following: 

1. Click File → Import G Code File. 

2. Select and Open the target file. 

Optional: The importing file will cover the original one. To save the original one, 
click Edit → Insert G Code File. 

4.5.3 Draw Machining Object in NcEditor 

To draw a machining object in NcEditor, do the following: 

1. To select drawing tools, do one of the following: 

– In menu bar, click Draw. Select drawing tools in the pull-down list. 

– In drawing toolbar, click drawing tools. 

2. Draw the machining object. 

3. Click File → Save to save the graphic. 

The file is saved as a NCE file which will be loaded in NcStudio automatically. 
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4.6 Set Workpiece Origin 

Setting workpiece origin is required before machining. 

To set workpiece origin, do one of the following: 

• Set in NcStudio. 

• Set in NcEditor. 

4.6.1 Set Workpiece Origin in NcStudio 

To set workpiece origin in NcStudio, do the following: 

1. Move each axis of the machine to the target position. 

2. Click  to reset the coordinate of current position. 

The current position will be the workpiece origin during machining. 

4.6.2 Set Workpiece Origin in NcEditor 

To set workpiece origin in NcEditor, do the following: 

1. To open Set Origin dialog box, do one of the following: 

– In menu bar, click Draw → Set Origin. 

– In toolbar, click . 

A dialog box named Set Origin pops up: 
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2. Set in the dialog box as actual situation. 

3. Click OK. 

4.7 Execute Simulation and Analog 

After setting workpiece origin, to learn the motion forms of machine in advance to 
prevent the damage of machine caused by programming errors, execute simulation 
or analog. 

4.7.1 Execute Simulation 

In simulation process, the system only shows the machining path of tools in Track 
window and does not drive the machine to take any machining actions. 

To execute simulation, do the following: 

1. Click Operate → Simulation Mode in the menu bar. 

2. Click . Simulation starts automatically. 

3. Click Operate → Stop Simulation and withdraw the simulation Mode to 
stop simulation. 

4.7.2 Execute Analog 

In analog process, the system will drive the tool to simulate toolpath on the XY two-
dimensional surface in a safe height without opening the air cylinder and driving Z-
axis. 

To execute analog, do the following: 

1. Click  to switch to Auto mode. 

2. Click . 

3. Click . 

In analog process, the air cylinder does not descend, so the glass will not be cut. 
There are also no port outputs. The machining time in analog is the same as that in 
normal machining.  
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4.8 Execute Auto Machining 

Auto machining process including four parts: 

• Start 

• Pause 

• Stop 

• Breakpoint resume 

4.8.1 Start Auto Machining 

To start auto machining, do one of the following: 

• Click F9 on the keyboard. 

• Click . 

• Click Operate → Start in menu bar. 

4.8.2 Pause Auto Machining 

To pause auto machining, do one of the following: 

• Click F10 on the keyboard. 

• Click . 

• Click Operate → Pause in menu bar. 

4.8.3 Stop Auto Machining 

To stop auto machining, do one of the following: 

• Click F11 on the keyboard. 

• Click . 

• Click Operate → Stop in menu bar. 

4.8.4 Use Breakpoint Resume 

Prerequisites: 

• In emergency situation, like power interruption, E-stop, etc. 

• The workpiece coordinate is correct. 

Step: 

• Click Shift+F9 on the keyboard. 

• Click Operate → Breakpoint Resume in menu bar. 
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5 Common Operations 

This chapter mainly introduces the following common operations of NcStudio V10: 

• Set parameters 

• Latch 

• Edge finding 

• Scan edge 

• Wizard 

• Label 

• Continuous machining 

• Set absolute value 

5.1 Set Parameters 

Parameters are divided into three kinds: 

• Operator parameters: to view operator parameters, click Operator. 

• Manufacturer parameters: to view manufacturer parameters, enter password. 

• Developer parameters: only WEIHONG personnel have permission to adjust 
and modify developer parameters. 

To set parameters, do the following: 

1. Click Parameter in tool bar. A dialog box named Parameter pops up: 
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2. Click Operator/Manufacturer/Developer to switch to corresponding page. 

3. Double click target parameter. 

4. Enter the value. Click OK. 

Pay attention to Effective time: 

• If it is Immediately, setting above takes effect immediately. 

• If it is After restarting, setting above takes effect after the software is restarted. 

• If it is After reloading, setting above takes effect after the program is reloaded. 

5.2 Commission Encoder Latch 

Encoder latch is used to adjust functions of returning to machine origin, edge finding 
and scan edge. It supports servo drives of both bus-type and pulse-type. 

Before commissioning, do the following: 

• Confirm that the drive is servo drive. 

• To adjust returning to machine origin function, confirm that the encoder is 
incremental encoder. 

• Before executing edge finding and scan edge, confirm that each axis has 
returned to machine origin and been set datum. 

5.2.1 Commission Encoder Latch of Bus Type Servo Drive 

To commission, do the following: 

1. Establish communication among axes. Set station address and drive type. 

Please refer to Set Bus Function for details. 

2. Set the following parameters according to actual situation: 

– N10000~10003 Axis direction 

– N11160~11163 Screw pitch 

– N11200~11203 Numerator of mechanical reducer ratio 

– N11200~11213 Denominator of mechanical reducer ratio 

– N16020~16023 Encoder digit 

– N16030~16033 Numerator of electronic gear ratio 

– N16040~16043 Denominator of electronic gear ratio 

– N11001 Encoder type 

3. Modify the value of parameter N11020 Enable encoder locker to Yes. 

4. Restart NcStudio software and drive. 
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After commissioning, returning to machine origin and edge finding will be executed 
by latch. 

5.2.2 Commission Encoder Latch of Non-Bus Type Servo Drive 

To commission, do the following: 

1. Set drive parameters according to actual situation. 

Taking YASKAWA drive as an example, set parameters in the table below: 

Drive 
parameter 

Set value Software 
parameter 

Rule 

PN000 0010(CCW) 
0011(CW) 

Encoder type Modify according to 
set value of drive 
parameter. 

PN002 0100(incremental 
type) 

Axis direction Modify according to 
right-handed 
coordinate rule. 

PN200 0005(Pulse equivalent, 
Pulse direction, 
Negative logic) 

Axis encoder 
direction 

Opposite to axis 
direction. 

PN20E 16777216(Numerator 
of electronic gear 
ratio) 

Screw pitch Modify according to 
the data of axis that 
corresponds to the 
machine. 

PN210 Pitch/(Pulse 
equivalent*Mechanical 
reducer ratio) 

Mechanical reducer 
ratio 

Modify according to 
the data of axis that 
corresponds to the 
machine. 

PN212 2500 PG frequency 
dividing ratio 

10000; four times 
PN212 of the drive 

PN50A 8100 Motor rotational 
mode(CCW, CW) 

Modify according to 
the value of PN000 
of the drive. 

PN50B 6548 Whether the 
rotational directions 
of Y1-axis and Y2-
axis motors are the 
same 

Modify according to 
machine structure. 

2. Execute returning to machine origin for all axes. 

Please refer to Return to machine origin for details. 
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3. Click Machine Tool → Set Datum. A dialog box named Set Datum pops up: 

 

4. Enable latch for target axis. 

5. Move the axis manually, and check whether machine coordinate and Feedback 
coordinate of the axis are the same. 

– Same: Feedback coordinate is correct. 

– Different: Feedback coordinate is incorrect. Check whether the 
parameters are set according to the rule. 

6. Set the value of parameter N11020 Enable encoder locker as Yes. 

After commissioning, returning to machine origin, edge finding and scan edge will 
be executed by latch. 
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5.3 Execute Edge Finding 

Edge finding function can be used in two situations: 

• To adjust the coordinate of target graphic when the material is deflected. 

• To confirm the position on workbench. 

To execute edge finding function, do the following: 

1. Click EdgeFinder in tool bar. A dialog box named EdgeFinder pops up: 

 

For successful edge finding, confirm the following: 

– The rotation angle between the new workpiece coordinate system and 
the original one cannot exceed 15°. 

– The new origin cannot be between point A and point B. 

2. Enter the value in the dialog box. Click OK. 

3. Click Load in tool bar, and select the toolpath file. 

4. Click . Edge finding starts. 
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5.4 Execute Scan Edge 

Scan edge is used to scan glass contour with laser head, and generate a DXF toolpath 
file which will be edited in CAD. 
This function is beneficial to improve efficiency and save cost. 

There are two kinds of scan edge function: 

• Common function 

• Advanced function 

To execute scan edge function, do the following: 

1. Place the workpiece on the machine. 

2. Click Scan in tool bar. A dialog box named Irregular Shape Scanning pops up: 

 

3. Optional: Click Advanced. Related parameters display in the dialog box. 

4. Set Scan Speed and Scan Inc according to the size of the workpiece. 

To avoid triggering limit during scanning, confirm sufficient space for 
workpiece. 
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5. Click To Center Pos to check whether current midpoint is proper. 

– Proper: Click Set Center Pos. 

– Improper: Move the spindle of the machine to make the laser head shine 
in the middle of the workpiece. Click Set Center Pos. 

6. Click To Start Pos to check whether current start point is proper. 

– Proper: Click Set Start Pos. 

– Improper: Move the spindle of the machine to make the laser head shine 
on the edge of the workpiece. Click Set Start Pos. 

7. Click Start Scan. Scanning starts. 

8. Export scanning result in one of the following ways: 

– Export: Output a DXF file in which all points are connected with lines. 

– Raw Data: Output a DXF file in which points are fitted to lines and arcs. 
Adjust by modifying Cor Index in Advance parameter. 

– Fitted Data: Output a DXF file in which all points are in it. 

5.5 Use Wizard 

There are three functions of wizard: 

• Generating three kinds of toolpath files: 

– Line cutting 

– Circle cutting 

– Region cutting 

• Using Command cutting 

• Selecting graphics from Gallery 

To use wizard function, do the following: 

1. Click Wizard in function window to switch to wizard interface. 

2. Select one of the following cut modes: 

– Line 

– Circle 

– Region 

– Command 

– Gallery 

3. Set parameters in Parameter Setting area. 

4. Click Load in tool bar. 
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5.5.1 Use Line Cut Mode 

Line cut mode supports loading file to machine after editing line cutting toolpath. 

The following figure is line cut mode wizard interface: 

 

Parameter Description 

X/Y Length Length of material in X-axis/Y-axis direction. 

X/Y Cut Length Per unit length of material in X-axis/Y-axis direction. 

X/Y Margin Distance between the first edge and workpiece. 

Overcut Cut allowance that exceeds effective distance. Used to decide the 
end point for tool and avoid damaging glass within effective 
distance. 

Retract Cut allowance ahead effective distance. Used to decide the start 
point for tool and avoid damaging glass within effective 
distance. 
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5.5.2 Use Circle Cut Mode 

Circle cut mode supports loading file to machine after editing circle cutting toolpath. 

The following figure is circle cut mode wizard interface: 

 

Parameter Description 

Circle Diameter The diameter of circle that has been cut out from material. 

X/Y Margin Distance between the first edge and workpiece. 

ColSpace Distance between circles in X-axis direction. 

RowSpace Distance between circles in Y-axis direction. 

Margin 
Tolerance 

Cut allowance of material in Y-axis direction. X-axis single 
cutting line will be generated only when the distance between 
the edge of the last line of circles and workpiece origin. 

Initial Angle Angle offset of plunge position. 
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5.5.3 Use Region Cut Mode 

Region cut mode supports editing different objects in different areas on material 
and loading to machine it. 

The following figure is circle cut mode wizard interface: 

 

Parameter Description 

Start Point X/Y Start point of tool cutting. 

Rows Set cutting row number. 

Columns Set cutting column number. 

X/Y Cut Length Cut length in X-axis/Y-axis direction. 

Over-cut Dist Cut allowance that exceeds effective distance. Used to decide the 
end point for tool and avoid damaging glass within effective 
distance. 

Retract Dist Cut allowance ahead effective distance. Used to decide the start 
point for tool and avoid damaging glass within effective 
distance. 
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5.5.4 Use Command Cut Mode 

Command cut mode assists users to generate machining toolpath. 

Following commands are supported by NcStudio V10 software: 

• Line cut command X, Y, Z, W, Q and R 

• Multiplier command M 

• Diagonal cutting command A, B, C, D 

The following figure is circle cut mode wizard interface: 

 

Parameter Description 

X/Y Length Length of material in X-axis/Y-axis direction. 

Edge Left Reserved scrap area in the left of material. 

Edge Down Reserved scrap area at the bottom of material. 

Safe Distance Vertical distance between tool head and glass. Used to protect 
tool from plunging and collision during cutting. 
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Description of commands: 

• X cut command: cut from the bottom edge of the material to the top edge 
vertically. Measure from the origin edge or last X cut line. 

 

• Y cut command: cut lengthways. Measure from the origin edge and the first X 
cut line, or between two X cut lines. 
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• Z cut command: cut vertically. Measure from the bottom edge and the first tool 
Y cut line of second material, or between two Y cut lines. 

 

• W command: cut lengthways. Measure from the origin edge and the first tool W 
line cut, or between two W cut lines. 
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• Q command: cut vertically. Measure from the origin edge and the first tool W 
line cut, or between two W cut lines. 

 

• R command: cut horizontally. Measure from the origin edge and first tool Q cut 
line, or between two Q cut lines. 
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• Multiplier command M: if you use multiplier before command X, Y, Z, W, Q, R, 
the other cut commands will be executed repeatedly. 

 

• Diagonal cutting command: diagonal cutting command A, B, C, D should be used 
in pair. Each command corresponds to an edge of fragment area. To diagonal 
cutting command A and D, the start point is on the left. While to diagonal 
cutting command B and C, the start point is at the bottom. 
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5.5.5 Use Gallery 

Gallery function supports setting parameters for graphics, generating machining 
toolpath file and loading to machine it. 

The following figure is circle cut mode wizard interface: 

 

To know more about X/Y Length, Margin Tolerance, X/Y Margin, ColSpace and 
Row Space, please refer to Use Line Cut Mode or Use Circle Cut Mode. 

Parameter Description 

X/Y No Separate No split line between each two lines in X/Y direction. 

X/Y Sep By One One split line between each two lines in X/Y direction. 

X/Y Sep By Two One split line every two lines in X/Y direction. 
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5.6 Use Label 

Label function supports labeling on each piece of glass. 

Before labeling, check whether the printer has been installed and commissioned: 

• If the printer has been installed, confirm the following: 

– The machine has been connected with printer (with ethernet port). 

– The printer works well. 

– The printer can be controlled through third party BarTender.exe and 
PrintLabel.exe. 

• If the printer has not been installed, please refer to Commissioning of NcStudio 
V10 Glass Cutting Label. 

To use label function, do the following: 

1. Click Parameter. Parameter dialog box pops up. 

2. In the dialog box, click Technics to switch to Technics interface. 

3. Click Manufacturer in the dialog box. 

4. Set the following parameters according to actual situation: 

– N84061 Printer Position 

– N84062~N84063 Labels Placement Position 

– N84072~N84073 Labeler-Cutter-Head Offset 

– N84083 Labeling Position 

5. Set the value of N84060 Enable Labeling as Yes. 
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6. Optional: Set other parameters according to actual situation. 

The following figure shows label parameters: 

 

7. Click Load to load a file with label information. 

8. Click . Labeling starts. 
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5.7 Continuously Machine 

For batch operation, continuous machining is a good choice. 

To machine continuously, do the following: 

1. Click Continuous in tool bar. A dialog box named Continuous Processing pops 
up: 

 

2. Select Naming rule in the dialog box. 

The system provides four naming rules. 

– If the file name is one of them, the system records and displays its 
related information. 

– If the file name is not one of them, click Edit to set its machining 
parameters information. 

3. Click Add. Select the file. 

4. Double click Process Times value. A dialog box pops up. Fill in the information 
according to actual situation. 

5. Click Load. 

6. Select Streamline/EdgeFindOnly/DirectCut. 
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7. Click Parameter. A dialog box pops up. 

8. Click Overview and Manufacturer. Set the following parameters: 

– EdgeFindOnly/DirectCut: 

• N84012 Edge Finder Position Box Delay 

• N84045 Enable Position Box 

– Streamline: 

• N84000 Up Cylinder Delay 

• N84012 Edge Finder Position Box Delay 

• N84045 Enable Position Box 

• N84050 X 

• N84051 Y 

9. Click  to start machining. 

10. Click input port Ejection. 

In online status, the system will transfer and load the glass that has been cut, 
and automatically machine the next toolpath.  
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5.8 Set Absolute Value 

The servo system of absolute encoder supports recording machine origin position. 
Through this function, set machine origin once during commissioning. When it is 
used in practice, returning to machine origin is not required. 

To use absolute function, a servo motor with absolute encoder is required. 

To set absolute value, do the following: 

1. Click Machine Tool. A dialog box pops up. 

2. Set datum. 

– If the datum has been set before, do the following: 

1. Click OneCorrect. 

2. Click DoubleJIGGLE. A dialog box named DoubleJIGGLE pops up. 

3. Click Y BK.REF.PT. 

– If the datum has not been set before, do the following: 

1. Click OneCorrect. 

2. Click DoubleJIGGLE. A dialog box named DoubleJIGGLE pops up. 

3. Adjust axis according to actual position of Y1Y2 axes. 

4. Click OK. 

Compare the verticality between X-axis and Y-axis and the 
parallelism between Y1-axis and Y2-axis. If it does not meet the 
requirement, set datum again. 

3. Move the target axis to machine origin. 

4. Click RefSet. 
Password is required. 

5. Click the datum button that corresponds to the axis. 

6. Click OneCorrect. 

7. Close the dialog box. Restart the software. 

After the software is updated, the datum information will be lost. Restore the 
software via Import Datum and Export Datum. 
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6 Miscellaneous Operations 

This chapter mainly introduces the following miscellaneous operations of NcStudio 
V10: 

• Diagnosis 

• Screw error compensation 

• Register 

• NcCloud 

6.1 View Diagnosis 

Diagnosis information includes the following: 

• Log 

• Port 

• PLC 

6.1.1 View Log 

Log information includes operating information, workpiece coordinate information, 
alarm information, etc. 

To view log information, do the following: 

1. Click Machine Tool → Log. A dialog box named Diagnosis pops up: 
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2. Click the button at the bottom of the dialog box to view corresponding 
information. 

Please clean system log regularly. Excessive logs slow down the performance and 
responsiveness of the system. 

6.1.2 View Port 

Please refer to Detect I/O Port for details. 

6.1.3 View PLC 

With built-in PLC module of NcStudio software, output port can be controlled by 
PLC. 

PLC information is used in PLC commissioning. Generally, this function is used by 
debugging personnel. For details, please refer to NcStudio Programming Manual. 

To view PLC information, do the following: 

1. Click Machine Tool → Log. A dialog box named Diagnosis pops up. 

2. Click PLC to switch to PLC interface: 

 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 52 / 80 

3. Double click the buttons at the bottom of the dialog box, and enter Channel, 
Timer and Counter. 

4. Click OK. 

6.2 Compensate Screw Error 

Screw error compensation includes pitch error compensation and backlash 
compensation. 

6.2.1 Compensate Backlash 

The spindle is fixed on the screw. There exists difference between screw external 
thread and internal thread. When spindle moves in one direction, it must go through 
the error between threads. Such error compensation is called backlash 
compensation. 

To compensate backlash, do the following: 

1. Measure screw error with dedicated gauge. 

2. Fix the gauge on spindle. And rotate the meter pointer to origin. 

3. Manually move the meter pointer by a millimeters, and move the pointer in the 
reverse direction by a millimeters. If the meter pointer moves by b millimeters 
actually, then the backlash is (a-b) millimeters. 

4. Click Parameter. A dialog box pops up. 

5. Click Manufacturer. Set value of parameter N12010~12013 Backlash that 
corresponds to the axis to (a-b). 

6. Restart the software. 

6.2.2 Compensate Pitch Error 

Calculation formula: 

Error = Actual machine coordinate - Nominal machine coordinate 

To compensate pitch error, do the following: 

1. List the modification value of each point on error curve in a table. And save the 
table in CNC system memory. 

2. Click Parameter. A dialog box pops up. 

3. Click Manufacturer. 
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4. Set the following parameters: 

– Set the value of parameter N12000 Enable Leadscrew CMPN as Yes. 

– Set the value of parameter N12001 Only Backlash CMPN as No. 

5. Restart the software. 

6.3 Register 

Registration function is used to register use time of card and drive. 

6.3.1 Get a Registration Code 

You can get a registration code either in WeChat or via the manufacturer.  

Before getting a registration code, click Help → About NcStudio to get the Device 
No.: 
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To get a registration code, do one of the following 

• Do the following to get a registration code in WeChat: 

1. Enter WEIHONG official account in WeChat. 

2. Click Service → Register → Activate Account to register. 

3. Return to Log In page. Fill in the blanks, and click Log in to jump to 
Time page. 

4. On Time page, enter related information. 

5. Click Generate. 

• Do the following to get a registration code via manufacturer: 

1. Send device No. to manufacturer. 

2. Ask the manufacturer to use APP “NcStudio Generator” to generate a 
registration code. 

6.3.2 Register in NcStudio 

To register in NcStudio, do the following: 

1. Click Help → About NcStudio → Register. 

A dialog box named REGISTER pops up: 

 

2. Fill in Registration code. 

3. Click OK. 

Registration completes. 

If drive registration enabled, card and drive will be registered at the same time. 
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If exception prompt occurs during registering, please refer to Exception prompt 
occurs during registering. 

6.4 Use NcCloud 

NcCloud, independently developed by WEIHONG, is a system of cloud-based 
monitoring and control. 

To use NcCloud, click Help → NcCloud. NcCloud Assitant pops up. 

Please refer to NcCloud Assistant User Manual for details.  
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7 Auxiliary Drawing Operations in NcEditor 

This chapter mainly focuses on auxiliary drawing operations, including: 

• Setting lead line 

• Catch option 

• Combining objects 

• Group 

• Array 

• Chamfer 

• Setting tool path 

• Expanding bidirectionally 

7.1 Set Lead Line 

If the object is closed, set lead line in workpiece scrap area of toolpath to avoid 
machining error and workpiece damage. 

To set lead line, do the following: 

1. Select the target closed graphic. 

2. Do one of the following to call Set Introduce dialog box: 

– Right click in edit window and select Set Introduce. 

– Click Object → Set Introduce in menu bar. 

Set Introduce dialog box is as follows: 
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3. Select lead line type and enter values of related parameters in the dialog box. 

4. Click OK. 

7.2 Catch Option 

Catch option is used to catch feature points of object in drawing precisely. 

To use catch option function, do the following: 

1. Do one of the following to open Catch Option dialog box: 

– In menu bar, click View → Catch Option. 

– In tool bar, click . 

Catch Option dialog box is as follows: 

 

2. Check the feature points that you need to catch according to the shape of the 
graphic. 

3. Set Sensitivity Hight and Add Angel. 

4. Click OK. 
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7.3 Combine Objects 

This function is used to combine straight line, arc and open polyline mutually, and 
improve machining efficiency. 

To combine objects, do the following: 

1. Click Object → Combine Object Tolerance Setting. A dialog box named 
Combine tolerance setting pops up: 

 

2. Enter Tolerance value according to actual situation. 

3. Click OK. 

4. Select at least two objects whose endpoints are near to each other. 

5. Do one of the following to combine the selected objects: 

– Click Object → Combine Object in menu bar. 

– Right click in edit window and select Combine Object. 
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7.4 Use Group 

Group function includes the following: 

• Group 

• Disbanding group 

7.4.1 Group 

Group function is used to edit objects integrally. 

To use group function, do the following: 

1. Do one of the following to select target objects: 

– Check the objects in object list area. 

– Press Ctrl in keyboard and click the objects at the same time. 

2. Do one of the following to compose the objects: 

– Click Object → Group in menu bar. 

– Right click in edit window and select Group. 

7.4.2 Disband Group 

Disbanding group function is used to edit part of objects. 

To disband group, do the following: 

1. Check the target group in object list area. 

2. Do one of the following to disband the group: 

– Click Object → Break Group in menu bar. 

– Right click in edit window and select Break Group. 

After disbanding, the objects in this group will return to last group. 
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7.5 Use Array 

To improve machining efficiency, use array function to display objects in 
rectangular or circular array during batch machining. 

To use array function, do the following: 

1. Select an object or group in object list area. 

To array multiple objects or groups, group first. 

2. Click Object in menu bar or right click, and select array type: 

– Rect array 

– Circle array 

A dialog box pops up. 

3. Set parameters in the dialog box. 

4. Click OK. 

The selected objects will be displayed in rectangular or circular array. 

7.6 Use Chamfer 

To deburr on parts, use chamfer function to cut the angle of workpiece to slope. 

To use chamfer function, do the following: 

1. To call Chamfer Parameter Setting dialog box, do one of the following: 

– Click Object → Champfer in menu bar. 

– Right click in edit window and select Champfer. 

Chamfer Parameter Setting dialog box is as follows: 
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2. Select chamfer type, mode and size setting mode, and enter size. 

– Select Distance mode: Enter chamfer distance between two edges. 

– Select Angle mode: Enter chamfer length and angle of the first edge. 

3. Click OK. 

4. Click the object. 

7.7 Set Tool Path 

Tool path function is used to set tool compensation by setting tool diameter. 

To set tool path, do the following: 

1. Check the target object to select it in object list area. 

2. To call Tool path, do one of the following: 

– Click Object → Tool Path in menu bar. 

– Right click in edit window and select Tool Path. 

Tool Path dialog box is as follows: 

 

3. Enter the values in the dialog box. 

4. Click OK. 
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7.8 Expand Bidirectionally 

Expanding bidirectionally function is used to set left and right tool compensation at 
the same time. 

To expand bidirectionally, do the following: 

1. Check the target object to select it in object list area. 

2. Do one of the following to open Gap compensation dialog box: 

– Click Object → Expand Bidirectionally in menu bar. 

– Right click in edit window and select Expand Bidirectionally. 

Gap compensation dialog box is as follows: 

 

3. Enter the values in the dialog box. 

4. Click OK. 
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8 Set Bus Function 

This chapter mainly introduces bus function in bus type configuration. 

Setting bus function includes the following: 

• Setting drive axis address 

• Setting control system parameters 

• Setting drive parameters 

Before commissioning, please check the hardware configuration, and make sure all 
have been correctly connected. 

8.1 Set Drive Axis address 

Setting drive axis address is the key to data transmission among control system, 
Lambda controller and the drive. 

8.1.1 Set Axis Address of YASKAWA Drive 

Setting axis address of YASKAWA drive via rotary switch S2 and toggle switch S3. 
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For a YASKAWA drive, to set axis address, do the following: 

1. Set S3: set switch 3 according to actual situation, and the other use the factory 
setting. 

Please refer to the table below for setting: 

Switch No. Function Description Factory 

1 Setting communication 
speed 

OFF: 4Mbps(M1) 

ON: 10Mbps(M2) 

ON 

2 Setting byte number OFF: 17 bytes 

ON: 32 bytes 

ON 

3 Setting station address OFF: Actual 
address=40H+S2 

ON: Actual address=50H+S2 

OFF 

4 System reservation 
(Unchangeable) 

OFF OFF 

2. Set S2: rotate S2 to the target value. 

Please refer to the table below for actual station address: 

No.3 of S3 S2 Station address No.3 of S3 S2 Station address 

OFF 0 Invalid ON 0 50H 

OFF 1 41H ON 1 51H 

OFF 2 42H ON 2 52H 

OFF 3 43H ON 3 53H 

OFF 4 44H ON 4 54H 

OFF 5 45H ON 5 55H 

OFF 6 46H ON 6 56H 

OFF 7 47H ON 7 57H 

OFF 8 48H ON 8 58H 

OFF 9 49H ON 9 59H 

OFF A 4AH ON A 5AH 

OFF B 4BH ON B 5BH 

OFF C 4CH ON C 5CH 

OFF D 4DH ON D 5DH 

OFF E 4EH ON E 5EH 

OFF F 4FH ON F 5FH 

3. Restart the drive. 
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8.1.2 Set Axis Address of WISE Drive 

Setting axis address of WISE drive via the front panel. 

For a WISE drive, to set axis address, do the following: 

1. Set parameter Pr001 Control mode setup as 1 Position control mode as 
following: 
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2. Set axis address No. as following: 

 

3. Restart the drive. 
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8.2 Set Control System Parameters 

To use bus function, setting control system parameters in NcStudio software is 
required. 

To set the following parameters, please refer to Set Parameters: 

N11001 Encoder type 
Choose encoder type according to actual situation. 

0: Normal 

1: Incremental 

2: Absolute 

N15000 Control system type 
Choose control system type. 

0: Non-bus control system 

1: Bus control system 

N16050~16053 Servo type X/Y/A 
Choose servo type. 

0: YASKAWA ∑5 servo drive 

1: YASKAWA ∑7 servo drive 

2: WISE servo drive 

N16000~16003 Driver station address X/Y/A 
It should be the same as rotary switch setting of drive station address. 0 is invalid 
address. 

Setting range: 0~15 

N16010~16013 Driver station address setting switch X/Y/A 
It should be the same as toggle switch S3 setting of drive station address. 

Yes: PN 

No: OFF 

N16020~16023 Encoder digit X/Y/A 
The digit number of encoder of the servo motor. 

Setting range: 10~30 
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N16990 Second axis driver station address 
The drive station address of the second axis. 

Setting range: 0~15 

N16991 Second axis driver station address setting switch 
The drive station address setting switch of the second axis. 

Yes: ON 

No: OFF 

8.3 Set Drive Parameters 

To use bus function, setting drive parameters in NcStudio software is required. 

To set drive parameters, do the following: 

1. Click Machine Tool → Set Servo Param in menu bar. A dialog box named 
Driver Parameter pops up. 

 

For a WISE drive, all parameters will be shown in the dialog box. While for a 
YASKAWA drive, only part of parameters will be shown. If you need to add 
more, click Add. 
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2. Click Select axis to select an axis to be set. 

Different axis has different drive and parameters. 

3. Scroll the mouse or press arrow keys “↑” and “↓” on keyboard to select 
parameter. 

4. Press “Enter” or double click to modify the selected parameter. 

5. Click OK. 

6. Click Machine Tool → Clear Servo Alarm. 
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9 Frequently Asked Questions(FAQ) 

This section contains answers to common questions in NcStudio V10 Glass Cutting 
CNC System. 

9.1 The origin signal cannot be detected during returning to 
machine origin. 

Cause 

Errors may exist in origin switch. 

Troubleshooting 
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9.2 The direction of the machine during returning to machine 
origin is wrong. 

Cause 

1. The polarity of the origin signal is wrong. 

2. Set related parameters incorrectly. 

Troubleshooting 

1. The polarity of the origin signal is N when the origin switch is normally open; 
otherwise, it is P. 

2. Check parameter N74020 Coarse Locating Direction, and change the value of 
the parameter accordingly. 

9.3 Coarse positioning speed is low during returning to 
machine origin. 

Cause 

1. The set value of parameter N74030 Coarse Locating Velocity is too small. 

2. The polarity of the origin signal in the software does not match the type of the 
origin switch. If the origin switch is normally close, and the polarity of the 
origin signal is N, the machine will move away from the origin at fine 
positioning speed. 

Troubleshooting 

1. Modify the value of parameter N74030 Coarse Locating Velocity. 

2. Modify the polarity of the origin signal according to the type of the origin 
switch. 
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9.4 The machine air cylinder does not plunge cut after 

 is clicked in machine control bar on the software 
interface. 

Troubleshooting 

1. In auto mode, check whether  turns green after being clicked. 

2. Click Port. Check the red dot ahead of output port Analog Enable turns green 
and outputs. 

3. Check whether the output port Y02 on the terminal board outputs. 

If the port outputs, then the software is proved connected with the hardware. 

4. Check whether the proportional electro-magnetic valve has been connected 
with the output port Y02 on the terminal board correctly. 

See following figure for wiring: 

 

5. If the problem remains, use the multimeter to detect ends of ports Y02 and 
GND, or the analog voltage between Proportional Valve Signal Line and 
Proportional Valve. 

6. Check whether the wiring between the proportional valve and the terminal 
board loosens. 
If the wiring loosens, reconnect it. 
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9.5 A-axis rotates incorrectly during machining toolpath. 

Troubleshooting 

1. Modify the value of parameter N83013 Angle for Tool Turning. The suggested 
value is 60°. 

2. If the angle of the adjacent two lines is about 60° by visual measurement, and 
A-axis still rotates incorrectly, please modify the value of the parameter to no 
more than 59°. 

The boundary angle value of the adjacent lines is prone to error. For example, 
the actual angle of the adjacent lines is 59.99°, while it is shown as 60° in the 
software. Therefore, it is necessary to continually modify the value until the 
problem is solved. 

9.6 The machine shakes during machining ellipse. 

Cause 

If the value of parameter N64100 Max Linear Machining Acceleration is too great, 
such as 160000mm/min, the machine will shake during machining of ellipse (about 
200*150mm). 

Troubleshooting 

1. Set the value of parameter N64120 Max Control Acceleration as twice to five 
times that of parameter N64100 Max Linear Machining Acceleration. 

2. Increase the value of parameter N64208 Reference Circle Max Velocity to a 
greater value, such as 5000mm/min or 10000mm/min. 

3. Set the value of parameter N64207 Limit Arc Velocity as No. 

9.7 Software expired. 

Cause 

1. Attachment destroyed. 

2. Drive expired. 

Troubleshooting 

1. Change the attachment. 

2. Unlock the drive with iMotion software. 

  



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 74 / 80 

9.8 Exception prompt occurs during registering. 

See the table below for details: 

Prompt Cause Solution 

Registration failure! 
Invalid registration 
code! 

The registration code is 
incorrect. 

Ask the manufacturer to 
provide a correct 
registration code, and 
register again. 

Drive alarms. The 
alarm No. is 513. 

Drive length of time 
registration expired. 

Register length of time 
again.  

Unlock the drive with 
iMotion software. 

Check wiring of drive 
N. 

Set software parameters 
incorrectly.  

Set wiring/version/parameter 
of the drive incorrectly. 

Check parameters. 

Check wiring of the drive. 

Registration failure. 
The N drive fails to 
register. 

Problem of drive wiring. 

Problem of drive. 

Wiring problem: Check 
wiring of the drive.  

Drive problem: Change 
the drive.  

Other problems: Contact 
with WEIHONG. 
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9.9 Alarm Information 

NcStudio system stops when alarm information occurs. After the alarm is removed, 
it continues working. 

Alarm information is in the table below: 

Type Content Cause Solution 

Warning 
message  

Simulation 
results show 
that program 
range exceeds 
the machine 
travel limit.  

Tool path of the 
program file exceeds 
the upper/lower limit 
of workbench travel, 
which are decided by 
settings of parameter 
N10020 and N10030 
separately.  

Check if the WCS zero is 
reasonable.  

Check the tool path 
program file. 

Modify parameter 
settings of N10020 and 
N10030 to enlarge the 
workbench travel limit.  

The system has 
not returned to 
the machine 
origin, failed to 
execute the 
operation!  

The system has not 
returned to machine 
origin. Whether the 
system has to return to 
the machine origin is 
decided by parameter 
N74001.  

Use this function after 
returning to the 
machine origin.  

The system is 
busy. This 
operation can’t 
be executed.  

Some illegal operations 
are performed under 
machining state.  

Stop machining, and 
execute some 
operations under idle 
state.  

Limit 
alarm  

Positive 
(negative) limit 
of X (Y/Z/A) 
axis  

The polarity of X axis 
positive limit port is 
wrong.  

Enter “IO Port” window 
in “DIAG” interface, and 
modify the port 
polarity.  

X axis runs into limit 
switch directly during 
motion.  

Manually move X-axis 
away from limit switch.  

There is an error in 
limit switch itself.  

Check if limit switch 
works normally.  
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Type Content Cause Solution 

Servo 
alarm  

Servo alarm of X 
(Y/Z/A) axis 

The polarity of X-axis 
servo alarm port is 
wrong.  

Enter “IO Port” window 
in “DIAG” interface, and 
modify the port 
polarity.  

There is an error in X-
axis servo drive itself.  

Check if X axis servo 
drive works normally.  

E-stop 
alarm  

E-stop button is 
pressed.  

The polarity of E-stop 
port is wrong.  

Enter “IO Port” window 
in “DIAG” interface, and 
modify the port 
polarity.  

The E-stop button is 
pressed.  

Turn the E-stop button 
clockwise to make it 
bounced.  

Machining 
alarm 

Machining 
executive 
program failure 

Software license 
expired 

Register the software. 

Terminal 
board not 
connected 
error 
alarm  

Terminal board 
not connected.  

Cable has not been 
firmly connected or 
there is error in 
Lambda controller.  

Re-plug the cable and 
restart the software to 
observe the occurrence 
of the error; 

Polarity of port is 
wrong. Invert the port 
polarity and restart the 
software; 

Analyze possible causes 
according to the status 
of indicator “SYSTEM” 
on Lambda controller; 

Change another Lambda 
controller.  
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10 Related Dimensional Drawing 

This chapter introduces product dimension. Before installing, please confirm that 
the space is sufficient. 

Product dimensional drawing are as follows: 

EX27A terminal board dimensional drawing: 

 

EX31A terminal board dimensional drawing: 
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PM95A motion control card dimensional drawing: 

 

Lambda 3S controller dimensional drawing: 
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Lambda 3L controller dimensional drawing: 

 

Lambda 4S controller dimensional drawing: 

 

Lambda 5S controller dimensional drawing: 
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Lambda 5E controller dimensional drawing: 

 

Lambda 5M controller dimensional drawing: 
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