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1 Software Overview 

Through this section, you can quick know the hardware and software of NcStudio V10 
Waterjet Cutting CNC System. 

Hardware 

• Host 

• Lambda terminal board 

• EX series extended terminal board: EX31A 

Software 

NcStudio V10 Waterjet Cutting CNC System includes multiple softwares with different 
axes (General Five-axis AB, General Five-axis AC). This manual takes NcStudio V10 General 
Five-axis AC (Bus) as an example to introduce how to use this system. 

About the software interface of NcStudio V10 Waterjet Cutting CNC System, see Software 
Interface. 

1.1 Host 

You can choose one of the following for host control: 

• NC65C industrial personal computer 

• PM95A control card 
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1.1.1 NC65C Industrial Personal Computer 

NC65C industrial personal computer, also called NC65C Controller (hereinafter referred to 
as NC65C). 

The structure and interface definition of NC65C are as follows: 

 

1. Interface of LNE (live wire, neutral wire and earth wire) 

  It is used to connect to a 220V power supply. 

2. Indicator light 

  It is an indicator light for the power supply. 

3. USB 2.0 interface 

  It is used to transmit data with a USB flash disk. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 3 / 195 

 

4. LAN interface 

  Its transmission rate is 100 Mbps. 

5. VGA interface for a display screen 

  It is used to connect to a display screen. 

6. Interface for a Lambda terminal board 

  It is used to connect to a Lambda terminal board. 

1.1.2 PM95A Control Card 

When PM95A control card is used with NcStudio, you need to insert it into PCI-E slot of 
your computer. 

PM95A is shown as follows: 

 

1.2 Lambda Terminal Boards 

This system supports the following Lambda terminal boards: 

• Lambda 5M 

• Lambda 5E 

• Lambda 21B 
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1.2.1 Lambda 5M 

It is used for the bus control system. 

Its structure and interface definition are as follows: 

 

1. Indicator light 

– Power: An indicator light for the power supply 

– System: An indicator light for the system 

2. 24V power interface 

  It has anti-reverse connection protection. 

3. Interface for switching high-low level 

  It is used to switch between the high level and low one. 

4. General input ports 

  They include X00 ~ X27. 

5. Interface for extended terminal board 

  A high-speed 485 interface. It is used for cascade and adopts serial communication. 
The baud rate is 10Mbps. 
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6. General output ports 

  They include Y00 ~ Y07 and 5 general ports. 

7. Analog output port 

– Analog voltage: 0 ~ 10V 

– Precision: 0.2V 

8. Handwheel interface 

  It is used to connect to a handwheel (supporting the 6-axis handwheel at most). 

9. M-II bus interface 

  It is used to connect to a M-II bus drive. And the interpolation period of pulses is 1ms. 

10. Moving-axis interface 

  It is used to connect to a servo drive. 

11. Host interface 

  It is used to connect to NC65C, NC60A, etc. 
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1.2.2 Lambda 5E 

It is used for the non-bus control system. 

Its structure and interface definition are as follows: 

 

1. Interface for a 24V power supply 

  It has anti-reverse connection protection. 

2. Interface for switching high-low level 

  It is used to switch between the high level and low one. 

3. General input ports 

  They include X00 ~ X27. 

4. Interface for extended terminal board 

  A high-speed 485 interface. It is used for cascade and adopts serial communication. 
The baud rate is 10Mbps. 

5. General Output ports 

  They include Y00 ~ Y07 and 5 general ports. 
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6. Analog output port 

– Analog voltage: 0V ~ 10V 

– Precision: 0.2V 

7. Handwheel interface 

  It is used to connect to a handwheel (supporting the 6-axis handwheel at most). 

8. Moving-axis interface 

  It is used to connect to a servo drive. 

9. Host interface 

  It is used to connect to NC65C, PM95A, the integrated CNC system, etc. 

1.2.3 Lambda 21B 

It is used for the bus control system. 

Its structure and interface definition are as follows: 

 

1. General input ports 

  They include X00 ~ X37. 

2. Extended interface 

  A DB9 interface. And it is called EXT. 
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3. Handwheel interface 

  It is called MPG. 

4. General output ports 

  They include C00 ~ C17 / Y00 ~ Y17. 

5. Output interface for analog voltages 

– AVC: An output interface for analog voltages 

– GND: The ground for analogy voltages 

6. Configurable ports for I/O valid level 

  NPN / PNP is configurable (S -> 24V / S -> com): 

– S1: Configure the valid level of X00 ~ X27. 

– S2: Configure the valid level of X28 ~ X37. 

7. Ground interface 

  It is used to connect to the ground. 

8. Power supply interfaces 

– +24V: Positive input for 24V DC 

– COM: The ground for 24 DC 

9. Mechatrolink-II communication interface 

  A RJ45 interface. And it is called LINK. The axis quantity is at most 16. 

10. Pulse-axis communication interface 

  A DB15 interface. And it is called AXIS. It supports an incremental encoder. 

11. Host communication interface 

  A DB6 interface. And it is called HOST. It follows the Phoenix bus protocol. 
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1.3 EX31A 

EX31A, the extended board of the Lambda terminal board, adopts the mounting structure 
of module rack, for good protection and easy installation. 

Its structure and interface definition are as follows: 

 

1. Power supply input 

  24V / 0.5A input (+24V, COM). 

2. Input ports 

  It supports a 10-path input and NPN / PNP can be configurable (S -> 24V / S -> COM) 

  S ports include the following: 

– S0: X00 ~ X03 

– S1: X04 ~ X07 

– S2: X08 

– S3: X09 

3. Communication interface 

  It is used for the cascade port communication and follows the Phoenix bus protocol. 
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4. Output ports 

  They support the 10-path relay contact output. 

5. Communication interface 

  Uplink port communication. It follows Phoenix bus protocol. 

1.4 Software interface 

NcStudio V10 Waterjet Cutting CNC System has the following interfaces: 

• NcStudio interface for machining 

• NcEditor interface for editing toolpath 

1.4.1 NcStudio Interface 

The main interface of NcStudio is as follows: 

 

1. Title bar 

2. Menu bar 

3. CNC status bar 

4. Machine tool control bar 

5. Operational button bar 

6. Function windows 
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1.4.1.1 Menu Bar 

It includes the following menus: 

• File: It is used to load / unload program files, generate an installation package, restart 
/ shut down the system, etc. 

• Work Mode: It is used to switch among Auto mode and Manual modes (including jog, 
handwheel and step modes). 

• Operate: It is used to execute machining commands, such as executing single block, 
setting the workpiece origin, executing simulation, rotating / mirroring toolpath, etc. 

• Machine Tool: It is used to execute operations related to machine tools, such as 
customizing valve ON / OFF order, checking time statistics for high pressure valve and 
oil pump, managing wearing parts, etc. 

• Window: It is used to switch among track, machining information, position diagnosis, 
hardware port, log and setup interfaces, show or hide NcEditor interface, open PLC or 
Manual Code dialog box, etc. 

• Language: It is used to switch a system language. 

• Help: It is used to check the system information, register the software, set the setup 
interface, open NcGateway interface, use the velocity calculator, etc. 

• Params: It is used to check and set common parameters about waterjet cutting. 

1.4.1.2 CNC Status Bar 

It includes the following: 

• Current operation mode: Auto, manual, etc. 

• Current system status: Running, idle, E-stop, etc. 

• Current running status: Normal running, normal or abnormal stop, etc. 

• Current workpiece coordinate system (WCS): G54 ~ G59 

• Machining time 

• Current system configuration: Bus type, standard A type and double-Y A type. 

• System prompts, alarms, etc. 
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1.4.1.3 Machine Tool Control Bar 

It includes the following: 

• Axis coordinate area: It shows the current machine coordinate and workpiece 
coordinate of each axis: 

   

  After returning to the machine origin, the sign  appears after each axis. 

• Feed speed area: It shows the actual feedrate and set value of linear axes and rotary 
axes. 

• Tool area: It shows the current tool and material thickness. 

• File area: It shows the name of current program file. 

• Operation mode area: The display differs in the operation mode: 

– Auto mode: It is used to adjust feedrate, abrasive valve and G00 rate during 
automatic machining: 
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– Manual mode: 

 

1. Axis direction buttons: It is used to move each axis towards positive / 
negative direction. 

  Note: Please do not click an axis direction button too frequently because the system needs 
a certain time to execute the command. 

2. Mode buttons: It is used to switch among the following modes: 

– Jog: Click Jog and do one of the following: 

• Click an axis direction button. The machine tool keeps 
running until you release the button. 

• Click several axis direction buttons. The clicked axes move 
at the same time at jog speed until you release buttons. 

  This operation is mainly used to move X-axis and Y-axis at 
the same time. 

• Click  and an axis direction button. The machine 
tool moves at rapid jog speed. 

– Handwheel: Click Handwheel, select the axis direction and 
handwheel override and rotate the handwheel for a certain 
degrees. The machine tool is controlled by the handwheel and 
moves towards the selected direction. 
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– Step: Select a step size among 0.01, 0.1, 1,10 or click  to 
customize the step size (default value: 5mm), click an axis 
direction button and then release it. The machine tool moves the 
selected step size. 

  Note: The step size should not be too large, otherwise, the machine tool may be 
damaged due to misoperations. 

• Port control area: It is used to turn on / off the following common ports: 

   

  Note: The rotating workbench is used to load / unload relatively large or heavy sheets by its rotation. 

1.4.1.4 Operational Button bar 

Operational buttons differ in the operation mode. They are used to execute related 
operations. 

1.4.1.5 Function Windows 

They include the following windows: 

• POS: It is used to show the following: 

– Toolpath in real-time during machining or simulation. 

– Contents of the program file in Auto mode. 

• INFO: It is used to show machining records, calculate the machining cost, etc. 

• POS DIAG: It is used to show feedback coordinates, sent pulse and feedback pulse and 
set the datum for each axis. 

• IO PORT: It is used to show the status of each IO port and communication status 
between the software and hardware. 

• LOG: It is used to show different types of logs that can help troubleshoot. 

• SETTING: It is used to set cutting parameters in Auto or Manual mode. 
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1.4.2 NcEditor Interface 

The main interface of NcEditor is as follows: 

 

1. Title bar 

2. Menu bar 

3. Tool bar 

4. Drawing area 

5. Drawing auxiliary bar 

6. Object attribute area 

7. Object list window 

1.4.2.1 Title Bar 

It is used to show the name of current program file. 
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1.4.2.2 Menu Bar 

It includes the following menus: 

• File: It is used to create / open / import / save a program file, generate an installation 
package, restart / shut down the software, etc. 

• Edit: It is used to undo / redo the operation, select all objects, insert a file, etc. 

• View: It is used to customize the displayed information in the main interface, adjust 
the view, return to NcStudio interface, etc. 

• Draw: It is used to select the object shape, measure distance, set the workpiece origin, 
lock the view, etc. 

• Object: It is used to set machining technics, such as chamfer, array, micro joint, bridge, 
etc. 

• Work Mode: It is used to switch between Auto mode and Manual modes (including 
jog, handwheel and step modes). 

• Operate: It is used to execute machining commands, such as executing single block, 
setting the workpiece origin, executing simulation and so on. 

• Language: It is used to switch a system language. 

• Help: It is used to check the system information, register the software and set the 
setup interface. 

1.4.2.3 Tool Bar 

It includes the following: 

• : It is used to open a program file. 

• : It is used to save a program file. 

• : It is used to cancel the last operation. 

• : It is used to recover canceled operations. 

• : It is used to translate the view. 

• : It is used to zoom in / out the view. 
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• : It is used to make the view fit to the drawing window. 

• : It is used to set the workpiece origin. 

• : It is used to bridge two adjacent objects. 

• : It is used to set the edge for the tilt angle. 

• : It is used to set the point for the tilt angle. 

• : It is used to set the machining direction as clockwise for the target object. 

• : It is used to set the machining direction as counterclockwise for the target 
object. 

• : It is used to set the groove direction on the left of the machining direction for 
unclosed objects. 

• : It is used to set the groove direction on the right of the machining direction for 
unclosed objects. 

• : It is used to change the filling attribute for closed objects. 

• : It is used to automatically set the filling attribute for closed objects. 

• : It is used to set a lead line. 

• : It is used to reverse the lead line. 

• : It is used to delete the lead line. 

• : It is used to set tool compensation. 

• : It is used to delete the set tool compensation. 
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• : It is used to sort the machining order. 

• : It is used to set the mode of vertical plunge, tilt angle and cutting speed. 
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1.4.2.4 Drawing Area 

It is used to draw the machined objects. 

1.4.2.5 Drawing Auxiliary Bar 

It includes the following: 

•  : It is used to select the object. 

•  : It is used to set the machining order. 

•  : It is used to show the machining order. 

•  : It is used to show the groove direction. 

•  : It is used to clear the machining track. 

•  : It is used to set catch options. 

•  : It is used to disable catching function. 

• : It is used to draw a dot. 

• : It is used to draw a line. 

• : It is used to draw an arc. 

• : It is used to draw a polyline. 

• : It is used to draw a rectangle. 

• : It is used to draw a circle. 

• : It is used to draw an ellipse. 

• : It is used to draw a polygon. 

• : It is used to draw a start. 

• : It is used to add text. 
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1.4.2.6 Object Attribute Area 

It is used to set the following attributes for the selected object: 

• For one object 

– X-axis and Y-axis coordinates 

– Width and height / diameter 

• For all objects 

– Width 

– Height 

– Rotating angle 

1.4.2.7 Object List Window 

It used to show all objects in the drawing area according to the drawing order. 
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2 Basic Commissioning 

Through this section, you can quick know the basic commissioning of NcStudio V10 
Waterjet Cutting Control System. 

The commissioning procedure is as follows: 

 

During commissioning, note the following: 

• If the manufacturer password is required during commissioning, please contact us. 

• If parameters whose effecting time is Reboot is modified, please restart the software 
to validate the modification. 
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2.1 Check the Machine Environment 

This operation is used to check the environment of the machine tool, so as to ensure the 
commissioning goes on well. 

It includes the following: 

• Check the mechanical structure 

• Check the electronic wiring 

• Check auxiliary circuits 

2.1.1 Check the Mechanical Structure 

This operation is used to check if the mechanical structure of machine tool is normal. 

Check the mechanical structure from the following aspects: 

• Installation of the moving servo axis and mechanism connection. 

• Connection of the coupling, decelerator and other parts without a relative slide. 

• Gear occlusion and something irrelevant on the screw rail. 

• Anti-collision safety device. 

2.1.2 Check Electrical Wiring 

This operation is used to check if the electrical wiring of the machine tool is normal. 

Check electrical wiring from the following aspects: 

• Ground connection of the machine tool. 

• Abnormal phenomena in the electrical box, such as short circuit and open circuit. 

• Power supply for the host, Lambda terminal board, and EX serial extended terminal 
board. 

• Communication among the host, Lambda terminal board, and EX serial extended 
terminal board. 

• NO / NC connection of each inductive switch. 

• Signal of E-stop button. 

• Connection between the Lambda terminal board and servo drive. 
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2.1.3 Check Auxiliary Circuits 

This operation is check if auxiliary circuits of the machine tool are normal. 

Auxiliary circuits include the following: 

• Hydraulic circuit 

• Circuit of cooling water 

• Circuit for abrasive sand supplying 

• Circuit for gas supplying 

2.1.3.1 Check the Hydraulic Circuit 

Check the hydraulic circuit from the following aspects: 

• Oil junctions. 

• Temperature of hydraulic liquid. 

  If it is too high, check the circuit of cooling water. 

• Oil pressure. 

– Too high: Check if the oil channel is clogged. 

– Too low or unstable: Check if there is an oil leakage. 

2.1.3.2 Check the Circuit of Cooling Water 

Check the circuit of cooling water from the following aspects: 

• Connection, such as reverse connection and other problems. 

• Block. 

2.1.3.3 Check the Circuit for Abrasive Sand Supplying 

Check the circuit for abrasive sand supplying from the following aspects: 

• Abrasive sand in the abrasive-sand tank. 

• Flow of abrasive sand. 

  If it is abnormal, check if the jewel nozzle and grit-sand circuit is clogged. 
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2.1.3.4 Check the Circuit for Gas Supplying 

Check the circuit for gas supplying from the following aspects: 

• Connection. 

• Air pressure for abrasive sand supplying, water valve, height measuring, blowing and 
so on. 

2.2 Install the Software 

Before installing the software, ensure the following: 

• The machine tool has been powered and can be normally used. 

• The installation package of NcStudio V10 Waterjet Cutting Control System has been 
copied to the host. 

To install the software, do the following: 

1. Double click the installation package. The dialog box for selecting the language pops 
up. 

2. Select the target language according to your need and click Yes. The dialog box about 
migrating parameters pops up. 

3. Choose whether to migrate parameters: 

– To migrate related parameter settings of the previous software in the host to 
the new software, click Yes. 

— After installing the software, previous parameter settings remain. 

— Note: It is recommended to migrate parameters only when the versions of the previous software 
and the new one are the same or similar. 

– To reset parameters instead of using the previous parameter settings, click No. 

— After installing the software, values of all parameters are default. 
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2.3 Select the System Configuration 

This operation is used to select the system configuration according to actual hardwares for 
the first installation. 

The system currently supports the following configurations: 

• Single Y-axis / double Y axes: It can be judged from the mechanical structure. 

• Bus control / non-bus control: It can be judged from the control system. 

• Standard / others: It can be judged from the actual wiring of terminal board and layout 
of IO ports. 

To select the system configuration, do the following: 

1. Click Machine Tool → Config Manage. Config Manage dialog box pops up: 
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2. To activate the selection box in Config Style area, click Login and enter manufacture 
password. 

3. According to actual conditions, select the configuration in Config Style area and click 
OK. 

The system automatically restarts to make the selected configuration effective. 

2.4 Clear IO Port Alarms 

This operation is used to clear IO port alarm before machining, so as to establish a good 
communication between the control system and servo drive. 

Common alarms include the following: 

• Alarm of terminal board disconnection 

• E-stop alarm 

• Limit alarm 

• Drive alarm 

• Alarm of port polarity error 

After you fail to clear these alarms, please contact us. 

2.4.1 Clear the Alarm of Terminal Board Disconnection 

To clear the alarm of terminal board disconnection, check the following: 

• Wiring related to the terminal board. 

  If it is not correct and firm, do wiring again. 

• Port polarities in IO Port window. 

  If they are not correct, modify the polarity of the corresponding port and restart the 
software. See Check Port Information for details. 

• Terminal board. 

  If it is damaged, replace it. 

2.4.2 Clear the E-stop Alarm 

To clear the E-stop alarm, check E-stop button: 

• If it is pressed, release the button. 

• If it is not pressed, modify the polarity of E-stop port in IO Port window and restart 
the software. 
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2.4.3 Clear the Limit Alarm 

When the machine tool triggers the limit switch, the system will send a positive / negative 
limit alarm. 

To clear the limit alarm, move the machine tool towards the opposite direction of limit 
switch. 

2.4.4 Clear the Drive Alarm 

To clear the drive alarm, check the following: 

• Wiring of the drive. 

  If it is not connected correctly and securely, do wiring again. 

• Polarity of Servo Alarm port. 

  If it is not correct, modify the port polarity of the corresponding port and restart the 
software. 

• Parameter Driver Station Address (only for bus configuration). 

  If it does not match with the actual station address of the servo drive, modify it 
according to the actual station address and restart the software. 

For the bus configuration, alternatively, you can clear common drive alarms by clicking 
Machine Tool → Clear Servo Alarm. 

2.4.5 Clear the Alarm of Port Polarity Error 

If the port polarity does not match with the switch of machine tool, an alarm will occur. 

To clear the alarm of port polarity error, modify the polarity of corresponding ports in IO 
Port window and restart the software. 

2.5 Set the Structure of Five-axis Tool Head 

Through RTCP algorithm, this operation helps to solve additional motions of the tool head 
during the rotary axis rotates, resulting from the fact that the control point of the CNC 
system may be not on the tool head due to the installation. As a result, the CNC system will 
automatically correct the control point and the tool head will move along the toolpath 
specified by commands. 

At present, both five-axis AB and five-axis AC software support to customize the structure 
of tool head. 
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2.5.1 Structures of Tool Head 

The description about structures of tool head is as follows: 

• Main rotary axis: Its rotation can change the position of the other rotary axis. 

  For the AC head tool, the main rotary axis is C-axis; for the AB head tool, it is B-axis. 

• Auxiliary rotary axis: Its rotation cannot change the position of the other rotary axis. 

  The auxiliary rotary axis is A-axis. 

• Control point: The point where the center lines of two auxiliary rotary axes intersect. 

• Cutting point: The optimal point where the spouted water and workpiece surface 
intersect. 

  In general, it is 3mm ~ 5mm below the abrasive tube. 

• Vector of main rotary axis: The direction vector of the main rotary axis in this 
coordinate system, taking the cutting point as the origin of space coordinate system. 

  In general, one of X-axis, Y-axis and Z-axis coordinates is set to 1. E.g. (0,0,1) 

• Vector of auxiliary rotary axis: The direction vector of the auxiliary rotary axis in this 
coordinate system, taking the cutting point as the origin of space coordinate system. 

  In general, one of X-axis, Y-axis and Z-axis coordinates is set to 1. E.g. (1,0,0) 

• Center of main rotary axis: The coordinate of an arbitrary point on the main rotary 
axis in this coordinate system, taking the cutting point as the origin of space 
coordinate system. 

• Center of auxiliary rotary axis: The coordinate of an arbitrary point on the auxiliary 
rotary axis in this coordinate system, taking the cutting point as the origin of space 
coordinate system. 

• Vector of tool rod: The direction vector of spouted water when each rotary axis rotates 
to 0°. 

  Default: (0,0,-1) 
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2.5.2 Set Five-axis AB Tool Head 

To set five-axis AB tool head, do the following: 

1. Click Params. Params dialog box pops up: 

   

2. To activate input boxes, check Manufacturer and input the manufacturer password. 

3. Select B-axis as the main rotary axis. 

4. Select Tool head structure and do related operations: 

– For option 90°AB / 45°AB / V-type AB, set Waterjet tool length in Technics 
interface. 

– For option Customize, customize all tool parameters. 

— About parameter details, see Structures of Tool Head. 

To validate parameter settings, reload a program file. 
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2.5.3 Set Five-axis AC Tool Head 

To set five-axis AC tool head, do the following: 

1. Click Machine Tool → Machine Tool. Machine Tool dialog box pops up: 

   

2. Click Log in, and input the manufacturer password. 
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3. Select the structure of tool head and do related operations: 

– For option 5-axis AC type without pivot distance, set Angle amid A and Z 
according to the actual situation. 

In general, the angle between A-axis and C-axis is 45°. 

 

– For option 5-axis AC type with pivot distance, set Y offset of A-axis, X offset 
of C-axis, Y offset of C-axis and Pivot Distance. 
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– For option 5-axis AC Custom Tool Head, customize all tool parameters: 

 

About parameter details, see Structures of Tool Head. 

To validate parameter settings, reload the program file. 
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2.6 Set Commissioning Parameters 

This operation is used to set related parameters for commissioning, so as to avoid damages 
to the machine tool caused by its motion. 

To set commissioning parameters, do the following: 

1. Click Machine Tool → System Parameters. System Parameters dialog box pops up: 

   

2. Click Params → Axes → Manufacturer, input the manufacturer password and find the 
following parameters: 

– Bus configuration: 

• Screw Pitch: Its setting should match with the actual situation. 

• Mechanical Reducer Ratio: Its setting should match with the actual 
situation. 

• Encoder Digit: Its setting should match with the actual situation. 

• Electronic Gear Ratio: Its setting should match with the actual situation. 
Default: 1:1. 
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– Non-bus configuration 

• Pulse Equivalent: It refers to the moving distance of screw or rotation 
degree of rotary axis per pulse sent by the system, the minimum 
available distance controlled by the system as well. 

• Electronic Gear Ratio: It can be calculated in term of the value of 
parameter Pulse Equivalent. 

3. Double click the target parameter, input its value and click OK. 

2.7 Adjust the Axis Direction 

This operation is used to check if the positive direction of each axis is the same with the 
direction stipulated by Right Hand Rule, and adjust it if not, so as to avoid damage to the 
machine tool due to incorrect direction. 

Taking X-axis as an example, to adjust the axis direction, do the following: 

1. Click Machine Tool → System Parameters. System Parameters dialog box pops up: 
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2. Click Params → Axes → Manufacturer, input the manufacturer password and check 
the current value of parameter Axis Direction (X): 

– 1: Positive direction 

– -1: Negative direction 

3. Judge the positive direction of X-axis according to Right Hand Rule. 

4. In Manual mode, move X-axis in positive direction. 

5. Observe if the actual positive direction of X-axis is the same with that stipulated by 
Right Hand Rule: 

– If they are the same, the parameter Axis Direction (X) is set correctly. 

– If they are opposite, modify the parameter Axis Direction (X) to the opposite 
value. 

2.8 Execute Returning to the Machine Origin / Set the Datum 

This operation can help the machine coordinate system of NcStudio V10 Waterjet Cutting 
Control System match with that of the machine tool for a preciser machining. 

Before returning to the machine origin, ensure all alarms have been cleared. 

According to the encoder type, it can be divided into the following: 

• For an absolute encoder, set the datum. 

• For an incremental encoder, execute returning to the machine origin. 

2.8.1 Set the Datum 

This operation is used to directly set the zero for the absolute encoder. 

Except the following conditions, this operation is unnecessary because the system will 
automatically read datum of each axis: 

• It is the first time to install the software. 

• The software is updated. 

• The absolute encoder runs out of battery. 

• The datum file has been damaged. 

Before setting the datum, ensure the following: 

• Hardwares have been connected well. 

• The axis direction is correct. 
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For double Y axes configuration, before setting Y-axis datum, to adjust parallelism of 
double Y axes, make the fine adjustment for Y1-axis and Y2-axis in POS DIAG window and 
make a trial cutting. 

Taking X-axis as an example, to set the datum, do the following: 

1. To enter POS DIAG window, click POS DIAG. 

2. To activate datum setting buttons, click RefSet or press F3, and input the 
manufacturer password. 

3. To open Table Travel Set dialog box, click X Datum → Yes. 

4. To set the upper limit of the workbench travel, move X-axis in the positive direction to 
a reasonable position, and click Upper Limit. 

5. To set the lower limit of the workbench travel, move X-axis in the negative direction to 
a reasonable position, and click Lower Limit. 

6. Click OK. 

The system starts to read datum data. 

Repeat the steps above to set datums for other axes, and restart the software to validate 
settings. 

To directly use the set datums after updating the software, export the set datums as an INI 
file by clicking Export Datum. After updating the software, insert the USB flash disk with 
the INI file and click Import Datum. 
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2.8.2 Execute Returning to the Machine Origin 

With an incremental encoder, every time you restart the software, you need to return to 
the machine origin before machining. But if no abnormal phenomenon occurs during this 
machining, you do not need to execute this operation before the next machining. 

To execute returning to the machine origin, do the following: 

1. To open BKRef dialog box, do one of the following: 

– Click Operate → Back to Reference Point. 

– In Manual mode, click REFER in POS window. 

   

  You can check This dialog box appears automatically when the software starts at 
lower left corner. BKRef dialog box will automatically pop up when the software starts 
next time. 
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2. Do one of the following: 

— To return Z-axis to the machine origin first and return the other axes, click All 
Axes. 

– If you ensure the following, click Direct Set to directly set the current position 
as the machine origin: 

• The current position is the same with the machine coordinate. 

• The machine has never been turned off. 

• E-stop has never occurred. 

– To return a single axis to the machine origin, click X-axis / Y-axis / Z-axis / A-
axis / B-axis / C-axis. 

For safety, it is recommended to return Z-axis first. 

After executing returning to the machine origin, the sign  appears after the 
corresponding axis in coordinate display area. 

2.9 Set Automatic Adjustment 

Taking the WISE drive as an example, according to the current machine tool status, this 
operation is used to adjust the gain of servo drive and related parameters, so as to improve 
responsiveness. 

It can be executed only for one axis among X-axis, Y-axis and Z-axis at a time. 

Before setting automatic adjustment, ensure connection and communication between the 
servo drive and control system is correct and normal. 

To set automatic adjustment, do the following: 

1. Set the station address for the drive. 

2. Set drive parameters. 

3. Execute the automatic adjustment: It is applicable to the bus control system. 
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2.9.1 Set the Station Address for the Drive 

This operation is used to set the station address by setting the drive parameter on the 
operation panel. 

To set the station address for the drive, do the following: 

1. To select the position control mode, set the drive parameter Pr001 Control mode 
setup to 1 according to the following procedure: 
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2. According to the following procedure, set numbers of the station address: 

   

  It is recommended to set numbers of the station address in order (E.g, X-axis: 1; Y-axis: 
2; Z-axis: 3 ). 

  Note: Station address 0 means disabling the communication function. 
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2.9.2 Set Drive Parameters 

This operation is used to set drive parameters through NcStudio. 

After NcStudio V10 Waterjet Cutting Control System is well connected to the drive, the 
system automatically reads drive parameters. And you can reset the drive parameters 
according to the structure of machine tool and your needs. 

To set drive parameters, do the following: 

1. Click Machine Tool → Set Servo Param. Driver Parameter dialog box pops up: 

   

2. Select the target axis. 

3. Double click target parameters, input the parameter value and click OK. 
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After setting drive parameters, do one of the following in Driver Parameter dialog box: 

• Increase parameters. 

• Delete parameters. 

• Restore the initial list. 

• Restore factory settings. 

• Input settings of servo parameters. 

• Export settings of servo parameters. 

2.9.3 Execute the Automatic Adjustment 

This operation is applicable to the bus control system. It is used to estimate inertia ratio 
according to the rigidity, limit range and track of each axis and load conditions, set the 
rigidity for each axis and then execute the related adjustment. 

To execute the automatic adjustment, do the following: 

1. Click Machine Tool→ Auto Adjust. Adjustment dialog box pops up: 
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2. To set axis moving range, do the following: 

1. Select the target axis. 

2. To set the first limit, move the machine tool to one safety position, and click Set 
after 1st Limit or Set 1st Limit at the bottom of the dialog box. 

3. To set the second limit, move the machine tool to another safety position, and 
click Set after 2nd Limit or Set 2nd Limit at the bottom of the dialog box. 

  Note: The distance between the first limit and the second one should be within [15, 1000]. 

3. To select function options, click Next, and select an initial mode and rigidity mode. 

4. Click Next, and click Estimation Start. The system automatically starts estimation. 

5. To set rigidity parameters, click Next, and set these parameters according to 
machining needs. 

6. Click Start. The system starts automatic adjustment. 

  If you are not satisfied with the result, you can adjust related parameters and execute 
automatic adjustment again. 

During automatic adjustment, according to your need, do one of the following: 

• To stop automatic adjustment, click Stop. 

• To save the parameter settings for later use, click Save. 
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3 Quick Start 

Through this section, you can quick know the basic machining procedure of NcStudio V10 
Waterjet Cutting Control System and start machining. 

The basic procedure is as follows: 
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3.1 Execute Returning to the Machine Origin 

This operation is used to make the machine tool return to the machine origin and adjust the 
coordinate system. 

It is only applicable to the machine tool with an incremental encoder. 

To execute returning to the machine origin, do the following: 

1. To open BKRef dialog box, do one of the following: 

– Click Operate → Back to Reference Point. 

– In Manual mode, and click REFER. 

   

  You can check This dialog box appears automatically when the software starts at 
lower left corner. BKRef dialog box will automatically pop up when the software starts 
next time. 
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2. Do one of the following: 

– To return Z-axis to the machine origin first and return the other axes, click All 
Axes. 

— Note: For a machine tool with double Y axes, before clicking All Axes, you need to click Detect Y REF 
to detect the difference of encoder origins of double Y-axes. 

– If you ensure the following, click Direct Set to directly set the current position 
as the machine origin: 

• The current position is the same with the machine coordinate. 

• The machine has never been turned off. 

• E-stop has never occurred. 

– To return a single axis to the machine origin, click X-axis / Y-axis / Z-axis / A-
axis / B-axis / C-axis. 

— For safety, it is recommended to return Z-axis first. 

After executing returning to the machine origin, the sign  appears after the 
corresponding axis in coordinate display area. 

3.2 Load a Program File 

This operation is used to load a program file before machining. 

The supported format of the program file includes G, DXF, ENG and PLT. 

To load a program file, do one of the following: 

• Load a program file in NcStudio: You cannot edit the program file in NcStudio. 

• Load a program file in NcEditor: You can edit the program file in NcEditor. 

• Draw and load an object in NcEditor: You can load the object drawn in NcEditor. 

The loaded program file shows in POS window. 

3.2.1 Load a Program File in NcStudio 

To load a program file in NcStudio, do one of the following: 

• Click File → Open and Load, select the target program file and click Open. 

• In Auto mode, in POS or INFO window, click Load and select the target program file. 
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3.2.2 Load a Program File in NcEditor 

To load a program file in NcEditor, do one of the following: 

• Click File → Open or directly click , select the target program file and click Open. 

• Click File → Import XXX File, open the target program file with the corresponding 
format and click Save. 

  The program file is saved as a NCE file. And it replaces the previous program file. 

If there is already a program file and you need to insert another one, click Edit → Insert 
XXX File, open the target program file with the corresponding format and click Save. The 
program file is saved as a NCE file. 

3.2.3 Draw and Load an Object in NcEditor 

To draw and load an object in NcEditor, do the following: 

1. To select a drawing tool, do one of the following: 

– Click Draw, and select the target tool. 

– Select the target tool in the drawing tool bar. 

2. Draw an object in the drawing area. 

3. To save the object as a NCE file, click Save. The object is automatically loaded. 

3.3 Set the Workpiece Origin 

The workpiece origin is the zero of X-axis / Y-axis / Z-axis / A-axis / B-axis / C-axis in the 
program file. Before machining, you need to set it. 

To set the workpiece origin, do one of the following: 

• Do clearing: by directly clearing workpiece coordinates. 

• Set the workpiece offset: by setting workpiece offset. 

• Set the current position as workpiece origin: by directly setting the current position. 

• Set the workpiece origin for the object: by setting workpiece origin in NcEditor. 
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3.3.1 Do Clearing 

This operation is used to clear the current workpiece coordinate of each axis and set 
machine coordinates of each axis as the corresponding workpiece offset. 

To do clearing, do the following: 

1. In Manual mode, move the machine tool to the target position that is to be set as the 
workpiece origin. 

2. To do clearing, in POS window, do one of the following: 

– For one or several axes, click Clear X, Clear Y, Clear Z or Clear XY. 

– For all axes, click Operate → Set Workpiece Origin. 

3. Click Yes in the confirmation dialog box. The system clears the current workpiece 
coordinates. 
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3.3.2 Set the Workpiece Offset 

This operation is used to set the offset of workpiece origin that is relative to the machine 
origin in the corresponding WCS (G54 ~ G59). 

To set the workpiece offset, do the following: 

1. In Manual mode, click Operate→ Offset→ Advanced Setting. Offset Setting dialog 
box pops up: 

   

2. Click X / Y / Z input box in Workpiece Offset area, input the corresponding value and 
click OK. 
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3.3.3 Set the Current Position as Workpiece Origin 

To set the current position as workpiece origin, do the following: 

1. In Manual mode, click Operate → Set Current Origin. Set Origin dialog box pops up: 

   

2. Do one of the following: 

– To clear workpiece coordinates of current position, move the machine tool to 
the workpiece origin by axis direction buttons and click Zero. 

– To directly input coordinates of the workpiece origin, check Manual Input, 
input coordinates of the workpiece origin and click Apply or OK. 

— Alternatively, click Operate → Work Coor, click the target input box, input 
coordinates of the workpiece origin and click OK. 

– To set the angular point as the workpiece origin, in Set the current point for 
application edge points area, click the corresponding button. 

Note: If the program file is empty, this way is unavailable and related buttons show gray. 
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– To load the saved workpiece origin, in Read the origin of the workpiece area, 
check Whether to read the origin of the workpiece, select the target 
workpiece origin and click Apply or OK. 

— Alternatively, click Operate → Load Workpiece Origin and select the target 
coordinates. 

3.3.4 Set the Workpiece Origin for the Object 

This operation is used to set the workpiece origin for the object in NcEditor. 

To set the workpiece origin for the object, do one of the following: 

• To set the workpiece origin in Set Origin dialog box, do the following: 

1. To open Set Origin dialog box, do one of the following: 

• In the menu bar, click Draw → Set Origin. 

• In the tool bar, click . 

 

2. Do one of the following: 

• To set the feature point on the object as workpiece origin, select Set 
origin by particular position, and select a feature point. 
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• To directly input coordinates of the workpiece origin, select Set directly 
and input its coordinates of X-axis / Y-axis. 

• To set the workpiece origin by your mouse, select Choose by mouse, 
left click the target position in the drawing area and right click for 
confirmation. 

• To directly set the workpiece origin in the drawing area, drag the sign  to the target 
position that is to be set as the workpiece origin and right click for confirmation. 

   is at the intersection of horizontal scale and vertical scale in the upper left corner of 
the drawing area. 

3.4 Set Machining Parameters 

This operation is used to set machining parameters before machining. 

To set machining parameters, do the following: 

1. Click Machine Tool → Params. Params dialog box pops up: 
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2. To set machining parameters, click Technics / Auto / Manual and set the related 
parameters: 

– Parameters in Technics interface 

• Valve control 

• Speed control 

• Punch setting 

• Five-axis control 

– Parameters in Auto interface 

• G00 speed 

• Z-axis jiggle 

• Safety setting for the tool head 

• Tool actions after machining 

– Parameters in Manual interface 

• Returning to REF point 

• Manual speed 

  See Parameters for details. 

3.5 Execute Simulation 

This operation helps to know the machining track in advance, so as to avoid damages to the 
machine tool caused by programming mistakes. 

Before executing simulation, ensure the program file has been loaded. 

To execute simulation, do one of the following: 

• Execute simulation by the system: The machine tool is not involved in machining. 

• Execute a trial by the machine tool: The machine tool is involved in machining. 

3.5.1.1 Execute Simulation by the System 

Through this operation, NcStudio V10 Waterjet Cutting Control System does not drive 
the machine tool and only displays the toolpath in POS window, and you can visually check 
the machining program. 

To execute the simulation by the system, do one of the following: 

• Click Operate → Simulation Mode. 

• In Auto mode, in operation button bar, click Simmu → Start. 

The system automatically executes simulation. And  shows in the upper left 
corner of POS window. 
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3.5.1.2 Execute a Trial by the Machine Tool 

Through this operation, NcStudio V10 Waterjet Cutting Control System will drive the 
machine tool, and you can check coordinates of the machine tool and the toolpath in POS 
window. 

In the area of valve control, click Simulate → Start. The trial automatically starts. 

3.6 Execute Machining 

To execute machining, do one of the following: 

• Execute automatic machining 

• Execute single block 

• Execute machining from a near point / execute selective machining 

Before executing machining, ensure the program file has been loaded. 

3.6.1 Execute Automatic Machining 

This operation is used to automatically execute machining from the beginning to the end. 

To execute automatic machining, in Auto mode, do one of the following: 

• In the menu bar, click Operate → Start. 

• In operation button bar, click Start. 

During automatic machining, you can do one of the following: 

• To pause machining, do one of the following: 

– In the menu bar, click Operate → Pause. 

– In operation button bar, click Pause. 

• To stop machining, do one of the following: 

– In the menu bar, click Operate → Stop. 

– In operation button bar, click Stop. 
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3.6.2 Execute Single Block 

This operation is used to executing program by blocks. And after executing one block, the 
system enters pause status. Thus, it can be used for error diagnosis and troubleshooting. 

To execute single block, do the following: 

1. To enable single block, click Operate → Single Block. 

2. In Auto mode, in operation button bar, click Start. The system enters pause status 
after executing one block of the program. 

3. To continue to execute an another block, click Start again. 

4. Repeat step 3 until the whole program has been executed. 

3.6.3 Execute Machining from a Near Point / Selective Machining 

This operation differs in the format of program file: 

• For NCE format, this operation is used to execute machining from a near point. 

• For the other formats, this operation is used to execute selective machining. 

3.6.3.1 Execute Machining from a Near Point 

During machining NCE files, with this method, you can move the tool head to some point 
precisely and visually and restart machining from this point. 

To execute machining from a near point, do the following: 

1. Click Machine Tool → System Parameters. System Parameters dialog box pops up. 

2. Click Operate, find and set the parameter Near Point Range to a reasonable value. 

3. In Manual mode, move the tool head to the position near the target point. 

  The distance between the tool and the target point should not be greater than the 
value of parameter Near Point Range. 

4. In Auto mode, to start machining from the position nearest to the tool position, do one 
of the following: 

– In the menu bar, click Operate → NearPoint Processing Block. 

– In operation button bar, click Near Point 
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3.6.3.2 Execute Selective Machining 

During machining the program file whose format is not NCE, with this method, you can 
select any block to machine. 

To execute selective machining, do the following: 

1. In Auto mode, click Operate → NearPoint Processing Block. Select Process dialog 
box pops up: 

   

2. Select a machining type: 

– Path number: It is automatically generated in POS window. 

– Line number: It shows in POS window. 

3. Specify the machining range: 

– Select Specify the processing track number and input a specified path 
number. 

It is available when the machining type is Path number. 
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– Select Specify the range according to track number and do the following: 

• To specify the start position, select File Start, or select Specific Position 
and input a specified path number or line number. 

• To specify the stop position, select File End, or select Specific Position 
and input a specified path number or line number. 

4. Click OK. The system starts machining within the specified range. 

4 Special Operations 

Through this section, you can quick know special operations of NcStudio V10 Water 
Cutting CNC Control System. 

Special operations include the following: 

• Execute Manual Contouring 

• Height Measurement 

• Use Manual Locating 

• Execute Scanning QR 

• Set Punching Parameters for the Waterjet Tool 

• Check Time Statistics for High Pressure Valve and Oil Pump 

• Execute Z-axis Jiggle 

• Execute Y1Y2 Jiggle 

• Back up Technic Parameters 

• Nest Parts 

• Use the Drill 

• Use the Velocity Model Calculator 

• Shoot with a Camera 

• Adjust Five-axis Tool Head Errors 
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4.1 Execute Manual Contouring 

In stone mosaic industry, this operation is used to deal with sheets with flaws or cracks by 
moving the tool head around the area that you would like to remove, and generating a DXF 
file according to the regular-shaped contour. When drawing or nesting toolpaths, you can 
open the DXF file to remove the area. 

Before executing manual contouring, ensure the following: 

• Each axis has been returned to the machine origin. 

• The version of the following softwares meet requirements: 

– NcStudio: 10.515.2 or above 

– CAD: 2004 or above. 

To execute manual contouring, do the following: 

1. In Manual mode, move the tool head to the target position. 

2. Click Operate → Manual Contouring. Manual Contouring dialog box pops up: 

   

3. To add the current position of tool head to the list in Manual Contouring dialog box, 
click Add Points. 

4. To get the whole contour of the target area that you would like to remove, repeat step 
2 and 3. 
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5. Optional: If there are several areas that you would like to remove, to add points for 
the target areas, modify the parameter Cur Graph to the corresponding number of 
area and repeat step 2 ~ 4. 

  All added points belong to the area whose number matches with the value of 
parameter Cur Graph. For example, when the value is 2, then all added points belong 
to the area 2 after clicking Add Point. 

6. Check if Z-axis is higher than or at the safety height: 

– Yes: Proceed to the next step. 

– No: Lift Z-axis to the safety height. 

7. Click Dry Run and check if the contour is reasonable: 

– Yes: Proceed to the next step. 

– No: To modify the contour, do one of the following: 

• To delete unnecessary or wrong points, check these points and click 
Delete. 

• To delete all points, click Select All → Delete. 

• To modify the coordinate of a point, double click its coordinate input box 
and input the target coordinate. 

8. To export the contour as a DXF file, click Export. 

  The workpiece origin is the zero point of exported DXF file. 

To draw or nest the contour, open the DXF file with CAD software and do related edition. 

  



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 60 / 195 

 

4.2 Measure Height 

This operation is used to guarantee the same distance from the tool head to the workpiece 
surface, so as to avoid the impact on cutting quality caused by change of cutting height. 

To measure height, do the following: 

1. In Manual mode, click Altimetry. Height Measurement dialog box pops up: 

   

2. To activate input boxes in Parameter area, check Manufacturer and input the 
manufacturer password. 
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3. Set the following standard parameters in Parameter area: 

– Cylinder X Offset: The offset of height measuring unit relative to the tool head in 
X-axis direction. 

– Cylinder Y Offset: The offset of height measuring unit relative to the tool head in 
Y-axis direction. 

– Z Start Pos: The machine coordinate of Z-axis before starting height 
measurement. 

– Z Speed at Getting Datum: The speed of Z-axis at the time of getting datum 
position. 

4. Optional: For height measurement with the laser sensor, set the baud rate of serial 
ports. 

5. Choose a way of height measurement: 

– With the cylinder: 

• Manual height measurement 

• In-process height measurement 

• Three-point height measurement 

– With the laser sensor: 

• Manual height measurement 

• Three-point height measurement 

• Scanning height measurement 

4.2.1 Set Standard Parameters 

This operation is used to set related standard parameters of height measurement. 

To set standard parameters, do the following: 

1. In Parameter area of Height Measurement dialog box, according to the actual 
situation, set parameters Z Start Pos and Z Speed at Getting Datum. 

2. To set parameters Cylinder X Offset and Cylinder Y Offset, do the following: 

1. Move the tool head to the proper position, click Clear XY and punch a hole on 
the workpiece. 

2. Open the cylinder of height measuring sensor and push out the height 
measuring sensor. 

3. To move the laser spot to the hole center, turn on laser and move X-axis and Y-
axis. 
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4. Respectively input the current workpiece coordinates in Cylinder X Offset and 
Cylinder Y Offset input boxes. 

3. To get the height difference, do the following: 

1. Manually move the abrasive tube to the cutting height and click Clear Z. 

2. Click Start Automatic Detection. 

  After detection, the system automatically fills in height difference. 

4.2.2 Set Baud Rate of Serial Ports 

This operation is used to set the baud rate of serial ports on the host, so as to ensure the 
communication between the laser sensor and host. 

It is applicable to height measurement with the laser sensor. 

To set baud rate of serial ports, do the following: 

1. To open Device Manager dialog box in the computer desktop, click Start → Control 
Panel → Device Manager. Device Manager dialog box pops up: 

   

2. Click Ports(COM/LPT), and double click the target communication port. Properties 
dialog box pops up. 
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3. Click Port Settings and set Bits per second to 38400: 
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4.2.3 Measure Height with the Cylinder 

This operation is used to measure height by traditional contact measuring method. 

Before measuring height with the cylinder, ensure the following: 

• The target workpiece has been placed on the workbench. 

• The parameter N79201 Software Configuration has been set to 1. 

• Z-axis has returned to the machine origin. 

• The workpiece origins of X-axis and Y-axis have been defined. 

To measure height with the cylinder, in Height Measurement Mode area of Height 
Measurement dialog box, select one of the following measuring methods: 

• Manual height Measurement 

• In-process height measurement 

• Three-point height measurement 

Note: The result of height measurement is still effective after reloading the program file or restarting the software. 
To disable the result, please uncheck Enable height measuring result in Height Measurement dialog box . 

To measure height during breakpoint resume, check Height measuring or not when 
resume. 

4.2.3.1 Execute Manual Height Measurement 

This operation is used to measure height for a single-point, and execute tool calibration by 
one key which saves troubles of tool calibration by clearing. 

To execute manual height measurement, do the following: 

1. Move the tool head to the target measuring point. 

2. In Height Measurement Mode area of Height Measurement dialog box, select 
Manual Altimetry. 

3. Click Start. Height measurement starts. 

During height measurement, you can do the following if there is something wrong: 

• If exceptions in the height measuring unit occur, measuring position is incorrect, or it 
is going to collide with the machine tool, click Stop to stop height measurement. 

• If the toolpath origin is set incorrectly, correct it, click XY Clear to clear workpiece 
coordinate of X-axis and Y-axis in the correct position, and measure height again. 
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4.2.3.2 Execute In-process Height Measurement 

This operation is used to measure height during cutting. And it is applicable to the 
workpiece with a relatively hard and smooth surface, whose machining effect is not 
influenced by scratches. 

To execute in-process height measurement, do the following: 

1. In Height Measurement Mode area of Height Measurement dialog box, select 
During Machining. 

2. To select the start point for height measurement, do one of the following: 

– Check At Start of Machining. Height measurement starts at the start point of 
program file. 

– Check At Start of object. Height measurement starts at the start point of each 
object. 

– Check By Distance and set the distance between the workpiece surface and 
tool head. If the actual distance is equal to the set distance during cutting, 
height measurement starts. 

3. Click OK. Height measurement starts. 

4.2.3.3 Execute Three-point Height Measurement 

This operation is used to identify a plane through three points. And it is applicable to the 
workpiece with an even surface and a tilt angle relative to the workbench. 

To execute three-point height measurement, do the following: 

1. In Height Measurement Mode area of Height Measurement dialog box, select By 
Three Points. 

2. To get three points (A, B, C) within the workbench, do one of the following: 

– Manually input workpiece coordinates of A, B and C. 

– Respectively move X-axis and Y-axis to A / B / C and click Set A / Set B / Set C. 
A, B and C are set as a measuring point. 

If you are not satisfied with the results, click Reset ABC and reset them. 

– To directly pick A, B and C on the object, click ABC by mouse and select three 
points in POS window. 

If you are not satisfied with the results, click Clear and reset them. 

3. Click Start. Height measurement starts. 
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During height measurement, you can do the following if there is something wrong: 

• If exceptions in the height measuring unit occur, measuring position is incorrect, or it 
is going to collide with the machine tool, click Stop to stop height measurement. 

• If the toolpath origin is set incorrectly, correct it, click XY Clear to clear workpiece 
coordinate of X-axis and Y-axis in the correct position, and measure height again. 

4.2.4 Measure Height with the Laser Sensor 

Compared with height measurement with the cylinder, this way can greatly improve the 
measuring precision and avoid possible damage to the workpiece by keeping the same 
distance between the tool head and the workpiece surface. And it is a perfect choice for 
rock workpieces with three-dimension or irregular surfaces. 

Before using height measurement with the laser sensor, ensure the following: 

• The laser sensor has been installed correctly. 

• The wiring between the laser sensor and host is correct. 

• The baud rate of serial ports has been set. 

To use height measurement with the laser sensor, do the following: 

1. In Height Measurement Mode area of Height Measurement dialog box, select By 
Scanning and set Sensor Port Address to the same port address with that in Device 
Manager dialog box of the host. 

2. Restart the software. 

  When the log Serial port has been successfully enabled appears, the laser sensor is 
successfully connected with the host. 

3. In Manual mode, click Altimetry in operation button bar, select By Scanning and 
click Open the Light, and observe if the light can be normally turned on or off: 

– Yes: Proceed to the next step. 

– No: Check the wiring and related settings of the communication port and laser 
sensor. 

4. To initialize the laser sensor, click Initialize Sensor. 

  When the prompt Succeeded in initializing the laser sensor appears, the laser sensor is 
successfully initialized. 
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5. To execute height measurement, select one of the following measuring methods: 

– Execute manual height measurement 

– Execute three-point height measurement 

– Execute scanning height measurement 

4.2.4.1 Execute Manual Height Measurement 

See Execute Manual Height Measurement for details. 

4.2.4.2 Execute Three-point Height Measurement 

See Execute Three-point Height Measurement for details. 

4.2.4.3 Execute Scanning Height Measurement 

With this completely new method, the scanning track can be automatically generated 
according to the preset workpiece information. 

During height measurement, the system automatically gets the datum at the start point of 
scanning track, then executes continuous scanning along the preset track at rapid speed, 
and gives feedback about precise height though the laser sensor. 

To execute scanning height measurement, do the following: 

1. In Height Measurement Mode area of Height Measurement dialog box, select By 
Scanning. 

2. Set the following parameters: 

– Scanning direction: The axis moving direction during scanning height 
measurement. 

– Horizontal space: It takes effect when scanning type is array scanning. 

— If the scanning direction is positive direction of X-axis, it is recommended to 
use the default horizontal space (50mm). 

– Vertical space: It takes effect when scanning type is array scanning. 

— If the scanning direction is positive direction of Y-axis, it is recommended to 
use the default vertical space (50mm). 

– Scanning speed: The axis moving speed during scanning height measurement. 

— To ensure the measuring precision, it is recommended to set it less than 
15000mm/min. 

– Travel lower limit: The minimum machine coordinate of Z-axis during scanning 
height measurement. 
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– Scan type: 

• Array scanning: Scan the workpiece along reciprocating lines that are 
automatically generated according to the object. 

• Track scanning: Scan the workpiece along the toolpath. 

– Height tolerance: The maximum deviation of height when XY-plane moves 
10mm. 

– Max height difference: The tolerate of difference between the maximum height 
and minimum one during scanning height measurement. 

– Ignore abnormal: Whether to ignore the limit of the parameter Max Ignorable 
Distance during scanning height measurement. 

  About parameter details, see Laser Height Measurement. 

3. Click Start. The system automatically generates the scanning track according to 
parameter settings and executes scanning height measurement. 

After height measurement, check Enable height measuring result and click OK. 

During height measurement, when one of the following situations occurs, data acquisition 
fails, an alarm Failed to collect data for Nth measuring point occurs and the system 
automatically stops scanning: 

• An exception occurs during scanning, e.g. exception in the power supply of the laser 
sensor, or the communication of the laser sensor, scanning is out of range, etc. 

• The height difference of the measuring area exceeds the set value of parameter 
N93214 Height Measurement Offset. 

• Sheet flaws. 

To continue to scan the remaining track, click B.P. Resume after dealing with these 
problems. 

4.3 Use Manual Locating 

This operation is applicable to the following situations: 

• During loading, precisely locating workpiece whose size is too large and the weight is 
too heavy and establishing a new coordinate system. 

• Based on the actual cutting situation, maximize utilization rate of workpiece during 
nesting. 
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Before using manual locating, ensure the following: 

• The NCE file has been loaded into NcStudio software. 

• The workpiece has been placed on the workbench. 

The methods of manual locating include the following: 

• One-point 

   

• Two-point 

   

• Three-point 
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Taking the two-point method as an example, to use manual locating, do the following: 

1. In Manual mode, click Operate → Locate Coor. Locate dialog box pops up: 

   

2. Check Use the located work-coor and select the axis whose travel is larger to locate 
in Locate-axis area. 

3. Select Two-point in Locate-Mode area and set Min-Length of BC in Machine Coor 
area. 

4. To get the machine coordinate of a point (B) on the workpiece edge, move the tool 
head in positive direction of the axis to the workpiece edge and click Set B in Machine 
Coor area. 
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5. To get the machine coordinate of an another point (C) on the workpiece edge, move 
the tool head in positive direction of the axis to the workpiece edge and click Set C. 

  Note: Please ensure B and C are in positive direction. Otherwise, the new origin cannot be between B and C. 

If you do not need to use manual locating again before machining normally ends, uncheck 
Use the located-workcoor in Locate dialog box and click OK. 

After locating: 

• If C coordinate is correct, the software automatically calculates the rotating angle of 
the workpiece relative to the machine coordinate system. Every time the system starts 
cutting, the workpiece coordinate system is automatically rotated to the 
corresponding angle. 

• If the actual distance between B and C is less than the setting value of Min-Length of 
BC, the prompt B and C is too close. appears. 

• If the rotating angle exceeds 45°, it means that the workpiece is over tilted. Please 
place the workpiece and execute locating again. 

After cutting, locating results will be automatically disabled but not removed: 

• If locating is not done for another cutting process, the cutting starts without rotating 
angle. 

• If the results are desired for another cutting process, check the box in front of Use the 
located-workcoor to apply last locating results to this cutting. 

4.4 Scan a QR Code 

This operation is used to recognize and load a program file in NcStudio V10 Waterjet 
Cutting CNC System with a barcode scanner. 

4.4.1 Name the Program File 

The supported format of program files include DXF, NC, G and NCE. 

According to the following conventions, name the program file: 

• The file name should contain at least 1 non-space character, and at most 28 characters. 

• The file name can only contain the following: 

– English letters 

– Numbers 

– Special characters: “~”, “!”, “@”, “#”, “$”, “%”, “^”, “&”, “( )”, 
"_“,”+“,”{ }“,”[ ]“,”;“,”’“,”,“,”.“,”`“,”=" and space 
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4.4.2 Recognize the Program File 

This operation is used to recognize the program file with a barcode scanner. 

Before recognizing the program file, ensure the following: 

• The version of NcStudio software is 10.515.2 or above. 

• The name of program file is correct. 

• The characters on the barcode are the same with the name of program file. 

• The system is in English input mode. 

• Parameter Barcode Enable is set to Yes. 

• The barcode scanner is connected correctly. 

To recognize the program file, do the following: 

1. Start the system and ensure it is in idle status. 

2. To set a storage path for the program file, click File → Set File Path. 

3. Put the target program file under the set storage path. 

  If there exist files with the same name, but in different formats, the format loaded first 
is decided by the parameter Priority Loading File Format. 

4. To ensure the focus is on the software interface, click on it by your mouse. 

5. Scan the corresponding barcode with the barcode scanner. 

If scanning succeeds, the system automatically loads the program file and shows the 
machining track. 

If scanning fails, troubleshoot the following: 

• If the prompt The file path is illegal. Please check. appears, modify the storage path for 
the program file. 

• If the prompt Current file does not exist. Please check. appears, modify the storage path 
for the program file or put the program file under the set storage path. 

• Check if parameter Barcode Enable is set to No. 

• Check if the system is in English input mode. 
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4.5 Set Punching Parameters for the Waterjet Tool 

Waterjet cutting uses high-speed and high-energy water current to cut material. Before 
feeding motion, the water current should penetrate the material. For hard and thick 
material, this cutting method can help to improve the machining efficiency and reduce 
material consumption in a great extent. 

To set punching parameters for the waterjet tool, do the following: 

1. Click Machine Tool → System Parameters. System Parameters dialog box pops up. 

2. Click Water Jet and set punching parameters. 

  About punching parameters, see Punching Parameters. 

3. Reload the program file. The modification to punching parameters takes effect. 

  See Load the Program File for details. 

During machining, the whole process is as follows: 

1. Execute punching. 

2. Cut the lead line. 

3. Machine the program file. 

4.6 Check Time Statistics for High Pressure Valve and Oil Pump 

This operation is used to check the used time of valuable and wearing parts high pressure 
valve and oil pump, so as to regularly maintain them and replace them in time. 

To check time statistics for high pressure valve and oil pump, do the following: 

1. Click Machine Tool → H.P and Oil Pump Time Statistic. H.P and Oil Pump Time 
Statistic dialog box pops up: 
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2. Check the used time for the high pressure valve and oil pump, and judge if it is 
necessary to maintain or replace them. 

  If necessary, maintain or replace them and do the following: 

1. To activate input boxes HP Time and Oil Pump, click Edit and input the 
manufacturer password. 

2. To clear the used time for the high pressure valve and oil pump, set parameters 
HP Time and Oil Pump to 0. 

4.7 Execute Z-axis Jiggle 

This operation is used to adjust height of the tool head, so as to find the best cutting height. 

Before executing Z-axis jiggle, ensure the system is in running status or pause status. 

To execute Z-axis Jiggle, do the following: 

1. Click Params. Params dialog box pops up: 

   

2. Click Auto to enter Auto interface and set the following parameters in Z-axis Jiggle 
area: 

– Speed: The speed of moving axis during jiggle. 

– Step size: The step size of moving axis during jiggle. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 75 / 195 

 

3. To adjust the tool head to the best cutting height, in Auto mode, click  or 

 (or press 7 or 1 on the keyboard). 

4.8 Execute Y1Y2 Jiggle 

This operation is used to eliminate offset and reset the datum of Y-axis when machine 
coordinates of Y1-axis and Y2-axis exist offset, so as to simplify operations and save time. 

It is only applicable to machine tools with diverter double Y whose Y1-axis and Y2-axis 
motors are connected to two separate interfaces of the terminal board. 

To execute Y1Y2 jiggle, do the following: 

1. To activate the button Y1Y2 Jiggle, in POS DIAG window, click Fix Y Only. 

2. Click Y1Y2 Jiggle. Y1Y2 Jiggle dialog box pops up: 

   

3. Select a step size or click  to customize a step size. 

4. According offsets of Y1-axis and Y2-axis, click axis buttons and move Y1-axis or Y2-
axis. 

For an absolute encoder, after executing Y1Y2 jiggle, click Reset DY Datum to directly 
reset the datum of Y-axis. 
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4.9 Back up Technic Parameters 

This operation is used to back up technic parameters, so as to conveniently edit and use 
them. 

Before backing up technic parameters, ensure the program file has been loaded. 

To back up technic parameters, do the following: 

1. Click Params. Params dialog box pops up. 

2. To enter Technics interface, click Technics: 

   

3. Click Add in the lower left of list. 

4. Set a group name for all technic parameters. 

The system backs up all technic parameters. 

After backing up technic parameters, according to the actual situation, do one of the 
following in the left list: 

• To delete a group of technic parameters, select the target group name and click Delete. 

• To apply your back-up parameters, select the target group name, click Apply. 

  After the operation, reload the program file to make back-up parameters effective. 
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• To import the local group of technic parameters, click Import, select the target local 
file and click Open. 

  After the operation, reload the program file to make back-up parameters effective. 

• To export the local group of technic parameters, select the target group name, click 
Export, input the file name and click Save. 

• To rename the group name, double click the target group name, input a new name and 
click OK. 

4.10 Nest Parts 

This operation is used to nest one or more kinds of parts in NcEditor based on part priority 
and the highest material utilization rate. Through previewing nesting effect and analyzing 
nesting results, including the sheet utilization rate and distribution of scrap material, 
material utilization and machining efficiency can be improved. 

Before nesting parts, ensure you have bought the dongle from your supplier, and plugged it 
into the USB interface of your host or industrial personal computer (IPC). 

To nest parts, do the following: 

1. Select toolpaths in the drawing area. 
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2. Click File → Nest. Nest dialog box pops up: 

   

3. To edit part information, select the target part in Part area and do one of the 
following: 

– Click Edit and modify the following: 

• Priority: On the premise of maximizing sheet utilization, the system 
prioritizes nesting toolpaths with higher priority. 

• Part Quantity: Total parts that you would like to nest. 

• Rotate Angle: Rotation way and rotation angle of parts. The default 
selection is free rotation. 

– Double click Priority, Part Quantity or Rotate Angle column for the target 
part and do modification. 
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4. Select the target sheet in Material area, click Edit, and modify the following: 

– Sheet Name 

– Sheet Quantity: Total sheets. And it should meet the following: Sheet Quantity 
* Sheet Size ＞ Part Quantity * Part Size 

– Width: Actual sheet width. 

– Height: Actual sheet height. 

5. Click Setting, set the following nesting parameters and click OK: 

– Material Margin and Part Space: The distance between parts and the edge of 
sheet, and distance between parts. 

– CoEdge: Parts with zero space share a line. It helps to reduce operations and 
save time. 

– Start Corner: The position to start nesting. 

– Nest direction: The nesting direction, including vertical direction and 
horizontal direction. 

  You can preview nesting effect in the right area. 

6. Click Execute. Nesting results (sheet utilization) show in Sheet area. 

After nesting, do one of the following: 

• If you are not satisfied with the results, reset part information, material information 
and nesting parameters and do nesting again. 

• If you are satisfied with the nesting results, click OK. The nested parts show in the 
drawing area. 
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4.11 Use the Drill 

This operation is used to bore a hole at the start point of object with the drill unit, so as to 
save time to cut objects and improve machining efficiency. 

To use the drill, do the following: 

1. In Manual mode, click Drill. Hole-drilling dialog box pops up: 

   

2. Check Driller ON at the upper left corner. 

3. Select a drilling mode in Drilling Mode area: 

– By Cylinder: The drill spindle is fixed on the cylinder while the cylinder on the 
Z-axis. And boring holes are realized by push-out actions of cylinder. 

– By Z-axis: The drill spindle is fixed on the cylinder while the cylinder on the Z-
axis. After the cylinder pushes out the drill in position, boring holes are realized 
by up-down actions of Z-axis. 
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4. Select a drilling strategy in Drilling Strategy area: 

– Single: During cutting multiple objects, bore a hole in one object and then cut 
this object before executing the same operation for one another. 

– Batch: During cutting multiple objects, bore a hole in each object and then cut 
them in turn. 

5. To bore a hole, do one of the following: 

– Automatic drilling: 

1. Set drilling parameters in Drilling Parameters area. 

  About parameter details, see Drilling. 

2. Measure the X-axis / Y-axis offset between centers of the drill and the 
abrasive tube, check Manufacturer at the lower left corner, input the 
manufacturer password, and input the X-axis / Y-axis offset in Offset 
Parameters area. 

3. In Auto mode, click Start. The system starts boring a hole. 

– Manual drilling 

In Manual Drilling area. click Driller ON → Cylinder ON → Start Drilling. The 
system starts boring a hole. 

Note: The system automatically switches to the drill unit during boring a hole and switches to the waterjet tool 
during cutting. 
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4.12 Use the Velocity Model Calculator 

As an auxiliary tool for improving the machining effect, the velocity model calculator is 
supported by the relatively accurate theoretic math model. It can provide an reference for 
machining velocity, so as to solve such problems as the coarsely cut surface, over cutting at 
the corner and bad quality of small arcs. 

This operation is applicable to the high-precise machining for metal, glass, thick sheets and 
the other special material. 

To use the velocity model calculator, do the following: 

1. Click Help → Velocity Calculator. Velocity Calculator dialog box pops up: 
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2. To add material, do one of the following: 

– Drag the slider bar and directly select the target material type. 

– Click Add and input the material name and machinability index. 

— Note: About the machinability index of the added material, contact us. 

3. According the actual conditions, input material information in Input Information 
area: 

– Thickness: You can choose thickness 5mm, 10mm and 15mm, or customize 
thickness by clicking Add Material. 

– Jewel Orifice Dia.: The diameter of the jewel nozzle. 

– Mixing Tube Dia: The diameter of the abrasive tube. 

– High Pressure: The high pressure during machining. 

– Abrasive Flow: The flow of abrasive sand. 

4. Select a quality level for cutting in Output Information area and click Set. 

5. Click Machine Tool → Optimize Cutting Speed, check Optimize Cutting Speed in the 
pop-up dialog box and click Reload. 

The speed calculated by the velocity model calculator takes effect during cutting. 

4.13 Shoot with a Camera 

This operation is used to precisely locate the workpiece and extract its contour, which is 
good for layout and quick cutting. 

Before shooting with a camera, do the following for commissioning: 

1. Correctly install a camera and light and do wiring. 

2. Adjust the camera, including its height, shooting direction and brightness and focus. 

3. Install the visual algorithm software (WeiHongCanon.exe) and NcStudio V10 
Waterjet Cutting Control System whose version is 10.515.2 or above. 

4. Plug the dongle with the visual algorithm into the USB interface of your host. 

To shoot with a camera, do the following: 

1. Do camera settings. 

2. Extract the contour. 

3. Use the gallery and lay out objects. 
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4.13.1 Do Camera Settings 

This operation is used to set the positioning parameters for the camera, and ensure 
shooting goes on well. 

To do camera settings, do the following: 

1. In NcStudio, click Machine Tool → System Parameters. System Parameters dialog 
box pops up. 

2. Click Param → Other → Manufactory and input the manufacturer password. 

3. Find and set positioning parameters. 

  About parameter details, see Positioning. 

4. In NcEditor, click Draw → Camera Settings. Camera Settings dialog box pops up: 

   

5. Set camera parameters. 

6. Calibrate coordinates. 

7. Correct the image. 
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4.13.1.1 Set Camera Parameters 

In Camera Settings dialog box, set the following in Parameters area: 

• Aperture: The larger the value, the smaller the aperture. At this time, less light gets 
through in unit time, the shoot becomes darker and the field in your shoot deeper. 

  Range: 2~22 

  Recommended value: 22 

• Shutter speed: The larger the value, the slower the shutter speed. At this time, more 
light gets through in unit area and the shoot becomes brighter. 

  Range: 1/8000~10 

• ISO: It measures the sensitivity of the image sensor. The larger the value, the more 
sensitive the image sensor. At this time, the shoot becomes brighter but noise becomes 
more. 

  Recommended value: 100 

• Accuracy: The larger the value, the fewer the contour detail. 

  Range: 50~255 

• Min gray scale: It will influence the contour extracting effect. If the background is black 
and the workpiece is white, set Max Grayscale to 255 and adjust the minimum gray 
scale. 

• Max gray scale: It will influence the contour extracting effect. If the background is 
white and the workpiece is black, set Min Grayscale to 0 and adjust the maximum 
gray scale. 

4.13.1.2 Calibrate Coordinates 

This operation is used to establish the corresponding relation between the calibrated 
coordinates and actual coordinates on the machine tool. 

Please carefully execute each step. Otherwise, calibration precision will be affected. 
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4.13.1.2.1 Execute Calibration 

To execute calibration, in Calibration area of Camera Settings dialog box, do the 
following: 

1. To shoot the machine tool and get four calibration points (red points), place four 
calibration blocks on the machine tool, click Cali Start: 

   

2. To get machine coordinates of the target calibration point, aim this calibration point 
with the laser sensor and click Get Coor. The system automatically fills in machine 
coordinates into MCS X and MCS Y input boxes. 

  Coordinates of the Calibration Point = Current Coordinates - Offset betwe
en the Tool Head and Laser Sensor 

3. To get pixel coordinates of the corresponding calibration point, move the mouse 
pointer on this calibration point, scroll the mouse wheel to zoom in the point, right 
click until finding the precise position of the calibration point. The system 
automatically fills in pixel coordinates into Pixel X and Pixel Y input boxes. 

4. To add the current calibration point, click Add Point. The system automatically fills in 
its calibrating coordinates into the table in the lower right. 

5. To add at least four calibration points, repeat above steps. 

  If added calibration points are incorrect, click Clear Point and add them again. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 87 / 195 

 

6. After getting four groups of calibrated coordinates, click Calculate. 

After calculation ends, click Cali Stop. The corresponding relation between travels of the 
pixel coordinate and machine coordinate is established. 

Note: If exceptions occur, such as power is off, the position of calibration block changes, the camera shakes, during 
calibration,please click Reset Status and calibrate coordinates again. 

4.13.1.2.2 Verify the Calibrating Result 

This operation is used to judge if the positioning error is within 1mm~2mm. 

To verify the calibrating result, do the following: 

1. Follow step 1 ~ 3 of Execute Calibration, get machine coordinates and pixel 
coordinates of one another calibration point: 
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2. Click Distort Collect. Distort Collect dialog box pops up: 

   

3. In Coordination Transform area, input pixel coordinates of this calibration point into 
Image X and Image Y input boxes. 

4. Click Calculate. NcEditor automatically calculates actual machine coordinates. 

5. Compare actual machine coordinates and the machine coordinates from step 1, and 
judge if the positioning error is within 1mm~2mm. 

  If not, calibrate coordinates again. 

4.13.1.3 Correct the Image 

In Operator area of Camera Settings dialog box, to correct the image, set the following 
and click Correct Image: 

• Lower Left X / Y: The lower limit of workbench travel. 

• Mach Width: The length of workbench in X-axis direction. 

• Mach Height: The length of workbench in Y-axis direction. 
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4.13.2 Extract the Contour 

This operation is used to extract the contour of workpiece, so as to get the tilt angle of 
workpiece relative to the workbench. And after setting the type of objects on the 
workpiece, objects can be rotated to the same angle. 

To extract the contour, do the following: 

1. In NcEditor, click Dustcover On. The cylinder of dust cover and light turns on. 

2. Click Self-check. The camera automatically shoots and import the image into 
NcEditor according to proportional scale 1:1: 

   

3. To select the target region to recognize, do one of the following: 

– Click Set Region. Valid regions in the image are automatically selected. 

— Every time you click Self-check, only the workpiece contour within the valid 
region can be extracted. 

– Click Contour Correct, manually select regions to recognize and extract the 
workpiece contour. 
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4. Click Show Contour / Hide Contour. The extracted workpiece contour shows / hides 
in the image. 

If you are not satisfied with the result, to extract the contour again, click Gain Angle and 
select two points on the lower edge of workpiece (that is parallel to X-axis). The system 
automatically extracts the workpiece contour again. 

4.13.3 Use the Gallery and Lay out Objects 

This operation is used to import program files into the gallery of NcEditor and lay out 
these objects on the workpiece. 

The supported format of program file includes G, NC and DXF. 

To use the gallery and lay out objects, do the following: 

1. In NcEditor, click Draw → Custom Gallery. Gallery dialog box pops up: 

   

2. To import the program file of target object into the gallery, click Import Graphics. 

3. In Graphic Position area, set position parameters for the object and click Import to 
NcEditor. 
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4. In NcEditor, manually lay out the target object, save the program and start machining. 

In Gallery dialog box, according to the actual situation, do one of the following: 

• To delete the object in the gallery, select the target object and click Delete the 
Selected. 

• To clear all imported objects, click Clear Gallery. 

4.14 Adjust Five-axis Tool Head Errors 

This operation is used to reduce errors and improve cutting precision. 

Before adjusting five-axis tool head errors, do the following: 

• Return A-axis and C-axis to machine origin. 

• Prepare an extended testing rod and a dial indicator with a flat head for measuring. 

To adjust five-axis tool head errors, do the following: 

1. Click Machine Tool → Five Axis Error Compensation. Five Axis Error 
Compensation pops up: 
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2. Optional: If it is not your first time to adjust five-axis tool head errors, uncheck 
Enable Compensation at lower left corner and click Yes. 

3. Click Guide at the upper right corner. Error compensation guide dialog box pops up. 

4. Execute adjustment according to steps in Error compensation guide dialog box. 

5. To make the compensation result effective, check Enable Compensation at the lower 
left corner and click Yes. 

5 Common Operations 

Through this section, you can quick know common operations of NcStudio V10 Waterjet 
Cutting Control System. 

Common operations include the following: 

• Manage Wearing Parts 

• Rotate or Mirror Machining Objects 

• Execute Breakpoint Resume 

• Control Abrasive Flow 

• Set Valve On and OFF Order 

• Use Customized Commands 

• Use NcGateway 

• Check Machining Information 

• Check Ports 

• Check Logs 
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5.1 Manage Wearing Parts 

This operation is used to count the service life and used time of wearing parts, and show a 
prompt before the service life runs out, so as to help to replace wearing parts in time. 

To manage wearing parts, do the following: 

1. Click Machine Tool → Deadline Manage. Device deadline manage dialog box pops 
up: 

   

2. Set the following parameters: 

– Deadline: The service life of each wearing part. 

– Forecast time: The time to show a prompt that the service life will run out. 

3. Select wearing parts that need to show a prompt in Tip or not column: 

– When the set forecast time is up, the system sends a yellow warning in CNC 
status bar. 

– When the set deadline is up, the system sends a red error in CNC status bar. 

4. Optional: To reset the used time of wearing parts after replacing them, click Clear in 
Zero Passed Time column. 

  The time in Passed time column is accumulated and cannot automatically be cleared 
even after replacing wearing parts. So, please manually clear it. 

Note: Alternatively, you can manage wearing parts through the WebChat version of NcCloud. 
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5.2 Rotate or Mirror Objects 

This operation is used to rotate or mirror objects for a program file. 

To rotate or mirror objects, do the following: 

1. Click Operate → Circumgyrate Mirror Process. Circumgyrate Mirror Process 
dialog box pops up: 

   

2. To select a rotation or mirroring strategy, do one of the following: 

– To mirror objects along X-axis, select X Axes Mirror. 

– To mirror objects along Y-axis, select Y Axes Mirror. 

– To rotate objects 90º in CW direction, select Circumgyrate 90 degree deasil. 

– To rotate objects 180º in CW direction, select Circumgyrate 180 degree 
deasil. 

– To rotate objects 90º in CCW direction, select Circumgyrate 90 degree 
anticlockwise. 

  No circumgyrate means the system does not rotate and mirror objects. 

3. Click OK. 

The system automatically executes the selected operation for the loaded program file. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 95 / 195 

 

5.3 Execute Breakpoint Resume 

This operation is used to resume machining on the breakpoint if power off or E-stop occurs 
during machining, so as to save the machining time. 

Before executing breakpoint resume, ensure workpiece coordinates are accurate. 
Otherwise, please return to the machine origin first. 

In the menu bar, click Operate → Breakpoint Resume. The cutting resumes from the 
position where it stopped last time. 

5.4 Control Abrasive Flow 

This operation can be divided into the following: 

• Control abrasive flow by analog quantity 

  It is used to control abrasive flow by adjusting the analog voltage output of Lambda 
terminal board that connects to the motor of abrasive valve. 

• Control abrasive flow by spindle 

  It is used to control abrasive flow by bus control system sending pulse to control the 
speed of stepping motor that connects to the abrasive valve. 

  It has more precise control and higher cutting precision. 

5.4.1 Control Abrasive Flow by Analog Quantity 

Before controlling abrasive flow by analog quantity, ensure parameter Abrasive Value 
Control Mode has been set to 0. 

The relation among the actual output voltage of abrasive valve, the set output voltage and 
rate of analog output voltage is as follows: 

Actual Output Voltage = Set Output Voltage × Rate of Analog Output Voltage 

To control abrasive flow by analog quantity, do the following: 

1. Click Machine Tool → System Parameters. System Parameters dialog box pops up. 

2. Click Param → Operation → Manufacturer, input the manufacturer password, find 
and set the parameter Abrasive Value Output Voltage. 

3. To adjust the rate of analog output voltage, in Auto mode, drag S. R. (N) slider in 
machine tool control bar. 
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5.4.2 Control Abrasive Flow by Spindle 

Before controlling abrasive flow by spindle, ensure the following: 

• The manufacturer parameter Abrasive Value Control Mode has been set to 1. 

• The drive subdivision is the same with the default value of internal parameter Pulse 
Output. 

The relation among the actual motor speed, the set motor speed and the rate of motor 
speed is as follows: 

Actual Motor Speed = Set Motor Speed * Rate of Motor Speed 

To control abrasive flow by spindle, do the following: 

1. Click Params → Machine Tool, check Manufactory at lower left corner, find and set 
the parameter Stepper Motor Speed. 

2. To adjust motor speed, in Auto mode, drag S. R. (N) slider in machine tool control bar. 

5.5 Customize Valve ON / OFF Order 

This operation is used to customize the order of turning on / off valves according to your 
need. 

To customize valve ON / OFF order, do one of the following: 

• Chick Machine Tool and do the following: 

1. For valve ON order, click Open Valves Order, and select an order. 

2. For valve OFF order, click Close Valve Order, and select an order. 

• Click Machine Tool → Open/Close Booster / Open/Close H/L / Open/Close H.p. / 
Open/Close Cut / Open/Close Abrasive. 

During machining, the system turns on / off these valves according to the set order. 
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5.6 Use Customized Commands 

This operation is used to input and execute at most 10 simple commands, so as to make 
machine tools move quickly or execute simple operations. 

To use customized commands, do the following: 

1. Click Window → Manual Code. Manual Code dialog box pops up: 

   

2. Click Edit, input commands in the pop-up dialog box and click OK. 

  All commands that have been input will be automatically saved for later use. 

3. To execute the target command, click Execute after the corresponding command. 
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5.7 Use NcGateway 

This operation is used to manage the CNC system by NcGateway, which is a component of 
Weihong IIoT solution and can provide data interface and communication protocols. 

About NcGateway, see NcGateway for details. 

To use NcGateway, click Help → WeihongCloud. WeihongCloud dialog box pops up: 

 

• Device information: It is used to check the basic information of the host and telephone 
number of technical support and edit its basic information. 

• Data management: It is used to import an authorization file for enabling MTConnect, 
OPC UA protocols and local data backup. 

• Remote monitoring: It is used to remotely monitor the running data and control the 
CNC system. 

• Online repair: It is used to report a repair to the maintainer and check the repair 
record online. 

• Device registering: It provides the QR code, device number and registration 
information for registering the CNC system. 
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• Data analysis: It is used to check the yesterday’s utilization rate and OEE, distribution 
of today’s working time (running, idle, E-stop and unavailable) and counts of today’s 
error, warning and smart information. 

• System setup: It is used to set the usage habit, IP or domain name of xFactory and 
related parameter of sampling data. 

5.8 Check Machining Information 

This operation is used to check machining information, including start time, machined time, 
cutting length and so on, and calculate machining charge if necessary. 

To check machining information, do the following: 

1. To enter Info window, click Info: 

   

2. Check the following machining information: 

– Process Time: Start time 

– Gxx L.: Cutting length 

– Total L.: Machining length 

– Gxx Time: Cutting time 

– Total Time: Machined time 

– Count: Number of units 
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3. Optional: To calculate machining charge, do the following: 

1. Select at least a program file. 

2. Select a charge type from the following: 

• Gxx L. 

• Total L. 

• Gxx Time 

• Total Time 

3. Input unit price (Unit: yuan). 

4. Click Calc to start calculation. 

5.9 Check Port Information 

This operation is used to check port information, conduct a simulation test and modify 
polarity for ports and so on. 

The relation between the status of the machine tool and IO ports is as follows: 

• Input port:  means no signal while  means having a signal. 

• Output port:  means no signal while  means having a signal. 
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To check port information, do the following: 

1. To enter IO PORT window, click IO PORT: 

   

2. Select the target port and do one of the following: 

– To conduct a simulation test, click Test On: 

• Input port:  

• Output port:  

– To close a simulation test, click Test Off: 

• Input port:  

• Output port:  

– To cancel a simulation test, click Canl Tst. 

– To cancel all simulation tests, click Canl All. 

– To modify the port polarity, click Convt Port. 

– To show all supported ports, click Disp All. 
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– To set the port attribute, click Port Attr and do one of the following in Inport 
Sampling Setting dialog box : 

—  

• Set the sampling interval. 

• Enable Filter and Port Enabled. 

• Rename the port. 

• Modify the port description. 
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5.10 Check Logs 

This operation is used to check different types of logs that record important operations and 
system events, including logs after this startup and historical logs. 

To check logs, do the following: 

1. To enter LOG window, click LOG: 

   

2. To check different types of logs, do one of the following: 

– Click Info. Logs with icon  about running status show in the window. 

– Click Warning. Warnings with icon  show in the window. 

– Click Error. Errors with icon  show in the window. 

– Click System. System logs with icon  show in the window. 

– Click Nowadays and click Info / Warning / Error / System. The 
corresponding logs that generate after this startup show in the window. 

  These buttons are clicked by default. 
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In LOG window, you can do one of the following: 

• To refresh logs, click Refresh. 

• To clear all logs, click Clear. 

  Note: Please regularly clear logs. Otherwise, too many log files will slow down the system. 

6 Object Edition 

Through this operation, you can know auxiliary drawing operations in NcEditor: 

• Bridge Objects 

• Use Micro Joint 

• Use Chamfer 

• Set the Groove Direction 

• Set Tool Compensation 

• Set a Lead Line 

• Reverse the Lead Line 

• Sort the Machining Order 

• Use Vertical Plunge 

• Set the Tilt Angle and Cutting Speed 
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6.1 Bridge Objects 

This operation is used to connect two objects close in distance with a bridge, so as to avoid 
unnecessary operations, such as lifting the tool and turning on / off valves, and reduce 
wear of wearing parts, like the high-pressure valve and oil pump. As a result, machining 
efficiency can be improved. 

To bridge objects, do the following: 

1. In NcEditor, click  and select at least two target objects. 

2. Click  in the tool bar. Bridge Connect dialog box pops up. 

3. Set bridging width and click OK. 

4. In the drawing area, click the internal area of an object, move the mouse to the internal 
area of the other object. 

The bridging result shows in the drawing window: 
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6.2 Use Micro Joint 

This operation is used to set reserved segments that are not cut during machining, so as to 
connect the cutting part with the material and avoid the part falls into the water sink. 

To use micro joint, do one of the following: 

1. In NcEditor, click  and select the target object. 

2. To open Add micro joint mode setting dialog box, do one of the following: 

– In the menu bar, click Object → Micro Joint. 

– In the drawing area, right click and select Micro Joint in the pop-up menu. 

   

3. Select the mode of micro joint: 

– Auto mode: Set the following and click OK: 

• Quantity: The quantity of reserved segments on the object. 

• Width: The width of reserved segments on the object. 

– Manual mode: Set the width of reserved segments, and select the position of 
reserved segments on the object in the drawing area. 
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6.3 Use Chamfer 

This operation is used to cut the arris into a line or an arc, so as to remove burrs from parts 
caused by machining, and help part assembly. 

Before using chamfer, ensure the following: 

• The target object has at least one arris formed by two lines. 

• Standard 5-axis machining has been enabled. 

To use chamfer, do the following: 

1. In NcEditor, to open Chamfer Setting dialog box, do one of the following: 

– In the menu bar, click Object → Chamfer. 

– In the drawing area, right click and select Chamfer in the pop-up menu. 

   

2. Select a chamfer type: 

– Chamfer: to cut the arris into a line. 

– Fillet: to cut the arris into an arc. 

3. Select a chamfer mode: 

– Two edges: Add chamfer for two selected adjacent edges. 

– Within objects: Add chamfer for all angles of all objects by batch. 
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4. To set the chamfer size, according to the chamfer type, do one of the following: 

– Chamfer: Select Distance and set chamfer distance of two edges, or select 
Angle and set chamfer length and angle of the first edge. 

– Fillet: Input the chamfer radius. 

5. Click OK. The cursor shape changes. 

6. According to the chamfer mode, do one of the following: 

– Two edges: Select two target edges in the drawing area. 

– Within objects: Select the target object. The system automatically adds chamfer 
for all included angles. 

6.4 Set the Groove Direction 

This operation is used to set the tilt angle for the cut surface by setting the groove direction 
of toolpath, so as to meet the requirement for the tilt angle during machining medallion 
technics. 

It differs in the object type: 

• For closed objects 

• For unclosed objects 

After setting the groove direction, to check the groove direction, click  in the tool bar of 
NcEditor. 
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6.4.1 For Closed Objects 

To set the groove direction for closed objects, do the following: 

1. In NcEditor, click  and select the target closed object. 

2. Click  in the tool bar and select Enable standard 5-axis machining or Enable 
Edit Inclination Angle. 

3. Do one of the following in the tool bar: 

– For Enable standard 5-axis machining 

• To change the groove direction, click . 

• To change the groove direction and valid region, click . 

– For Enable Edit Inclination Angle 

• To change the groove direction, click  / . 

• To change the groove direction and machining direction, click  / 

. 

• To change the groove direction and valid region, click . 

6.4.2 For Unclosed Objects 

To set the groove direction for unclosed objects, do the following: 

1. In NcEditor, click  amd select the target unclosed object. 

2. Do one of the following in the tool bar: 

– To change the groove direction, click  / . 

– To change the groove direction and machining direction, click  / . 
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6.5 Set Tool Compensation 

This operation is used to compensate the tool diameter on the designed machining 
dimension, so as to reduce the offset between the actual machined dimension and designed 
dimension, which is caused by the tool diameter. 

To set tool compensation, do the following: 

1. In NcEditor, click  and select the target object. 

2. Click  in the tool bar. Tool Compensation dialog box pops up: 

   

3. Check Enable Cutter Comp and select a type of tool compensation: 

– Auto: The system will automatically set the position of tool compensation 
according to the groove direction. The default position is at the side of toolpath 
in the scrap region. 

– Left: Along the machining direction, compensate the tool diameter on the left of 
workpiece. 

– Right: Along the machining direction, compensate the tool diameter on the 
right of workpiece. 

– Tilt angle: The kerf width differs in the tilt angle. According to different tilt 
angles, compensate the corresponding tool diameter. 

4. According to the actual tool diameter, set parameter Tool Dia. 

5. Click OK. 
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To delete added tool compensation, select the target object and do one of the following: 

• In the tool bar, click . 

• In Tool Compensation dialog box, uncheck Enable Cutter Comp and click OK. 

6.6 Set a Lead Line 

This operation is used to set a lead line in scrap region (invalid region) for closed objects, 
so as to avoid possible cutting errors or damage to the workpiece caused by the tool 
dwelling above the start point of machining for a long time. 

To set a lead line, do the following: 

1. In NcEditor, click  and select the target object. 

  Note: You can check the groove direction by clicking . 
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2. To open the Lead Line dialog box, do one of the following: 

– In the tool bar, click  . 

– In the drawing area, right click and select Set Lead Line in the pop-up menu. 

– In the menu bar, click Object → Set Lead Line.  

   

3. Select a lead line group : 

– Smart Planning: The software automatically selects a group among the preset 
groups for the target object. 

– Manual Planning: Manually select a group among the preset groups for the 
target object. 
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  The preset groups include the following: 

– Corner extension: The extension line of corner. 

 

– Inner hole Arc: With an arc shape, the lead line is at the center position of the 
longest edge. 

 

– Vertical Guide line 

 

4. Select the following mode of lead line: 

– Angel and length 

– Line and arc 

– Offset 

5. Set the type of lead-in line and lead-out line. 
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6. Select one of the following strategies for the lead line: 

– Edge first: Set the lead line at the center position of the longest edge of the 
closed object. 

– Corner first: Set the lead line at the corner with the largest angle in the closed 
object. 

7. Set parameter Seal Len. 

– If it is greater than 0, the waterjet tool will over cut at the sealing position. 

– If it is less than 0, the waterjet tool will not cut through at the sealing position. 

8. To add a lead line, do one of the following: 

– Click OK. Lead lines will be automatically added. 

– Click ManualSet and select the position of lead line by your mouse. 

To delete the added lead line, select the target object and do one of the following: 

• In the tool bar, click . 

• In Set Lead Line dialog box, set the type of lead-in line and lead-out line to None and 
click OK. 
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6.7 Reverse the Lead Line 

In general, the groove direction is in the internal region of the object while the lead line is 
added to the external region of object. This operation is used to reverse the lead line 
without changing the groove direction, so as to make them both in the internal region of 
object. 

At this time, the scrap region of workpiece (invalid region) is the the internal region of 
object. 

Before reversing the lead line, ensure the lead line has been added. 

To reverse the lead line, do the following: 

1. In NcEditor, click  and select the target object. 

2. To reverse the lead line, click  in the tool bar. 

The result is as follows: 

 

• Red arc: lead line 

• Green dash line: groove direction 

6.8 Sort the Machining Order 

This operation is used to sort the machining order for several objects in the program file. 

To sort the machining order, do one of the following: 

• Automatically sort the machining order. 

• Manually sort the machining order. 

• Set the machining order in the list. 
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6.9 Automatically Sort the Machining Order 

This operation is used to automatically sort the machining order for several objects. 

To automatically sort the machining order, do the following: 

1. In NcEditor, click  and select the target object. 

2. To open Auto Sort dialog box, do one of the following: 

– In the tool bar, click . 

– In the drawing area, right click and select Auto Set Machining Orderin the 
pop-up menu. 

– In the menu bar, click Object → Auto Set Machining Order. 

   

3. Select one of the following strategies in Sort Strategy area: 

– Minimum Distance: Sort the machining order by the stipulated minimum 
distance. 

– Horizontal Direction: Sort the machining order in X-axis direction. 

– Vertical Direction: Sort the machining order in Y-axis direction. 
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4. Set the start position of sorting in Start Position area: 

– Top Left 

– Top Right 

– Bottom Left 

– Bottom Right 

5. Optional: To set the sorting direction, check one or several option(s) in Advanced 
Options area: 

– Inside object first: The system sorts the machining order from the inside to the 
outside when several objects are nested. 

– Two-way sort: Based on the selected the sort strategy and start position, the 
system alternately sorts the machining direction based on one of the following: 

• One row from left to right and another row from right to left. 

• One column from top to bottom and another column from bottom to top. 

– Scan width: Based on the set scanning width, the system sorts the machining 
direction. 
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6.9.1 Manually Sort the Machining Order 

This operation is used to select one object and manually input its machining order. 

To manually sort the machining order, do the following: 

1. In NcEditor, click  and select one single object. 

2. To open Manual specify object mach. order dialog box, do one of the following: 

– In the drawing area, right click and select Manual Set Machining Orderin the 
pop-up menu. 

– In the menu bar, click Object → Manual Set Machining Order. 

   

3. Specify a number among 1 ~ n and click OK. 

  n is the total of objects and the maximum number. 
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6.9.2 Set the Machining Order in the List 

This operation is used to modify the machining order in the list for at least 2 objects 
according to the object number specified by the system. 

To set the machining order in the list, do the following: 

1. In NcEditor, to open Machining List dialog box, do one of the following: 

– In the menu bar, click Object → Machining Order List. 

– In the drawing area, right click and select Machining Order Listin the pop-up 
menu. 
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2. To adjust the machining order, check the target object number and double click the 
other numbers. The former is listed in front of the latter. 

  E.g. Check 0002 and double click 0007. Then 0002 is listed in front of 0007. 

   

  With Follow the object checked, the former is listed behind the latter. E.g. 0002 is 
listed behind 0007. 

3. Click OK. The system cuts objects from top to bottom in the list. 
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6.10 Use Vertical Plunge 

The abrasive tube keeps vertically downward to penetrate workpieces at the start point of 
object, and then the rotary axis swings to the correct cutting position. As a result, damage 
to the vulnerable and layered workpieces caused by punching can be reduced. 

It is only applicable to NCE files. 

To use vertical plunge, do the following: 

1. In NcEditor, to open NcEditor Common Parameters dialog box, do one of the 
following： 

– In the tool bar, click . 

– In the menu bar, click View → NcEditor Common Parameters. 
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2. To select the position for vertical plunge, select one of the following in the drop-down 
box of Vertical Cutting Type: 

– NCE files with lead lines: Use vertical plunge at the start point of lead line. 

– All the NCE file: Use vertical plunge at the start point of cutting. 

3. Click OK. 

6.11 Set the Tilt Angle and Cutting Speed 

This operation is used to set the tilt angle and cutting speed according to the actual 
situation. 

To set the tilt angle and cutting speed, do one of the following: 

• Use standard five-axis machining. 

• Edit tilt angle. 

  



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 123 / 195 

 

6.11.1 Use Standard Five-axis Machining 

This operation is used to machining all objects with standard five-axis machining 
parameters. 

It is applicable to the object whose tilt angle of each edge is the same. 

To use standard five-axis machining, do the following: 

1. In NcEditor, to open NcEditor Common Parameters dialog box, do one of the 
following： 

– In the tool bar, click . 

– In the menu bar, click View → NcEditor Common Parameters. 
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2. Select Enable standard 5-axis machining and click OK. 

  It is recommended to use default values of parameters Tilting Angle and Cutting 
Speed. 

6.11.2 Edit Tilt Angle 

This operation is used to select different tilt angles and corresponding speed, so as to 
ensure cutting effect of workpiece surface. 

It is applicable to the object whose tilt angle of each edge is different. 
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To edit tilt angle, do the following: 

1. In NcEditor, to open NcEditor Common Parameters dialog box, do one of the 
following： 

– In the tool bar, click . 

– In the menu bar, click View → NcEditor Common Parameters. 

   

2. Select Enable Edit Inclination Angle, select the following parameters in Param for 
Lean Angle area: 

– Optimize Cutting Method: Optimize cutting by controlling the uncertain factors 
caused by tool error in scrap region (invalid region). 

— Note: Only when the groove direction and valid region are within the internal region of object, this 
parameter takes effect. 
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– Show Tilting Angle of Edge: show in figures as follows: 

 

– Show Valid Range: Shows in purple lines. 

– Show Edge of Large Angle in Boldface: The larger the tilt angle of edge, the 
wider the line weight of edge. 

3. To add / delete technics for tilt angles, including tilt angle and speed of the linear axis, 
in Angle Process Library area, click Add/ Delete. 

  Note: The added tilt angle cannot be the same with the existing one. 

4. To set tilt angle and speed for each edge of object, do one of the following: 

– By selecting the target edge: 

1. Click  in the tool bar and select the target edge. Set Tilt Angle 
dialog box pops up and the selected edge shows as a dash line: 

   

2. Set the tilt angle and tilt direction of the tool head and click OK. 

  The speed for the tilt angle corresponds to that in Angle Process 
Library area of Editor Common Parametersdialog box. 
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– By selecting the start point and end point: 

1. To open Set Tilt Angle dialog box, click  in the tool bar, select the 
start point on the object, move along the machining direction and select 
the end point. 

   

  The red arrow represents the machining direction. 

2. Set the tilt angle and tilt direction of the tool head and click OK. 

After selecting Enable Edit Inclination Angle, according to your need, do one of the 
following in the tool bar: 

• To change the groove direction, click  / . 

  Alternatively, do related settings in Set Tilt Angle dialog box. 

• To change the valid region of object, click . 
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7 System Management 

Through this section, you can quick know related information about system management 
of NcStudio V10 Waterjet Cutting Control System. 

System management includes the following: 

• Generate an Installation Package 

• Select a System Language 

• Register the Software 

• Customize the Startup Interface 

7.1 Generate an Installation Package 

This operation is used to create a complete installation package on the basis of current 
system data, which is useful to back up system files and save a stable version of the system. 

According to different purposes, installation packages include the following types: 

• Formal installation package: for actual use and simulation. 

  It is mainly used for debugging and adjustment. 

• Simulative installation package: for simulation. 

  It is mainly used for demonstrations to customers. 

To generate an installation package, do one of the following: 

• To generate an formal installation package, click File → Generate Installation and 
select the installation path. 

• To generate a simulative installation package, click File → Generate Emute 
Installation and select the installation path. 

The system begins to generate an installation package. 

After finishing, you can find the generated installation package under the set path. 

7.2 Select a System Language 

At present, NcStudio supports Chinese and English. 

To select a system language, do one of the following: 

• During installing the software, select a system language. 

• After installing the software, in the menu bar, click Language → Chinese / English. 
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7.3 Register the Software 

This operation is used to do registration through the board card and restrict the system 
usage time. 

Before registering the software, do the following: 

1. The machine tool is in idle or E-stop status. 

2. To get a registration code, send the device number to your supplier. 

To register the software, do the following: 

1. Click Help → About NcStudio. About NcStudio dialog box pops up: 
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2. Click Register. REGISTER dialog box pops up: 

   

3. Input the registration code and click OK. 

  The prompt Register succeeded. Please restart the software. appears. 

Restart the software to make registering effective. 

7.4 Customize the Startup Interface 

This operation is used to customize the startup interface for both English and Chinese 
interfaces. 

To customize the startup interface, do the following: 

1. Click Help → Manufacturer Customize. Manufacturer Customize dialog box pops 
up: 

   

2. Select the target language. 
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3. To activate Import button, click Login, and input the manufacturer password. 

4. Click Import and select an image with BMP format. 

If the software normally shuts down, the customized startup interface shows after 
restarting the software. 

8 Parameters 

Through this section, you can quick know the related parameters of NcStudio V10 
Waterjet Cutting CNC System. 

Including the following: 

• Cutting parameters 

• Operation parameters 

• Axis parameters 

• Controller parameters 

• Program parameters 

• Interface parameters 

• Other parameters 

8.1 Cutting Parameters 

Including the following: 

• Delay 

• Output Mode of Low Pressure 

• Pressure Way 

• Cutting Type 

• Tilt Angle of Cut Plane 

• Tilt Direction of Cut Plane 

• Arc Fitting Accuracy 

• Max Rotating Angle of C-axis 

• Punching 

• Velocity 

• Conner Controlling 

• Drilling 
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8.1.1 Delay 

Open HP Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 1000 

• Effective: Immediately 

• Description: The delay time after turning on the high-pressure valve. 

Close HP Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 1000 

• Effective: Immediately 

• Description: The delay time after turning off the high-pressure valve. 

Open Cutting Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 1000 

• Effective: Immediately 

• Description: The delay time after turning on the water valve. 

Close Cutting Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 1000 

• Effective: Immediately 

• Description: The delay time after turning off the water valve. 

Open Abrasive Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 1000 

• Effective: Immediately 

• Description: The delay time after turning on the abrasive valve. 
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Close Abrasive Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 1000 

• Effective: Immediately 

• Description: The delay time after turning off the abrasive valve. 

Pause before Cut 

• Unit: ms 

• Range: 0~600000 

• Default value: 0 

• Effective: Immediately 

• Description: The delay time before cutting. 

Pressure Discharge Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 0 

• Effective: Immediately 

• Description: The delay time to turn off the water valve after machining. 

Pause after Cut Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 0 

• Effective: Immediately 

• Description: The delay time after cutting. 

Close LP Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 1000 

• Effective: Immediately 

• Description: The delay time after turning off low-pressure valve. 
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Open LP Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 1000 

• Effective: Immediately 

• Description: The delay time after turning on low-pressure valve. 

After Stop Close Abrasive And Hv Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 0 

• Effective: Immediately 

• Description: The delay time to turn off the water valve after turning off the high-
pressure abrasive valve when “Stop” button is clicked. 

Close Booster Delay Time 

• Unit: ms 

• Range: 0~600000 

• Default value: 30000 

• Effective: Immediately 

• Description: With the high-pressure valve off, the delay time to automatically turn off 
the water pump. 

8.1.2 Output Mode of Low Pressure 

LP Output Mode 

• Unit: - 

• Range: 0;1;2;3 

• Default value: 1 

• Effective: Immediately 

• Description: The output mode of low pressure. 

– 1: turn on the low-pressure valve before turning on the high-pressure valve 
while turning off the low-pressure valve after turning off the high-pressure 
valve. 

– 2: turn on the low-pressure valve first. And after delay time, turn off the low-
pressure valve and turn on the high-pressure valve. 

– 3: turn on the low-pressure valve before machining while turning off the low-
pressure valve after machining. 
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8.1.3 Pressure Way 

Pressure Way 

• Unit: - 

• Range: 1;2;3 

• Default value: 1 

• Effective: Immediately 

• Description: The way of turning on pressure valves. 

– 1: turn on the high-pressure valve only. 

– 2: turn on the low-pressure valve only. 

– 3: turn on high-pressure valve and low-pressure valve. 

8.1.4 Cutting Type 

Select Cutting Type 

• Unit: - 

• Range: 0;1 

• Default value: 0 

• Effective: Immediately 

• Description: It is used to select cutting type. 

– 0: abrasive cutting 

– 1: pure-water cutting 

8.1.5 Tilt Angle of Cut Plane 

The Lean Angle of Plane Cutted 

• Unit: deg 

• Range: 0~90 

• Default value: 2 

• Effective: After restart 

• Description: The tilt angle of cut plane. 
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8.1.6 Tilt Direction of Cut Plane 

The Lean Direction of Tool 

• Unit: - 

• Range: 0;1 

• Default value: 0 

• Effective: After restart 

• Description: The leaning direction of cut plane. 

– 0: seeing from the machining direction, the cut plane leans to the right. 

– 1: seeing from the machining direction, the cut plane leans to the left. 

8.1.7 Arc Fitting Accuracy 

Arc Fitting Accuracy 

• Unit: mm 

• Range: 0.0001~1 

• Default value: 0.01 

• Effective: After restart 

• Description: The length of each short line in interpolation. 

8.1.8 Max Rotating Angle of C-axis 

Max Rotating Angle of C Axis 

• Unit: deg 

• Range: 360~108000 

• Default value: 0 

• Effective: After restart 

• Description: The maximum rotating angle of C-axis to prevent enlacing during 
generating toolpath. 
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8.1.9 Punching 

Punch Type 

• Unit: - 

• Range: 0;1;2 

• Default value: 0 

• Effective: After restart 

• Description: The punching type. 

– 0: none 

– 1: arc punching. That is, circle is punched at the start point of the lead line. 

– 2: swing punching. That is, straight-line is punched at the start point of the lead 
line. 

Punching Strategy 

• Unit: - 

• Range: 0;1 

• Default value: 0 

• Effective: After restart 

• Description: The punching strategy. 

– 0: single punching. That is, during machining multiple objects, each object is 
punched and cut before machining the next one. 

– 1: batch punching (only support NCE file). That is, during machining multiple 
objects, all objects are punched first before cutting them. 

Punch Distance 

• Unit: mm 

• Range: 0.01~10000 

• Default value: 2 

• Effective: After restart 

• Description: The punching diameter for arc punching, and punching interval for swing 
punching. 

Punch Counts 

• Unit: - 

• Range: 1~1000 

• Default value: 3 

• Effective: After restart 

• Description: The machining times of circle for arc punching, and the swinging times of 
straight-line for swing punching. 
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Punch Speed 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 1000 

• Effective: After restart 

• Description: The speed to punch. 

Arc Punching Position 

• Unit: - 

• Range: 0;1;2 

• Default value: 0 

• Effective: After restart 

• Description: The circle position relative to the start point of the lead line for arc 
punching. 

– 0: left. That is, the circle is on the left of the start point of the lead line. 

– 1: middle. That is, the circle is at the middle of the start point of the lead line. 

– 2: right. That is, the circle is on the right of the start point of the lead line. 

Punch Position 

• Unit: - 

• Range: 1;2 

• Default value: 1 

• Effective: After restart 

• Description: The punching position of waterjet cutter. 

– 1: at the start point of lead line. 

– 2: at start points of all objects. 

8.1.10 Velocity 

AX Startup Vol 

• Unit: mm/min 

• Range: 0~100000 

• Default value: 0 

• Effective: Immediately 

• Description: The minimum feedrate during machining. 
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Default Feedrate 

• Unit: mm/min 

• Range: 0~100000 

• Default value: 800 

• Effective: Immediately 

• Description: The default speed during machining (It does not refer to the positioning 
speed). 

AX Linear Mach ACC 

• Unit: mm/s^2 

• Range: 0.001~100000 

• Default value: 300 

• Effective: Immediately 

• Description: The maximum acceleration of each linear axis during machining. 

REV Default Feedrate 

• Unit: rpm 

• Range: 0~100000 

• Default value: 15 

• Effective: Immediately 

• Description: The default speed of each revolving axis during machining (It does not 
refer to the positioning speed). 

8.1.11 Conner Controlling 

Whether Use ACC 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: Immediately 

• Description: Whether to use corner deceleration. 

Conner Speed Percentage 

• Unit: - 

• Range: 0~100 

• Default value: 100 

• Effective: Immediately 

• Description: The percentage of the corner speed and normal machining speed at the 
other places. 
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Corner ACC Distance 

• Unit: mm 

• Range: 0~100 

• Default value: 2 

• Effective: Immediately 

• Description: The accelerating distance at the corner. 

Corner DECEL Distance 

• Unit: mm 

• Range: 0~100 

• Default value: 2 

• Effective: Immediately 

• Description: The decelerating distance at the corner. 

End Section DECEL Distance 

• Unit: mm 

• Range: 0~100 

• Default value: 2 

• Effective: Immediately 

• Description: The decelerating distance at the last segment of object. 

Conner Slow Angle 

• Unit: deg 

• Range: 0~180 

• Default value: 60 

• Effective: Immediately 

• Description: The corner deceleration is enabled when the corner angle is larger than 
this parameter. 

8.1.12 Drilling 

Start Height 

• Unit: mm 

• Range: 0,9999 

• Default value: 5 

• Effective: Immediately 

• Description: The Z-axis coordinate of the drill at the beginning. 
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ON Delay 

• Unit: ms 

• Range: 0,1e+007 

• Default value: 3000 

• Effective: Immediately 

• Description: The delay time to start drilling after the drill moves to the start point. 

Max Drilling Time 

• Unit: ms 

• Range: 0,1e+007 

• Default value: 3000 

• Effective: Immediately 

• Description: The longest time of the cylinder to move down. During drilling, the 
cylinder pushes out down until trigger the signal of drilling in position, which means 
drilling ends and the cylinder pulls in. 

Pulled in Time 

• Unit: ms 

• Range: 0,1e+007 

• Default value: 3000 

• Effective: Immediately 

• Description: The duration from detecting the signal of drilling in position to detecting 
the signal of drill pulling in in position. 

Start Machine Coor 

• Unit: ms 

• Range: -10000,10000 

• Default value: 100 

• Effective: Immediately 

• Description: The machine coordinates of the drill at the start time of drilling. 

Falling Distance 

• Unit: mm 

• Range: 0,10000 

• Default value: 100 

• Effective: Immediately 

• Description: The down depth of the drill before drilling. 
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Drilling Depth 

• Unit: mm 

• Range: 0,10000 

• Default value: 10 

• Effective: Immediately 

• Description: The down depth of the drill after drilling. 

Drilling Speed 

• Unit: mm/min 

• Range: 0.01,100000 

• Default value: 1000 

• Effective: Immediately 

• Description: The feedrate during drilling. 

8.2 Operation Parameters 

Including the following: 

• Wait time on E-stop 

• Brake control 

• Abrasive valve 

• Controlling pressure 

• Controlling circle velocity 

• Manual mode 

• Automatic machining 

• Reference point 

• Other operation parameters 

8.2.1 Wait Time on E-stop 

Wait Time On Estop 

• Unit: sec 

• Range: 0.001~10 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The wait time for a complete stop after E-stop. 
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8.2.2 Brake Control 

Brake Control 

• Unit: - 

• Range: 0;1;2 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The way of brake control. 

– 0: by communication data. 

– 1: by brake input signal. 

– 2: by the driver. 

8.2.3 Abrasive Valve 

Abrasive Valve Control Mode 

• Unit: - 

• Range: 0;1 

• Default value: 0 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The way of controlling the abrasive valve. 

– 0: by analog quantity 

– 1: by pulse spindle 

Abrasive Valve Output Voltage 

• Unit: mv 

• Range: 0~10000 

• Default value: 5000 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The output voltage of the abrasive valve that is controlled by the analog 
quantity. 
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Abrasive Valve Output Voltage Increment 

• Unit: mv 

• Range: 0~100 

• Default value: 5 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The increment of output voltage in each analog control period of the 
abrasive valve. 

Abrasive Valve Output Voltage Mode 

• Unit: - 

• Range: 0;1 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The mode of output voltage when the abrasive valve is controlled by the 
analog quantity. 

– 0: gradual change 

– 1: abrupt change 

Abrasive Value Stepper Motor Speed 

• Unit: rpm 

• Range: 0.001~59999.9 

• Default value: 200 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The speed of stepping motor when the abrasive valve is controlled by the 
pulse spindle. 

8.2.4 Controlling Pressure 

Press. Serial Port Address 

• Unit: - 

• Range: 1~9 (Integer) 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer 

• Description: 1: COM1; 2: COM2; 3: COM3; 4: COM4; 5: COM5; 6: COM6; 7: COM7; 8: 
COM8; 9: COM9. 
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Press. Serial Port Node No 

• Unit: - 

• Range: 0~99 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The node number for communication when the serial port controls 
pressure. 

8.2.5 Controlling Circle Velocity 

Ref Circle Max Velo 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 800 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The maximum velocity of circle with 10mm diameter. 

Circle Min Velo 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 100 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The minimum velocity of circle motions. 

8.2.6 Manual Mode 

Jog Vol 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 1800 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The default velocity of X-axis or Y-axis in jog mode. 
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Rapid Jog Vol 

• Unit: mm/min 

• Range: 0.001~Max Speed of Each Axis 

• Default value: 5000 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The velocity of X-axis or Y-axis in high-speed jog mode. 

Rev Jog Vol 

• Unit: rpm 

• Range: 0.001~100000 

• Default value: 2 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The default velocity of rotary axis in jog mode. 

Rev Rapid Jog Vol 

• Unit: rpm 

• Range: 0.001~100000 

• Default value: 3 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The velocity of rotary axis in high-speed mode. 

Lock Dir After Limited 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: When the soft limit is triggered, the machine tool can only move toward 
direction not limited, otherwise, it may damage the machine tool. 

Jiggle Feedrate 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 400 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The speed of fine-tuning. 
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Jiggle Step Length 

• Unit: mm 

• Range: 0.001~2 

• Default value: 0.5 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The step length of machining corresponding to each fine-tuning. 

Jog Vol Z 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 800 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The default velocity of Z-axis in jog mode. 

Rapid Jog Vol Z 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 1000 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The default velocity of Z-axis in high-speed jog mode. 

The Step Range of Z axis 

• Unit: mm 

• Range: 0~10000 

• Default value: 10000 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The safe range of step size for Z-axis. 
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8.2.7 Automatic Machining 

Speed Assign Type 

• Unit: - 

• Range: 0;1;2 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The mode to specify feedrate. 

– 0: use the speed specified by the program file. 

– 1: use the default speed. 

– 2: use the speed specified according to the proportion. 

Height Z Raise 

• Unit: mm 

• Range: -10000~10000 

• Default value: 5 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The lifting height of Z-axis during dry run. 

8.2.8 Reference Point 

REFPT Coor 

• Unit: - 

• Range: - 

• Default value: 0 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The machine coordinate of the machine origin. And its default value is 0. 

Axis Type Of Bkref 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: Whether to return to the machine origin before machining. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 149 / 195 

 

Driving Spindle Back Distance 

• Unit: mm 

• Range: -1000~1000 

• Default value: 100 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The retract distance of driving spindle when double Y-axes return to the 
machine origin or during checking the machine origin. 

The Speed of Going to Machine Origin 

• Unit: mm/min 

• Range: 0~1000 

• Default value: 200 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The speed to return to the machine origin. 

Tool Lift Speed 

• Unit: mm/min 

• Range: 0~1000 

• Default value: 50 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The lifting speed during height measurement. 

8.2.9 Other Operation Parameters 

Safe Height 

• Unit: mm 

• Range: 0~10000 

• Default value: 10 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The safe height to avoid collisions in the workpiece coordinate, which is 
used after returning to the machine origin and breakpoint resume. 
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Near Point Rang 

• Unit: - 

• Range: 0~500 

• Default value: 100 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Adjacent point machining can be used within the machining range of 
adjacent point. 

Use Special Control of Z axis or not 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to adopt optimized toolpath in NCE file during G00 positioning. 

Enable Edit Inclination Angle 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: :Whether editing inclination angle of each edge is allowable in NcEditor. 

Show Edge Inclination Angle 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to show inclination angle of each edge in NcEditor. 
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Action After Programming 

• Unit: - 

• Range: 0;1;2;3 

• Default value: 3 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The tool action every time machining ends. 

– 0: do not move. 

– 1: back to the fix point. 

– 2: back to the workpiece origin. 

– 3: back to the set point (workpiece coordinate). 

SETPT POS 

• Unit: - 

• Range: -99999~99999 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The workpiece origin of the set end point. 

FIXPT POS 

• Unit: - 

• Range: -99999~99999 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The machine coordinate of the fixed point. 

Display Simu Out Range 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to prompt if simulation is out of machine travel range. 
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Clear Cycle Times at Cycle Stop 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to clear the cycle times when cycle stops or software is restarted 
or files are reloaded. 

Y-Axis Work Range 

• Unit: - 

• Range: 1;2 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: It is used to specify the Y-axis work range. 

– 1: positive work range 

– 2: negative work range 

Axis of Rotation is Valid or not 

• Unit: - 

• Range: 0;1 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: Whether the rotary axis is valid. 

– 0: valid 

– 1: invalid 
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8.3 Axis Parameters 

Including the following: 

• Axis 

• Position feedback 

• Compensation 

• Velocity limit 

• Bus drive 

• Setting double Y 

• Controlling dry run 

• Laser head travel 

8.3.1 Axis 

Axis Dir 

• Unit: - 

• Range: 1;-1 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The direction of axes. 

– 1: positive 

— The actual direction is the same with the set direction of machine tool. 

– -1: negative 

— The actual direction is opposite to the set direction of machine tool. 

Workbench Lower Limit 

• Unit: - 

• Range: -99999~Machine Origin 

• Default value: - 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The machine coordinate of the lower limit of workbench travel range that 
is checked effective. 
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Workbench Upper Limit 

• Unit: - 

• Range: Machine Origin~99999 

• Default value: - 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The machine coordinate of the upper limit of workbench travel range that 
is checked effective. 

Check Workbench Range 

• Unit: - 

• Range: Yes;No 

• Default value: - 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to check the workbench travel range. 

Axis Type 

• Unit: - 

• Range: 1;2;3 

• Default value: - 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The axis type. 

– 1: linear axis 

– 2: rotary axis 

– 3: rotary axis with the shortest path 

Enable Driver Registration 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to enable drive registration function. 
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8.3.2 Position Feedback 

Leadscrew Pitch 

• Unit: - 

• Range: 0.001~99999 

• Default value: - 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The actual moving distance or degree of corresponding axis per 
revolution of motor. 

  It is related with the specified machine tool. So it is recommended to set this                   
parameter according the actual measuring result. 

Power Err 

• Unit: - 

• Range: 0~99999 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: If the position difference between power and reboot is greater than this 
value, the alarm occur. And it is only for the absolute encoder. 

Mechanical Reduction Ratio (Numerator) 

• Unit: - 

• Range: 1~99999 

• Default value: - 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The numerator of mechanical reduction ratio. 

Mechanical Reduction Ratio (Denominator) 

• Unit: - 

• Range: 1~99999 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The denominator of mechanical reduction ratio. 
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8.3.3 Compensation 

Enable Leadscrew CMPN 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to enable compensations for the leadscrew errors, including 
compensations for backlash errors and pitch errors. 

Only Backlash CMPN 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: 

– Yes: the data is read from the parameter Backlash to execute compensation. 

– No: the data of backlash errors and pitch errors is read from error file to 
execute comprehensive compensation. 

Backlash 

• Unit: - 

• Range: 0~1 

• Default value: 0 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The backlash of each axis. 

  This parameter takes effect only when the parameter Only Backlash CMPN is set to 
Yes. 

Maximum Angle Allowed for Correction 

• Unit: deg 

• Range: 0~1 

• Default value: 0.8 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum allowable angle of axis offset in perpendicularity 
correction. 
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8.3.4 Velocity Limit 

AX MAX VOL 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: - 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum allowable velocity of each axis. 

AX MAX CTRL VOL 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: - 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum allowable velocity of control point on each axis during 
machining. 

8.3.5 Bus Drive 

Driver Station Address 

• Unit: - 

• Range: 0;1;2;3;4;5 

• Default value: - 

• Effective: After restart 

• Permission: Manufacturer 

• Description: It should be the same with rotary switch setting of drive station address. 
0 represents the invalid address. 

Driver Station Address Setting Switch 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether it should be the same with dial switch setting of drive station 
address. 
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Encode Digit 

• Unit: - 

• Range: 10~30 

• Default value: 23 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The digit number of encoder of the servo motor. 

Electronic Gear Ratio (Numerator) 

• Unit: - 

• Range: 1~1.07374e+009 

• Default value: 23 

• Effective: After restart 

• Permission: Manufacturer 

• Description: It should be the same with electronic gear ratio (numerator) of the drive. 

Electronic Gear Ratio (Denominator) 

• Unit: - 

• Range: 1~1.07374e+009 

• Default value: 23 

• Effective: After restart 

• Permission: Manufacturer 

• Description: It should be the same with electronic gear ratio (denominator) of the 
drive. 

Servo Type 

• Unit: - 

• Range: 0;1;2 

• Default value: 2 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The type of servo drive. 

– 0: Yaskawa Σ5 servo drive 

– 1: Yaskawa Σ7 servo drive 

– 2: WISE servo drive 
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Brake Output 

• Unit: - 

• Range: 

• Default value: NA 

• Effective: After restart 

• Permission: Manufacturer 

• Description: It specifies the PLC address for output port of each brake. 

  This parameter takes effect only when the parameter Brake Control is set to 0. 

8.3.6 Setting Double Y 

Is Double Y System or not 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to use the double Y-axes configuration. 

Check Y1Y2 Encoder Error 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to check the encoder error between feedback value of Y1-axis 
and Y2-axis. 

Double Y Static Tolerance 

• Unit: - 

• Range: 0.001~999999 

• Default value: 5 

• Effective: After restart 

• Permission: Manufacturer 

• Description: When Y1-axis and Y2-axis are static, if the difference between the 
feedback and output value is bigger than this value, corresponding alarm will occur. 
This parameter is effective for Double Y configuration. 
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Double Y Dynamic Tolerance 

• Unit: - 

• Range: 0.00~999999 

• Default value: 5 

• Effective: After restart 

• Permission: Manufacturer 

• Description: When Y1-axis and Y2-axis are dynamic, if the difference between the 
feedback and output value is bigger than this value, corresponding alarm will occur. 
This parameter is effective for Double Y configuration. 

8.3.7 Controlling Dry Run 

Rapid Travel Feedrate 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 5000 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The default speed of linear axis during positioning. It is not the machining 
speed. 

Rev Rapid Travel Feedrate 

• Unit: rpm 

• Range: 0~Max Speed of Each Axis 

• Default value: 26 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The default speed of rotary axis during positioning. It is not the machining 
speed. 

Ax Linear Post Acc 

• Unit: mm/s^2 

• Range: 0.001~100000 

• Default value: 400 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum acceleration of each linear axis during positioning. 
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8.3.8 Laser Head Travel 

Laser Upper Limit 

• Unit: mm 

• Range: -99999~99999 

• Default value: 0 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The machine coordinate of the upper limit of laser head travel during 
height measurement. 

Laser Lower Limit 

• Unit: mm 

• Range: -99999~99999 

• Default value: -150 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The machine coordinate of the lower limit of laser head travel during 
height measurement. 

8.4 Controller Parameters 

Including the following: 

• General controller 

• Handwheel and keyboard 

• Operation panel 

• Valve state at pause 

8.4.1 General Controller 

Pausing Time 

• Unit: - 

• Range: 0.01~10 

• Default value: 0.5 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The duration time from running to pause or stop state. And if the value is 
too small, rock to the machine will occur. 
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Show REF Point Sign If Soft Limit Triggered 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to show the sign of reference point if the soft limit is triggered. 

– Yes: the soft limit takes effect after returning to the machine origin. 

– No: the soft limit immediately takes effect. 

8.4.2 Handwheel and Keyboard 

HW Count Strictly 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: If count pulses strictly, the machine tool will move the exact pulses 
generated by handwheel; Otherwise, the machine tool moves only when the 
handwheel starts turning. 

HW Direction 

• Unit: - 

• Range: 1;-1 

• Default value: -1 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The relation between the handwheel direction and the moving direction 
of axis. 

HW Multiple_1 

• Unit: - 

• Range: 0.0001~10 

• Default value: 0.001 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The handwheel multiple*1. 
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HW Multiple_10 

• Unit: - 

• Range: 0.0001~10 

• Default value: 0.01 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The handwheel multiple*10. 

HW Multiple_100 

• Unit: - 

• Range: 0.0001~10 

• Default value: 0.1 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The handwheel multiple*100. 

HW Gear Factor 

• Unit: - 

• Range: 1~1000 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The ratio of the rotational speed of handwheel to the feeding speed of 
axis. The greater the value is, the bigger the feeding speed is. 

Forbid Handwheel Gear Track Back Function 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to forbid the track back function during handwheel guide. 

Hw Acc 

• Unit: mm/s^2 

• Range: 1~1000 

• Default value: 200 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The smaller the value is, the smoother handwheel movements are. 
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Support NK Ex Keyset 

• Unit: - 

• Range: 0;1;2 

• Default value: 0 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The type of extended keyword. 

– 0: null 

– 1: Mini keyboard 

– 2: Naiky extended keyboard 

Install Extended Keyboard Hook 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to install the extended keyboard hook. 

Wireless Handwheel Connection Prompt 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to prompt that the wireless handwheel is successfully 
connected. 

Bar Code Enable 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to support barcode scanning. 
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Where to Load Toolpath in Scanning 

• Unit: - 

• Range: 0;1 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: It is used to select where to load toolpath during scanning with a barcode 
scanner. 

– 0: NcStudio 

– 1: NcEditor 

Max Interval for Scanning 

• Unit: ms 

• Range: 50~5000 

• Default value: 150 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The maximum interval to scan barcode of toolpath with a barcode 
scanner. 

Priority Loading File Format 

• Unit: - 

• Range: 0;1 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: During scanning the code, if there is a toolpath file with the same name 
and different extensions in the folder, the priority file format to load. 

– 0: DXF、NC、G format 

– 1: NCE format 

Shortest Response Time of Keyboard 

• Unit: ms 

• Range: 5~120 

• Default value: 30 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The barcode scanner responds within the shortest response time of 
keyboard. Otherwise, the keyboard responds. 
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8.4.3 Operation Panel 

Min Frp 

• Unit: - 

• Range: 0~Max Frp 

• Default value: 0 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The minimum allowable feedrate. 

Max Frp 

• Unit: - 

• Range: Min Frp~120 

• Default value: 120 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The maximum allowable feedrate. 

Manual Feedrate is Effective or not 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: When the feedrate in manual mode is not effective, the default feedrate is 
100%. 

Granularity Feedrate 

• Unit: - 

• Range: 1~120 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: The granularity of the feedrate slider bar. 
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Granularity Abrasive Ctrl 

• Unit: - 

• Range: 1~100 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: The granularity of the abrasive control slider bar. 

Granularity G00 Feedrate 

• Unit: - 

• Range: 1~100 

• Default value: 25 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: The granularity of the G00 feedrate slider bar. 

Turn Off Ports When Tracking Back 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to turn off ports during automatically tracking back. 

– Yes: if ports are turned on previously, turn off. 

– No: do not change the previous state. 

8.4.4 Valve State at Pause 

Pause Port Close Style 

• Unit: - 

• Range: 1;2;3 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The mode to turn off valves at pause. 

– 1: keep turning on valves 

– 2: immediately turn off valves 

– 3: delay to turn off valves 
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Start Open Port Style 

• Unit: - 

• Range: 1;2;3 

• Default value: 3 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The mode to turn on valves at pause. 

– 1: keep turning off valves 

– 2: immediately turn on valves 

– 3: delay to turn on valves 

8.5 Program Parameters 

Including the following: 

• G code options 

• Controlling track 

• Controlling the velocity 

• DXF file translation 

8.5.1 G Code Options 

RT DEC LEN 

• Unit: mm 

• Range: 1~999 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: During rapid positioning, the distance to decelerate when the spindle gets 
close to the target position and then moves at the approach speed. 

Speed While Approaching to Workpiece 

• Unit: mm/min 

• Range: 0.001~99999 

• Default value: 120 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The feeding speed of the tool when it gets close to the workpiece during 
positioning. 
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8.5.2 Controlling Track 

Track Corner Tol 

• Unit: mm 

• Range: 0~0.1 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: To improve the finish of machined workpiece, the tool may not move to 
the exact set position at two-segment connection. When difference of current position 
and set position reaches value specified by this parameter, the system takes it 
machining is completed. 

Smooth Time 

• Unit: s 

• Range: 0~1 

• Default value: 0.03 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The longer the time, the smoother the surface of the workpiece. But some 
of the details may be weakened. 

Optimize Cutting Method 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to optimize the cutting method. 

Max Inclination Angle Difference 

• Unit: - 

• Range: 0~360 

• Default value: 20 

• Effective: After restart 

• Permission: Manufacturer 

• Description: When the parameter Optimize Cutting Method is set to Yes, angles 
exceeding set value will be sectioned. 
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Vertical Cutting Type 

• Unit: - 

• Range: 0;1;2 

• Default value: 2 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The type of vertical cutting at the start point of object. 

– 0: never 

– 1: only NCE files with lead lines 

– 2: all the NCE files 

8.5.3 Controlling the Velocity 

Ax Startup Vol 

• Unit: mm/min 

• Range: 0~100000 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The minimum velocity during machining. 

Min Smooth Angle during Lines Connect 

• Unit: deg 

• Range: 0~180 

• Default value: 5000 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: When the angle between two lines is smaller than the value of this 
parameter, the angle is smoothed. 

Rev Default Feedrate 

• Unit: rpm 

• Range: 0.001~100000 

• Default value: 15 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The default feeding speed of rotary axis during machining. It is not the 
positioning speed. 
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Angle Acceleration 

• Unit: deg/s^2 

• Range: 0.001~100000 

• Default value: 300 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The angular acceleration of the rotary axis. 

Z Linear Acc 

• Unit: mm/s^2 

• Range: 0.001~100000 

• Default value: 400 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum linear acceleration of Z axis. 

Axis Max Acc 

• Unit: mm/s^2 

• Range: 0.001~100000 

• Default value: - 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum acceleration of each axis. 

Ax Con Acc 

• Unit: mm/s^2 

• Range: 0.001~100000 

• Default value: 1200 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum resultant feed acceleration of adjacent two axes. The 
recommended value is 1~2 times of the single axis acceleration. 

Ax Acc Acc 

• Unit: mm/s^3 

• Range: 0.001~100000 

• Default value: 5000 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The change rate of acceleration for each axis. 
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Velo Slide Time 

• Unit: s 

• Range: 0~99999 

• Default value: 0.05 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The longer the time, the smoother the speed. This parameter has no effect 
on track precision. 

Limit Arc Velo 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: Whether to limit the arc-motion velocity. 

Arc Forward Length 

• Unit: mm 

• Range: 0~100 

• Default value: 2 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The forward length of limiting the arc-motion velocity. 

Slide Speed for Small Lines 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: Whether to eliminate speed wave during machining small lines. 
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Reference Length of Slide Speed for Small Lines 

• Unit: mm 

• Range: 0.001~200 

• Default value: 5 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: It is used to adjust the speed wave for the line whose length is shorter 
than reference length. 

Speed Slide Length 

• Unit: mm 

• Range: 0~300 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The forward length of smoothing speed. 

Arc Speed Limit Type 

• Unit: - 

• Range: 1;2 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The type of arc speed limit. 

– 1: reference circle speed limit 

– 2: linear arc speed limit 

Maximum Arc Radius 

• Unit: mm 

• Range: 0~5000 

• Default value: 100 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum radius of linear arc speed limit. 
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Maximum Arc Speed 

• Unit: mm/min 

• Range: 1.66667~100000 

• Default value: 1800 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum speed of linear arc speed limit. 

Minimum Arc Radius 

• Unit: mm 

• Range: 0~Maximum Arc Radius 

• Default value: 10 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The minimum radius of linear arc speed limit. 

Minimum Arc Speed 

• Unit: mm/min 

• Range: 0~Maximum Arc Speed 

• Default value: 100 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The minimum speed of linear arc speed limit. 

8.5.4 DXF File Translation 

Tool Up Height 

• Unit: mm 

• Range: 0~99999 

• Default value: 10 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: The lifting height of the tool during dry run. 
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Depth Layer 

• Unit: mm 

• Range: -99999~0 

• Default value: 0 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: The machining depth of each tool layer in 2D machining. 

First Point as Origin 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: Whether to set the first point of DXF file as zero point. 

Enable Machine Bottom 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: The valve operation is performed only when cutter arrives at workpiece 
surface in 3D machining. 

Force to Recognize Dxf File As Metric Sys 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: Whether to ignore programming Unit in DXF file. 

Ignore Height in DXF 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: Whether to ignore height in DXF file. 
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8.6 Interface Parameters 

Including the following: 

• Object operation 

• Position interface 

• Setting interface showing 

8.6.1 Object Operation 

Interval Distance 

• Unit: - 

• Range: 0~100000 

• Default value: 10 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The interval distance between two dashes during drawing the groove 
direction. 

Dash Length (Groove Direction) 

• Unit: - 

• Range: 0~100 

• Default value: 15 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The length of the dash that represents groove direction. 

Front Size of Angle 

• Unit: - 

• Range: 1~1000 

• Default value: 15 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The pixel size of angle during drawing the leaning angle. 
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Show Valid Material Range 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to show valid material range when the parameter Enable Edit 
Inclination Angle is set to Yes. 

Space for Valid Material Range 

• Unit: - 

• Range: 1~1000 

• Default value: 10 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The space for drawing valid material range with equal distance. 

Valid Material Range Dash Length 

• Unit: - 

• Range: 1~1000 

• Default value: 15 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The length of the dash that represents valid material range. 

Max No. of Dashed Line on Single Edge 

• Unit: - 

• Range: 1~100 

• Default value: 10 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The maximum number of dashed lines on a single edge in valid range. 
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Show Edge of Large Angle in Boldface 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: When Enable Edit Inclination Angle is set to Yes, the edges will become 
bold if the angle becomes larger. 

Dash Width (Groove Direction) 

• Unit: - 

• Range: 0.1~100 

• Default value: 2 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The width of the dash that represents groove direction. 

8.6.2 Position Interface 

Auto Load Track 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to automatically parse the machining track after loading the 
program file. 

Auto Load Track Limit 

• Unit: KB 

• Range: 0~100000 

• Default value: 1000 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: A machining file can be automatically loaded only when the file size is less 
than this value. 
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Whether Auto Load Files 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to automatically load the previous program file when the 
software starts. 

Whether Lock Edit After Machining 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: Whether to lock editing the position and size of objects after machining. 

Whether Lock Edit After Import 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to lock editing the position and size of objects after importing 
the file. 

NcEditor Forbid Scaling 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to forbid zooming objects in NcEditor. 
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8.6.3 Setting Interface Showing 

Font Show Adjust Factor 

• Unit: - 

• Range: 1~100 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The factor to adjust the front size of paragraph number. 

8.7 Other Parameters 

Including the following: 

• Cylinder 

• Software configuration type 

• Application 

• Laser height measurement 

• Scanning track 

• Shooting positioning 

8.7.1 Cylinder 

Red Light When Finish 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: Whether to prompt by the red light before input with a mouse or 
keyboard after machining. 
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8.7.2 Software Configuration Type 

Software Configuration 

• Unit: - 

• Range: 0;1 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer;operator 

• Description: The type of software configuration. 

– 0: normal 

– 1: with height measurement 

8.7.3 Application 

Use Metric 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to use metric. 

Change Value When the Conversion of the Metric System and British Standard 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to automatically modify parameter values during the conversion 
of the metric system and british standard. 

Enable Rotary Workbench Mode 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to enable the mode of rotary workbench. 
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8.7.4 Laser Height Measurement 

Laser Sensor Station Address 

• Unit: - 

• Range: 1~16 

• Default value: 1 

• Effective: After restart 

• Permission: Manufacturer 

• Description: The station address of laser sensor. 

Coarse Position Speed 

• Unit: mm/min 

• Range: 0.001~10000 

• Default value: 800 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The speed of Z-axis downwards the upper limit of laser sensor during 
getting the datum. 

Sensor Clearance Height 

• Unit: mm 

• Range: 65~105 

• Default value: 85 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The clearing height of laser sensor. 

Altimetry Result Processing Method 

• Unit: - 

• Range: 0;1 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The method to process the result of height measurement. 

– 0: linear area method 

– 1: linear distance method 
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Sample Period 

• Unit: us 

• Range: 200;500;1000;2000 

• Default value: 2000 

• Effective: After restart 

• Permission: Manufacturer 

• Description: After changing the sampling period, the sensor needs to be initialized. 

Average Times 

• Unit: us 

• Range: 1;4;16;64;256;1024 

• Default value: 64 

• Effective: After restart 

• Permission: Manufacturer 

• Description: After changing the average times, the sensor needs to be initialized. 

Max Ignorable Distance 

• Unit: mm 

• Range: 0~200 

• Default value: 50 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum continuous distance of getting height errors during laser 
height measurement. 

Tolerance of Height Measurement 

• Unit: mm 

• Range: 0.01~10 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The maximum deviation of height when XY-plane moves 10mm. 

Delay to Push out Dustcover 

• Unit: ms 

• Range: 0~100000 

• Default value: 1000 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The delay time to push out dust cover during laser height measurement. 
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Buffer Length during Resume 

• Unit: mm 

• Range: 0~200 

• Default value: 10 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The extra scanning length to eliminate measurement errors during 
breakpoint resume. 

Ignore Large Segment Abnormal 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: Whether to ignore the parameter Max Ignorable Distance during laser 
height measurement. 

8.7.5 Scanning Track 

Take Direction 

• Unit: - 

• Range: 0;1 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The start direction for automatically picking points. 

– 0: the positive direction of X-axis 

– 1: the positive direction of Y-axis 

Take the Horizontal Spacing 

• Unit: mm 

• Range: 1~10000 

• Default value: 50 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: Take the preset value of the point Horizontal spacing. 
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The Buffer Length 

• Unit: mm 

• Range: 1~100 

• Default value: 10 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The buffer length of inflection point. 

Scan Speed 

• Unit: mm/min 

• Range: 0.001~100000 

• Default value: 6000 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: The scanning speed during automatic measurement. 

Take the Longitudinal Spacing 

• Unit: mm 

• Range: 1~10000 

• Default value: 200 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: Take the preset value of the point longitudinal spacing. 

Cutting Edge Length 

• Unit: mm 

• Range: 1~1000 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer 

• Description: During picking points, precut the edge length. 
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8.7.6 Shooting Positioning 

Enable Positioning by Shooting 

• Unit: - 

• Range: Yes;No 

• Default value: No 

• Effective: After restart 

• Permission: Manufacturer 

• Description: Whether to position by shooting. 

Show Shooting Result in NcEditor 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to show shooting result in NcEditor. 

Picture Display Mode 

• Unit: - 

• Range: 1;2 

• Default value: 1 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The mode of picture display. 

– 1: by effect 

– 2: by performance 

Custom Tool Path Color 

• Unit: - 

• Range: Yes;No 

• Default value: Yes 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: Whether to customize the color of toolpath. 

– Yes: use customized tool path color. 

– No: use the color set in the system. 
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Red in RGB 

• Unit: - 

• Range: 0~255 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The customized value of red in RGB. 

Green in RGB 

• Unit: - 

• Range: 0~255 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The customized value of green in RGB. 

Blue in RGB 

• Unit: - 

• Range: 0~255 

• Default value: 255 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The customized value of blue in RGB. 

Dustcover ON Delay 

• Unit: ms 

• Range: 0~100000 

• Default value: 3000 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The delay time to turn on dust cover. 

Deviation X between Cutter Head and Laser Sensor 

• Unit: mm 

• Range: -99999~99999 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The offset X between the center position of the water cutter head and the 
laser projection point in the vertical state. 
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Deviation Y between Cutter Head and Laser Sensor 

• Unit: mm 

• Range: -99999~99999 

• Default value: 0 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The offset Y between the center position of the water cutter head and the 
laser projection point in the vertical state. 

Machine Position when Shooting 

• Unit: mm 

• Range: -99999~99999 

• Default value: - 

• Effective: Immediately 

• Permission: Manufacturer;operator 

• Description: The machine coordinate of cutter head that does not affect the shooting 
result during shooting. 
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9 FAQs 

Through this section, you can quickly find solutions to common questions that you may 
encounter during using NcStudio V10 Waterjet Cutting Control System. 

Common questions include the following: 

• Questions during returning to the machine origin 

• Questions about warnings 

• Questions about alarms 

9.1 Questions during Returning to the Machine Origin 

It includes the following: 

• Cannot detect origin signal 

• Axis direction is incorrect 

• Speed of coarse positioning is too slow 

9.1.1 Cannot Detect Origin Signal 

Cause 

Error in the origin switch. 

Solution 

1. Touch the origin switch, check and observe if related ports haves signals in IO Port 
window: 

– Yes: Contact us. 

– No: Proceed to the next step. 

  See Check Port Information for details. 

2. Check if indicator lights of X00, X03, X06, X09 and X12 on the terminal board are on. 

– Yes: Check if the electric circuit between the board card and the terminal board 
loosens: 

• Yes: Tighten it. 

• No: Contact us. 

– No: Check if the electric circuit between the origin switch and the terminal 
board loosens: 

• Yes: Tighten it. 

• No: Replace the origin switch. 
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9.1.2 Axis Direction is Incorrect 

Cause 

1. Incorrect polarity of port Reference Point. 

2. Incorrect value of parameter Axis Direction. 

Solution 

1. Modify its polarity. 

  See Check Port Information for details. 

2. Modify its value to the opposite value. 

  See Adjust Axis Direction for details. 

9.1.3 Speed of Coarse Positioning is Too Slow 

Cause 

1. Too small value of the parameter Coarse Locating Velo. 

2. Polarity of the port Reference Point in NcStudio does not match with type of the 
origin switch. 

Solution 

1. Modify the parameter Coarse Locating Velo to a larger value. 

2. Modify its polarity. 

  See Check Port Information for details. 

9.2 Questions about Warnings 

It includes the following: 

• Simulation result shows running range exceeded machine travel. Enter LOG window to 
learn more 

• Cannot execute the operation. The system has not returned to the machine origin 

• The parser is busy. Cannot execute the operation 
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9.2.1 Simulation Result Shows Running Range Exceeded Machine Travel. Enter 
Log Window to Learn More 

Cause 

The workbench travel in the program file exceeds the set upper limit and lower limit of 
workbench travel. 

Solution 

1. Check if the workpiece origin is set reasonably: 

– Yes: Proceed to next step. 

– No: Set it again. 

— See Set the Workpiece Origin for details. 

2. Check if the workbench travel in the program file is reasonable: 

– Yes: Modify parameters Workbench Upper Limit and *Workbench Lower 
Limit to enlarge the workbench travel. 

– No: Modify the workbench travel in the program file. 

9.2.2 Cannot Execute the Operation. The System has not Returned to the 
Machine Origin 

Cause 

The system has not returned to the machine origin. 

Solution 

Return to the machine origin first. See Return to the Machine Origin for details. 

9.2.3 The Parser is Busy. Cannot Execute the Operation 

Cause 

Cannot execute the operation in the current machining status. 

Solution 

Execute the operation in idle status by stopping machining or waiting for the end of the 
machining. 
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9.3 Questions about Alarms 

It includes the following: 

• X (Y/Z/A/B/C) positive (negative) limit alarm 

• X (Y/Z/A/B/C) servo alarm 

• ESTOP alarm 

• Failed to execute machining 

• The terminal board is disconnected 

9.3.1 X/Y/Z/A/B/C Positive (Negative) Limit Alarm 

Cause 

1. Incorrect polarity of port Negative Limit / Positive Limit. 

2. X-axis / Y-axis / Z-axis / A-axis / B-axis / C-axis collided with the limit switch. 

3. Failure of the limit switch. 

Solution 

1. Modify the polarity of the corresponding port. 

  See Check Port Information for details. 

2. Manually move the corresponding axis away from the limit switch. 

3. Replace the limit switch. 

9.3.2 X/Y/Z/A/B/C Servo Alarm 

Cause 

1. Incorrect polarity of port Servo Alarm. 

2. The alarm of X-axis / Y-axis / Z-axis / A-axis / B-axis / C-axis in the servo drive occurs. 

Solution 

1. Modify the polarity of the corresponding port. 

  See Check Port Information for details. 

2. Check servo connecting wires of X-axis / Y-axis / Z-axis / A-axis / B-axis / C-axis. 
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9.3.3 ESTOP Alarm 

Cause 

1. The ESTOP button is pressed. 

2. Incorrect polarity of port Emergency Stop. 

Solution 

1. Rotate ESTOP button clockwise. 

2. Modify the polarity of port Emergency Stop. 

  See Check Port Information for details. 

9.3.4 Failed to Execute Machining 

Cause 

The software has expired. 

Solution 

Register the software again. 

See Register the Software for details. 

9.3.5 The Terminal Board is Disconnected 

Cause 

1. Incorrect polarity of port Terminal Board Disconnection / Extended Terminal 
Board 1 Disconnection / Extended Terminal Board 2 Disconnection. 

2. Cables of terminal board have not been firmly connected. 

3. Failure of Lambda terminal board. 

Solution 

1. Modify the polarity of corresponding port. 

  See Check Port Information for details. 

2. Re-plug cables of terminal board and restart the software. 

3. Check if SYSTEM indicator light of Lambda terminal board is on: 

– Yes: contact us. 

– No: replace a new terminal board. 
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10 Legal Notices 

Important—Read Carefully before Using This Product: 

The term “Software Product” includes all copies of the licensed software and its 
documentation. This license agreement is a legal agreement between You (either an 
individual, a legal entity or any affiliated companies or other entities) and Weihong 
Electronic Technology Co., Ltd. (hereinafter referred to as Weihong Company). By 
installing, copying, or otherwise using the Software Product, you agree to be bound by the 
terms and conditions of this license. Unless otherwise stated in this agreement, you shall 
not use, copy, revise, rent, or transfer the Software product or any part of the Software 
Product for any other purposes. 

10.1 Description of Further Rights and Restrictions: 
• You may install for use one copy of the Software Product on a single machine; 

• You may make a copy of the Software Product for archive or backup purposes and the 
copy is to be used on this machine only; 

• You may transfer the Software Product and the license agreement to a third party, 
provided that the third party accepts the terms and conditions stated in this 
agreement, with prior express permission from Weihong Company; 

• When transfer confirmed, you shall transfer all the copies of the original documents 
and the supplementary documents to the third party or destroy all the copies un-
transferred; 

• You can use the Software Product on a network server or intranet server only if it is 
stipulated in explicit terms that you are allowed to use the Software Product on a 
network server or intranet server, or you have purchased license for each node and 
terminal using the Software Product; 

• You may NOT sublicense, assign or transfer the license agreement; 

• You may NOT or direct any third party to reverse engineer, decompile or disassemble 
the Software Product; 

• You may NOT copy or transfer the Software Product or any part of the Software 
Product unless otherwise expressly stated in this agreement; 

• The license agreement shall be terminated automatically upon you transfer the 
Software Product or copies of all or part of the Software Product to a third party. 

10.2 Intellectual Property Rights Notice: 

The Software Product and all intellectual property rights therein (including but not limited 
to any all copyrights, patents, trademarks, and publicity rights) are owned by Weihong 
Company. The Software Product is protected for Weihong Company on the basis of 
copyright law and international treaty provisions as well as on the basis of other laws and 
agreements regarding intellectual property. You are not allowed to remove the copyright 
statement made in the Software Product, and guarantee that you shall copy the copyright 
statement in all copies of the Software Product or of any part of the Software Product. You 
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are obliged to stop any form of illegal copying of the Software Product and accompanying 
materials. 

10.3 After-sales Guarantee: 

Weihong Company guarantees that for 90 days from the date of shipment the software 
carrier will be free from defects in materials and workmanship. When such a defect has 
been confirmed, our only responsibility is to replace the software carrier. This remedy is 
your exclusive remedy. This after-sales guarantee is invalid for any carrier defect caused by 
accidents, abuses or maloperation. The replaced software carrier enjoys the remaining 
guarantee time of the original software carrier or of a 30-day guarantee time, whichever is 
longer. Except as the after-sales guarantee made above, the Software Product does not 
enjoy any other form of after-sale guarantee. 

10.4 Limitation of Liability: 

The above guarantee, whether made explicitly or by implication, constitutes the entire 
contents of the guarantee, including guarantee for the commerciality and applicability of 
special application aim. Whether you follow other terms in this agreement or not, Weihong 
Company, as well as its agents and sales staff, will not be responsible for any profits loss, 
availability loss, business break-off or any forms of indirect, special, accidental or inevitable 
damage or claim made by any third party, generated from the using of the Software 
Product, even if Weihong Company has been informed of the possible occurrence of such 
events in advance. 

10.5 Termination: 

This license may be terminated by Weihong Company at any time once you violate any 
terms or conditions made in this agreement. Once the license is terminated, you are obliged 
to destroy all the copies of the Software Product or return them to Weihong Company. 

10.6 Applicable Law: 

Copyright Law, Regulations for the Protection of Computer Software, Patent Law and other 
relevant laws and regulations. Now, we affirm that you have already read through this 
agreement and understood it thoroughly and agreed to comply with all of the terms and 
conditions of this agreement strictly. 

Weihong Electronic Technology Co., Ltd. 
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