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Preview 
Thank you for using the NcStudio Phoenix Nine Axis Six-Side Drilling System. 

This manual introduces the software interface, shape-related functions, and methods for 
wiring, machine debugging, and material measurement. 

Before installing and using this product, please read this manual carefully to help you 
understand how to use the product. 

You will not be notified of any improvements or changes to the product. You can find 
related product information on our official website: https://www.weihong.com.cn/en/. 

Special Icon 

 
The icon is used to indicate supplementary information and notes that require your 
attention other than safety precautions. 

 
 
Revision History 

Version Date Update Reason 

R1.0 2021-1-17 Released the first time. 
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1 System Introduction 
1.1 Overview 
This section introduces the NcStudio Phoenix Nine Axis Six-Side Drilling System 
hardware, software, and machine structure. 

The NcStudio Phoenix Nine Axis Six-Side Drilling System supports only bus 
configuration. 

Hardware 

 Industrial computer: NC65C 
 Controller: Lambda 21B 
 EX series terminal board: 

o EX Series Terminal Board: Supports 32-channel output 
o EX Series Terminal Board: Supports 32-channel input 

For connection diagram of the system hardware, see Hardware Connection Diagram. 

Software 

For the introduction of the NcStudio Phoenix Nine Axis Six-Side Drilling System 
software interface, see Software Interface. 

Machine commonly includes a symmetrical left part and right part. This section takes the 
left part as an example to introduce the machine structure. 

1.2 Hardware Connection Diagram 
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1.3 Software Interface 
After the software is opened, Process screen is displayed by default. Click the Process or 
Control tab in the upper right corner to switch between the two screens. 

Different content is displayed in Process and Control screens. 

 Process: Plate editing and machining control functions. 
 Control: Cylinder, valve output, and axis movement control functions. 

1.3.1 Process 
The layout of the Process screen is shown below: 

 
 

1. Menu Bar 2. Status Bar 3. Screen Switch 4. Machining Operation Bar 5. Board and 
Stigma List 6. Work List 7. Board Display Area 8. Board Editing Bar 9. Board 
information and parameter bar 10. WEIHONG logo 

1.3.1.1 Menu Bar 
In the menu bar, you can: 

 
 

 File: Load a Machining File, close/restart the system, restart the software, and 
Create Installation Package, etc. 

 Edit: Creating and Editing Holes, Shape-Related Functions, etc. 
 Operate: Execute Simulation, Change I/O Port Polarity, Edit Drills, Set Datum, etc. 
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 System: View the Log, Change the Password, back up and restore parameter 
settings, View Machining Statistics, Check Tool Lifespan, and Board Measurement. 

 Help: Check the system information and remaining time, and Register the Software. 

1.3.1.2 Status Bar 

 
 
Displays the following information: 

 Current system status: running, idle, or emergency stop 
 System prompts or alarms 

Double-click the blank area to open the Log dialog box and View the Log. 

1.3.1.3 Screen Switch 

 
 
Click the Process/Control tab in the upper right corner to switch between the screens. 

1.3.1.4 Machining Operation Bar 

 
 
You can adjust the feed rate, start/pause/stop the machining process, execute simulation, 
and use the handwheel to guide machining. 

: Feedrate adjustment 
slider 

: Start machining 

: Pause machining 

: Stop machining 

: Execute simulation 

: Use handwheel 

1.3.1.5 Board and Stigma List 
Includes the following lists: 
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 Board list: Shows the code, name, and size of the imported board. 
 Stigma list: Shows the information of the hole positions created on the board. 

1.3.1.6 Work List 

 
 
Shows the information of the current board and available operations. 
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1.3.1.7 Board Display Area 

 
 
Shows the created or imported board and holes. 

1.3.1.8 Board Editing Bar 
The following operations are available: 

: For selecting objects. 

: For making the board view adjusted to the window. 

: For moving in the board view. 

: For saving the current board settings. 
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: For creating a new board. 

/ : For creating a side/vertical hole on the board. 

: For creating a slot on the board. 

: For pocket milling on the board. 

/ : For creating a side/front lamello on the board. 

: For creating a lock on the board. 

: For cutting an angle on the board. 

/ : For pocket milling of round corners/slots on the board. 

: For removing chamfering and undo all created angles and pocket milling of round 
corners and slots. 

/ : For creating mirroring. 

/ : For flipping the board upward/downward/leftward/rightward. 

: For rotating the board. 

: For managing the layers and layer attributes, such as color. 

1.3.2 Controller 
The layout of the Controller screen is shown below: 
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1. Menu Bar 2. Status Bar 3. Screen Switch 4. Machining Operation Bar 5. Axis 

Coordinate Area 6. Axis Direction and Mode Selection Area 7. Valve Control Area 8. 
WEIHONG logo 

1.3.2.1 Menu Bar 
In the menu bar, you can: 

 
 

 File: Load a Machining File, close/restart the system, restart the software, and 
Create Installation Package, etc. 

 Operate: Execute Simulation, Change I/O Port Polarity, Edit Drills, Set Datum, etc. 
 System: View the Log, Change the Password, back up and restore parameter 

settings, Check Tool Lifespan, View Machining Statistics, and Board Measurement. 
 Help: Check the system information and remaining time, and Register the Software. 

1.3.2.2 Status Bar 
Displays the following information: 

 
 

 Current system status: running, idle, or emergency stop 
 System prompts or alarms 

Double-click the blank area to open the Log dialog box and View the Log. 

1.3.2.3 Screen Switch 
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Click the Process/Control tab in the upper right corner to switch between the screens. 

1.3.2.4 Machining Operation Bar 

 
 
You can adjust the feed rate, start/pause/stop the machining process, execute simulation, 
and use the handwheel to guide machining. 

: Feedrate adjustment 
slider 

: Start machining 

: Pause machining 

: Stop machining 

: Execute simulation 

: Use handwheel 

1.3.2.5 Axis Coordinate Area 
Shows the name of the current workpiece coordinate system, and the mechanical and 
workpiece coordinates of the axes. 

 
 

After an axis goes to the machine origin, the  icon will be displayed before the axis. 
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1.3.2.6 Axis Direction and Mode Selection Area 

 
 
Includes the following functions: 

 Axis direction buttons: For control of the axis movement in the positive and negative 
directions. 

 Mode selection: 
o Jog 

 Continuous low-speed movement: Click and hold an axis direction 
button to make the axis move at a relatively lower speed continuously 
until the button is released. 

 Continuous high-speed movement: Highlight the HSpeed button. Click 
and hold an axis direction button to make the axis move at a relatively 
higher speed continuously until the button is released. 

o HW: Use a handwheel to control the axis movement. 
Rotate the axis dial and multiplier dial of the hand wheel to select the target 
axis and movement multiplication ratio. Rotate the biggest control dial by 
certain degrees. The selected axis moves in the target direction. 

o Step: In Step mode, you need to select or specify a step value. 
The axis moves by the specified step in the target direction after the axis 
direction button is clicked. 

 
Do not set the step to a very large value or click an axis direction button too quick. 
Otherwise, the machine may be damaged due to misoperation. 

 
 

1.3.2.7 Valve Control Area 
Includes the valve control buttons and drilling package display area. 
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You can edit the drilling package display area based on the actual situation. 

1.4 Machine Structure 
The main components are the clamp, drilling packages, and side leaning mechanism. The 
structure of the left part is shown below: 
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1. Clamp: One or two clamps (clamp 1 and clamp 2) are used to hold the board and 
make it move in the X1 and X2 directions. 

2. Drilling packages: Used to process the board. Include drilling package 1, 2, and 3. 
The types of drills in the packages include vertical drill, spindle drill, upper and lower 
horizontal drills, left and right horizontal drills, X drill, Y drill, side drill, milling tool, 
etc. 

3. Side leaning mechanism: Used to secure the board during machining and measure 
the Y-axis width. The corresponding axis is axis U. 
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2 Wiring 
This section introduces the signals supported by the NcStudio Phoenix Nine Axis Six-
Side Drilling System and the port definitions to help you in wiring. 

2.1 Port Definition 
This section introduces the port definitions of NC65C, Lambda 21B, and EX series 
terminal boards. 

2.1.1 NC65C 
The appearance and structure of NC65C are shown below: 

 
 

1. LNE (live, neutral, and earth) port 2. Indicator 3.USB 2.0 port ×4 4. Network cable 
port 5. VGA port 6. Terminal board port 

Port Function 

LNE Connect to a 220V power supply 

Indicator Power indicator 
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Port Function 

USB 2.0 
ports 

USB data transmission 

Network 
cable port 

Connect to a network. Its transmission rate is 100 Mbps. 

VGA port Connect to a display 

Terminal 
board port 

Connect to the Lambda controller 

2.1.2 Lambda 21B 
Lambda 21B can connect to multiple EX35A terminal boards. An example of the port 
definition of the Lambda controller is shown below: 
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2.1.3 EX Series Terminal Board 
Select an extension terminal board based on your needs: 

 EX35A: Supports 35-channel output 
 EX36A: Supports 32-channel output 

The following section introduces the port definitions in a case that a Lambda 21B controller 
is connected to an EX36A terminal board, which in turn is connected to two EX35A 
terminal boards. 
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2.2 Signal Type 
The following signal types are supported: 

 Switch Value Input Signal 
 Relay Output Signal 
 Analog Output Signal 

2.2.1 Switch Value Input Signal 
The switch value input signal supports active high and active low: 

 Connecting to the COM port in NO mode means to receive signal. 
 Disconnecting with the COM port in NC mode means to receive signal. 

The figure is as follows: 
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The input port supports active high and active low: 

 When the common port S of the Lambda controller is connected to the COM port, 
inputs are active in high voltage. 

 When the common port S of the Lambda controller is connected to +24V, inputs are 
active in low voltage. 

2.2.2 Relay Output Signal 
The Lambda controller outputs relay signals. 

The load capacity of relay output contact points is AC 7A/250V or DC 7A/30V. If high 
power load is needed, a contactor should be connected as follows: 

 
 

2.2.3 Analog Output Signal 
The AVC port, externally connected to the inverter's analog voltage frequency command 
input port, can output controllable voltage from 0V to 10V. By changing the voltage, it 
controls the inverter frequency and in turn the spindle speed. 

The figure is as follows: 
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3 System Debugging 
3.1 Overview 
This section introduces a debugging process for the NcStudio Phoenix Nine Axis Six-
Side Drilling System. 

If a password is required during debugging, please contact the manufacturer. 

The debugging process is shown below: 

 
 
The operations above can be executed in both the Process and Control screens if no 
information is mentioned indicating otherwise. 

3.2 Install the Software 
This section introduces how to install the NcStudio Phoenix Nine Axis Six-Side Drilling 
System. 
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Prerequisite: 

The software installation package is stored on the computer. 

Procedures: 

1. Decompress the installation package. Double-click . Follow the displayed 
installation wizard. 

2. Set the installation language to English. Deselect Keep manufacturer parameters 
or Keep local user parameters based on your needs. 

3. (Optional): Check Enable automatic startup and select Complete startup 
(initialize the desktop first and the software next) or Start software only. 

4. Click Next. Check your settings and click Next. The software installation process 
starts. 
After the installation is complete, a message will be displayed, indicating installation 
success. 
Double-click the desktop icon to open the software. 

3.3 Change I/O Port Polarity 
After the software is started normally, modify the port polarity based on the detection 
switch and limit switch type: 

 Set the port polarity of normally closed switches to NC. 
 Set the port polarity of normally open switches to NO. 

The mapping between the port state and icons are shown below: 

 Input port:  No signal detected;  Signal detected 

 Output port:  No signal detected;  Signal detected 
Procedures: 

1. In the menu bar, go to Operate > Port. 
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2. In the Port list dialog box, select the target port and click the Convert button to set 
its polarity to NC/NO. 

3. After the polarity of a port is modified, you can use the following functions based on 
your requirements: 

o To test if a port has output signals, click Test On/Test Off. 
o To cancel a port test, click Cancel Test. 
o To cancel all port tests, click Cancel All. 

4. (Optional): To set sampling interval, follow the steps below: 
a. Click Filter. 

 
 

b. In the Sampling Setting dialog box, drag the Interval slider. 
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If the box before Filter is checked, the system will rule out signals whose 
duration is shorter than the interval. 

3.4 Set Debugging Parameters 
You need to set the debugging parameters to avoid damage caused by improper 
movement. 

Procedures: 

1. In the menu bar, go to System > Global Parameters. 

 
 

2. In the Param dialog box, click the first pull-down menu in the lower left corner and 
select Manufact. 

3. Click the second pull-down menu in the lower left corner and select Axis. Set the 
following parameters: 

Parameter Description 

Handwheel Direction Indicates the direction of the axis encoder. 1: 
positive; -1: negative. 

Encoder digits Indicates the number of the encoder digits. 
Range: 10–30. 

Electronic gear 
ratio(numerator)/electronic 
gear ratio(denominator) 

Determines if the servo drive enlarges or 
shrinks the frequency sent from the upper 
computer. If the ratio is larger than 1: 
enlarging; if the value is smaller than 1: 
shrinking. 
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Parameter Description 

Pitch Indicates the distance or angle change by the 
axis every lead screw turn. 

 
4. Double-click the target parameter row. An input box is displayed. 

 
 

5. Enter the desired value in the field and click OK. 

3.5 Check Axis Direction 
Determine the positive direction for each axis with the right hand rule. The purpose is to 
avoid machine damage caused by axis moving in the wrong direction. 

Operations for checking each axis direction are similar and this section takes those for the 
X axis as an example. 

Procedures: 

1. (Optional): Click  in the upper right corner to 
switch to the Control screen. 

2. Determine the X-axis positive direction based on the right hand rule 
3. In the menu bar, go to System > Global Parameters. 
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4. In the Param dialog box, click the first pull-down menu in the lower left corner and 
select Manufact. Click the second pull-down menu in the lower left corner and 
select Axis. Check the value of Axis Direction(X): 

o 1: positive 
o -1: negative 

5. In Jog or Step mode, click the X+ button. Check to see if the X axis moves in the 
positive direction as determined by the right hand rule. 

o Yes: The axis direction is correct. 
o No: Set Axis Direction(X) to opposite of its current value. 

3.6 Set Datum 
If an absolute encoder is used, its datum can be directly set and no need of going to the 
mechanical origin. 

In cases of system reboot, power cut, or emergency stop, the system reads the datum 
automatically and there is no need of datum resetting. However, datum resetting is 
required if the drive or motor is replaced. 

Prerequisite: 

 The hardware is properly connected. 
 The axis directions are correct. 
 There is an anti-collision model in the software. 

Procedures: 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 25 / 103 

 

1. (Optional): Click  in the upper right corner to 
switch to the Control screen. 

2. Control the target axis to move to the target position in Jog or Step mode. 
3. In the menu bar, go to Operate > Datum setting. 

 
 

4. In the NcStudio dialog box, enter the password and click Confirm. The Datum 
setting dialog box is displayed: 

 
 

5. Click the corresponding button to set datum for a single axis or all axes. 

After datum is set for an axis, the  icon will be displayed before the axis in the 
axis coordinate area. 

6. (Optional:) If the set datum does not meet the requirements, you can cancel the 
datum for a single axis or all axes. 

a. In the menu bar, go to Operate > Datum cancellation. 
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b. In the NcStudio dialog box, enter the password and click Confirm. The 
Datum cancellation dialog box is displayed: 

 
 

c. Click the corresponding button to cancel the datum for a single axis or all 
axes. 

3.7 Set Workbench Travel Limits 
The purpose is to set the travel lower and upper soft limits to restrict machine movement in 
the X, Y, and Z directions. 

If this is the first time that you set the limits, check the actual range of machine movement 
first to avoid accidents. 

Procedures: 

1. In the menu bar, go to System > Global Parameters. 
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2. In the Param dialog box, click the first pull-down menu in the lower left corner and 
select Manufact. Set Check Worktable Stroke to Yes to enable the travel limits. 

3. Set the following parameters based on actual situation: 
o Upper Limit of Worktable Stroke: The mechanical coordinate of the upper 

limit. 
o Lower Limit of Worktable Stroke: The mechanical coordinate of the lower 

limit. 

3.8 Set Anti-collision Parameters 
Set anti-collision parameters to avoid collision between the drilling package and clamps 
and between clamp 1 and clamp 2. 

Procedures: 

1. (Optional): Click  in the upper right corner to 
switch to the Control screen. 

2. In the menu bar, go to System > Global Parameters. 

 
 

3. Click the second pull-down menu in the lower left corner, select Anti-collision and 
set related parameters: 

o Minimum distance of double gripper: The minimum distance between the 
closest sides of the two clamps during manual movement control. If the 
distance between the two clamps becomes smaller than this value, a soft 
position limit alarm will be reported. In this case, you need to manually 
control the clamps to move away from each other. 
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o Clamp/gripper length: The actual length of the clamp 
o Minimum value of axis A in anti collision zone between drill bag and 

gripper: The minimum workpiece coordinates of axis A within the anti-
collision zone between the drill package and clamps. 

o Maximum value of axis A in anti collision zone between drill bag and 
gripper: The maximum workpiece coordinates of axis A within the anti-
collision zone between the drill package and clamps. 

o Minimum value of x-axis in anti collision zone between drill bag and 
gripper: The minimum workpiece coordinates of the axis X within the anti-
collision zone between the drill package and clamps. 

o Maximum value of x-axis in anti collision zone between drill bag and 
gripper: The maximum workpiece coordinates of axis X within the anti-
collision zone between the drill package and clamps. 

o Reference distance of double gripper: The distance between the farthest 
sides of clamp X and clamp A after the datum is set. 

o X gripper length: The length of clamp X in the X direction 
o Anti Collision Upper Limit Y3: The Y3 axis mechanical coordinate upper 

limit for anti-collision between the upper drill package and clamps 
o Upper limit of Y-axis collision prevention between upper drill bag and 

gripper: The Y axis mechanical coordinate upper limit for anti-collision 
between the upper drill package and clamps 

o Anti Collision Lower Limit Y3: The Y3 axis mechanical coordinate lower 
limit for anti-collision between the upper drill package and clamps 

o Lower limit of Z axis for collision prevention between upper drill bag 
and clamping jaw: The Z axis mechanical coordinate lower limit for anti-
collision between the upper drill package and clamps 

o The upper limit of Z2 axis anti-collision between the down drill bag and 
the beam: The Z2 axis mechanical coordinate upper limit for anti-collision 
between the lower drill package and horizontal beam 

o Upper drill bag length (Y direction): The length of the upper drill package 
in the Y direction. 

o Datum Distance Double UpDrill: The distance between the farthest sides of 
drill package Y and drill package Y3 after the datum is set. 

o Min Distance Double UpDrill: The minimum distance between the closest 
sides of the two upper drill packages during manual movement control. 

o UpDrill 2 Length: The length of the upper drill package 2 
o UpDrill And SideView Datum Distance Y3: The distance between the 

closest sides of the drill package 3 and the side leaning axis base point in the 
Y3 axis direction. 

o UpDrill And SideView Datum OffsetY: The offset between the drill package 
1 and side leaning axis based point in the Y axis direction. A positive value 
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means the side leaning axis is in the front while a negative value means the 
side leaning axis is in the back. 

o Side structure length (U direction): The length of the side leaning 
mechanism. 

o Enable anti-collision check: Indicates whether to enable anti-collision 
check. 

o Anti collision tolerance: The maximum tolerance for anti-collision auto-
check. 

o Z axis minimum value of interference between upper drilling and side 
rest: The lower drill package crosses the side leaning axis. If the Z2 axis 
coordinate exceeds this value, the lower drill package cannot drill. 

3.9 Set Workpiece Origin 
The purpose is to set the current point as the workpiece origin, which means to clear the 
workpiece coordinates of all axes at the current point and set the workpiece offsets to the 
axis mechanical coordinates. 

Procedures: 

 Clear the X Axis 
 Clear the Y Axis 
 Clear the Z Axis 
 Clear the U Axis 

3.9.1 Clear the X Axis 
The process is shown below: 

 
 
Procedures: 

1. (Optional): Click  in the upper right corner to 
switch to the Control screen. 

2. In the valve control area, click the X Clamp button to align the clamp with a board 
edge. 

3. Lower the positioning cylinder. Move the clamp to make the board lean against the 
drill package positioning pillar. 

4. In the menu bar, go to Operate > Offset. 
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5. In the Bias setting dialog box, click the Set button behind the X axis in the G54 
Work offset region. 

6. In the displayed message box that requires your confirmation, click Yes to complete 
offset setting. 

3.9.2 Clear the Y Axis 
The process is shown below: 

 
 
Procedures: 

1. (Optional): Click  in the upper right corner to 
switch to the Control screen. 

2. In the valve control area, click the X Clamp or A Clamp button to hold the board by 
its edge and move it to the datum tool. 
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3. Click  to lower the datum tool. Move drill package 1 to align the datum tool 
center with the board clamp side edge. 

4. In the menu bar, go to Operate > Offset. 

 
 

5. In the Bias setting dialog box, click the Set button behind the Y axis in the G54 
Work offset region. 

6. In the displayed message box that requires your confirmation, click Yes to complete 
offset setting. 

Repeat the steps above with drill package 2 and 3 to set offsets for axis Y2 and Y3. 

3.9.3 Clear the Z Axis 
The process is shown below: 
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Procedures: 

1. (Optional): Click  in the upper right corner to 
switch to the Control screen. 

2. In the valve control area, click  to lower the datum tool and manually 
control the Z axis to move to the workbench surface. 

3. In the menu bar, go to Operate > Offset. 

 
 

4. In the Bias setting dialog box, click the Set button behind the Z axis in the G54 
Work offset region. 

5. In the displayed message box that requires your confirmation, click Yes to complete 
offset setting. 

Repeat the steps above with drill package 2 and 3 to set offsets for axis Z2 and Z3. 

3.9.4 Clear the U Axis 
The process is shown below: 

Procedures: 

1. (Optional): Click  in the upper right corner to 
switch to the Control screen. 

2. In the valve control area, click the X Clamp or A Clamp button to hold the standard 
board. 

3. Manually control the side leaning mechanism to touch the board tightly and record 
the current coordinate U. 
If the board width is 400 mm, the U-axis offset = U-400. 

4. In the menu bar, go to Operate > Offset. 
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5. In the Bias setting dialog box, click the Set button behind the U axis in the G54 
Work offset region. 

6. In the displayed message box that requires your confirmation, click Yes to complete 
offset setting. 

3.10 Edit Drills 
You can add and arrange drills in the upper and lower drill packages and set related 
parameters. 

A drill package can include: 

Drill Description 

 Vertical drill 

For machining of vertical holes 

 Spindle 

For machining of slots and lamello, and pocket milling. 

 Cross drill 

For machining of front and rear side holes. 

 Left and right cross drill 

For machining of left and right side holes. 

 XSaw 

For machining of lamello in the X axis direction. 
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Drill Description 

 YSaw 

For machining of lamello in the Y axis direction. 

 SideSaw 

For machining of lamello on the sides. 

 MillingTool 

For milling lamello once or twice 

 Left milling cutter 

For milling of lamello on the right. 

 Right milling cutter 

For milling of lamello on the left. 

 Upper milling cutter 

For milling of lamello on the back. 

 Lower milling cutter 

For milling of lamello in the front. 

 

Procedures: 

1. In the menu bar, go to Operate > Drill Edit. Enter the password. 

 
 

2. In the displayed DrillEdit window, click the pull-down menu in the upper left corner 
to select the drill package you want to edit. 

3. Different types of drills are displayed on the top. Select the target drill and click on 
the target position to add the drill to the position. 
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4. (Optional): To move a drill, double-click on the corresponding field and enter the 
desired values. 

5. Set the parameters based on the drill number: 

Parameter Description 

X/Y/Z The drill/spindle offset in the X/Y/Z axis direction. 

Tool Diameter The drill or spindle tool diameter. 

SafeDistance The required minimum distance between each tool. 
Machining is not allowed if the distance between tools 
is smaller than the safe distance. 

FeedSpeed The tool speed during machining. 

Hole bottom delay The duration that a tool stays on a hole bottom. 

Port The output port of each tool. 

 
6. Click OK to save your settings. 
7. You can uncheck the IsEnable box of a drill to disable it. 
8. (Optional): To show the drill view in the middle, click the FitView button on the top 

side. 
Related tasks: 

 Arranging the table by a certain parameter value in ascending/descending order 
o Click a parameter name to arrange the table by the column values in 

ascending order. 
o Click the parameter name again to arrange the table by the column values in 

descending order. 
 Setting a drill as the base/main drill 

a. Click the target drill shape. It turns green . 
b. Click the Set Main Drill button on the top. The X, Y, and Z values of the 

selected drill become 0. 
c. Click OK to save your settings. 

 Setting offsets for all drills 
a. Click the Overall offset button on the top. The Overall offset drilling 

package dialog box is displayed: 
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b. Enter the target position X and Y coordinates for the base/main drill and click 
Sure. 

c. Click OK to save your settings. 

3.11 Set Pressing Wheel and Board Parameters 
You need to set the pressing wheel and board related parameters. 

Procedures: 

1. (Optional): Click  in the upper right corner to 
switch to the Process screen. 

2. In the board information and parameter bar, click the CAM Parameter button on the 
right side to access the Parameter List screen. 

 
 

3. (Optional): Click the Advanced button in the upper right corner and enter the 
manufacturer password. 

4. In the left list, click Pressure's to show related parameters on the right. 

Parameter Description 

Length X The length of the pressing board in the X axis direction. 

Width Y The length of the pressing board in the Y axis direction. 

Coordinates 
X 

The center point offset relative to the base drill in the X axis 
direction. 

Coordinates 
Y 

The center point offset relative to the base drill in the Y axis 
direction. 

Press table 
Z 

Adjust this value based on the spindle datum to make the 
pressing board press on the board material. 

Open Code Specify an M code for enabling the pressing wheel and board. 

Close Code Specify an M code for withdrawing the pressing wheel and 
board. 

Open T(ms) Delay for enabling the cylinder. 

Close T(ms) Delay for withdrawing the cylinder. 

Check code 
for closed 

Specify an M code for pressing wheel and board withdrawal 
detection. 
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3.12 Execute Simulation 
During simulation, the system does not drive machine movement or consume machine or 
workpiece resources. Only the machining path and process are displayed in the software 
for you to spot possible problems and edit the program accordingly. 

Prerequisite: 

A machining file is loaded. For details, see Load a Machining File. 

Procedures: 

1. Select one of the following methods to enter simulation mode: 

o In the machining operation bar, click . 
o In the menu bar, go to Operate > Simulate. 

2. Select one of the following methods to start simulation: 
o Press the F9 key. 

o In the operation button bar, click . 
o In the menu bar, go to Operate > Cycle Start. 
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4 Quick Start 
4.1 Overview 
This section introduces a simple machining process using the NcStudio Phoenix Nine 
Axis Six-Side Drilling System. 

The process is shown below: 

 
 
The operations above need to be executed in the Process screen if no notes are provided 
indicating otherwise. 

4.2 Load a Machining File 
Before starting machining, you need to load a machining file. After the file is loaded, the 
board information in the file is shown in the Board List on the right. 

Procedures: 

1. Use one of the following methods to load a machining file: 
o Creating an XML file 

In the board editing bar, click . 
o Importing an XML file 

 In the menu bar, go to File > Open > Open standard XML/Open SVJ 
XML. 

 Right-click on the Board List and click Import xml. Select an option 
as needed. 

o Importing an MPR/BAN file 
 In the menu bar, go to File > Input > InputMpr/InputBan. 
 Right-click on the Board List and click Import mpr/ban. 

o Importing a CIX file 
 Right-click on the Board List and click Import cix. 

2. (Optional): After loading a file, if you need to edit it, see Creating and Editing Holes. 
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4.3 Start Machining 
Prerequisite: 

No alarm is reported, such as an emergency stop alarm. 

Procedures: 

1. Use a scanner to scan the barcode on the board. 
2. Select one of the following methods to start machining: 

o If the CAM parameter EnableScanAuto is set to 1, follow the steps below 
after the system starts to run the initial code: 

i. Place the board on the workbench. 
ii. Select one of the following methods to start machining: 

 Step on the pedal. 
 Press the F9 key. 

 In the machining operation bar, click . 
 In the menu bar, go to Operate > Cycle Start. 

o If the CAM parameter EnableScanAuto is set to 0, follow the steps below: 
i. Select one from the following methods to run the initial code: 

 Step on the pedal. 
 Press the F9 key. 

 In the machining operation bar, click . 
 In the menu bar, go to Operate > Cycle Start. 

ii. Place the board on the workbench. 
iii. Select one of the following methods to start machining: 

 Step on the pedal. 
 Press the F9 key. 

 In the machining operation bar, click . 
 In the menu bar, go to Operate > Cycle Start. 

3. (Optional): To stop machining, select one from the following methods: 
o Press the F11 key. 

o In the machining operation bar, click . 
o In the menu bar, go to Operate > Cycle Stop. 

After machining is stopped, the system enters idle state. 
Related task: 

Customization of M code: 

1. In the menu bar, go to Operate > MDI. 
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2. In the MDI dialog box, enter the M code in a box and click the corresponding 
Execute button. 
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5 Creating and Editing Holes 
This section introduces how to create and edit holes in the NcStudio Phoenix Nine Axis 
Six-Side Drilling System. 

The system supports different types of holes: 

: Side hold 

: Vertical hole 

: Slot 

: Pocket milling 

: Side lamello 

: Front and rear lamello 

: Lock 

: Cutting angle 

: Round angle 

: Groove 

The operations need to be executed in the Process screen if no notes are provided 
indicating otherwise. 

5.1 Creating a Side Hole 
Procedures: 

1. Select one of the following methods to enable the side hole tool: 

o In the board editing bar, click . 
o In the menu bar, go to Edit > CreatSideHole. 

2. Move the mouse pointer to a board edge. The mouse pointer becomes 

. Click where you want the side hole reference point. 
3. Move the mouse pointer to the target hole position and click. 
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4. In the displayed Create Side Hole dialog box, set the following parameters: 

Parameter Description 

DRP The distance between the side hole and the reference point. 

Z The Z-axis position of the side hole. 

HoleD The side hole diameter. 

HDeep The side hole depth. 

Count The side hole number. 

Space The distance between side holes. 

5. (Optional): To create a vertical hole, check Create Vertical Hole and set HoleD 
and HDeep. 

6. (Optional): To create a symmetrical hole in the X-/Y-axis direction, check Mirror 
X/Mirror Y. 
An example of created holes is shown below: 
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Related task 

Modifying side hole parameters 

1. Double-click a side hole. 
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2. In the displayed Edit Side Hole dialog box, change the values of DRP, Z, HoleD, 
and HDeep parameters. 

3. Check the options based on your needs. 
o Modify 32 multiple relationship: Change the parameter settings for side 

holes whose distances are 32 mm multiplied by x (an integer) at the same 
time. 

o Modify associated hole position relationship: Change the parameter 
settings for the mirrored symmetrical hole at the same time. 

o Modify the associated vertical holes: Change the parameter settings for 
the corresponding vertical hole at the same time. 

5.2 Create a Vertical Hole 
Procedures: 

1. Select one of the following methods to enable the vertical hole tool: 

o In the board editing bar, click . 
o In the menu bar, go to Edit > CreatVerHole. 

2. Move the mouse pointer to a board edge. The mouse pointer becomes 

. Click where you want the vertical hole reference point. 
3. Move the mouse pointer to the target hole position and click. 
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4. In the displayed Create Vertical Hole dialog box, set the following parameters: 

Parameter Description 

Surface Select whether to create the vertical hole in the front or 
back surface of the board. 

OffsetX The distance between the vertical hole and the reference 
point in the X axis direction. 

OffsetY The distance between the vertical hole and the reference 
point in the Y axis direction. 

HoleD The vertical hole diameter. 

HDeep The vertical hole depth. 

Count The vertical hole number. 

Space The distance between vertical holes. 

Direction Select whether to create a vertical hole in the X axis or Y 
axis direction. 

5. (Optional): To create a symmetrical hole in the X-/Y-axis direction, check Mirror 
X/Mirror Y. 
An example of created holes is shown below: 
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Related task 

Modifying vertical hole parameters 

1. Double-click a vertical hole. 
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2. In the displayed Edit Vertical Hole dialog box, change the values of Surface, 
Offset X, Offset Y, HoleD, and HDeep parameters. 

3. Check the options based on your needs. 
o Modify 32 multiple relationship: Change the parameter settings for side 

holes whose distances are 32 mm multiplied by x at the same time. 
o Modify associated hole position relationship: Change the parameter 

settings for the mirrored symmetrical hole at the same time. 
o Keep the aperture of all associated holes: Do not change the hole 

diameter of all associated vertical holes. 

5.3 Create a Slot 
Procedures: 

1. Select one of the following methods to enable the slot tool: 

o In the board editing bar, click . 
o In the menu bar, go to Edit > CreatSlot. 

2. Move the mouse pointer to a board edge. Click where you want the slot. 

 
 

3. In the displayed Create Slot dialog box, set the following parameters: 
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Parameter Description 

Surface Select whether to create the slot in the front or back 
surface of the board. 

SlotP The slot offset relative to the board edge. 

Buckle1/Buckle2 The reduced slot length relative to the board length. 
Used to change the slot length. The default slot length 
equals to the board length. 

Width The slot width, 

Depth The slot depth. 

An example of a created slot is shown below: 

 
 
Related task 

Modifying slot parameters 

1. Double-click a slot. 
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2. In the displayed Edit Slot dialog box, change the values of Surface, SlotP, 
Buckle1, Buckle2, Width, and Depth parameters. 

5.4 Create a Pocket Milling 
Procedures: 

1. Select one of the following methods to enable the pocket milling tool: 

o In the board editing bar, click . 
o In the menu bar, go to Edit > CreatPocketMilling. 

 
 

2. In the displayed Pocket Milling Instrument dialog box, set the following 
parameters: 

Parameter Description 

Surface Select whether to create the pocket milling in the front or back 
surface of the board. 

XDir 
Dis/YDir 
Dis 

Specify the position of the pocket milling. 
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Parameter Description 

Length The pocket milling length. 

Width The pocket milling width. 

Depth The pocket milling depth, which needs to be equal to or smaller 
than the board thickness. 

Radius The radius of the four round corners of the pocket milling. 

Ro-Angle The pocket milling rotation angle (anti-clockwise). 

P-M Type Area Clear: Cut the target shape with the milling tool step by 
step. Processing Along The Inside: Cut along the target shape 
inside the frame once. Processing Along The Center Line: Cut 
along the target shape on the frame once. Processing Along 
The Outside: Cut along the target shape outside the frame 
once. 

 

An example of a created pocket milling is shown below: 
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Related task 

Modifying pocket milling parameters 

1. Double-click a pocket milling. 
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2. In the displayed Milling Editing dialog box, change the values of Surface, 
XDirOffSet, YDirOffSet, Depth, and MillingCraftType parameters. 

5.5 Create a Side Lamello 
Procedures: 

1. Select one of the following methods to enable the side lamello tool: 

o In the board editing bar, click . 
o In the menu bar, go to Edit > Creat Side Lamello. 

2. Move the mouse pointer to a board edge. The pointer becomes . 
Click where you want the side lamello reference point. 

3. Click where you want the side lamello. 

 
 

4. In the displayed Create Side Lamello dialog box, set the following parameters: 
 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 53 / 103 

 

Parameter Description 

DRP The distance between the side lamello and the reference point. 

Z The Z-axis position of the side lamello. 

De-Type Standard: Set the Type and Lock Face parameters based on 
the model of the lamello invisible connection piece. Custom: 
Enter the Depth, Length, Jump Dis, Lock Face, and Hole Dis 
parameter values based on the actual situation. 

5. (Optional): To create a symmetrical side lamello in the X-/Y-axis direction, check 
Mirror X/Mirror Y. 

An example of a created side lamello is shown below: 

 
 
Related task 

Modifying side lamello parameters 
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1. Double-click a side lamello. 

 
 

2. In the displayed Edit Lamello dialog box, change the values of DRP, Z, and 
Standard/Custom parameters. 

5.6 Create Front Lamello 
Procedures: 

1. Select one of the following methods to enable the front lamello tool: 

o In the board editing bar, click . 
o In the menu bar, go to Edit > Creat Vertical Lamello. 

2. Move the mouse pointer to a board edge. The pointer becomes . 
Click where you want the lamello reference point. 

3. Click where you want the lamello (inside the board). 
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4. In the displayed Create Front Lamello dialog box, set the following parameters: 

Parameter Description 

Surface Select whether to create the lamello on the front or back 
surface of the board. 

Offset X The distance between the lamello and the reference point in 
the X axis direction. 

Offset Y The distance between the lamello and the reference point in 
the Y axis direction. 

De-Type Standard: Set the Direction and Type parameters based on 
the model of the lamello invisible connection piece. Custom: 
Set Direction and enter the Depth, Length and Jump Dis 
parameter values based on the actual situation. 

5. (Optional): To create a symmetrical lamello in the X-/Y-axis direction, check Mirror 
X/Mirror Y. 

An example of a created front/vertical lamello is shown below: 
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Related task 

Modifying front lamello parameters 

1. Double-click a front lamello. 
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2. In the displayed Edit Lamello dialog box, change the values of Surface, Offset X, 
Offset Y and De-Type parameters. 

5.7 Create a Lock 
Procedures: 

1. In the board editing bar, click . 

 
 

2. In the displayed Create Lock dialog box, set the following parameters: 

Parameter Description 

XDir 
Dis/YDir 
Dis 

Determine the position of the lock. 

Wide L(L1) The length of the wider slot of the lock 
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Parameter Description 

Narrow 
L(L2) 

The length of the narrower slot of the lock 

Wide 
W(W1) 

The width of the wider slot of the lock 

Narrow 
W(W2) 

The width of the narrower slot of the lock 

Depth1(D1) The depth of the wider slot of the lock 

Depth2(D2) The depth of the narrower slot of the lock 

Direction The direction of the narrower slot. ↑: up; ↓: down; ← : left; →: 
right. 

Surface Select whether to create the lock on the front or back surface 
of the board. 

3. (Optional): To create a symmetrical lock in the X-/Y-axis direction, check Mirror 
X/Mirror Y. 

An example of a created lock is shown below: 
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Related task 

Modify lock parameters 

1. Double-click a lock. 
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2. In the displayed Edit Lock dialog box, change the parameter values. 

5.8 Create an Angle 
Procedures: 

1. Select one of the following methods to enable the angle cutting tool: 

o In the board editing bar, click . 
o In the menu bar, go to Edit > CreatLcorner. 

2. Click on a board corner. 
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3. In the displayed Angle Cutting Tool dialog box, set the parameters based on the 

angle type: 

Angle Type Parameter 

Cutting 
Bevel 

Size X (angle X-axis length) and Size Y (angle Y-axis length). 

Right 
Angle L 

Size X (angle X-axis length) and Size Y (angle Y-axis length). 

Angle 
Rounded L 

Size X (angle X-axis length), Size Y (angle Y-axis length), 
Corner Radius, and Edge Radius L. 

Oblique 
Angle L 

Size X (angle X-axis length), Size Y (angle Y-axis length), 
Corner Radius, and Edge Radius L. 

An example of a created angle is shown below: 

 
 
Related task 

Removing an angle 

For details, see Remove Chamfers. 

5.9 Create a Round Angle 
Procedures: 

1. Select one of the following methods to enable the round angle tool: 

o In the board editing bar, click . 
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o In the menu bar, go to Edit > CreatRcorner. 
2. Click a board corner. 

 
 

3. In the displayed Circle Tool dialog box, select the round angle type and set the 
angle radius. 

An example of created round angle is shown below: 

 
 
Related task 

Removing an angle 

For details, see Remove Chamfers. 
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5.10 Create a Groove 
Procedures: 

1. Select one of the following methods to enable the groove tool: 

o In the board editing bar, click . 
o In the menu bar, go to Edit > CreatGroove. 

2. Move the mouse pointer to a board edge. The mouse pointer becomes 

. Click where you want the groove reference point. 
3. Click where you want the groove. 

 
 

4. In the displayed Add Groove dialog box, set the following parameters: 

Parameter Description 

DBP The distance between the groove and the reference point. 

Gap 
Length 

The length of the groove. 

Gap 
Depth 

The depth of the groove. 

Gap 
Count 

The number of the groove(s). 

Gap 
Interval 

The distance between grooves. 

 

An example of created grooves is shown below: 
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Related task 

Removing a groove 

For details, see Remove Chamfers. 

5.11 Remove Chamfers 
Use this function to remove unwanted angles and grooves. 

Prerequisite: 

At least one angle or groove has been created. 

Procedures: 

Select one of the following methods to enable the chamfer removing tool: 

 In the board editing bar, click . 
 In the menu bar, go to Edit > ClearLRCorner. 

 
This function erases all cut and round angles, and grooves. It does not support undo. 
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Related task 

 Removing board(s) 
o Removing one board 

In the Board List on the right, click the target board to select it. Right-click 
on it and click Remove Panel in the right-click menu. 

o Removing all boards 
In the Board List on the right, right-click on the blank area and click Clear 
Panel in the right-click menu. 

 Saving the current board file as an XML file 

o In the board editing bar, click ; or 
o In the menu bar, go to Edit > SaveThisPanel. 

 Adding a board into the machining list 
In the Board List on the right, click the target board to select it. Right-click on it and 
click Add to Machining List in the right-click menu. 
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6 Shape-Related Functions 
This section provides an introduction of the shape-related functions of the NcStudio 
Phoenix Nine Axis Six-Side Drilling System. 

The following operations are available in the Process screen if not indicated otherwise. 

6.1 Select an Object 
You need to select an object, such as a hole, before being able to edit it. 

Procedures: 

1. In the board editing bar, click  to enable the selection tool. 
2. Use one of the following methods to select one or multiple objects: 

o Select one object: Click on the target object. 
o Select multiple objects at one time: Press and hold the left mouse button to 

draw a square from the upper left corner to the lower right corner. All objects 
entirely inside the square will be selected. Or you can press and hold the left 
mouse button to draw a square from the lower right corner to the upper left 
corner. All objects included or intersected with the square will be selected. 

6.2 Adjust the Window 
You can make the board to adjust itself for better display. 

Procedures: 

In the board editing bar, click . 

6.3 Move the View 
You can move the board view to check different areas. 

Procedures: 

Use one of the following methods to move the view: 

 Press and hold the mouse wheel and move the mouse to the target position. 
 Follow the steps below: 

a. In the board editing bar, click . 
b. Select a base point and hold the left mouse button. Move the mouse until the 

view suits your need and then release the button. 
c. Press Esc to exit the tool. 

6.4 Mirror an Object 
Objects can be mirrored up/down and left/right. 

 Left/Right: Mirror the object along the Y axis. 

 Up/Down: Mirror the object along the X axis. 
Procedures: 

Use one of the following methods to mirror an object: 

 In the board editing bar, click / . 
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 In the menu bar, go to Edit > MirrorLR/MirrorUD. 

6.5 Flip a Board 
Boards can be flipped up/down and left/right. 

 Left/Right: Flip the board left/right. 

 Up/Down: Flip the board up/down. 
Procedures: 

Use one of the following methods to flip a board: 

 In the board editing bar, click / . 
 In the menu bar, go to Edit > FlipLR. 

6.6 Rotate a Board 
A board can be rotated clockwise by 90° at one time. 

Procedures: 

Use one of the following methods to rotate the board: 

 In the board editing bar, click . 
 In the menu bar, go to Edit > Rotate. 

6.7 Manage Layers and Layer Properties 
In this window, you can modify the layer properties. 

Procedures: 

1. In the board editing bar, click . In the displayed Layer window, you can view 
the layer properties. 

 
 

2. (Optional): Modify layer properties (taking modification of the negative elements 
layer as an example): 

a. Check the FillCheck box. Click the FillColor box. 
b. In the displayed dialog box, select the target filling color and click OK. 
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c. Restart the software to make the modification take effect. 
(Optional): Create a new layer and customize its properties: 

1. Click New to add a layer. 

 
 

2. Edit the properties as needed. Click Confirm. 
3. (Optional): Delete a layer: 

a. Click the leftmost column of the target row and click Delete. 
b. In the pop-up dialog box requiring confirmation, click Yes. 
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7 Board Measurement 
This section introduces how to measure the width, length, and thickness of a board. 

The operations below are available in the Process screen if not indicated otherwise. 

7.1 Measure Board Width 
This function measures board width with the loading of the side leaning mechanism. After 
the loading reaches the set value, the side leaning mechanism stops movement and reads 
the coordinates. The measured width needs to be compared with the board actual width. 

Procedures: 

1. In the board and stigma list area, check Sidelean in the upper right corner to enable 
the side leaning mechanism. 

2. In the Work List area, check WidthM to enable board width measurement. 
3. In the menu bar, go to System > Width measurement setting. 

 
 

4. In the Plate width measurement parameter setting dialog box, set the following 
parameters: 
 

Parameter Description 

Backing 
plate speed 

The speed at which the measuring point approaches the 
board. 

Distance 
from the 
point 

The distance between the measuring point and the board. 

Measure the 
distance 

The distance between the measuring axis mechanical origin 
and the clamp (for position calculation). 

Maximum 
distance 

The maximum distance that the measuring axis can move. 

Measurement 
end fallback 

The withdrawal distance of the side leaning mechanism after 
the measurement is complete. 

Width The tolerance allowed for width measurement. 
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Parameter Description 

tolerance 

Stop load 
rate 

The side leaning mechanism stops when the load rate reaches 
this value. Set it to a value as large as possible to avoid 
stopping in middle of normal movement. 

Starting load 
rate 

The measurement starts when the side leaning mechanism 
reaches the board and the load rate reaches this value. 

Traveling 
load rate 

The load rate when the side leaning mechanism is in middle of 
movement. 

Maintain load 
rate 

The load rate that needs to be kept after side leaning is 
complete. 

 
5. Click Save to save changes. 
6. Use one of the following methods to start measuring: 

o Press the F9 key. 

o In the machining operation bar, click . 
o In the menu bar, go to Operate > Cycle Start. 

7. In the menu bar, go to System > Width measurement setting. In the Plate width 
measurement parameter setting dialog box, check the measurement result. 

8. Compare the measuring result with the actual board width and see if the measuring 
error is within the tolerance: 

o Yes: Measurement is successful. 
o No: Repeat the steps above to measure again. 

7.2 Measure Board Length 
The opto-electric switch is used to calculate the board length by measuring the presence 
of signals, which needs to be compared with the board actual length. 

Procedures: 

1. In the board and stigma list area, check Sidelean in the upper right corner to enable 
the side leaning mechanism. 

2. In the Work List area, check LengthM to enable board length measurement. 
3. In the menu bar, go to System > Length measurement setting. 

 
 

4. In the Plate length measurement parameter setting dialog box, set the following 
parameters: 
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Parameter Description 

Dis between 
pos and pho 

The distance between the positioning cylinder and the opto-
electric signal in the clamp movement direction. 

Compensation 
distance 

Compensation during movement to ensure the normal entry 
into and exit from the signal area of the board. 

Length 
tolerance 

Tolerance allowed during length measurement 

Spot error 
compensation 

Compensation for the measurement result if there are errors. 

5. Use one of the following methods to start measuring: 
o Press the F9 key. 

o In the machining operation bar, click . 
o In the menu bar, go to Operate > Cycle Start. 

6. In the menu bar, go to System > Length measurement setting. In the Plate 
length measurement parameter setting dialog box, check the measurement 
result. 

7. Compare the measuring result with the actual board length and see if the 
measuring error is within the tolerance: 

o Yes: Measurement is successful. 
o No: Repeat the steps above to measure again. 

7.3 Measure Board Thickness 
Magnetic grating ruler is used to measure the height difference when the clamp is released 
and clamped. The measured thickness needs to be compared with the actual board 
thickness. 

Procedures: 

1. In the board and stigma list area, check Sidelean in the upper right corner to enable 
the side leaning mechanism. 

2. In the Work List area, check ThickM to enable board thickness measurement. 
3. In the menu bar, go to System > Thickness measurement setting. 

 
 

4. In the Plate thickness measurement parameter setting dialog box, set the 
following parameters: 
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Parameter Description 

Clamp 
release H 

The maximum height between the clamp internal sides when the 
clamp is released. 

Clamp 
delay 

Delay before measurement. 

Tolerance The tolerance allowed during thickness measurement. 

5. Use one of the following methods to start measuring: 
o Press the F9 key. 

o In the machining operation bar, click . 
o In the menu bar, go to Operate > Cycle Start. 

6. In the menu bar, go to System > Thickness measurement setting. In the Plate 
thickness measurement parameter setting dialog box, check the measurement 
result. 

7. Compare the measuring result with the actual board thickness and see if the 
measuring error is within the tolerance: 

o Yes: Measurement is successful. 
o No: Repeat the steps above to measure again. 
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8 System Management 
This section introduces system-related operations in the NcStudio Phoenix Nine Axis 
Six-Side Drilling System. 

The operations below are available in the Process or Control screen. 

8.1 Create Installation Package 
You can create an installation package with the current system data for system file backup 
and keeping a copy of a stable system version. 

Procedures: 

1. In the menu bar, go to File > Generate Installation Package. 

 
 

2. In the displayed Packup Tool dialog box, click Browse to select a storage path for 
the installation package. 

3. Click Pack up to make the system start generating an installation package. 
After an installation package is generated, you can find it under the selected 
directory. 

8.2 View the Log 
The system log shows important user operations, and system events and time after 
current system boot and in history. 

Procedures: 

1. Use one of the following methods to view the log: 
o In the status bar, double-click the blank area/warning message. 
o In the menu bar, go to System > Log. 
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In the Log dialog box, all information after current system boot is displayed by 
default. 

2. Highlight the corresponding button based on the type of log you want to check: 

o Software running information ( ): Click Show Info. 

o Alarms ( ): Click Show Alarms. 

o Errors ( ): Click Show Errors. 
o All logs after current system boot: Click All Logs. 
o All logs since the software is installed: Click Show History. 

3. (Optional): To delete all log information, click Clear. 

8.3 Change the Password 
The manufacturer password is required to edit drills, view/modify global manufacturer 
parameters, and set datum. 

Procedures: 

1. In the menu bar, go to System > Change Password. 
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2. In the displayed Modify Password dialog box, enter the old password and new 
password. 

3. Click Modify. 

8.4 Back up and Restore CNC Parameter Settings 
You can back up the machining parameter settings and import the backup data later if 
needed. 

Procedures: 

In the menu bar, go to System > Recover Parameter Backup. 

 Click Backup to save the settings as an XML file in the directory D:\Weihong\XML. 
 To import a backup file, select it and click Restore. 

8.5 NcTune 
NcTune includes functions that are not required during machining but may be needed 
during machine debugging. 

In NcTune, you can use functions of lead screw error compensation, tool calibration, 
modifying port polarity, viewing the log, using MDI, setting drive parameters, setting tool 
compensation parameters, collecting data, centering, setting offset, using the control panel, 
updating firmware, setting system parameters, and viewing machining statistics data. 

Use one of the following methods to show the NcTune page: 

 In the menu bar of NcStudio, go to System > NcTune. 
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 Close NcStudio. Open the following directory, and find and double-click 
NcTune.exe: 
C:\Program Files\Weihong\NcStudio\Bin 
For details about machine debugging, see Overview. 

8.6 Check Tool Lifespan 
You can check the tool lifespan to replace old tools in time, manually clear tool wearing 
data and define the tool lifespan. 

Procedures: 

1. In the menu bar, go to System > ToolLifeStatistics. 

 
 

2. The UsableTimes, UsableDistance, and UsableDuration fields of the tools can be 
modified. 

3. The UsedTimes, UsedDistance, and UsedDuration fields show the automatically 
collected data. 
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4. (Optional): If a tool has reached the set usable times/distance/duration and is 
replaced, you need to click Reset to clear the old data. 

8.7 View Machining Statistics 
The system records the number of boards and the board area processed, the machining 
duration, and compares those with yesterday's data. 

On the statistics page, you can check the board size, machining duration, and the number 
of holes and slots. 

Procedures: 

1. In the menu bar, go to System > ProcessStatistic. 

 
 

2. In the ProcessStatistic dialog box, enter the board bar code, name, and machining 
start and end time, and click Search to search for machining records that meet the 
conditions. 

3. (Optional): To clear machining data, specify a date in the Clear data area and click 
Clear. Machining data before the specified date will be erased. 

8.8 Register the Software 
You need to register the software if the software use period has or is about to expire, or if 
the writing type does not match. 

Procedures: 

1. In the menu bar, go to Help > About. 
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2. Click Register. 

 
 

3. Use one of the following methods to acquire the registration code: 
o Send the device number to the machine manufacturer and get a registration 

code. 
o Click Apply for reg, follow the instructions, and click OK. 
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4. Enter the registration code in the field. Click registered. 

8.9 Edit Start and End Codes 
You can edit the start and end codes (supporting M codes) to change the machine 
movements before and after machining. 

Procedures: 

1. (Optional): To check the definitions of M codes, go to System > Custom M 
instruction in the menu bar: 
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2. In the NcStudio home page, select the Process screen in the upper right corner. 
Click the CAM Parameter button above the drawing area. 

 
 

3. In the displayed Parameter List window, click StartEndCode in the left list: 
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4. Modify the codes based on your needs. 
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9 CAM Parameters 
CAM parameters include operation parameters, equipment parameters, pressing wheel 
and board parameters, and start/end codes. 

Contact us if the manufacturer password is required when modifying a parameter. 

Procedures: 

1. (Optional): In the NcStudio home page, select the Process screen in the upper 
right corner. 

2. Click the CAM Parameter button above the drawing area to access the Parameter 
List window. 

 
 

9.1 Operation Parameters 
Include common parameters controlling the machining process. 

The operation parameters are divided into the following categories: 

 Element selection 

Parameter Description 

IsOutputVerHoles Whether to process holes on the board 
front side. 0: Not process; 1: process. 

IsOutputVerHolesBack Whether to process holes on the board 
rear side. 0: Not process; 1: process. 

IsOutputHorHoles Whether to process board horizontal 
holes. 0: Not process; 1: process. 

IsOutputSlotes Whether to process slots on the board 
front side. 0: Not process; 1: process. 

IsOutputSlotesBack Whether to process slots on the board 
rear side. 0: Not process; 1: process. 

IsOutputShape Whether to process irregular-shaped 
outlines. 0: Not process; 1: process. 

IsOutputShapeHor Whether to process horizontal holes in 
the irregular-shaped position (when not 
process irregular-shaped outlines). 0: 
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Parameter Description 

Not process; 1: process. 

IsBigHoleAtFaceA Whether to forcibly flip the big hole 
(spindle tool) to the front side. 0: No; 1: 
Yes. 

HolesSortingStyle Hole sequencing rule. 1: only in and no 
out; 2: shortest path. 

SingleFaceFlipStyle Board flipping method. 0: not flip; 1: flip 
only when there is data on the rear side; 
2: slots first; 3: side with more holes 
facing up; 4: automatic. 

IsForceHorSlot Whether to forcibly rotate the board with 
vertical slots by 90 degrees. 

RotateBoardStyle Whether to forcibly rotate the element in 
the clamp position by 180 degrees. 0: 
not rotate; 1: rotate. 

IsMaxEdgeNearPawAndLocation Whether to show information of larger 
edge seal near the clamp and 
positioning cylinder. 0: no; 1: yes. 

PerLenForSorting The length of each segment during 
shortest path segmental optimization. 

DifferentOperatePlaneAddDistance The distance punishment during 
sequencing of elements to be processed 
when switching on different operation 
surfaces of the upper drill package.  

UpDownOperatePlaneAddDistance The distance punishment during 
sequencing of elements to be processed 
when switching between the upper and 
lower drill packages. 

IsOutputSideSlots Whether to process side slots. 0: no; 1: 
yes. 

IsOutputLamelloes Whether to process the front side 
lamello. 0: no; 1: yes. 

IsOutputBottomLamelloes Whether to process the rear side 
lamello. 0: no; 1: yes. 

IsOutputSideLamelloes Whether to process the side lamello. 0: 
no; 1: yes. 

 Hole machining 

Parameter Description 

MaxDepthForVerHole Maximum depth of a vertical hole. 

MaxHorHoleDepth Maximum depth of a side hole. 
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Parameter Description 

HorMaxDistanceFromPaw The maximum X-axis distance 
between the side hole and the 
clamp. Effective when the GraspR 
box in the Work List is checked. 

VerMaxDistanceFromPaw The maximum X-axis distance 
between the vertical hole and the 
clamp. Effective when the GraspR 
box in the Work List is checked. 

IsEnableFaceAPress Whether to enable pressing board 
for the front side holes. 0: no; 1: 
yes. 

IsHoleUseTwoPresses Whether to enable dual-pressing 
for the front side holes. 0: no; 1: 
yes. 

IsDownPressCanUseUpFace Whether the pressing board for 
rear side holes can be used for the 
front side. 0: no; 1: yes. 

FaceBPressHeight The slight lift height of the pressing 
board for the rear side holes. 

VerVelSinglePaw The machining speed for vertical 
holes with single clamp. 

HorVelSinglePaw The machining speed for side 
holes with single clamp. 

SizeHorVelSinglePaw The machining speed for side 
holes at the side leaning position 
with single clamp. 

MultiHorVelSingleSpeed The machining speed when more 
than 3 side holes are processed at 
the same time. 

HoleDelayCode Hole bottom delay code. 

UpVerHolePairWithHorHoleMaxDistance When the distance between the 
side hole and the upper vertical 
hole is less than this value, the 
side hole will be processed first. If 
the value is less than 0, the 
function is disabled. 

IsXHorHoleUseDoubleDrillMutilTool Whether to enable dual-drill-
package for processing of the X-
axis side holes. 0: no; 1: yes. 

IsYHorHoleUseDoubleDrillMutilTool Whether to enable dual-drill-
package for processing of the Y-
axis side holes. 0: no; 1: yes. 
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Parameter Description 

UseDoubleDrillMinWidth Minimum board width for enabling 
machining with dual drill packages 
when selecting tools matching the 
holes 

XHorDoubleDrillNoPressMaxDistance When using dual-drill-package to 
process X-axis side holes and if 
the distance between the side hole 
in the clamp position and the 
clamp exceeds this value, the 
pressing wheel will not press. 

BrokenSkinDistanceForVerHole Distance for vertical surface 
breaking. 

BrokenSkinSpeedForVerHole Machining distance during the 
vertical surface breaking distance. 

 Spindle machining 

Parameter Description 

MaxDepthForMain The maximum depth that can be 
reached by machining with the 
spindle. 

PerCutDepth The maximum depth that can be 
reached in one time of cutting with 
the spindle. 

IsMainSpindleFirstKnife Whether to lower the tool first during 
machining with the spindle. 0: no; 1: 
yes. 

IsUpMianCynStopSpindle Whether the spindle stops running 
after the spindle cylinder is 
withdrawn. 0: no; 1: yes. 

IsMainSpindleUsePress The type of pressing material used 
during machining with the upper 
spindle. 0: pressing wheel; 1: spindle 
pressing material. 

IsSMainSpindleUsePress The type of pressing material used 
during machining with the lower 
spindle. 0: pressing wheel; 1: spindle 
pressing material. 

IsMainSpindlePressCanUp Whether to withdraw the cylinder for 
the spindle pressing material. 0: no; 
1: yes. 

MainSpindleSinglePaw The spindle machining speed with 
one clamp. 
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Parameter Description 

SlotSpeed The slot machining speed. 

SlotShortMoveSpeed Wide slot direction-changing 
machining speed. 

NomalMillingSpeed Pocket milling speed. 

CutMillingSpeed Milling cutting speed. 

SlotToolSpacing Spindle milling tool offset. 

HorXSlotProcessingSettedDir Whether specify machining direction 
for X-axis slots. 0: not specify; 1: X- 
to X+; 2: X+ to X-. 

HorYSlotProcessingSettedDir Whether specify machining direction 
for Y-axis slots. 0: not specify; 1: Y- 
to Y+; 2: Y+ to Y-. 

IsSlotExpansionRadius Whether to extend slots outward by 
the spindle tool radius. 0: no; 1: yes. 

SlotConnectionDistance The maximum distance that can be 
connected by slots with the same 
depth and width on the same 
surface. 

SlotLengthForNoSlotExpansion Slots whose lengths are smaller than 
this value will not be extended 
outward along with other slots. 

IsUpSectionSlotUsePress Whether to enable pressing material 
for the segmented slots on the front 
side. 0: no; 1: yes. 

IsSlotChangePawsNeedPress Whether a pressing material is 
required when replacing the clamp 
for segmented slots. 0: no; 1: yes. 

BrokenSkinDistance The surface cutting distance (equal 
to or more than the spindle tool 
radius is recommended). 

InBrokenSkinSlotSpeed The machining speed within the 
surface cutting distance. 

IsBrokenSkinSlowSpeed The surface cutting method. 0: no 
setting; 1: slow speed; 2: start cutting 
outside of the board. 

IsThroughSlotMilling Whether to process slots and milling 
shapes whose depths are the same 
as the board thickness into upper 
and lower parts. 0: no; 1: yes. 

ThroughHoleAddDepth Additional depth to half of the board 
thickness when processing elements 
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Parameter Description 

whose depths are the same as the 
board thickness. 

MinDistanceForUpDownSpindleSlots Minimum distance allowed between 
the centers of the upper and lower 
slots when the upper and lower 
spindles are used for machining at 
the same time (-1 means creating 
slots up/down is forbidden). 

MillingNeedPause Whether to pause before discharging 
milled elements. 0: no; 1: yes. 

ThroughObjUseCutMinLength During cut-through machining, if any 
edge of the circumscribed rectangle 
of the board elements is smaller than 
this value, regional clearing will be 
enabled; otherwise, outline cutting 
will be enabled. 

MillingCutMinRectLength If any edge of the circumscribed 
rectangle of the milled shapes in the 
board outline is smaller than this 
value, regional clearing will be 
enabled; otherwise, outline cutting 
will be enabled. 

AdditionalDepth Additional depth to the element 
bottom during outline cut-through 
machining. 

PreSatrtCodeAdvanceLineCount The number of rows in advance in 
the M code for spindle pre-start.  

IsSpindleUsingOneFrequencyChanger Whether to use only one frequency 
inverter for the spindle. 0: no; 1: yes. 

 Special process 

Parameter Description 

MaxDepthForLock The lock maximum depth. 

MaxDepthForSaw The maximum depth for saw machining. 

MillingToolPath How to process lamello with a milling 
tool. 0: one cut; 1: two cuts. 

SideSlotPriorToolType The type of tools to be used for side 
slots preferably. 1: milling tool; 2: saw. 

SideFaceSlotForMaxWidth Maximum board speed available for the 
tool milling side slots at the side leaning 
position. 

SideFaceLRMaxDistance Maximum distance between the left and 
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Parameter Description 

right side slots and the clamp internal 
side. 

IsSideSawAntiClockWiseMachining Whether to process side slots anti-
clockwise along the board with the side 
saw. 0: no; 1: yes. 

DoublePanelModeType Dual-board mode. 0: Disable dual-board 
mode; 1: mirror; 2: left/right; 3: up/down. 

 Compensation parameters 

Parameter Description 

IsUseCompZ Whether to enable side hole Z-axis compensation 
if the pressing wheel does not press. 0: no; 1: yes. 

FrontHorCompZ Z-axis compensation for the left side hole. 

BackHorCompZ Z-axis compensation for the right side hole. 

PawHorCompZ Z-axis compensation for the clamp side hole. 

SideHorCompZ Z-axis compensation for the side hole at the side 
leaning position. 

NoPressPawSlotUpZOff Z-axis compensation for the upper spindle clamp 
slot when there is no pressing material. 

NoPressPawSlotDownZOff Z-axis compensation for the lower spindle clamp 
slot when there is no pressing material. 

PanelHeightComp Board thickness compensation. A positive value 
indicates that the board actual thickness is larger 
than the data while a negative value indicates that 
the board actual thickness is smaller than the data. 

 Discharge parameters 

Parameter Description 

BoardExitStyle Material discharge method. 0: front; 1: rear. 

MinWidthFroFront If the board width is smaller than this value, materials 
will be forced to use front discharge. 

MaxWidthForNormalVel If the board width is larger than this value, materials 
will be forced to use front discharge with the low 
speed. 

FrontBoardOutVel Front discharge speed. 

BoardOutLowVel Front discharge low speed. 

FrontBoardOutMaxX The clamp maximum workpiece coordinates during 
front discharge. 

BoardExitPos The board head position for front discharge. 

BoardExitPos2 The board tail position for rear discharge. 
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Parameter Description 

BackBoardOutVel Rear discharge speed. 

BackOutPanelMaxX When the board head position is equal to or larger 
than this value during rear discharge, the rear 
discharge waiting M code will be added. 

 Other parameters 

Parameter Description 

UseHitWhereCatchWherePanelMinWidth If the board width is smaller 
than this value, the GraspR 
function will be enabled 
forcibly. 

IsDrawDimension Whether to show hole 
information. 0: no; 1: yes. 

IsAutoShowNextPanel Whether to show the next 
board to be processed. 0: 
no; 1: yes. 

IsEnableSide Whether to enable side 
leaning. 0: no; 1: yes. 

IsAnnotateNc Whether to add notes for the 
tool path. 0: no; 1: yes. 

IsClearTaskListFirstTime Whether to clear the 
machining list after the 
software is restarted. 0: no; 
1: yes. 

IsProcessedPanelNeedTip Whether to show a message 
window when you are trying 
to add a processed board. 0: 
no; 1: yes. 

EdgePlus Shrinking multiplier of edge 
seal information. 

ChangeToolAddDistance Distance punishment when 
replacing the lowered tool 
with the tool not lowered 
during tool selection. 

ChangePressAddDistance Distance punishment when 
replacing the lowered 
pressing material with the 
pressing material not 
lowered during pressing 
material selection. 

HorHoleDownSlotMinSinglePawLength The minimum length held by 
a single clamp during 
machining with a horizontal 
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Parameter Description 

tool or spindle on the rear 
side. 

NumPrecision The number of digits after 
the decimal point of the tool 
path coordinates. 

EnableScanAuto Whether to enable 
automatic machining after 
code scanning. 0: no; 1: yes. 

lgnoreOrRemainScanPIDFrontOrBackCharacter Code reading filtering rule X-
Y (0-0 by default). X: 0: 
Neglect the Xth digit from 
the end of the barcode; 1: 
Neglect the first X digits of 
the barcode; 2: Neglect the 
last X digits of the barcode; 
3: Keep the first X digits of 
the barcode. Y: The filtering 
rule is effective when Y is 
larger than 0. 

FolderPathForScanPanel Fixed directory for board 
barcode scanning and 
downloading. 

FileSuffixForScanPanel The suffix of the board data 
file in the fixed directory (1: 
mpr; 2: ban; 3: xml). 

XMLFileTypeForScanPanel The source of the XML file in 
the fixed directory (1: 
KDTXml; 2: ProgramXml). 

DistinguishIndexForScanFrontPanel Use the Xth digit from the 
last of the file to distinguish 
between the front and rear 
sides (effective when larger 
than 0). 

DistinguishScanFrontPanelCharacter Scan in the fixed directory 
for file names containing 
front side data characters. 

DistinguishScanBackPanelCharacter Scan in the fixed directory 
for file names containing 
rear side data characters. 

 

IsUpTablelnM108 Whether to add workbench 
lifting movement in the 
received commands. 0: no; 
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Parameter Description 

1: yes. 

ZMinusFaceToolNumber The tool number matching 
the operation surface 
opposite to the vertical 
pocket milling (ID 112 in the 
mpr file). If the tool number 
is not shown in the 
parameter screen, the 
surface is a side surface. 

IsZCoorFromZeroForFaceBDepth Whether to calculate the 
depth of rear side elements 
in the ban files as 0 surface. 
0: no; 1: yes. 

9.2 Equipment Parameters 
Include parameters related to equipment, such as the drill packages, clamps, and side 
leaning mechanism. 

The equipment parameters are divided into the following categories: 

 Mechanical specifications 
 

Parameter Description 

UsingFixLocation The type of positioning cylinder. 0: movable; 1: 
fixed. 

IsLocationlnY Whether the movable positioning cylinder is 
located on the drill package Y (the upper left drill 
package). 0: no; 1: yes. 

LocationWidth The Y-axis height of the movable positioning 
cylinder. 

PawLocationlnternelDistance The minimum gap between the positioning rod 
and the clamp Y-axis edge. 

BoardHeadOffset The Y-axis offset of the movable positioning 
cylinder relative to the base drill. 

ZLocationPostion The Z-axis position when the positioning 
cylinder lowers with its bottom attached firmly on 
the workbench surface. 

PawLength The clamp length. 

PawWidth The clamp width. 

OnePawToPanelDis The distance between the released single clamp 
and the board. 

MaxSinglePawLength The maximum board length with a single clamp. 

PawMinLengthAtBoard The minimum clamp length held on the board 
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Parameter Description 

when there are dual clamps. 

MinSinglePawLength The minimum clamp length held on the board 
when there is a single clamp. 

MaxBoardLength The maximum board length that can be 
processed. 

MinBoardLength The minimum board length that can be 
processed. 

MaxBoardWidth The maximum board width that can be 
processed. 

MinBoardWidth The minimum board width that can be 
processed. 

MinLengthUsingSide The minimum board length that allows side 
leaning. 

MaxWidthUsingSide The maximum board width that allows side 
leaning. 

MinWidthUsingSide The minimum board width that allows side 
leaning. 

SideHeight Side leaning width. 

SideFarwardDir Whether the side leaning mechanism moves in 
the positive direction. 

SideOrigin The workpiece coordinates of the side leaning 
mechanism when it is not enabled. 

SideSimuDir Whether the initial direction for the side leaning 
simulation is positive. 0: no; 1: yes. 

PressMinLength The minimum length that the pressing 
wheel/pressing board hold the board material. 

DisableAxisID Identifiers of disabled axes. Use blank spaces to 
separate the identifiers. 

OpenTableTools Serial numbers of tools that require a fully open 
workbench. Use English commas to separate 
the tool numbers. 

HalfOpenTableTools Serial numbers of tools that require a half open 
workbench. Use English commas to separate 
the tool numbers. 

CloseTableTools Serial numbers of tools that require a closed 
workbench. Use English commas to separate 
the tool numbers. 

DownPressTools Serial numbers of tools that enable lower 
support. Use English commas to separate the 
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Parameter Description 

tool numbers. 

SameToolHandle Tool number for spindles with the same tool 
handle. Separate the same tool handles with the 
English underscore. Separate different tool 
handles with the English comma. 

 Security parameters 

Parameter Description 

AbsSafeHeight Absolute safety height for upper drill packages. 

AbsSDrillHeight Absolute safety height for lower drill packages. 

UpDrillSafeDistance Safe distance between upper drill packages. 

PawVerSafeDistance Safe distance between the vertical drill and 
clamp. 

PawHorSafeDistance Safe distance between the horizontal drill and 
clamp. 

MainSafeDistance Safe distance between the upper spindle and 
clamp. 

SMainSafeDistance Safe distance between the lower spindle and 
clamp. 

SawSafeDistance Safe distance between the saw and clamp. 

SideSawLameloSideAvoidDi
stance 

Safe distance between the saw and side leaning 
mechanism. 

PressSafeDistance1 Safe distance between the pressing 
wheel/pressing board and clamp. 

PressSafeDistanceWithSide Safe distance between the pressing 
wheel/pressing board and side leaning 
mechanism. 

PawSafeDistance Safe distance between the clamps. 

SideBackerlnit Initial distance of the side leaning mechanism 
(safe distance between the side leaning 
mechanism and the board edge). 

HorHoleCenterToPanelConc
aveAngelSafeDistance 

Safety distance between the irregular shape 
horizontal hole center and the board reentrant 
angle. 

SDrillPawUpXSafeDistance X-axis safety distance between the lower tray 
X+ side edge and the clamp (effective during 
machining on the lower operation surface). 

SDrillPawDownXSafeDistanc
e 

X-axis safety distance between the lower tray X- 
side edge and the clamp (effective during 
machining on the lower operation surface). 
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Parameter Description 

XDirMillingToolPawSafeDist
ance 

Safety distance between the X-axis side milling 
tool and clamp. 

YDirMillingToolPawSafeDist
ance 

Safety distance between the Y-axis side milling 
tool and clamp. 

AbsUpSpindleSafeHeight Absolute safety height of the upper spindle. 

SidePressAvoidDistanceFor
SideTool 

Safety distance for the side leaning mechanism 
to evade the board edges when the spindle 
elements face the machining side. 

XHorDrillDownPalletYOff The Y-axis safety offset of the lower drill 
package (lower tray) relative to the upper drill 
package during X-axis side leaning in the 
machining process. 

SideHorPanelY2FollowMinDi
stance 

If the board width is smaller than this value, 
enable evading for the lower drill package (lower 
tray) during machining of side holes at the side 
leaning position. 

SideHorPanelY2AvoidDistan
ce 

Safety offset of the lower drill package relative to 
the upper drill package if evading is enabled for 
the lower drill package (lower tray) during 
machining of side holes at the side leaning 
position. 

SideHorDrillDownPalletMinB
oardLength 

If the board width is smaller than this value, 
enable Y-axis offset relative to the upper drill 
package for the lower drill package (lower tray) 
during machining of side holes at the side 
leaning position. 

SideHorDrillDownPalletYOff Safety offset of the lower drill package relative to 
the upper drill package if offset is enabled for 
the lower drill package (lower tray) during 
machining of side holes at the side leaning 
position. 

DownSpindleCutPanelPress
YOff 

Y-axis safety offset to be added for spindle 
pressing material during cut-through machining 
with the lower spindle. 

UpSpindleCutPanelDownPall
etYOff 

Y-axis safety offset to be added for lower 
support during cut-through machining with the 
upper spindle. 

XFaceSideSlotDownPalletYO
ff 

Y-axis safety offset of the lower drill package 
(lower tray) relative to the upper drill package 
during machining of left and right side slots. 

MaxPanelWidthForSideFace
SideSlotDownPalletAvoid 

If the board width is smaller than this value, 
enable evading for the lower drill package (lower 
tray) during machining of side slots at the side 
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Parameter Description 

leaning position. 

SideFaceSideSlotDownPallet
AvoidYOff 

Safety offset of the lower drill package relative to 
the upper drill package if evading is enabled for 
the lower drill package (lower tray) during 
machining of side slots at the side leaning 
position. 

XFaceSideLamelloDownPall
etYOff 

Y-axis safety offset of the lower drill package 
(lower tray) relative to the upper drill package 
during machining of left and right lamelloes. 

MaxPanelWidthForSideFace
SideLamelloDownPalletAvoi
d 

If the board width is smaller than this value, 
enable evading for the lower drill package (lower 
tray) during machining of side lamelloes at the 
side leaning position. 

SideFaceSideLamelloDownP
alletAvoidYOff 

Safety offset of the lower drill package relative to 
the upper drill package if evading is enabled for 
the lower drill package (lower tray) during 
machining of side lamelloes at the side leaning 
position. 

IsDrillAvoid Whether to enable evading for the upper drill 
package. 0: no; 1: yes. 

DrillAvoidDistange Minimum distance between the upper drill 
package and clamp internal side. Effective when 
evading is enabled for the upper drill package. 

IsSDrillAvoid Whether to enable evading for the lower drill 
package. 0: no; 1: yes. 

SDrillAvoidDistance Minimum distance between the lower tray and 
clamp internal side. Effective when evading is 
enabled for the lower drill package. 

SDrillInterferenceYLength Y-axis length of the lower tray (for specifying a 
tool that allows for non-interference between the 
rear side holes and the clamp. Effective when 
evading is enabled for the lower drill package). 

SDrillPawSafeDistance Safety distance between the lower tray and 
clamp Y-axis edge (for specifying tools that 
allow for non-interference between the rear side 
holes and the clamp. Effective when evading is 
enabled for the lower drill package). 

ToolPressThroughPawAvoid
Style 

Handling method for the tool and pressing 
material crossing the clamp. 0: withdraw tool 
and pressing material; 1: enable evading for the 
drill package. 

IsThroughPawsBackTool Whether to withdraw the tool when it is crossing 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 96 / 103 

 

Parameter Description 

the clamp. 0: no; 1: yes. 

IsSideHorHoleThroughPaws
UpZ 

Whether to lift the horizontal drill when crossing 
the clamp. 0: no; 1: yes. 

IsVerHorHoleThroughPawsU
pZ 

Whether to lift the vertical drill when crossing the 
clamp. 0: no; 1: yes. 

ThroughPawsUpZPostion The Z-axis position for lifting the upper drill 
package when it crosses the clamp. 

IsChangePawNeedUpTool Whether to withdraw tool for clamp replacement. 
0: no; 1: yes. 

IsNoPanlePawNeedClose Whether to enable dry clamping for clamps 
holding no boards. 0: no; 1: yes. 

IsThroughSideBackSide Whether to withdraw the side leaning 
mechanism when the milling tool approaches it. 
0: no; 1: yes. 

IsSideAvoidlrregularOutLine Whether to enable evading for the side leaning 
mechanism forcibly when the board 
corresponding side has an irregular outline. 0: 
no; 1: yes. 

IsPressCanOutSide Whether the pressing material can exceed the 
side leaning mechanism. 0: no; 1: yes. 

IsDownPressCanParallelWit
hPaw 

Whether the lower material stripper can be 
aligned with the clamp internal side. 0: no; 1: 
yes. 

IsUpDrillUnloadAvoid Whether to enable Y-axis evading for the upper 
drill package during material discharge. 0: no; 1: 
yes. 

IsDownDrillUnloadAvoid Whether to enable Y-axis evading for the lower 
drill package during material discharge. 0: no; 1: 
yes. 

IsHorHoleCanUnderPaw Whether side holes under clamps are allowed. 
0: no; 1: yes. (To avoid empty running or 
collision between the drill and clamp.) 

 M code configuration 

Parameter Description 

PawClose M code for clamping X+ clamp 

PawLoosen M code for releasing X+ clamp 

Paw2Close M code for clamping X- clamp 

Paw2Loosen M code for releasing X- clamp 

AllPawsCloseM M code for clamping all clamps. 
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Parameter Description 

AllPawsOpenM M code for releasing all clamps. 

Paw1MoveDownCode M code for enabling X+ clamp floating. 

Paw1MoveUpCode M code for disabling X+ clamp floating. 

Paw2MoveDownCode M code for enabling X- clamp floating. 

Paw2MoveUpCode M code for disabling X- clamp floating. 

LocationDown M code for enabling the positioning cylinder. 

Locationup M code for disabling the positioning cylinder. 

UpSpindleCyOnM M code for enabling the upper left drill package 
spindle cylinder. 

UpSpindleCyOffM M code for disabling the upper left drill 
package spindle cylinder. 

UpSpindle2CyOnM M code for enabling the upper right drill 
package spindle cylinder. 

UpSpindle2CyOffM M code for disabling the upper right drill 
package spindle cylinder. 

DownSpindleCyOnM M code for enabling the lower spindle cylinder. 

DownSpindleCyOffM M code for disabling the lower spindle cylinder. 

UpSpindleDownReadyCode M code for enabling upper spindle in-position 
detection. 

DownSpindleDownReadyCode M code for enabling lower spindle in-position 
detection. 

LocationUpReadyCode M code for enabling positioning cylinder 
withdrawal in-position detection. 

XHorPanelDownMCode M code for lowering the workbench surface for 
machining X-axis side holes. Optional based 
on the machine model. 

XHorPanelUpMCode M code for lifting the workbench surface for 
machining X-axis side holes. Optional based 
on the machine model. 

YHorPanelDownMCode M code for lowering the workbench surface for 
machining Y-axis side holes. Optional based 
on the machine model. 

YHorPanelUpMCode M code for lifting the workbench surface for 
machining Y-axis side holes. Optional based 
on the machine model. 

PanelHalfOpenMCode M code for making the workbench half open. 
Optional based on the machine model. 

PanelOpenMCode M code for making the workbench entirely 
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Parameter Description 

open. Optional based on the machine model. 

PanelCloseMCode M code for making the workbench entirely 
closed. Optional based on the machine model. 

MainKnifeStart M code for starting the upper left drill package 
spindle. 

MainKnifeEnd M code for stopping the upper left drill package 
spindle. 

MainKnifeStart2 M code for starting the upper right drill 
package spindle. 

MainKnifeEnd2 M code for stopping the upper right drill 
package spindle. 

SMainStart M code for starting the lower drill package 
spindle. 

SMainEnd M code for stopping the lower drill package 
spindle. 

MainStartCheckCode M code for checking upper spindle frequency 
arrival. 

SMainStartCheckCode M code for checking lower spindle frequency 
arrival. 

UpSpindlePreSatrtCode M code for upper spindle pre-start. 

DownSpindlePreSatrtCode M code for lower spindle pre-start. 

DrillStart M code for starting the upper left drill package 
group. 

DrillEnd M code for stopping the upper left drill package 
group. 

Drill2Start M code for starting the upper right drill 
package group. 

Drill2Stop M code for stopping the upper right drill 
package group. 

SDrillStart M code for starting the lower drill package 
group. 

SDrillEnd M code for stopping the lower drill package 
group. 

HorSawStartCode M code for starting the horizontal drill. 

HorSawStopCode M code for stopping the horizontal drill. 

CheckBoardLenM M code for board length measurement. 

CheckBoardThickness M code for board thickness measurement. 
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Parameter Description 

CheckBoardWidthM M code for board width measurement. 

SidePushCode M code for side leaning torque material 
pushing. 

WaitBackOutPanelMCode M code for waiting when the board head 
position during rear discharge is larger than 
the parameter value. 

FrontOutPanelMCode M code for no response during front discharge. 

BackOutPanelMCode M code for no response during rear discharge. 

SidelnCode M code for pushing the side leaning 
mechanism. 

SideOutCode M code for withdrawing the side leaning 
mechanism. 

 Delay parameters 

Parameter Description 

DelayPawClose Clamp closing delay. 

DelayPawOpen Clamp releasing delay. 

MoveDownDelay Delay for enabling clamp floating. 

MoveUpDelay Delay for disabling clamp floating. 

DelayDrillSel Delay for pushing out the vertical drill. 

DelayDrillBack Delay for withdrawing the vertical drill. 

DelayHorDrillSel Delay for pushing out the horizontal drill. 

DelayHorDrillBack Delay for withdrawing the horizontal drill. 

DelayMainSel Delay for pushing out the spindle. 

DelayMainBack Delay for withdrawing the spindle. 

DelayMainStart Delay for starting the spindle. 

DelayDrillStart Delay for starting the drill package. 

SawSelDelay Delay for pushing out the saw. 

SawBackDelay Delay for withdrawing the saw. 

HorSawSelDelay Delay for pushing out the side saw. 

HorSawBackDelay Delay for withdrawing the side saw. 

TableOpenDelay Delay for opening the workbench. 

TableCloseDelay Delay for closing the workbench. 

TableDownDelay Delay for lowering the workbench. 

TableUpDelay Delay for lifting the workbench. 
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Parameter Description 

SidelnDelay Delay for pushing out the side pushing mechanism. 

SideOutDelay Delay for withdrawing the side pushing mechanism. 

 Automatic anti-collision 
 

Parameter Description 

PawMaxThickness Clamp height when it is open. 

PawThickness The clamp thickness. 

UpDrillXLength The X-axis length of the upper left drill 
package. 

UpDrillXOffset Distance between the base drill of the 
upper left drill package and the drill 
package edge in the X- direction. 

UpDrillYOffset Distance between the base drill of the 
upper left drill package and the drill 
package edge in the Y- direction. 

DownDrillOffsetZ Z-axis offset from the bottom side of the 
lower drill package to the base drill. 

DownDrillXLength X-axis length of the lower drill package. 

DownDrillXOffset Distance between the base drill of the 
lower drill package and the drill package 
edge in the X- direction. 

DownDrillYOffset Distance between the base drill of the 
lower drill package and the drill package 
edge in the Y- direction. 

UpDrill2OffsetZ Z-axis offset from the bottom side of the 
upper right drill package to the base drill. 

UpDrill2XLength X-axis length of the upper right drill 
package. 

UpDrill2XOffset Distance between the base drill of the 
upper right drill package and the drill 
package edge in the X- direction. 

UpDrill2YOffset Distance between the base drill of the 
upper right drill package and the drill 
package edge in the Y- direction. 

 
 Clamp related 

Parameter Description 

InterferenceMaxCount If the number of interference elements is larger 
than this value, remove certain interference 
elements based on the initial position quickly 
located and then iterate holding possibilities. 

GetPawsPostionTime Maximum time allowed for execution of the 
clamping strategy of a single type of elements. 
The unit is ms. Iterate holding possibilities. 

PawsAreaMaxDistance If the distance between the clamp and the 
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Parameter Description 

board exceeds this value, do not iterate other 
holding possibilities. 

WeightChangePawsCount Weight of the times of clamp change in the 
evaluation function. 

WeightFirstPawsPostion Weight of the clamp initial position in the 
evaluation function. 

WeightPawsDistance Weight of the clamp interval in the evaluation 
function. 

WeightPawsLength Weight of the clamp holding length in the 
evaluation function. 

IsAvoidMilling Whether to evade milled outline. 

NoChangePawsMaxDistance Maximum distance for two times of clamping 
without clamp change. 

IsUPaws Whether the clamp is a U-shaped one. 

UPawsConcaveUpXDis The X-axis distance between the X+ edge of 
the U-shaped clamp notch and the X+ edge of 
the clamp. 

UPawsConcaveDownXDis The X-axis distance between the X- edge of the 
U-shaped clamp notch and the X- edge of the 
clamp. 

UPawsConcaveYLength The Y-axis length of the U-shaped clamp notch. 

 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 102 / 103 

 

 

Legal Notices 
The term “Software Product” includes all copies of the licensed software and its 
documentation. This license agreement is a legal agreement between You (either an 
individual, a legal entity or any affiliated companies or other entities) and Weihong 
Electronic Technology Co., Ltd. (hereinafter referred to as Weihong Company). By 
installing, copying, or otherwise using the Software Product, you agree to be bound by the 
terms and conditions of this license. Unless otherwise stated in this agreement, you shall 
not use, copy, revise, rent, or transfer the Software Product or any part of the Software 
Product for any other purposes. 

Requirements of Use 
1. You may install for use one copy of the Software Product on a single machine; 
2. You may make a copy of the Software Product for archive or backup purposes and 

the copy is to be used on this machine only; 
3. You may transfer the Software Product and the license agreement to a third party, 

provided that the third party accepts the terms and conditions stated in this 
agreement, with prior express permission from Weihong Company; 

4. When transfer confirmed, you shall transfer all the copies of the original documents 
and the supplementary documents to the third party or destroy all the copies un-
transferred; 

5. You can use the Software Product on a network server or intranet server only if it is 
stipulated in explicit terms that you are allowed to use the Software Product on a 
network server or intranet server, or you have purchased license for each node and 
terminal using the Software Product; 

6. You may NOT sublicense, assign or transfer the license agreement; 
7. You may NOT or direct any third party to reverse engineer, decompile or 

disassemble the Software Product; 
8. You may NOT copy or transfer the Software Product or any part of the Software 

Product unless otherwise expressly stated in this agreement; 
9. The license agreement shall be terminated automatically upon you transfer the 

Software Product or copies of all or part of the Software Product to a third party. 

Intellectual Property Rights Notice 
The Software Product and all intellectual property rights therein (including but not limited to 
any all copyrights, patents, trademarks, and publicity rights) are owned by Weihong 
Company. The Software Product is protected for Weihong Company on the basis of 
Chinese copyright law and international treaty provisions as well as on the basis of other 
laws and agreements regarding intellectual property. You are not allowed to remove the 
copyright statement made in the Software Product, and guarantee that you shall copy the 
copyright statement in all copies of the Software Product or of any part of the Software 
Product. You are obliged to stop any form of illegal copying of the Software Product and 
accompanying materials. 

Weihong Company can update the Software Product at any time. You can pay real-time 
attention to Weihong Company's official website. 

Termination 
This license may be terminated by Weihong Company at any time once you violate any 
terms or conditions made in this agreement. Once the license is terminated, you are 
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obliged to destroy all the copies of the Software Product or return them to Weihong 
Company. 

Now, we affirm that you have already read through this agreement and understood it 
thoroughly and agreed to comply with all of the terms and conditions of this agreement 
strictly. 

Weihong Electronic Technology Co., Ltd. 

 



Shanghai Weihong Electronic Technology Co., Ltd.

Address: No. 1590, Huhang Rd., Fengxian, Shanghai, China, 201401

Hot-line: 400 882 9188 

Website: www.weihong.com.cn/en
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