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1 System Introduction 
1.1 Overview 
This section gives you a brief introduction of the hardware and software of the NcStudio 
Phoenix Three-axis Engraving System. 

Hardware 

 Industrial computer: NC60A, NC65C, NC68A, etc. 

 Lambda controller 
o Lambda 21B: Applicable to bus control systems 
o Lambda 21A: Applicable to non-bus control systems 
o Lambda 20A and so on 

 EX series terminal board: EX31A 
For the hardware connection diagram, see section 1.2 Hardware Connection Diagram. 

Software 

For introduction of the NcStudio Phoenix Three-axis Engraving System software 
interface, see section 1.3 Software Interface. 

1.2 Hardware Connection Diagram 
Hardware connection method varies based on the control system type. Example of a non-
bus control system and a bus control system using NC60A are shown below. 

Non-bus control system 

 

 
Bus control system 
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1.3 Software Interface 
This section gives you a brief introduction of the software interface of the NcStudio 
Phoenix Three-axis Engraving System. 

1.3.1 NcConfig 
The homepage of NcConfig is shown below: 
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1. Menu bar 
2. Function area 
3. Project configuration area 

1.3.1.1 Function Area 
Target functions are selected in the project configuration area and debugged in the 
function area. 

1.3.1.2 Project Configuration Area 
Click the Project or Configuration tab in the project configuration area's lower part to use 
different functions (If the Project tab is not displayed in this area, go to View > Project in 
the menu bar). 

Functions on the Configuration page: 

 Topology configuration 

 Machine parts 

 Port mapping 

 Port protection 

1.3.2 NcTune 
The homepage of NcTune is shown below: 
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1. Menu bar 
2. Status bar 
3. Welcome page 

1.3.3 NcStudio 
The homepage of NcStudio is shown below: 
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1. Menu bar 
2. Status bar 
3. Axis coordinate area 
4. Override setting area 
5. Machining information area 
6. Function window 
7. Operation mode area 
8. Operation button bar 

1.3.3.1 Menu Bar 
You can access the following functions in the menu bar: 

 File: Open and Load, Load History File, Unload, Generate Installation Package, 
Multi-Config Pack Up, Restart software, Close System, Restart System, Show 
Desktop, and Exit 

 Program: Machining Wizard, Machining Information, and Machining Statistics 

 Machine: Single Block Execution, HW Guide, Current Point as Work Zero, Cycle 
Start, Cycle Pause, Cycle Stop, Simulate, Resume, Jiggle, Homing, To Work Zero, 
To Fixed Point, Centering, MDI, Datum Setting, Adjustment, Datum Cancel, Double 
Y Jiggle, Double Y Origin Detection, Clear Servo Alarm, Reconnect Drive, and 
Reconnect Controller 

 Advanced: Selective Machining, ENG choose tool and row, AdvAuto, Cycle Setting, 
Timed Stop, and Nearby Resume 

 System: Log, Global Parameters, Driver Parameters, Tool Compensation 
Parameters, Tool Offset, Change Password, Language, Multi-Z Mode Switching, 
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Data Backup, NcTune, Remote Assistance, NcCloud, M Instruction Table, and 
About 

1.3.3.2 Status Bar 
You can access the following functions in the status bar: 

 System modes: Auto, Manual, and Homing 

 System status: Idle, running, paused, or emergency stop. 

 Information/alarms: Current information and alarms 
Double-click the blank area to open the Log dialog box to view system alarms, 
errors and information. 

1.3.3.3 Axis Coordinate Area 
The axis coordinate area is shown below: 

 
 
It shows the name of the current workpiece coordinate system, and the mechanical and 
workpiece coordinates of the axes. 

After an axis has gone to the machine origin, the  icon will be displayed before the axis 
in this area. 

1.3.3.4 Override Setting Area 
The override setting area is shown below: 

 
 

 In this area, you can set the spindle rotational speed, feed rate and G00 speed 
parameters by entering values in the corresponding field. 

 You can adjust the spindle rotational speed, feed rate and G00 override/multiplier 
by dragging the corresponding slider. 
 
Actual spindle rotational speed = Spindle rotational speed multiplier * Spindle rotational speed setting 
 
Actual machining speed = Feed rate multiplier * Feed rate setting  
 
Actual G00 speed = G00 multiplier * G00 setting 

 

1.3.3.5 Machining Information Area 
The machining information area is shown below: 
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It shows the current machining progress, current program line number, machining duration 
and current tool number. 

1.3.3.6 Function Window 
Click the following tabs in the function window to access different functions: 

 Track: Displays the machining or dry running track. 

 Offset: Setting of the workpiece offset and public offset, Z-axis lowing and lifting 

 Calibration: Setting of the tool sensor position and tool calibration method (Auto 
Measure, Z Mobile Cali, Z Manual Set) 

 Program Management: Loading, editing, deleting, renaming and creating 
programs 

 Common: Viewing and setting of common parameters 

 Log: Viewing of information, alarm, and error logs. 

 Port: Viewing of port status and polarity, testing of ports, modification of port 
polarity, and setting of the filter 

1.3.3.7 Operation Mode Area 
The system supports the following operation modes: 

 Auto 
o The loaded program is displayed in this mode. 
o Common function: Going to the fixed point 
o Common ports: Spindle, Cool, Vacuum, and Lube. The common ports can 

be modified in NcConfig. 

 Manual 
o Axis buttons: control of the axis movement in each direction 

 Jog 

 Click and hold an axis button to make the target axis move in 
the target direction continuously at the relatively lower speed. 

 Click and hold multiple axis buttons at the same time to make 
the target axes move in the target directions continuously at the 
relatively lower speed. 
Mainly used to move the X axis and Y axis at the same time. 

 Click and hold an axis button and the Rapid button at the same 
time to make the target axis move in the target direction 
continuously at the relatively higher speed. 

 Click and hold multiple axis buttons and the Rapid button at the 
same time to make the target axes move in the target 
directions continuously at the relatively higher speed. 

 HW: In this mode, you use the handwheel to control the machine 
movement. Select the axis direction and multiplier on the handwheel 
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and turn the handwheel knob by a certain degree to make the target 
axis move in the target direction. 

 Stepping: Select 0.01, 0.05, 0.1, 0.5, 1, 5, or 10 (the unit is mm), or 
enter a value in the blank field. Click and release an axis button to 
make the target axis move in the target position by the set step. 
Note: Please do not set the step to a value that's too large to avoid 
damage due to misoperation, and do not click an axis button too 
frequently in short time. 

o Common function: Going to the fixed point 
o Common ports: Spindle, Cool, Vacuum, Lube, etc. The common ports can 

be modified in NcConfig. 

 Homing 
o Tick Execute homing when software starts to make the axes go to the 

mechanical origin upon software start. 
o You can also check and clear the homing average values in this area. 

1.3.3.8 Operation Button Bar 
You can use the following functions with buttons in the operation button bar: 

In Auto and Manual modes: 

 Loading and unloading of programs 

 Axis clearing 

 MDI, selective machining, going to the workpiece origin, and simulation 

 Using the handwheel to control machining movement 

 Starting, pausing, or stopping machining; resuming machining from the interrupted 
point 

In Homing mode: 

 Making the axes go to the mechanical origin 

 Starting, pausing, or stopping machining; resuming machining from the interrupted 
point 
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2 Wiring 
This section gives you a brief introduction of the signal types supported by the NcStudio 
Phoenix Three-axis Engraving System and the port definition. 

2.1 Hardware 
This section gives introduction of the following hardware: 

 NC60A 

 Lambda controller 

 EX31A 

2.1.1 NC60A 
Definitions of the NC60A ports are shown below: 

 
 

1. USB 2.0 port: For USB data transmission 
2. Network port: For network connection 
3. 24V DC power supply port: For connection to a 24V DC power supply 
4. LED indicator: Shows the current system status 

o ON: The system is powered on 
o OFF: The system is not powered on 

5. Lambda controller port: Phoenix bus RS485 port. For connection to the Lambda 
controller. 

6. Operation panel port: Phoenix bus RS485 port. For connection to the operation 
panel. 

7. VGA display port: For connection to the display 

2.1.2 Lambda Controller 
Use different Lambda controllers based on the type of the control system: 

 Lambda 21B: Applicable to bus control systems 

 Lambda 21A: Applicable to non-bus control systems 
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Definitions for Lambda 21B and Lambda 21A ports are basically the same; therefore, the 
following content introduces port definitions for the Lambda 21B controller as an example. 

Multiple EX31A extension terminal boards can be connected to the Lambda 21B controller 
to meet your needs. 

The port definitions are shown below: 

 
 

2.1.3 EX31A 
Select extension terminal boards based on your needs. 

 EX31A: Supports 10-channel input and 10-channel output 
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 EX35A: Supports 32-channel output 

 EX36A: Supports 32-channel input 
Port definitions of the Lambda 21B connected to two EX35A terminal boards and one 
EX36A terminal board are shown below as an example: 
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2.2 Operation Panel Ports 
Descriptions of the operation panel ports are shown below: 

 
 

 +5V: Provides power supply for the operation panel. 

 Tx_N: Sends differential signal. 

 NC: Needs no wire connection. 

 Rx_P: Receives differential signal. 

 GND: Connects to the ground. 

 Tx_P: Sends differential signal. 

 Rx_N: Receives differential signal. 

2.3 Signal Type 
The following signal types are supported: 

 Switch Value Input Signal 

 Relay Output Signal 
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 Analog Output Signal 

 Command Pulse Signal 

2.3.1 Switch Value Input Signal 
The switch value input signal supports active high and active low: 

 Connecting to the COM port in NO mode means to receive signal. 

 Disconnecting with the COM port in NC mode means to receive signal. 
The figure is as follows: 

 
 
The input port supports active high and active low: 

 When the common terminal board S of the Lambda controller is connected to the 
COM port, inputs are active in high voltage. 

 When the common terminal board S of the Lambda controller is connected to the 
+24V port, inputs are active in low voltage. 

2.3.2 Relay Output Signal 
The Lambda controller outputs relay signals. 

The load capacity of relay output contact points is AC 7A/250V or DC 7A/30V. If high 
power load is needed, a contactor should be connected as follows: 

The figure is as follows: 

 
 

2.3.3 Relay Output Signal 
The AVC port, externally connected to the inverter's analog voltage frequency command 
input port, can output controllable voltage from 0V to 10V. By changing the voltage, it 
controls the inverter frequency and in turn the spindle speed. 
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The figure is as follows: 

 
 

2.3.4 Command Pulse Signal 
Pulse commands that control the controller's motion consist of pulse + direction, negative 
logic, as shown below. The maximum pulse frequency is 1MHz. 
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3 Machine Debugging 
3.1 Overview 
This section gives you a brief introduction of the basic debugging process for the 
NcStudio Phoenix Three-axis Engraving System. 

The debugging process is shown below: 

 
 
If the manufacturer's password is required during debugging, contact the manufacturer. 

3.2 Install the Software 
Before installing the software: 

 Ensure that the machine can be powered on normally. 

 The USB flash drive storing the installation package is connected to the USB port of 
the NC65C host. 

Follow the steps below to install the software: 

1. Double-click the installation package. The installation wizard window is displayed. 
2. Select the installation language. Go to OK > Next. 
3. After all settings are finished, click Finish. 

3.3 Modify I/O Port Polarity 
After the software is started, modify the polarity of the I/O ports based on the type of the 
detection and position limit switches: 

 Set the polarity of normally closed switches to NC. 

 Set the polarity of normally open switches to NO. 
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The relationship between the signal status and the port symbols is shown below: 

 Input port:  no signal is detected;  signal is detected 

 Output port:  no signal is detected;  signal is detected 
Follow the steps below to modify the I/O port polarity: 

1. Click the Port tab in the function window: 

 
 

2. Click the target port and click Convert Polarity to reverse the current polarity. 
3. The following functions are also supported: 

o To test port signal output: Click Test On/Test Off. When the port symbol 
becomes  or , the port is under test. 

o To cancel testing of the selected port: Click Cancel Test. 
o To cancel testing of all ports: Click Cancel All. 
o To set sampling interval, click Filter and drag the Interval slider. The system 

will rule out signals whose duration is smaller than the interval. 

3.4 Set Debugging Parameters 
Debugging parameters need to be set for bus control systems to prevent machine motion 
from causing unintentional damage. 

Follow the steps below to set the debugging parameters: 

1. In the menu bar, go to System > Global Parameters. 
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2. In the Param window, click the Operator pull-down menu in the left column and 
select Manufacturer. 

3. Set the following parameters: 
o Encoder Direction: Indicates the direction of the axis encoders. 1: positive 

direction; -1: negative direction 
o Encoder digits: Indicates the digit number of the servo motor encoder. 

Value range: 10–29. 
o Electronic gear ratio(numerator)/Electronic gear ratio(denominator): 

Indicates whether the servo drive enlarges or shrinks the received pulse 
frequency from the upper computer. If the Electronic gear 
ratio(numerator)/Electronic gear ratio(denominator) value is larger than 1, 
the servo drive enlarges the pulse frequency. If the Electronic gear 
ratio(numerator)/Electronic gear ratio(denominator) value is smaller than 
1, the servo drive shrinks the pulse frequency. 

o Pitch: The movement or rotation angle of the feed axis per lead screw turn. 

3.5 Check Axis Direction 
Determine the positive direction for the machine axes based on the right-hand rule and 
check to see if the axis directions are correct to avoid possible damage. 

Taking the X axis as an example, follow the steps below to check the axis direction: 

1. Determine the X axis positive direction based on the right-hand rule. 
2. In the menu bar, go to System > Global Parameters. 
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3. In the Param window, click the Operator pull-down menu in the left column and 
select Manufacturer. 

4. Check the Axis Direction(X) value. 
o 1: positive direction 
o -1: negative direction 

5. In Manual mode, click the X+ button to move the X axis. Check to see if the X axis 
moves in the positive direction as determined by the right-hand rule. 

o Yes: the axis direction is correct. 
o No: Reverse the current Axis Direction(X) value. 

3.6 Go to Mechanical Origin or Set Datum 
Select one from the following two operations based on the encoder type: 

 Make the axes go to the mechanical origin: Applicable to incremental encoders 

 Set datum: Applicable to absolute encoders 
Before making the axes go to the mechanical origin or setting datum, ensure that there is 
no drive or motor alarm. 

3.6.1 Making Axes Go to Mechanical Origin 
The mechanical coordinate system is the inherent coordinate system of the machine itself. 
The origin of the mechanical coordinate system is called mechanical origin or reference 
point. The position of the mechanical origin/reference point is determined and fixed during 
the design and debugging stages before being shipped out of factory for delivery. If you 
are using an incremental encoder, you need to make the axes go to the mechanical origin 
every time the machining system is restarted before starting machining to calibrate the 
coordinates for more accurate machining. 
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Select one from the following methods to make the axes go to the mechanical origin: 

 In Homing mode, click X Homing/Y Homing/Z Homing in the operation button bar 
to make the X/Y/Z axis go to the mechanical origin. You can also click All Homing 
to make all the axes to the mechanical origin in the sequence of Z axis, X axis and 
Y axis. 

 In the menu bar, go to Machine > Homing to open the Home dialog box: 

 
 
To make the Home dialog box automatically displayed when the software is started, 
tick Dialog box pops up when cycle starts at the dialog box lower left corner. 

o To make the X/Y/Z axis go to the mechanical origin, click X axis(X)/Y 
axis(Y)/Z axis(Z). 

o To make all axes go to the mechanical origin, click All Axes(A). 
o To set the current position as the mechanical origin: Ensure that the current 

position is consistent with the mechanical coordinates and there was no 
cases that may cause coordinate error, such as machine power-off or 
emergency stop. Click DirectSet. 
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After an axis has gone to the mechanical origin, the  icon will be displayed before the 
axis in the axis coordinate area. 

3.6.2 Setting Datum 
If an absolute encoder is used, you can directly set the encoder zero conveniently without 
having to make the axes go to the mechanical origin. 

If the system has restarts, power-off, emergency stop or similar situations, the system will 
automatically read the datum information and there is no need for manual datum setting. 
However, if the drive or motor is replaced, manual setting of datum is needed. 

Follow the steps below to set datum: 

1. In Manual mode, control the target axis move to the target position. 
2. Switch to Homing mode. In the menu bar, go to Machine > Datum Setting > X-

axis(X)/Y-axis(Y)/Z-axis(Z)/All Axis Datum Setting to set datum for a single axis 
or all axes. 

After setting datum for an axis, the  icon will be displayed before the axis in the axis 
coordinate area. 

3.7 Set Workpiece Origin 
A certain point on the workpiece is selected as the workpiece origin (origin of the axis 
coordinate system of the machining paths). The workpiece origin is fixed relative to the 
points on the workpiece and mobile relative to the mechanical origin. Programmers select 
the workpiece origin commonly under considerations of convenience for programming and 
size conversion, and less machining error. 

You can select one from the following methods to set the position of the workpiece origin: 

 Clearing 

 Centering 

 Setting workpiece offset and public offset parameters 

 Tool calibration 

 Setting tool compensation parameters 

3.7.1 Clearing 
When the machining accuracy requirement is not very high and the work piece has an 
irregular shape, you can select the workpiece origin with the clearing method. Clearing 
means to set the workpiece coordinates of the current point to 0. 

Taking the X axis as an example, follow the steps below to execute clearing: 

1. Control the X axis to move to the target point which you want to set as the 
workpiece origin. 

2. In Auto mode, click the F3 pull-down menu in the operation button bar and select 
XClear; or press the F3 key; or click the X-axis workpiece coordinate button in the 
axis coordinate area, a message box will be displayed, as shown below: 
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Click Yes. The X-axis workpiece coordinate of the current point becomes 0. 

3.7.2 Centering 
Two types of centering are supported: line centering and circle centering. Line centering is 
mostly used to locate the center of regular rectangle work pieces while circle centering 
circular work pieces. 

Taking line centering for the X axis as an example, follow the steps below: 

1. In Manual mode, go to Machine > Centering in the menu bar to open the Center 
window: 

 
 

2. Optional: To change the workpiece coordinate system, click the WCS pull-down 
menu. Workpiece coordinate systems of G54–G59 are supported. The default 
workpiece coordinate system is G54. 

3. Set Centering Type to Line. 
4. Optional: If an edge finder is used for more accurate positioning, follow the steps 

below: 
a. In the Spindle speed field, enter the target spindle speed during centering. Its 
value should not be too large and is set to 500 (r/min) by default. 
b. Click Start Center to make it highlighted in green. 

5. Click the X+ / X- button to make the X axis move to one end of the work piece. Click 
Record X to record the X-axis mechanical coordinate of the current point into the 
system. 

6. Click the X+ / X- button to make the X axis move to the other end of the work piece. 
Click Center X. The system automatically calculates the X-axis midpoint 
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mechanical coordinate based on the X-axis mechanical coordinate of the current 
point and the X-axis mechanical coordinate recorded in the last step, and sets the 
X-axis workpiece coordinate of the midpoint to zero. 

3.7.3 Setting Workpiece Offset and Public Offset 
Workpiece offset indicates deviation of the workpiece origin from the mechanical origin. 
Public offset indicates deviation of a whole workpiece coordinate system from the positions 
established based on the workpiece offset. 

Follow the steps below to set the workpiece offset and public offset parameters: 

1. Click the Offset tab in the function window. 

 
 

2. Select the target workpiece coordinate system, such as G54. 
3. Enter X/Y/Z-axis workpiece offset in the X/Y/Z fields. 
4. Click the Set buttons behind the X/Y/Z fields. In the popped up dialog box, click Yes 

to set the X/Y/Z-axis workpiece coordinate of the current point to 0. 
5. Optional: Enter X/Y/Z-axis public offset values in the X/Y/Z fields in the Public 

Offset area. 
6. Optional: Click the 0.01/0.1/1 buttons in the Deepen/Lift area to adjust the Z-axis 

public offset by certain amount separately. 

3.7.4 Tool Calibration 
Tool calibration is used to measure the selected tool and check the tool offset to ensure 
that the tool can work properly. 

Follow the steps below to calibrate the selected tool: 

1. In Auto or Manual mode, click the Calibration tab in the function window. 
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2. Set Setting in the upper left corner to ON. 
3. In the Basic Setting area, click the Active Tool pull-down menu, select the target 

tool number, and set the following parameters: 
o Positioning Times: Indicates the times of fine positioning when approaching 

the tool sensor during tool calibration. 
o Positioning Speed: Indicates the speed when approaching the tool sensor 

during tool calibration. 
4. In the Fixed tool setter coordinate 1 area, set the parameters of the fixed tool 

sensor: 
o X FixedPoint: X-axis mechanical coordinate of the fixed tool sensor 
o Y FixedPoint: Y-axis mechanical coordinate of the fixed tool sensor 
o Z FixedPoint: Z-axis mechanical coordinate of the fixed tool sensor 
o LowestPoint: Mechanical coordinate of the Z-axis lowest point during tool 

calibration. 
5. Select one from the following tool calibration methods: 

o Fixed calibration 
o First-time calibration/Calibration after tool change 
o Mobile calibration 

3.7.4.1 Fixed Calibration 
If a tool is replaced due to being broke or other reasons, the length of the new tool and 
where the new tool is clamped may be different from the replaced one. In this case, fixed 
calibration can be used to measure the length of the new tool from a fixed position of the 
machine and determine the tool offset for better machining accuracy. Fixed calibration is 
applicable to machine with a tool magazine. 

Before executing fixed calibration, set the manufacturer parameter Tool Calibration Type 
to 1. 

Follow the steps below to execute fixed calibration: 
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In the Calibration Mode area of the Calibration tab, select one method: 

 Automatic measuring: Click Auto Measure. The system carries out fixed calibration 
automatically. 
The process of automatic fixed calibration is shown below: 

 
 

 Manual calibration: Control the tool to move to the tool sensor surface and click Z 
Manual Set. The system records the calibration result into the tool offset. 

After fixed calibration is finished, control the tool to move to the work piece surface and 
execute Z-axis clearing. 

3.7.4.2 First-time Calibration/Calibration After Tool Change 
First-time calibration/Calibration after tool change operations are used to record tool 
differences into the workpiece offset. 

The operations are applicable to machine without automatic tool change functions and 
need to be executed every time a tool is changed. 

Before executing first-time calibration/calibration after tool change operations: 

 Set the manufacturer parameter Tool Calibration Type to 2. 

 Control the Z axis to move to the work piece surface and execute clearing to 
determine the workpiece origin. 

In the Calibration Mode area of the Calibration tab, select one method: 

 First-time calibration: Click First Cali. The system automatically records the Z-axis 
mechanical coordinate of the current point. 

 Calibration after tool change: Click Second Cali. The system automatically 
recovers the Z-axis workpiece coordinate of the current point. 

First-time calibration process and calibration after tool change process are similar, as 
shown below: 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 26 / 61 
 

 
 

3.7.4.3 Mobile Calibration 
During mobile calibration, the Z-axis workpiece coordinate is automatically cleared. Only 
workpiece offset of the current workpiece coordinate system will be changed. 

Before executing mobile calibration, ensure that: 

 Set the manufacturer parameter Tool Calibration Type to 1. 
In the Calibration Mode area of the Calibration tab, Click Z Mobile Cali. The system 
executes tool calibration at the current position and records the calibration result into the 
tool offset parameter. 

3.7.5 Setting Tool Compensation Parameters 
For details, see section 3.7.5 Tool Compensation Parameters. 
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4 Quick Start 
4.1 Overview 
This section gives you an introduction of a simple machining process with the NcStudio 
Phoenix Three-axis Engraving System: 

 
 

4.2 Loading a Machining File 
Before starting machining, you need to load the machining program first. 

For details, see section 5.1.1 Loading a Program. 

4.3 Running Simulation 
During simulation, the system does not drive machine movement or consume machine or 
workpiece resources. Only the machining path and process are displayed in the software 
for you to spot possible problems and edit the program accordingly. 

Follow the steps below to run simulation: 

1. In Auto or Manual mode, select one from the following methods to access 
simulation mode: 

o In the operation button bar, click Simulate. 
o In the menu bar, go to Machine > Simulate. 

2. Select one from the following methods to start simulation: 

 Press the F9 key. 

 In the operation button bar, click . 

 In the menu bar, go to Machine > Cycle Start. 
The simulation track is displayed in the Track tab of the function window. 
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4.4 Starting Machining 
Select one from the following methods to start machining: 

 Press the F9 key. 

 In the operation button bar, click . 

 In the menu bar, go to Machine > Cycle Start. 
After machining is started, the following functions are supported: 

 To pause machining, select one from the following methods: 
o Press the F10 key. 

o In the operation button bar, click . 
o In the menu bar, go to Machine > Cycle Pause. 

 To stop machining, select one from the following methods: 
o Press the F11 key. 

o In the operation button bar, click . 
o In the menu bar, go to Machine > Cycle Stop. 

 To resume machining from the interrupted position in case of power-off, emergency 
stop, or other exception, select one from the following methods: 

o Press the F12 key. 

o In the operation button bar, click . 
o In the menu bar, go to Machine > Resume. 
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5 Program-related Functions 
5.1 Program Management 
You can create, load, unload, edit, delete, and rename a program in the software. 

5.1.1 Loading a Program 
Select one from the following methods to load a machining program: 

 For nc., g., eng., nce., ncex., dfx. and plt. files: 
o In the operation button bar, click Load. 
o In the menu bar, go to File > Open and Load. 
o In the function window, click the Program Management tab. Select the 

target path in the upper left corner. All g.,eng., dxf., nc., plt., txt., nce., anc., 
cnc. and tap. programs in the path will be displayed. Select the target file and 
click Load below. 

 To load a file that was loaded before, go to File > Load History File in the menu 
bar. 

5.1.2 Unloading a Program 
Select one from the following methods to unload a machining program: 

 In the operation button bar, click Unload. 

 In the menu bar, go to File > Unload. 

5.1.3 Creating, Editing, Deleting and Renaming a Program 
Follow the steps below: 

1. In the function window, click the Program Management tab. 
2. Select the target path in the upper left corner. All g.,eng., dxf., nc., plt., txt., nce., 

anc., cnc. and tap. programs in the path will be displayed. 
3. To create a file, click New File. To modify an existing file, click the target program 

and click Edit/Delete/Rename. 

5.2 Machining Wizard 
The system provides Cir. Contour, Cir. Pocket, Rect. Contour, and Rect. Pocket wizard. 
The system automatically generates corresponding machining programs to help you save 
the time of manual editing. 

Follow the steps below to use the machining wizard: 

1. In Auto mode, go to Program > Machining Wizard to open the Wizard window: 
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2. Select a tab and set the parameters based on the left figure. 
3. Click Execute. The system starts machining. 

5.3 Single Block Machining 
In this mode, the program commands will be executed line by line for you to check the 
machine movement. 

Follow the steps below to execute single block machining: 

1. In Auto mode, go to Machine > Single Block Execution in the menu bar to enable 
single block machining mode. 

2. Select one from the following methods to make the system run a command line and 
pauses: 

o Press the F9 key. 

o In the operation button bar, click . 
o In the menu bar, go to Machine > Cycle Start. 

3. Repeat step 2 to make the system run the next command line until all commands 
are executed. 

5.4 Selective Machining 
In this mode, you can specify the start and end command line number to run the target 
commands. 

Follow the steps below to use selective machining: 

1. Select one from the following methods to open the Selective MC dialog box: 
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o In Auto mode, click Selective MC in the operation button bar. 
o In the menu bar, go to Advanced > Selective Machining. 

2. Enter target values in the Start Row and End Row fields. 
3. Optional: To reset the row numbers, click Reset. The Start Row and End Row 

values will be restored to their default values. 
The default start row is the first row and the default end row is the last row. 

4. Select one from the following methods to start selective machining: 
o Press the F9 key. 

o In the operation button bar, click . 
o In the menu bar, go to Machine > Cycle Start. 

5.5 ENG Tool and Line Selection 
If the loaded program is an ENG file, you can specify a tool to run certain command lines. 

Follow the steps below to use this function: 

1. After loading the ENG program, go to Advanced > ENG choose tool and row in 
the menu bar to open the ENG Choose dialog box: 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 32 / 61 
 

 
 

2. To specify the tool, set Select No. to ON. A selection box column will be displayed 
before the tool number column. 

 
 
Tick the target tool number. 
To modify a tool number, set Modify No. to ON. The Modify No. column will be 
displayed, as shown below: 
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Double-click the target field in the Modify No. column and enter the target tool 
number. Click Confirm. 

3. In the Choose line processing area, enter values in the Start Row and End Row 
fields. Click OK. 

5.6 Advanced Machining 
Advanced machining includes adding of machining path array, rotation, and mirroring. 

5.6.1 Array 
Array machining means to copy the machining path along a rectangular array. 

Follow the steps below to use array machining: 

1. In Auto or Manual mode, go to Advanced > AdvAuto in the menu bar to open the 
AdvAuto window: 
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2. In the Array area, click the Array Mode pull-down menu and select Rectangular. 
The array mode is set to Convention by default, which means does not enable 
array. 

3. Enter the number of rows and columns, row interval, and column interval in the 
Rows, Columns, Row Space R, and Column Space C fields. 

5.6.2 Rotation and Mirroring 
Rotation means to rotate the machining path by a certain angle while mirroring means to 
generate a symmetrical path along the X axis or Y axis. 

Follow the steps below to use the rotation and mirroring function: 

1. In Auto or Manual mode, go to Advanced > AdvAuto in the menu bar to open the 
AdvAuto window: 
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2. In the Mirror & Rotate area, click the Machining Mode pull-down menu and select 
an option: 

o To rotate the path: 
a. Select CW 90°/CW 180°/CCW 90°. 
b. Enter the rotation center X and Y coordinates in the Rotate Center X and 
Rotate Center Y fields. 

o To mirror the path: 
a. Select Mirroring by X/Mirroring by Y. 
b. Tick Mirror. 
c. Optional: To adjust the position of the paths, enter the target deviation in 
the Eccentricity L field. 

The machining mode is set to Convention by default, which means not to enable 
rotation or mirroring. 

5.7 Machining Cycle 
You can set the machining to be repeated for a certain number of times and at certain 
interval, and check the current times of machining. 

Every complete running of the program counts as one time. 

Follow the steps below to set machining cycle: 

1. In the menu bar, go to Advanced > Cycle Setting to open the Cycle Setting 
dialog box: 
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2. Enter the target cycle times and interval in the Cycles and Interval fields. 
The current times of machining will be displayed after Cycle Index. 
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6 Check Machining Information and Statistics 
You can check the machining information automatically collected by the system to 
formulate machining plans and avoid possible problems. 

Follow the steps below to check the machining information/statistics: 

In the menu bar, go to Program > Machining Information/Machining Statistics to check 
corresponding information: 

In the Machining Information window, the movement range, machining range and tool 
travel length are displayed. 

In the Machining Statistics window, you can search for machining records by name or 
date and clear records before a certain date. 

Machining Information 

 
 
Machining Statistics 
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7 System Settings 
7.1 Viewing and Setting Parameters 
This section introduces how to set the system global parameters, drive parameters, and 
tool compensation parameters. 

7.1.1 Global Parameters 
In the menu bar, go to System > Global Parameters to open the Param window: 

 
 
Click the Operator pull-down menu on the left side. Select Operator or Manufacturer to 
check and set corresponding parameters. 

There are seven types of global parameters: operating parameters, feed axis parameters, 
program parameters, origin parameters, tool parameters, compensation parameters, and 
equipment parameters. 

You can search for a parameter by clicking a parameter type in the left list or clicking 
Search in the lower left corner, entering the parameter name in the field, and clicking Next. 

7.1.2 Drive Parameters 
After the system is connected to the drive, it automatically reads the drive parameter 
settings. You can also modify the drive parameter settings based on the machine structure 
and your demands. 

Before setting drive parameters, ensure that the system is connected to the hardware 
correctly. 

Follow the steps below to set drive parameters: 
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1. In the menu bar, go to System > Driver Parameters to open the Driver Param 
window: 

 
 

2. Double-click the target field, enter the target value, and click OK. 
In the Driver Param window, the following functions are also supported: 

 To show common driver parameters, tick Show common. 

 To refresh the parameter list, click Refresh. 

 To import drive parameter settings, click Import, select the target file, and click 
Open. 

 To export drive parameter settings, click Export, select the target storage path, and 
click Save. 

 To restore parameter default values, click Reset. 

7.1.3 Tool Compensation Parameters 
If a tool is worn or changed, the diameter or length of the new tool may be different. In this 
case, you need to modify the tool compensation parameter values to achieve accurate 
machining. 

Before setting tool compensation parameters: 

 Set the global parameter Enable Tool Length Compensation to Yes. 

 Set the global parameter Enable Tool Radius Compensation to Yes. 

 Measure and record the following parameters: 
o Tool Diameter: The diameter of the tool. 
o Diameter Wear: The amount of the tool diameter that is worn. 
o Tool Length: The length of the tool. 
o Length Wear: The amount of the tool length that is worn. 

Follow the steps below to set tool compensation values: 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 41 / 61 
 

1. In the menu bar, go to System > Tool Compensation Parameters to open the 
Tool Compensation dialog box: 

 
 

2. Double-click the target field, enter the measured value, and click OK. 

7.2 Adding Common Parameters 
You can set target parameters to become common parameters and displayed under the 
Common tab of the function window. 

Follow the steps below to add a parameter into the common parameter list: 

1. Click the Common tab in the function window. 
2. Click Set in the lower right corner to open the Usually Param window: 
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3. Click the first pull-down menu and select Operator or Manufacturer to display 
operator or manufacturer common parameters. Click the second pull-down menu 
and select Name, Description, or Address to determine the query condition. Enter 
the searching keyword in the blank field and click the searching icon. 

4. After locating the target parameter, click it and click Add. The target parameter will 
also be displayed under the right Common Parameter List. 

5. Repeat step 3 and step 4 until all target parameters are added. 
6. Optional: To remove a parameter from the common parameter list or adjust its 

position in the list, click the parameter and click Delete/Up/Down. 

7.3 Changing Password 
The password is used to view and modify manufacturer parameters. 

Follow the steps below to change the password: 

1. In the menu bar, go to System > Change Password to open the Modify 
Password dialog box: 
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2. Enter the old password and new password in the corresponding fields and click 
Modify. 

7.4 Switching System Language 
The software supports Chinese and English. 

Follow the steps below to switch to English interface: In the menu bar, go to System > 
Language > English. 

Restart the software. 

7.5 Data Backup 
The system supports backup of the parameter settings and log. 

Follow the steps below to back up the data: 

1. In the menu bar, go to System > Data Backup to open the Save as dialog box. 
2. Select a storage path for the backup files and click Save. 

7.6 Remote Assistance 
You can use the remote assistance service to let your machining system remotely 
controlled by technical support personnel to help troubleshoot. 

Before using the remote assistance service, ensure that your computer is connected to the 
Internet. 

Follow the steps below to use the remote assistance service: 

1. In the menu bar, go to System > Remote Assistance. 
2. Give the computer identification code and the verification code to the technical 

support staff for remote control. 

7.7 Using NcGateway 
NcGateway is a component of the WEIHONG NcCloud system. It provides data interfaces 
and communication protocols for device Internet connection. You can use NcGateway to 
manage devices. 

In the menu bar, go to System > NcCloud to open the NcGateway window. 

For details, see NcGateway manuals. 

7.8 M Codes 
You can use M codes to run pre-defined sub-programs. 

Follow the steps below to check the currently available M codes: 

In the menu bar, go to System > M Instruction Table: 
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After adding software components in NcConfig, M codes of the components will also be 
added. Modification is supported. 

7.9 Software Registration 
You need to register the software if the software use period has or is about to expire, or if 
the writing type does not match. 

Follow the steps below to register the software: 

1. In the menu bar, go to System > About > Register: 

 
 

2. Click Apply for reg and acquire the registration code by following instructions in the 
application guide, or contacting the supplier. 

3. Enter the registration code in the Registration Code field. 
4. Click registered. 
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8 NcConfig 
With NcConfig, you can configure Lambda controllers, terminal boards and machine parts, 
set port mapping and port protection to improve project efficiency. 

8.1 Opening NcConfig 
Use the following method to open NcConfig: 

1. Open C:\Program Files\Weihong\NcStudio\NcConfig\Bin. Double-click 
NcConfig.exe. 

2. Optional: In the menu bar, go to View > Configuration/Project to show the 
Configuration or Project tab in the left column. 

8.2 Configuring Device 
You can configure the Lambda controller and terminal boards used in the system. 

Follow the steps below to configure the system devices and mapping ports: 

1. In the left column, click the Configuration tab. Go to NcStudio > Hardware 
Connection and Configuration > Topology Configuration. 

2. Right-click on Topology Configuration and click Edit Topology, or double-click 
Topology Configuration to open the Topology Configuration dialog box: 

 
 

3. Configure the devices based on your demands: 
o To add a controller/terminal board, click Add and double-click the target 

controller/terminal board in the displayed list. 
o To replace a controller/terminal board, click the controller/terminal board to 

be replaced on the left side and click Replace. Double-click the target 
controller/terminal board in the displayed list. 

o To delete a controller/terminal board, click the controller/terminal board to be 
deleted on the left side and click Delete. 

o To move a controller/terminal board, click the controller/terminal board to be 
moved on the left side and click Move Up/Move Down. 

4. Click Confirm. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 46 / 61 
 

8.3 Configuring Machine Parts 
In NcConfig, you can select and configure the machine parts in use, such as M codes, 
operation panel, tool magazine, saw, double work station, clamp, and handwheel. 

Follow the steps below to configure machine parts: 

1. On the left Configuration list, go to NcStudio > Machine Parts. Double-click 
Machine Parts to open the Components page on the right. 

 
 

2. Tick required parts. The functions of the ticked parts will be displayed in the 
software. 

3. Configure the parts as shown below: 
o Configure M codes 
o Configure function buttons 
o Configure the tool magazine 
o Configure saws 
o Configure dual drive 
o Configure dual work stations 
o Configure press wheels 
o Configure clamps 
o Configure the handwheel 

8.3.1 Configure M Codes 
You can configure the M codes for control of machine movement and port status. 

After a machine part is ticked and the settings saved, corresponding available M codes will 
be displayed on the MCodeConfig page. 

Note: Configure M codes based on the selected machine parts. 

M codes include: 

 Function M codes: Running functional M codes generates machine movement. 

 Valve M codes: Running valve M codes controls port status. 
Follow the steps below to configure M codes: 
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1. In the left Configuration list, double-click MCodeConfig to open the MCodeConfig 
page on the right: 

 
 

2. Select the target row and double-click the target MCode field to modify the M code. 

8.3.2 Configure Function Buttons 
In NcConfig, you can add or delete function buttons in NcStudio. 

Available function buttons include those for spindle switch, going to workpiece origin, 
cooling, vacuum pump, lubrication, etc. 

Before configuring function buttons, tick required machine parts on the Components page. 

Follow the steps below to configure function buttons: 

1. In the left Configuration list, double-click PanelConfig to open the PanelConfig 
page on the right: 

 
 

2. To add a function button, click the pull-down menu at the target position and select 
the target function. To remove an existing function button, click the pull-down menu 
of the function button and select the first blank option. The removed button will no 
longer be displayed in NcStudio. 
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8.3.3 Configure the Tool Magazine 
The system supports tool magazines of different mechanical structures, combination of 
multi-cylinder single-frequency and multi-cylinder multi-frequency functions, and tool 
magazine selection. 

Tool magazine options on the Components page include: 

 NoneMagazine 

 LinearMagazine 

 DiskMagazine 

 ServoToolMagazine 

 Cylinder 
Follow the steps below to configure the tool magazine: 

1. In the left Configuration list, double-click ToolMagazine to open the 
ToolMagazine page on the right: 

 
 

2. Set the tool magazine parameters based on the tool magazine type specified on the 
Components page. 

o NoneMagazine: No tool magazine parameters need setting. 
o LinearMagazine: Set the parameter Tool magazine capacity (the 

maximum number of tools). 
o DiskMagazine: Set the parameter Tool magazine capacity (the maximum 

number of tools) and Count tool overtime (maximum time waiting for tool 
count signals). 

o ServoToolMagazine: Set the parameter Tool magazine capacity (the 
maximum number of tools) and rotary axis name. 

o Cylinder: Select the cylinder type and set the parameter Cylinder count. 
 Multi-Cylinder Single-Fre: Every Z axis has multiple cylinders. One 

inverter controls multiple spindles. 
 Multi-Cylinder Multi-Fre: Every Z axis has multiple cylinders. Multiple 

inverters control multiple spindles. 
 Four-Cylinder Double-Fre: Every Z axis has four cylinders. Two 

inverters control multiple spindles. 
3. Double-click the target PhysicalAddress field to specify a physical address 

(controller and port) for the corresponding logical address. 

8.3.4 Configuring Saws 
Follow the steps below to configure saw: 

1. In the left Configuration list, double-click Saw to open the Saw page on the right: 
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2. Double-click the target PhysicalAddress field to specify a physical address 
(controller and port) for the corresponding logical address. 

8.3.5 Configure Dual Drive 
Follow the steps below to configure dual drive axis: 

1. In the left Configuration list, double-click Distribute to open the Distribute page 
on the right: 

 
 

2. Double-click the target PhysicalAddress field to specify a physical address 
(controller and port) for the corresponding logical address. 

8.3.6 Configure Dual Work Stations 
If dual work stations are enabled, the system directly starts machining on work station 2 
after machining on work station 1 is finished to save loading and unloading time and 
improve efficiency. 

Follow the steps below to configure dual work stations: 

1. In the left Configuration list, double-click DoubleArea to open the DoubleArea 
page on the right: 

 
 

2. Double-click the target PhysicalAddress field to specify a physical address 
(controller and port) for the corresponding logical address. 

8.3.7 Configure Press Wheel 
Press wheels can be used to prevent plates from moving when being processed. 

Follow the steps below to configure press wheels: 

1. In the left Configuration list, double-click PressWheel to open the PressWheel 
page on the right: 

 
 

2. Set the parameter Number of Presswheel. 
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3. Double-click the target PhysicalAddress field to specify a physical address 
(controller and port) for the corresponding logical address. 

8.3.8 Configure Clamps 
Follow the steps below to configure clamps: 

1. In the left Configuration list, double-click Clamp to open the Clamp page on the 
right: 

 
 

2. Set the parameter Number of Clamp. 
3. Double-click the target PhysicalAddress field to specify a physical address 

(controller and port) for the corresponding logical address. 

8.3.9 Configure the Handwheel 
You can use a handwheel to control machine movement. 

Follow the steps below to configure the handwheel: 

1. In the left Configuration list, double-click Handwheel Configuration to open the 
Handwheel Configuration page on the right: 

 
 

2. Set Turn on to ON. 

8.4 Set Port Mapping 
You can change the physical address of a logical address based on the port mapping. 

Follow the steps below to set port mapping: 

1. In the left Configuration list, double-click Port Mapping to open the Port Mapping 
page on the right: 
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2. Double-click the target Physical Port field to specify a physical address (controller 
and port) for the corresponding logical address. 

3. Select one from the following methods to save the changes: 

o To save changes on the current page, click  under the menu bar. 

o To save changes on all pages, click  under the menu bar. 
The * symbol on an open window tab indicates that the changes on the page have not 
been saved. The * symbol disappears after changes on the page are saved. 

8.5 Set Port Protection 
When the software is closed, the protected ports will be automatically closed or opened 
based on their port protection type. 

There are several types of port protection: 

 Open: The port will be automatically opened when the software is closed. 

 Close: The port will be automatically closed when the software is closed. 

 Follow: The protected port status will be turned the same with that of the port 
specified in the Follow Port column. 

 RFollow: The protected port status will be turned the opposite to that of the port 
specified in the Follow Port column. 

 Hold: The port state will not be changed when the software is closed. 
Follow the steps below to set port protection: 

1. In the left Configuration list, double-click Port protection to open the Port 
protection page on the right: 
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2. Set the Enable switch of the target port to ON. 
3. Double-click the Protection Type field of the target port and select a protection 

type in the pull-down menu. 
4. Select one from the following methods to save the changes: 

o To save changes on the current page, click  under the menu bar. 

o To save changes on all pages, click  under the menu bar. 
The * symbol on an open window tab indicates that the changes on the page have not 
been saved. The * symbol disappears after changes on the page are saved. 

8.6 Creating Multi-configuration Installation Package 
You can create a complete installation package in the current system to keep a backup of 
the system files and a steady version of system. 

Note: A multi-configuration installation package includes all folders whose names are 
started with "DefaultConfig". 

Follow the steps below to create a multi-configuration installation package: 

1. In the menu bar, go to File > Multi-Config Pack Up. 
2. Enter a name and storage path for the installation package. 
3. Set the parameters as desired. 

After generating an installation package, you can find it under the selected path. 
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9 NcTune 
NcTune includes functions that can be used during debugging instead of normal 
machining. 

Functions supported by NcTune are displayed on the welcome page, as shown below, 
such as setting lead screw error compensation and centering parameters, etc. 

Select one from the following methods to open NcTune: 

 Open NcStudio. In the menu bar, go to System > NcTune. 

 Close NcStudio. In the NcStudio installation path (C:\Program 
Files\Weihong\NcStudio\Bin), double-click NcTune.exe. 
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10 Other Functions 
10.1 Generating Installation Package 
You can create a complete installation package in the current system to have a backup of 
the system files and a steady version of system. 

Follow the steps below to create an installation package: 

1. In the menu bar, go to File > Generate Installation Package to open the Packup 
Tool dialog box: 

 
 

2. Enter a name for the installation package. 
3. Click Browse to select a storage path. 
4. Optional: Click Advanced and set the following parameters: 

 
 

 Language: The software supports interface in Chinese and English. 

 Parameter Migrate 
o Keep local manufacturer parameters: Keeps manufacturer parameter 

settings. 
o Keep local user parameters: Keeps user local settings. 

 Auto Boot: Whether to start the software automatically upon computer system boot. 

 Support Language Selection: Whether supports switching between Chinese and 
English interfaces. 
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 Create A Desktop Shortcut: Whether to create a software shortcut on the desktop. 

 Start The Software After Installation: Whether to automatically start the software 
after installation is complete. 

1. Click Pack up. 
After generating an installation package, you can find it under the selected path. 

10.2 Using Handwheel 
In Auto mode, you can use a handwheel to control machining speed and avoid tool 
damage caused by loading wrong programs. 

A WEIHONG handwheel is shown below: 

 
 
Follow the steps below to use a WEIHONG handwheel for machining control: 

1. In Auto mode, select one from the following methods to enter handwheel mode: 
o In the operation button bar, click HW Guide. 
o In the menu bar, go to Machine > HW Guide. 

2. Rotate the step knob to select the movement unit (step). 
X1, X10, and X100 represent steps of 0.001 mm, 0.01 mm, and 0.1 mm 
respectively. 

3. Rotate the axis knob to select the target axis. 
4. Rotate the handwheel control knob clockwise to run the machining program. 

The program running speed is determined by how fast you rotate the handwheel 
control dial. 

10.3 Dual-Y Origin Detection 
This function can be used when your machine has two Y axes that use incremental 
encoders. 

Before executing origin detection for the Y axes, you need to manually level the Y axes. 
Execute origin detection to record the distance between the origins of the Y axes. Use the 
recorded value when making the Y axes go to the mechanical origin to ensure that the Y 
axes are still leveled. 

Follow the step below to execute origin detection for the Y axes: 

In the menu bar, go to Machine > Double Y Origin Detection. 

10.4 Jiggle 
This function is used to adjust the cutter position to find the best cutting distance. Jiggle 
settings are applicable to the current machining task and will lose effect after machining is 
stopped. 

Before jiggling the cutter: 
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 Switch to Auto mode. 

 Ensure that the system is in running or paused state. 
Follow the steps below to jiggle the cutter: 

1. In the menu bar, go to Machine >Jiggle: 

 
 

2. In the right JiggleDistance area, select or enter a movement unit/step. 
3. Click axis buttons in the middle to control the target axis to move in the target 

direction. 
The accumulated movement of the axes are displayed in the left JiggleCount area. 

10.5 Dual-Y Axis Jiggle 
You can use this function to adjust the position of a single Y axis or both Y axes. 

In the menu bar, go to Machine > Double Y Jiggle: 
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 To adjust the positions of the two Y axes at the same time: 

a. Select or enter a movement unit/step on the right side (0.01, 0.1, 1, or other 
values). 

b. Click Y- or Y+ to move the Y axes in the positive or negative direction by the 
selected or entered amount. 

 To adjust the position of one Y axis: 
a. Set Enable Level to ON. 
b. Select or enter a movement unit/step on the right side (0.01, 0.1, 1, or other 

values). 
c. Click Y- or Y+ to move the Y axis in the positive or negative direction by the 

selected or entered amount. Click Y2- or Y2+ to move the Y2 axis in the 
positive or negative direction by the selected or entered amount. 

The Y-axis and Y2-axis coordinates after jiggling are displayed in the Feedback area. 

Note: After jiggling the Y axes, you need to set datum or make them go to the mechanical 
origin. 

10.6 Calibration 
If the motor feedback coordinates are different from the mechanical coordinates, you can 
manually calibrate the axes to synchronize the actual position of the absolute encoder and 
update the mechanical coordinates by reading the encoder feedback. 

Follow the step below to manually calibrate the axes: 

In the menu bar, go to Machine > Adjustment and select the target axis. 

10.7 Going to Workpiece Origin 
Making the axes go to the workpiece origin means to make the X axis and Y axis move to 
the workpiece origin from their current positions and make the Z axis move to the safe 
height (determined by the Safe Height parameter value) from its current position. 

Follow the step below to make the axes go to workpiece origin: 

In the menu bar, go to Machine > To Work Zero. 
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10.8 Going to Fixed Point 
You can control the axes to move to a point with specified mechanical coordinates. 

You can change the point mechanical coordinates by modifying the values of Fixed Point 
Position(X), Fixed Point Position(Y), and Fixed Point Position(Z) parameters. 

Follow the step below to make the axes move to the point: 

In the menu bar, go to Machine > To Fixed Point. 

10.9 MDI 
The system supports at most 8 user-entered simple commands to achieve quick 
movement or machining. 

Follow the steps below to use the MDI function: 

1. In Auto or Manual mode, go to Machine > MDI in the menu bar: 

 
 

2. Enter a command in a field and click Execute to make the system run the entered 
command. 

10.10 Clearing Drive Alarms 
Some types of drive alarms can be cleared in the software. In some cases, after such 
alarms are cleared, no other drive alarms will be reported and the system will exit 
emergency stop state. 

Follow the step below to clear drive alarms: 

In the menu bar, go to Machine > Clear Servo Alarm. 

10.11 Reconnecting to the Controller 
In cases such as the controller is powered off and on, you can reconnect to the controller 
without restarting the software. 

Follow the step below to reconnect to the controller: 
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In the menu bar, go to Machine > Reconnect Controller. 

10.12 Switching between Multi-Z Modes 
This function is available in software with multiple-Z axis configuration to switch between 
sequential movement mode and linkage movement mode. 

Follow the step below to switch between the modes: 

In the menu bar, go to System > Multi-Z Mode Switching. 

  



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 60 / 61 
 

Legal Notices 
The term “Software Product” includes all copies of the licensed software and its 
documentation. This license agreement is a legal agreement between You (either an 
individual, a legal entity or any affiliated companies or other entities) and Weihong 
Electronic Technology Co., Ltd. (hereinafter referred to as Weihong Company). By 
installing, copying, or otherwise using the Software Product, you agree to be bound by the 
terms and conditions of this license. Unless otherwise stated in this agreement, you shall 
not use, copy, revise, rent, or transfer the Software Product or any part of the Software 
Product for any other purposes. 

Requirements of Use 
1. You may install for use one copy of the Software Product on a single machine; 
2. You may make a copy of the Software Product for archive or backup purposes and 

the copy is to be used on this machine only; 
3. You may transfer the Software Product and the license agreement to a third party, 

provided that the third party accepts the terms and conditions stated in this 
agreement, with prior express permission from Weihong Company; 

4. When transfer confirmed, you shall transfer all the copies of the original documents 
and the supplementary documents to the third party or destroy all the copies un-
transferred; 

5. You can use the Software Product on a network server or intranet server only if it is 
stipulated in explicit terms that you are allowed to use the Software Product on a 
network server or intranet server, or you have purchased license for each node and 
terminal using the Software Product; 

6. You may NOT sublicense, assign or transfer the license agreement; 
7. You may NOT or direct any third party to reverse engineer, decompile or 

disassemble the Software Product; 
8. You may NOT copy or transfer the Software Product or any part of the Software 

Product unless otherwise expressly stated in this agreement; 
9. The license agreement shall be terminated automatically upon you transfer the 

Software Product or copies of all or part of the Software Product to a third party. 

Intellectual Property Rights Notice 
The Software Product and all intellectual property rights therein (including but not limited to 
any all copyrights, patents, trademarks, and publicity rights) are owned by Weihong 
Company. The Software Product is protected for Weihong Company on the basis of 
Chinese copyright law and international treaty provisions as well as on the basis of other 
laws and agreements regarding intellectual property. You are not allowed to remove the 
copyright statement made in the Software Product, and guarantee that you shall copy the 
copyright statement in all copies of the Software Product or of any part of the Software 
Product. You are obliged to stop any form of illegal copying of the Software Product and 
accompanying materials. 

Weihong Company can update the Software Product at any time. You can pay real-time 
attention to Weihong Company's official website. 
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Termination 
This license may be terminated by Weihong Company at any time once you violate any 
terms or conditions made in this agreement. Once the license is terminated, you are 
obliged to destroy all the copies of the Software Product or return them to Weihong 
Company. 

Now, we affirm that you have already read through this agreement and understood it 
thoroughly and agreed to comply with all of the terms and conditions of this agreement 
strictly. 

Weihong Electronic Technology Co., Ltd. 

 



Shanghai Weihong Electronic Technology Co., Ltd.

Address: No. 1590, Huhang Rd., Fengxian, Shanghai, China, 201401

Hot-line: 400 882 9188 

Website: www.weihong.com.cn/en
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