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1 System Overview 
1.1 Overview 
WEIHONG NcStudio CNC System for Cutting Machines is a CNC solution to cutting 
machines in woodworking industry. 

The system consists of the following: 

Hardware 

 Industrial computer: NC60A 

 Lambda terminal board: 
o Lambda 21A: applicable to the non-bus control system. 
o Lambda 21B: applicable to the bus control system. 

 Extended terminal board: EX31A 

 Servo drive 

 Servo motor 

 Inverter 

 Handwheel 
For the connection of each hardware, see Connection Diagram. 

Software 

 NcConfig software: mainly used for commissioning. 

 NcTune software: mainly used for commissioning. 

 NcStudio software: mainly used for machining. 
For the layout of the main software interfaces of NcStudio CNC System for Cutting 
Machines, see Main Software Interface. 
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1.2 Connection Diagram 
The connection diagram differs in the type of control system: 

Connection diagram for the non-bus control system 

The connection diagram for the non-bus control system is as follows: 
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Connection diagram for the bus control system 

The connection diagram for the bus control system is as follows: 
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1.3 Main Software Interface 
Through this part, you can quickly know the main software interfaces of WEIHONG 
NcStudio CNC System for Cutting Machines. 

1.3.1 Main Interface of NcConfig Software 
The main interface of NcConfig software is as follows: 

 

1. Menu bar 
2. Function display bar 
3. Configuration bar 

1.3.1.1 Function Display Bar 
You can do function commissioning in this bar after selecting the target function in the 
configuration bar. 

1.3.1.2 Configuration Bar 
In this bar, you can do the following: 

 Configuring devices 

 Setting machine parts 

 Setting port mapping 

 Setting port protection 
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1.3.2 Main Interface of NcTune Software 
The main interface of NcTune software is as follows: 

 

1. Menu bar 
2. Welcome page 

In the welcome page, you can do the following: 
o Setting screw error compensation 
o Inputting MDI 
o Executing tool calibration 
o Executing data acquisition 
o Executing learning for the circularity test 
o Doing commissioning for the circularity test 
o Executing centering 
o Setting parameters 
o Setting port polarity 
o Setting drive parameters 
o Managing offsets 
o Checking control panel 
o Checking machining statistics 
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o Setting gang drilling 
o Setting parameters for loading and unloading 
o Checking logs 
o Doing commissioning for the tool magazine 
o Setting tool compensation 
o Upgrading firmware 

3. Status bar 

1.3.3 Main Interface of NcStudio Software 
The main interface of NcStudio software is as follows: 

 

1. Title bar 
2. Status bar 
3. Machine control bar 
4. Function control bar 
5. Operation control bar 
6. Function window 

1.3.3.1 Title Bar 
In this bar, you can check the following: 

 Weihong logo 

 Status of the control system 

 Current date and time 

 Hamburger menu  
In the hamburger menu, you can achieve the following: 

o Executing returning to the machine origin or set datum. 
o Setting tool parameter. 
o Setting parameters for the tool magazine. 
o Setting parameters for loading and unloading. 
o Setting printer. 
o Setting common parameters. 
o Setting NcTune. 
o Checking help information. 
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1.3.3.2 Status bar 
In this bar, you can check the current operation mode, status, and tips or warnings. 

You can double click the blank area to check different types of logs for troubleshooting, 
including information, warning, alarms. See Check System Logs for details. 

1.3.3.3 Machine Control Bar 
In this area, you can control the movement of the machine tool. 

This bar is as follows: 

 

1. Manual control bar 
o Buttons for axis direction: move each axis towards positive or negative 

direction. 
o Mode buttons 

 Jog 
Click an axis direction button. The machine tool keeps running at jog 
speed until you release the button. 
Click Rapid and an axis direction button. The machine tool keeps 
running at rapid jog speed until you release the button. 

 HW: select the axis direction and handwheel override gear in the 
handwheel, and rotate the control disk. The machine tool is controlled 
by the handwheel and the selected axis moves at the selected 
handwheel speed. 

 Step: click an axis direction button and release it. The machine tool 
moves the selected step size. 
You can select the fixed step size among 0.01mm, 0.1 mm, and 1 mm 
or a customized step size (default: 5mm). 
Note: Please do not set the step size to a too large value to avoid 
damage due to misoperation, and do not click an axis direction button 
too frequently because the system needs a certain time for response. 
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2. Coordinate display bar: check the workpiece coordinate, machine coordinate of 
each axis and the current workpiece coordinate system. 

3. Speed control bar: adjust the spindle speed, feedrate and G00 speed, and check 
the current spindle speed and feedrate. 
The relationship between the override and speed is as follows: 
Current feedrate = Current feedrate override * Setting speed 
Current G00 speed = Current feedrate override * G00 setting speed 

1.3.3.4 Function Control Bar 
This bar is as follows: 

 

1. Operations for tool calibration 
o Check the current tool number and tool number on the spindle. 
o Do tool calibration: 

 Set T Length: directly set tool offset of Z-axis. 
 Measure: do tool calibration. 
 Measure All: select several tools and do tool calibration. 

2. Cylinder control bar: turn on / off the cylinders. At most four cylinders are supported. 
Note: If no cylinder is selected in the configuration bar in NcConfig software, this 
bar will be hidden. 

3. Customized function bar: show ports and functions configured by NcConfig 
software. See Set Machine Parts for details. 

1.3.3.5 Operation Control Bar 
Operations in this bar are as follows: 

 : load a program file. 

 : unload a program file. 

 : do clearing for a single axis or all axes. 
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 : input MDI, including rapid movement and simple machining. 

 : execute simulation. You can check the simulation track in Tool 
Path&Trace window to see if the toolpath exceeds the workbench stroke. 

 : control the machine tool with the handwheel. 

 : execute an optional skip of the program file, by customizing the start 
line and end line of the program block, so that you can freely select the machining 
range. 

 : execute returning to the workpiece origin. 

 : start machining. 

 : pause machining. 

 : stop machining. 

 : resume machining from the exact interrupted position when power 
interruption or an E-stop alarm occurs. 

1.3.3.6 Function Windows 
Function windows include the following: 

 Tool Path&Trace: show the content of the loaded program file and the track during 
machining. 

 Multi-task Manage: manage and edit task files for multi-task machining. 

 Offset Manage: manage the workpiece offsets and public offsets. 

 Craftsmanship: show the current technics, and set related technic parameters. 

 Gang Drilling: add and orange the drilling in the drilling packages. 
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2 Settings in NcConfig Software 
2.1 Overview 
With NcConfig software, you can configure machine parts, set port mapping and port 
protection, and generate an installation package for multi-configuration, so as to improve 
the efficiency of project developing. 

To open the main interface of NcConfig software, do the following: 

1. Under the installation path C:\Program Files\Weihong\NcStudio\NcConfig\Bin, find 
and double click NcConfig.exe. 

2. Optional: If Projects / Configuration page does not show in the left, in the menu 
bar, click View → Projects / Configuration. 

2.2 Configure Devices 
You can freely configure Lambda terminal board and the extended terminal board. 

To configure devices, do the following in the main interface of NcConfig software: 

1. In Configuration page in the left, click NcStudio → Hardware Connection and 
Configuration. 

2. Click Topology Configuration, and right click to choose Edit Topology. Topology 
Configuration dialog box pops up: 

 
3. Configure terminal boards based on your needs: 

o To add the target terminal board, click Add. 
o To replace the target terminal board, click Replace. 
o To Delete the target terminal board, click Delete. 
o To change the order of terminal boards, click Move Up / Move Down. 

4. Click Confirm. 

2.3 Configure Machine Parts 
It is used to set machine parts by NcConfig software, so that you can customize related 
functions in the customized bar of NcStudio software. 
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Machine parts include M codes, panels, double stations, tool magazine, saw, gang drill, 
material loading and unloading, handwheel and press wheel. 

To configure machine parts, do the following: 

1. In Configuration page in the left, click NcStudio, and double click Machine Parts. 
Components page shows: 

 
2. Check the target machine parts. 

After the target machine parts are checked, you can customize the following 
functions in the related software: 
NcTune software: 

o Doing commissioning for the tool magazine 
o Setting the gang drill 
o Setting tool compensation 
o Setting parameters for loading and unloading 

NcStudio software: 
o Setting tool parameter 
o Setting parameters for the tool magazine 
o Setting parameters for loading and unloading 
o Setting printer 

3. Do the following based on your needs: 
o Configuring M codes 
o Configuring panels 
o Configuring double stations 
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o Configuring the tool magazine. 
o Configuring the saw 
o Configuring the gang drill 
o Configuring loading and unloading 
o Configuring handwheel 
o Configuring press wheel 

2.3.1 Configure M Codes 
It is used to configure M codes, so as to control the movement of the machine tool and the 
port status. 

Note: Please configure M codes based on the selected machine parts, instead of 
configuring them freely. 

M codes include the following: 

 Function: these M codes are used to control the movement of the machine tool: 

Code Meaning Code Meaning 

MCode 13 Drill on MCode 15 Drill off 

MCode 100 Load MCode 200 Unload 

MCode 300 Load & unload MCode 753 Press wheel on 

MCode 754 Press wheel off MCode 23 Saw on 

MCode 25 Saw off MCode 26 Saw blade retracted 

MCode 27 
Saw blade swings in X 
direction 

MCode 28 
Saw blade swings in Y 
direction 

 Valve: these M codes are used to control the port status: 

Code Meaning Code Meaning 

MCode 701 Vacuum adsorption on MCode 702 Vacuum adsorption off 

MCode 703 Front pos cylinder on MCode 704 Front pos cylinder off 

MCode 707 Left pos cylinder on MCode 708 Left pos cylinder off 

MCode 709 Right pos cylinder on MCode 710 Right pos cylinder off 

MCode 711 Back push cylinder on MCode 712 Back push cylinder off 

MCode 713 Right push cylinder on MCode 714 Right push cylinder off 

MCode 715 Left push cylinder on MCode 716 Left push cylinder off 

MCode 719 Unload cylinder on MCode 720 Unload cylinder off 

MCode 721 Load cylinder on MCode 722 Load cylinder off 

MCode 723 Load blow on MCode 724 Load blow off 

MCode 725 Vacuum destroy on MCode 726 Vacuum destroy off 

To configure M codes, do the following: 

1. In Configuration page in the left, double click MCodeConfig. MCodeConfig page 
shows. 

2. To modify the target M code, select the target function, click on the target input box 
of MCode column, and input a value. 
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2.3.2 Configure Panels 
It is used to configure panels, so that buttons of related functions will show in the 
customized bar of NcStudio software. 

The configurable function buttons include: spindle switch, one key back, to fixed position, 
area 1/2 start, area 1/2 pos cylinder, area 1/2 vacuum adsorption, area 1/2 vac on, area 1 
dust removal, area 1 pos cylinder, dust removal cylinder, drill start, drill cylinder, drill reset, 
load material, unload material, load & unload material, unload measure start, load cylinder, 
unload cylinder, vacuum adsorb, vacuum destroy, load blow, load adsorb, front/right/left 
pos cylinder, back/left/right push cylinder, press switch, saw T31/T32, saw ON, saw 
cylinder, manual unclamp tool, tool magazine cylinder, and dust cover. 

Before configuring panels, make sure related machine parts have been checked in 
Components page. 

To configure panels, do the following: 

1. In Configuration page in the left, double click PanelConfig. PanelConfig page 
shows. 

2. To configure a button for the target function in the customized bar of NcStudio 
software, click the target dropdown box, and select a target function. 

2.3.3 Configure Double Stations 
It is used to use two stations for machining by configuring related ports, in which the 
system can directly start machining on station 2 after machining on station 1 finishes, so 
as to save time of loading and unloading and improve machining efficiency. 

To configure double stations, do the following: 

1. In Configuration page in the left, double click DoubleArea. DoubleArea page 
shows. 

2. Double click the target port in PhysicalAddress column, and select the target 
Lambda terminal board and port. 

2.3.4 Configure the Tool Magazine 
It is used to configure the target type of tool magazine and multi-cylinder. 

The supported tool magazines include the following: 

 Linear tool magazine 

 Disk tool magazine 

 Servo tool magazine 
To configure the tool magazine, do the following: 

1. In Configuration page in the left, double click Machine Parts. Components page 
shows. 

2. In ToolMagazine area, select the target magazine type. 
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3. In Configuration page in the left, double click ToolMagazine. ToolMagazine page 
shows: 

o If the type of tool magazine is linear tool magazine, set parameter Tool 
magazine capacity. 
Tool magazine capacity: the total number of tools in tool magazine. 

o If the type of tool magazine is disk tool magazine, set the following 
parameters: 

 Tool magazine capacity: the total number of tools in the tool 
magazine. 

 Count tool overtime(ms): the maximum time to wait for the tool 
counting signal. 

o If the type of tool magazine is servo tool magazine, set the following 
parameters: 

 Tool magazine capacity: the total number of tools in the tool 
magazine. 

 Servo axis index: the axis number of the servo axis. 
o If the type of tool magazine is multi-cylinder, select a cylinder type and set 

parameter Cylinder count: 
 Multi-cylinder single-fre: one inverter controls the start and stop of 

several spindles. 
 Multi-cylinder multi-fre: one Z-axis equips with two or four cylinders, 

and several inverters control the start and stop of several spindles. 
 Four-cylinder double-fre: one Z-axis equips with four cylinders, and 

two inverters control the start and stop of several spindles. 
4. Double click the target port in PhysicalAddress column, and select the target 

Lambda terminal board and port. 

2.3.5 Configure the Saw 
To configure the saw, do the following: 

1. In Configuration page in the left, double click Saw. Saw page shows. 
2. Set parameters Saw axis index. 
3. Double click the target port in PhysicalAddress column, and select the target 

Lambda terminal board and port. 

2.3.6 Configure the Gang Drill 
To configure the gang drill, do the following: 

1. In Configuration page in the left, double click Drill. Drill page shows. 
2. Set parameter Drill start number. 
3. Double click the target port in PhysicalAddress column, and select the target 

Lambda terminal board and port. 

2.3.7 Configure Loading and Unloading 
It is used to make sure that the physical address is the same with the logic address, so as 
to control the movement of the front positioning cylinder. 

To configure loading and unloading, do the following: 

1. In Configuration page in the left, double click LoadMaterial. LoadMaterial page 
shows. 

2. Select a type for loading and unloading: 
o Standard load & unload material: load and unload a group of boards. 
o Multi-plate load & unload material: load and unload two or four groups of 

boards. 
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3. Double click the target port in PhysicalAddress column, and select the target 
Lambda terminal board and port. 

Example 

There is only one front positioning cylinder for three types of boards, which is connected to 
Y10 on Lambda terminal board. Thus, you need to set the logic address of front 
positioning cylinder for board 1, board 2 and board 3 to Y10. 

2.3.8 Configure the Handwheel 
After configuring the handwheel, you can control the movement of the machine tool by the 
handwheel or enable handwheel guide. 

To configure the handwheel, do the following: 

1. In Configuration page in the left, double click Handwheel configuration. 
Handwheel configuration page shows. 

2. Change Turn on switch to ON status. 

2.3.9 Configure the Press Wheel 
After configuring the press wheel, the phenomenon that the board deviates during 
machining can be avoided. 

To configure the press wheel, do the following: 

1. In Configuration page in the left, double click PressWheel. PressWheel page 
shows. 

2. Double click the target port in PhysicalAddress column, and select the target 
Lambda terminal board and port. 

2.4 Set Port Mapping 
It is used to make sure that the physical address is the same with the logic address. 

To set port mapping, do the following: 

1. In Configuration page in the left, double click Port Mapping. Port Mapping page 
shows: 
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2. Double click the target port in PhysicalAddress column, and select the target 
Lambda terminal board and port. 

3. To save the modification, do one of the following: 

o In the menu bar, click . 
o Close the Port Mapping page, and click Yes in the popup. 

If the modification is not saved, sign * shows in the page name. 

2.5 Set Port Protection 
The type of port protection includes the following: 

 Open: the protected port automatically has a signal when the software starts. 

 Close: the protected port automatically closes its signal when the software closes. 

 Follow: the status of the following port is the same with that of the protected port. 

 RFollow the status of the following port is different from that of the protected port. 
To set port protection, do the following: 

1. In Configuration page in the left, click NcStudio → Hardware Connection and 
Configuration, and double click Port protection. Port Protection page shows. 

2. Change the ON/OFF switch of the target port in Enable column to ON status. 
3. Double click the target port of Protection Type column, and select a protection type: 
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4. To save the modification, do one of the following: 

o In the menu bar, click . 
o Close Port Protection page, and click Yes in the popup. 

If the modification is not saved, sign * shows in the page name. 

2.6 Generate an Installation Package for Multi-configuration 
It is used to create a complete installation package on the basis of the current system data, 
which is useful to back up system files and save a stable version of the system. 

This operation will pack up all folders whose name begins with Default_Config. 

To generate an installation package, do the following: 

1. In the menu bar, click System → Multi-configuration packaging. Packup Tool 
dialog box pops up: 

 
2. Modify the name and storage path of the installation package. 
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3. Optional: Click Advanced, and set the following advanced settings: 

 
o Language: at present, the system supports Chinese and English. 
o Parameter migration: 

 Keep All Local Parameters: use all parameters in the local. 
 Keep Only Machine-Specific Parameters: use parameters about 

machine characteristics in the local. 
 Fresh Installation: fresh Installation 

o Auto boot: whether to automatically start the software once the machine 
boots. 

o Others 
 Support language selection: whether to support switching the 

current language. 
 Create a desktop shortcut: whether to create a shortcut on the 

desktop. 
 Start the software after installation: whether to automatically start 

the software after installation. 
4. Click Pack up. The system starts to generate the installation package. 

After finishing, find the generated installation package under the set path. 
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3 Settings in NcTune Software 
3.1 Overview 
With NcTune software, you can do basic commissioning, applied commissioning, 
commissioning for the machine tool, and machining commissioning for WEIHONG 
NcStudio CNC System for Cutting Machines. 

Each page in NcTune software can be dragged into an independent page for checking 
information on several pages at the same time. You can double click the title bar of the 
target page for restoring. 

To enter the main interface of NcTune software, do one of the following: 

 In the upper right corner of the main interface of NcStudio software, click the 

hamburger menu  → NcTune. 

 Close NcStudio software, find and double click NcConfig.exe in the installation 
path C:\Program Files\Weihong\NcStudio\NcConfig\Bin. 

3.2 Basic Commissioning 

3.2.1 Overview 
Through this part, you can quickly know the commissioning process of WEIHONG 
NcStudio CNC System for Cutting Machines. 

The basic commissioning process is as follows: 

 

3.2.2 Set Parameters 
It is used to set parameters according to the machining demands, to make sure the 
machining precision and improve machining efficiency. 
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To set parameters, do the following: 

1. To open Parameter page, do one of the following: 
o In Welcome page, click Parameter. 
o In the menu bar, click View → Parameter. 

 
2. To modify the value of the target parameter, double click the target parameter in 

Value column, and input a value. 
3. Optional: To set the target parameter as a frequently used parameter, select the 

target parameter and click Set Common in the upper right corner. 
After setting it as a frequently used parameter, to check common parameters, in the 
upper right corner of the main interface of NcStudio software, click the hamburger 

menu  → Common Parameters. 

3.2.3 Set the Port Polarity 
It is used to check if the polarity of each port is correct, and modify the polarity if not. 
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The polarities of input/output ports in the software are specified in terms of the switch type: 

 Polarities of normally open ports: NO. 

 Polarities of normally closed ports: NC. 
The status of each port includes the following: 

 : the port has no signal. 

 : the port has a signal. 

 : the port is under test with no signal. 

 : the port is under test with a signal. 
To set the port polarity, do the following: 

1. To open Port page, do one of the following: 
o In Welcome page, click I/O Port. 
o In the menu bar, click View → I/O Port. 
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2. Select the target port, right click and select Invert Polarity. 
In this interface, you can also do the following: 

 To simulate the hardware signal, press Test On to conduct a simulation test or Test 
Off to close a simulation test. 

 To cancel a simulation test for the selected port, click Cancel Test. 

 To cancel a simulation test for all ports, click Cancel All. 

 To open or close the target port without affecting its use in the actual use, click 
Valve Switch. 

 To set the sampling interval and enable filter time, click Sampling, slide bar 
Sampling Interval to set the sampling interval, and check Filter. The system rules 
out interference signals whose occurrence time is shorter than the set interval. 

 To show all ports, click Show All. 

3.2.4 Set Commissioning Parameters 
It is used to set commissioning parameters to make the system, the servo drive and the 
machine tool can match with each other. 

This operation differs in the type of control system: 

 Set commissioning parameters for the non-bus type control system: including 
setting parameters Pulse Equivalent, Subdivision, Pitch, Mechanical 
Deceleration Ratio, Electronic Gear Ratio. 

 Set commissioning parameters for the bus type control system: including setting 
parameters Electronic Gear Ratio, Encoder Resolution, Pitch, and Mechanical 
Deceleration Ratio. 

3.2.4.1 Set Commissioning Parameters for the Non-bus Type Control System 
To set commissioning parameters for the non-bus type control system, do one of the 
following based on the motor type: 

 If a stepping motor is used, do the following: 
a. Set system parameters Pulse Equivalent, Pitch, and Mechanical 

Deceleration Ratio. 
b. Set drive parameter Subdivision. 
c. Verify if the parameter settings are correct according to the following formula: 

Pulse Equivalent = Pitch / (360 / Stepping Angle * Subdivision * Mechanical 
Deceleration Ratio) 
If the parameter settings are incorrect, repeat step 1~3. 

 If a servo motor is used, do the following: 
a. Set system parameters Pulse Equivalent, Encoder Revolution, Pitch, 

Mechanical Deceleration Ratio and Electronic Gear Ratio. 
b. Verify if the parameter settings are correct according to the following formula: 

Electronic Gear Ratio = (Encoder Revolution * Pulse Equivalent) / Pitch * Me
chanical Deceleration Ratio 
If the parameter settings are incorrect, repeat step 1~2. 

Related Parameters 

 Pitch: the axial distance between the corresponding points of two adjacent teeth on 
the threads. 

 Stepping angle: the angle at which the motor rotates every time the control system 
sends a stepping pulse signal. 

 Subdivision: the percentage of the actual step angle to the fixed step angle. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

25 / 74 

 Mechanical Deceleration Ratio: the ratio of reducer input speed to output speed. It 
equals to the ratio of the teeth number of driven wheel to that of driving wheel. 
When applied in CNC machines, it specifies the ratio of motor speed to screw 
speed. 

 Encoder Resolution: the pulse needed when the servo motor axis rotates one 
circle. 

 Pulse Equivalent: the moving distance of screw or rotation degree of rotary axis 
per pulse sent by the system, the minimum available distance controlled by the 
system as well. Smaller value gets higher machining precision and surface quality; 
larger value gets faster maximum feedrate. 
It can be calculated in terms of the actual electronic gear ratio of the servo drive. 

 Electronic Gear Ratio: the ratio that the servo enlarges or shrinks the received 
pulse frequency. If its value is greater than 1, the servo enlarges the received pulse 
frequency; if it is less than 1, the servo shrinks the received pulse frequency. 
It can be calculated in term of the value of system parameter Pulse Equivalent. 

3.2.4.2 Set Commissioning Parameters for the Bus Type Control System 
When the control system is the bus type control system, the motor type is servo motor. 

To set commissioning parameters for the bus type control system, do the following: 

1. Set system parameters Encoder Revolution, Pitch and Mechanical Deceleration 
Ratio. 

2. Set drive parameter Electronic Gear Ratio: 
3. Verify if the parameter settings are correct according to the following formula: 

Electronic Gear Ratio = (Encoder Revolution * Pulse Equivalent) / Pitch * Mechanic
al Deceleration Ratio 
If the parameter settings are incorrect, repeat step 1~3. 

Related Parameters 

 Pitch: the axial distance between the corresponding points of two adjacent teeth on 
the threads. 

 Stepping angle: the angle at which the motor rotates every time the control system 
sends a stepping pulse signal. 

 Subdivision: the percentage of the actual step angle to the fixed step angle. 

 Mechanical Deceleration Ratio: the ratio of reducer input speed to output speed. It 
equals to the ratio of the teeth number of driven wheel to that of driving wheel. 
When applied in CNC machines, it specifies the ratio of motor speed to screw 
speed. 

 Electronic Gear Ratio: the ratio that the servo enlarges or shrinks the received 
pulse frequency. If its value is greater than 1, the servo enlarges the received pulse 
frequency; if it is less than 1, the servo shrinks the received pulse frequency. It 
should be set the same with the electronic gear ratio set in the servo drive. It is set 
to 1:1 by default. 

 Encoder Resolution: the pulse needed when the servo motor axis rotates one 
circle. 

 Encoder Type: it should be set the same with the actual encoder type. 
o 0: incremental encoder 
o 1: absolute encoder 

 Encode Digit: it should be set the same with the actual condition. 
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3.2.5 Adjust the Axis Direction 
It is used to check if the positive direction of each axis is the same with the direction 
specified by Right Hand Rule, and adjust it if not, so as to avoid damage to the machine 
tool due to incorrect direction. 

Taking X-axis as an example, to adjust the axis direction, do the following: 

1. Judge the positive direction of X-axis according to Right Hand Rule. 
2. In the control panel, click X+ to move X-axis and observe if the moving direction of 

X-axis is the same with the judged direction. 
If not, modify the value of parameter Axis Direction(X) to the opposite value. 

3.2.6 Execute Returning to the Machine Origin or Set Datum 
Before operating the machine tool, please execute returning to the machine origin or set 
datum to adjust coordinates. 

This operation differs in the encoder type: 

 Incremental encoder: execute returning to the machine origin 

 Absolute encoder: set datum 
The encoder type is determined by parameter Encoder Type. 

3.2.6.1 Execute Returning to the Machine Origin 
The origin of the machine coordinate system (inherent coordinate system of a machine 
tool), also called mechanical origin or home, is a fixed point assigned by designing, 
manufacturing and debugging before the machine tool leaves the factory. 

This operation is used to synchronize the machine coordinate system of the system and 
the machine tool. 

Before executing returning to the machine origin, make sure all servo alarms have been 
removed. 

To execute returning to the machine origin, do the following: 

1. In the menu bar, click Machine → Homing. Homing dialog box pops up: 

 
2. Optional: If the switch position of the machine origin changes, click Clear Average. 
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3. Do one of the following: 
o To return all axes to the machine origin, click All Axis. Z-axis returns to the 

machine origin firstly, then X-axis, and Y-axis return in sequence. 
o To return a single axis to the machine origin, click the button for a single axis, 

the target axis returns to the machine origin. 
o If you make sure that the current position is the same with the machine 

coordinate, the machine tool has never been turned off and E-stop has never 
occurred, to set the current position as the machine origin, click Direct Set. 

After executing returning to the machine origin, sign  appears in front of each axis in the 
axis coordinate display bar. 

3.2.6.2 Set Datum 
With an absolute encoder, you can set the current position as the machine origin through 
setting datum when you use the system at the first time. Compared to returning to the 
machine origin with an incremental encoder, it owns the following advantages: No need to 
set returning orders for all axes. 

No need to set datum again after restarting the system, and recovering from power 
interruption and E-stop because the system will automatically read the datum information. 

To set datum, do the following: 

1. In the menu bar, click Machine → Datum Setting. 
2. Do one of the following: 

o To set datum for all axes, click All Axis Datum Setting. 
o To set datum for a single axis, click Datum Setting(X) / Datum Setting(Y) / 

Datum Setting(Z). 

After setting datum, sign  appears in front of each axis in the axis coordinate display bar. 

3.3 Applied Commissioning 

3.3.1 Set Drive Parameters 
It is used to set basic drive parameters to drive the movement of the machine tool during 
commissioning. 

To set drive parameters, do the following: 

1. To open Driver Parameter page, do one of the following: 
o In Welcome page, click Driver Parameter. 
o In the menu bar, click View → Driver Parameter. 

2. To get the latest drive parameters, click Refresh. 
3. To check the drive parameters of the target axis, click the dropdown box of the 

related box, and select the target axis. 
4. To modify the value of the target drive parameter, double click the target drive 

parameter in Value column, and input a value. 
5. Optional: To export drive parameters for later use, click Export. 

3.3.2 Manage Offsets 
Offsets include the following: 

 Workpiece offset: the distance between the workpiece origin and the machine 
origin. 

 Public offset: the distance between X-axis / Y-axis / Z-axis and the machine origin 
for all workpiece coordinate systems. 

 Tool offset: the distance between the tool and standard tool. 
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The relationship between workpiece coordinate and offsets is as follows: 

Workpiece coordinate  = Machine coordinate - Workpiece offset - Public offset - Tool offset 
To manage offsets, do the following: 

1. To open Offset page, do one of the following: 
o In Welcome page, click Offset. 
o In the menu bar, click View → Offset. 

 
2. In the dropdown box of Current Coor, select the target workpiece coordinate 

system. 
3. To set the public offset, in Public Offset area, click the input box of the target axis, 

and input a value. 
4. To set the workpiece offset, in Workpiece Offset, click the input box of the target 

axis, and input a value. 
5. To set the tool offset, in Tool Offset, click the input box of the target axis, and input 

a value. 
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3.3.3 Check the Control Panel 
With the control panel, you can check the coordinates of each axis, control the status and 
movement of the machine tool, adjust spindle / feedrate / G00 speed, check the current 
spindle and feed speed, use function buttons, and view the content of the load program file. 

Function buttons include Load, Unload, To Origin, To Fixed, Simu, Start, Pause, Stop, 
Resume, Selective, and HWGuide. 

To open Control Panel page, do one of the following: 

 In Welcome page, click Control Panel. 

 In the menu bar, click View → Control Panel. 
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3.3.4 Check Machining Statistics 
It is used to check the whole machining results. 

The machining statistics include the following: 

 Workpiece count 

 Current line 

 Machining length 

 Upper limit / lower limit of machining range 

 Difference of machining range 

 Cut time / elapsed time / start time / end time 

 G00~G03 Tool travel length 

 In machining 

 Upper limit / lower limit of movement range 

 Difference of movement range 

 Name 

 Finished 

 Process time 

 Remaining time 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

31 / 74 

To open Statistics page, do one of the following: 

 In Welcome page, click Statistics. 

 In the menu bar, click View → Statistics. 
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3.3.5 Set the Gang Drill 
It is used to add and arrange drills and set related parameters. 

Before setting the gang drill, make sure gang drill has been enabled in NcConfig software. 

Operations about drill include the following: 

  Select: select the target drill. 

  Spindle: add a spindle. 

  Vertical drill: add a vertical drill to cut vertical holes. 

  Horizontal drill (up and down): cut side openings in front of or behind the 
actual position. 

  Horizontal drill (right and left): cut side openings in the right/left of the 
actual position. 

To set the gang drill, do the following: 

1. To open Drill page, do one of the following: 
o In Welcome page, click Drill. 
o In the menu bar, click View → Drill. 

 
2. In the upper right corner, check Enable edit. 
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3. Click Drill edit. Drill edit dialog box pops up: 

 
4. In the upper area, select a drill type and add a drill. 
5. Optional: To move the target drill, press the mouse wheel and drag the target drill 

to the target position and release the mouse wheel. 
6. Set the following parameters for the target drill: 

o X, Y and Z: The offset of drill or spindle in X-axis / Y-axis / Z-axis direction. 
o X / Y length: The size of each drill, except horizontal drills. 
o X / Y extended length: The size of each horizontal drill. 
o Port: The logic address of the drilling cylinder. 

7. In Drill page, click Drill Cylinder. 
8. Optional: To close all drills, click All drills up. 

To open all drills, click All drills down. 
9. Optional: To measure tool offsets of all drills in Z-axis direction, click Measure all. 

To measure the tool offset of the target drill, click Measure single. 
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3.3.6 Check Logs 
It is used to check different types of logs that record important operations and system 
events after this startup and historical logs for troubleshooting. 

To check logs, do the following: 

1. To open Log page, do one of the following: 
o In Welcome page, click Log. 
o In the menu bar, click View → Log. 

 
2. Check different types of logs: 

o Click Information. Logs with icon  about running status show. 

o Click Alarms. Warnings with icon  show. 

o Click Errors. Errors with icon  show. 

o Click Others. Logs with  about operation steps and internal codes show. 
o Click All. The corresponding logs that generate after this startup show. 
o Click History. Logs since the installation of the software show. 

3. Optional: To clear logs, click Clear. 
Note: Please regularly clear logs. Otherwise, too many log files will slow down the 
system. 

3.3.7 Do Commissioning for the Tool Magazine 
Before doing commissioning for the tool magazine, make sure multi-cylinder configuration 
is not enabled. 
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To do commissioning for the tool magazine, do the following: 

1. To open Magazine Setting, do one of the following: 
o In Welcome page, click Magazine Setting. 
o In the menu bar, click View → **Magazine Setting. 

 
2. In Magazine Common Parameter area, set the following parameters: 

o Magazine capacity: the total number of tools in the tool magazine. 
o Speed in tool change: The spindle speed during tool change. 
o Speed of Z-axis: the speed for Z-axis moving to the upper / lower position 

during tool change. 
o Magazine cylinder delay: the delay time to turn on the magazine cylinder. 
o Spindle tool clamp delay: the delay time to clamp / unclamp tool. 
o Dustcover cylinder delay: the delay time for the dustcover up and down. 
o X safe position: it is used to set the X-axis protection position by judging if 

the current X-axis position is less than the X-axis position of the tool 
magazine when the tool magazine is pushed out. 

3. To set the current position of tool magazine, in Magazine Tools Position area, 
click Set. 

4. Optional: To replace the current tool, in Change Tool Test area, click the 
dropdown box of Active tool number, select the target tool number, and click 
Change. 

3.3.8 Set Tool Compensation 
Tool compensation includes tool length compensation and tool radius compensation. 

In CNC machining, the CNC system actually controls the tool center or the related point of 
the tool rest whose motion track is controlled directly to realize profile processing for the 
parts. The cutting part actually involved is the tool nose or the cutting edge which has 
dimensional variation with the tool center or the related point of the tool rest, so the CNC 
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system has to compute the corresponding coordinates of the tool center or the related 
point of the tool rest according to the actual coordinate position of the tool rest or the 
cutting edge (namely the actual coordinate position of the part profile), which is called tool 
compensation. 

Before setting tool compensation, set the following parameters to Yes: 

 Enable Tool Length Compensation 

 Enable Tool Radius Compensation 
To set tool compensation, do the following: 

1. To open Tool Compensation page, do one of the following: 
o In Welcome page, click Tool Compensation. 
o In the menu bar, click View → Tool Compensation. 

 
2. Set the following parameters for the target tool: 

o Tool Diameter: the diameter of the current tool. 
o Diameter Wear: the diameter wear of the current tool. 
o Tool Length: the length of the current tool. 
o Length Wear: the length wear of the current tool. 
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3.3.9 Turn on the Spindle in Advance 
It is used to turn on the spindle of the target cylinder before switching to the target cylinder, 
so as to reduce the spindle preparation time and improve machining efficiency. It is 
controlled by the parameter Spindle before Hand Time. 

At present, it is only applicable to the mechanical structure of multi-cylinder and multi-
inverter. 

To modify the value of parameter Spindle before Hand Time, see Setting Parameters to 
find the parameter, and modify its value based on your needs. 

Example 

If the parameter Spindle before Hand Time is set to 1000 and changing from T1 to T3 is 
required. Then: 

1. Before executing T3 command, the system turns on the spindle corresponding to 
T3 1000ms in advance. 

2. When executing the T3 command, the system does the following: 
o Turn off the spindle corresponding to T1. 
o Pull in the cylinder corresponding to T1. 
o Push out the cylinder corresponding to T3. 

3.3.10 Set Parameters for Loading and Unloading 
It is used to set parameters for loading and unloading, so as to improve machining 
accuracy and efficiency. 

Before setting parameters for loading and unloading, make sure loading and unloading 
function is configured in NcConfig software. 
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To set parameters for loading and unloading, do the following: 

1. To open Load Material page, do one of the following: 
o In Welcome page, click Load Material. 
o In the menu bar, click View → Load Material. 

 
2. Set the following parameters according to your needs: 

o Load start / end position: the start / end position for loading material. 
o Side push position: the fixed position for side pushing. 
o Unload start / end position: the start / end position for unloading material. 
o Vacuum adsorption / destroy delay: the delay time for vacuum adsorption / 

destroy. 
o Loading adsorption delay: the delay time for loading adsorption. 
o Front / Left / Right / Back position delay: the delay time to turn on front / 

left / right / back positioning cylinder. 
o Back / Left / Right / push delay: the delay time to turn on back / left / right 

pushing cylinder. 
o Load / unload delay: the delay time to turn on loading / unloading cylinder. 
o Load / unload speed: the speed for loading and unloading. 

3. In Operate area, select Load to load material / Unload to unload material / Load 
and Unload to load and unload material. 
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3.4 Commissioning for the Machine Tool 

3.4.1 Adjust the Workpiece Origin 
It is used to adjust the workpiece origin. 

To adjust the workpiece origin, do the following: 

1. In the menu bar, click Machine → Datum Setting. 
2. Do one of the following: 

o To adjust the workpiece origin for all axes, click All Axis Adjustment. 
o To adjust the workpiece origin for a single axis, click Adjustment(_X)(X) / 

Datum Setting(_Y)(Y) / Adjustment(_Z)(Z). 

3.4.2 Execute Tool Calibration 
It is used to measure the selected tool, so as to make sure it works normally during 
machining. 

Types of tool calibration includes the following: 

 Multi-tool measure: it is used to measure the tool on a certain fixed position of the 
machine tool to reconfirm tool offset. 

 First calibration / after tool change: the first calibration is used to define the 
workpiece coordinate system. After tool change, please do tool calibration again to 
define the tool length offset. 

 Mobile calibration it is used to do tool calibration in the current position. 
This operation mainly focuses on the last two types of tool calibration. 

To execute tool calibration, do the following: 

1. To open Calibration page, do one of the following: 
o In Welcome page, click Calibration. 
o In the menu bar, click Machine → Calibration. 

2. Click the dropdown box of Calibration Mode and select the target calibration type. 
3. In Basic Setting area, set the following parameters: 

o Positioning Times: set the fine positioning times during tool calibration to 
improve calibration precision. 

o Positioning Speed: set the speed during fine positioning of tool calibration. 
4. In Fixed Tool Sensor area, set the following parameters, and click Set: 

o Fixed Point in X: the coordinate position of the fixed tool sensor in X-axis / 
Y-axis direction. 

o Start Point in Z: the coordinate position to start tool calibration in Z-axis 
direction. 

o Z Lowest Pos: the lowest coordinate of Z-axis during tool calibration. 
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5. To start tool calibration, do one of the following: 
o Multi-tool measure 

 To set the current machine coordinate of Z-axis to Z-axis tool offset of 
the current tool, click Manual Set. 

 Click **Auto Measure **. The system automatically starts tool 
calibration and saves offset to the corresponding tool offset after 
measurement. 

o First calibration / after tool change 
 If it is the first time to start tool calibration, click First-time. The 

system automatically starts the first-time tool calibration and saves 
offset to the corresponding tool offset after measurement. 

 After tool change, click After Change. The system automatically 
starts the first-time tool calibration and saves offset to the 
corresponding tool offset after measurement. 

The system starts tool calibration: 

 Multi-tool measure 

 
 First calibration / after tool change 

 
After tool calibration, to verify if the corresponding tool offset is set successfully, check 
parameter Tool Offset in Parameter page. 

3.4.3 Set Screw Error Compensation 
It is used to compensate the screw error and improve the machining precision when errors 
exist in the machine tool and the desired precision cannot be reached. 
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To set screw error compensation, see Set Parameters to find parameter Lead Screw 
Compensation Mode, and set it to a value except 0. 

 1: backlash compensation 

 2: backlash compensation and unidirectional compensation: this operation is the 
same with the bidirectional compensation. 

 Bidirectional compensation 

3.4.3.1 Set the Backlash Compensation 
To set backlash, see Set Parameters to find and set parameter Backlash. 

3.4.3.2 Set the Bidirectional Compensation 
To set bidirectional compensation, do the following: 

1. To open Screw Error Compensation page, do one of the following: 
o In Welcome page, click Screw Error. 
o In the menu bar, click Machine → Screw Error. 

2. To generate the curve for screw error compensation, do one of the following: 
o To import the target file of screw error compensation, click Import, and 

select the target file. 
o To add error value, click Add. 

 
Red curve: positive error; blue curve: negative error. 
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3. Click Apply. The system automatically saves the compensation data to the 
corresponding configuration file. 

To make compensation data effective, restart NcTune. During machining, the system 
automatically does screw error compensation based on the compensation file. 

3.4.4 Execute MDI 
It is used to input and execute simple commands, so as to make machine tools move 
quickly or execute simple operations. 

To execute MDI, do the following: 

1. To open MDI page, in the menu bar, click Machine → MDI: 

 
2. Enter the target commands. 
3. Click Execute. The system starts to execute the input commands. 
4. Optional: To clear the input commands, click Clear. 
5. Optional: To clear the target history command, click the dropdown box of Clear 

History Code, and the target history command, and click Clear History Code. 
To clear all history commands, click Clear All History Code. 

3.4.5 Execute Centering 
It is used to get the center point of a regular workpiece and set it as the workpiece origin. 

To execute centering, do the following: 

1. To open Centering dialog box, in the menu bar, click Machine → Centering. 
2. To select a centering type, in the dropdown box of Centering Type, select Line / 

Circle. 
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3. In the dropdown box of WCS, select the target workpiece coordinate system 
(G54~G59). 

4. Optional: To enable the edge finder for accurate centering, click Edge Finder. 
5. Do one of the following according to the centering type: 

o Line centering 
o Circle centering 

3.4.5.1 Execute Line Centering 
It is used to find the midpoint of a workpiece between any two points in X-axis / Y-axis 
direction. The shape of workpiece is rectangle, square, or regular polygon. 

The schematic diagram of line centering is as follows: 

 

Among them: 

 X1 and X2: the edge of workpiece in X-axis direction. 

 Y1 and Y2: the edge of workpiece in Y-axis direction. 
To execute line centering, do the following: 

1. Move the tool to X1-axis / Y1-axis position, and click Record X / Record Y. The 
system records the machine coordinate of the current point. 

2. Move the tool to X2-axis / Y2-axis position, and click Center X / Center Y. The 
system automatically calculates the midpoint coordinate based on the coordinate of 
the current point and records in the last step, and sets it as the workpiece origin. 

Note: During centering, when one axis is being centered, the other should keep still. 

3.4.5.2 Execute Circle Centering 
It is used to automatically calculate the center point of a circular blank via three points on 
the circumference. The center point will be set as the workpiece origin. 

The schematic diagram of circle centering is as follows: 

 

Among them: P1, P2, and P3: three points on the circumference. 

Note: To make sure the accuracy of the circle center, the three points on the 
circumference should be scattered as far as possible. 

To execute circle centering, do the following: 

1. Move the tool to P1 position, and click Record 1. The system records the machine 
coordinate of the current point as the first group. 

2. Move the tool to P2 position, and click Record 2. The system records the machine 
coordinate of the current point as the second group. 
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3. Move the tool to P3 position, and click Centering. The system records the machine 
coordinate of the current point as the third group, and automatically calculates the 
coordinates of the circle center based on the three groups and sets it as the 
workpiece origin. 

3.4.6 Adjust Y1-axis and Y2-axis 
It is used to separately adjust Y1-axis and Y2-axis. You can adjust the feedback 
coordinates of Y1-axis and Y2-axis to the same according to the actually synchronous 
deviation. 

To adjust Y1-axis and Y2-axis, do the following: 

1. In the menu bar, click Machine → Y1Y2 Jiggle. Y1Y2 Jiggle dialog box pops up: 

 
2. Check Enable Jiggle. 
3. Select a step size (0.01, 0.1 and 1) or customized a step size. 

The customized step size is 5 by default. 
4. To adjust the feedback coordinates of Y1-axis or Y2-axis, click Y1+ / Y1- / Y2+ / Y2-. 

After Y1-axis and Y2-axis adjustment, execute returning to the machine origin or set datum 
again. 

3.4.7 Execute Data Acquisition 
It is used to collect the specified data for each axis, and check sent pulses and feedback 
pulses. 

The specified data include the following: 

 Command position in the command / machine coordinate system 

 Positional deviation 

 Feedback / feedback latch position in the machine coordinate system 

 Internal command position in the command coordinate system 

 Feedback / command / target speed 

 Command torque 
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To execute data acquisition, do the following: 

1. To open Data Acquisition page, do one of the following: 
o In Welcome page, click Data Acquisition. 
o In the menu bar, click Machine → Data Acquisition. 

 
2. Select the target axis and check Collect. 
3. Double click Collect Option3 / Collect Option4, and select the target data. 
4. In the input box of Collect Time, input a value and click Start Collect. 
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3.4.8 Execute Learning for the Circularity Test 
It is used to run a circle and collect data, to provide reference for circularity test. 

To execute learning for the circularity test, do the following: 

1. To open QEC Learning page, do one of the following: 
o In Welcome page, click QEC Learning. 
o In the menu bar, click Machine → QEC Learning. 

 
2. In Frame Cutting Setting area, set parameter Speed, and click Framecheck. 
3. In Frame Region Setting area, set parameters Min Radius, Max Radius, Min 

Speed, and Max Speed. 
4. Click Start. 
5. Optional: To check learning data, click QEC Error List. 

3.4.9 Execute Commissioning for the Circularity Test 
It is used to remove distortion phenomenon (usually sharp corner) at the transition caused 
by one quadrant entering into another. 

Before executing commissioning for the circularity test, make sure learning for the 
circularity test has been executed. 

To execute commissioning for the circularity test, do the following: 

1. In QEC Learning page, click QEC Error List and record a group of data. 
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2. To open QEC Debugging page, do one of the following: 
o In Welcome page, click QEC Debugging. 
o In the menu bar, click Machine → QEC Debugging. 

 
3. Input the recorded data in Test Circle area. 
4. In QEC Data area, check Enable QEC. 
5. Click Start. 
6. According to the preview in the right, adjust parameters for the circularity test. 

When the result is close to a circle and no indent phenomenon occurs, 
commissioning finishes. 

7. Optional: To save data for the circularity test, click Save QEC Data. 
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3.5 Machining Commissioning 

3.5.1 Modify Password 
It is used to modify password that used to enter the main interface of NcTune software. 

To modify password, do the following: 

1. In the menu bar, click System → Modify Password. Modify Password dialog box 
pops up: 

2. Enter the old password. 
3. Enter the new password. 
4. Enter the new password again. 
5. Click Modify. 

3.5.2 Upgrade Firmware 
After upgrading firmware, software function can be improved and the stability of the 
system can be enhanced. 

Note: Please execute this operation in the help of the technician. 

To upgrade firmware, do the following: 

1. To open Update Firmware page, do one of the following: 
o In Welcome page, click Update Firmware. 
o In the menu bar, click System → Update Firmware. 

 
2. Select the target controller and check Update. 

3. In Firmware File Path column, click , select the target file under the target file 
path, and click Open. 

4. To start upgrade the firmware, in the upper left corner, click  Update. 

After the system upgrades the firmware, sign  shows in front of the corresponding 
Lambda terminal board or terminal board and the prompt Succeeded in upgrading the 
firmware. Please restart the system and hardware shows. 
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3.5.3 Load a Program File 
It is used to load a program file for machining. 

To load a program file, in the menu bar, click File → Open and Load, and select the 
target program file. The system automatically loads the program file. 

You can check the track in Tool Path&Trace window of NcStudio software. 

To unload the program file, click File → Unload. The track in Tool Path&Trace window of 
NcStudio software disappears. 

3.5.4 Generate an Installation Package 
It is used to create a complete installation package on the basis of current system data, 
which is useful to back up system files and save a stable version of the system. 

This operation will pack up the current folder whose name begins with Default_Config. 

To generate an installation package, do the following: 

1. In the menu bar, click File → Pack Up Software. Packup Tool dialog box pops up: 

 
2. Modify the name and storage path of the installation package. 
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3. Optional: Click Advanced, and set the following advanced settings: 

 
o Language: At present, the system supports Chinese and English. 
o Parameter migration: 

 Keep All Local Parameters: use all parameters in the local. 
 Keep Only Machine-Specific Parameters: use parameters about 

machine characteristics in the local. 
 Fresh Installation: fresh Installation 

o Auto boot: whether to automatically start the software once the machine 
boots. 

o Others 
 Support language selection: whether to support switching the 

current language. 
 Create a desktop shortcut: whether to create a shortcut on the 

desktop. 
 Start the software after installation: whether to automatically start 

the software after installation. 
4. Click Pack up. The system starts to generate the installation package. 

After generating an installation package, find the generated installation package under the 
set path. 
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3.5.5 Start Machining 
It is used to start automatic machining from the first program file to the last program file in 
the machining task. 

Before starting machining, make sure the following: 

 Returning to the machine origin has been executed. 

 No alarms like E-stop alarm. 
In the menu bar, click Machining → Start. The system automatically starts machining 
from the first program file to the last program file. 

During automatic machining, you can also do the following: 

 To pause machining, in the menu bar, click Machining → Pause. 

 To stop machining, in the menu bar, click Machining → Stop. 

 To resume machining from the exact interrupted position when power interruption or 
E-stop occurs, in the menu bar, click Machining → Resume. 
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3.5.6 Use Machining Wizard 
It is used to quickly generate the machining program with the machining wizard. 

With the machining wizard, you only need to set related parameters and save setting, and 
the system will automatically generate the machining program. Compared to traditional 
manual programming, this way is simpler and more convenient. Besides, you can also 
export the machining program generated by the wizard to the local for later use. 

To use machining wizard, do the following: 

1. In the menu bar, click Machining → Wizard. Wizard dialog box pops up: 

 
2. Select the target wizard, and set related parameters. 

The supported wizard includes the following: 
o Circle contour 
o Circle pocket 
o Rectangle contour 
o Rectangle pocket 
o Screw comp wizard 
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3.5.6.1 Set Machining Wizard for Circle Contour 
It is used to engrave the outer frame or inner frame of the circle. 

The schematic diagram is as follows: 

 Outer frame 

 
 Inner frame 

 
To set machining wizard for circle contour, check Outer / Inner, and set the following 
parameters: 

Part Dia d 

 Start X / Y 

 Z Depth h 

 Cut Depth H 

 Tool Dia D: 
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3.5.6.2 Set Machining Wizard for Circle Pocket 
It is used to engrave the bottom of the circle. 

The schematic diagram is as follows: 

 

To set machining wizard for circle pocket, set the following parameters: 

 Part Dia d 

 Start X / Y 

 Z Depth h 

 Cut Depth H 

 Tool Dia D: 

 Nose Space T 

3.5.6.3 Set Machining Wizard for Rectangle Contour 
It is used to engrave the outer frame or internal frame of the rectangle. 

The schematic diagram is as follows: 

 Outer frame 
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 Inner frame 

 
To set machining wizard for rectangle contour, check Outer / Inner, and set the following 
parameters: 

 Length L 

 Width W 

 Start X / Y 

 Z Depth h 

 Cut Depth H 

 Tool Dia D: 

3.5.6.4 Set Machining Wizard for Rectangle Pocket 
It is used to engrave the bottom of the rectangle. 

The schematic diagram is as follows: 

 Horizontal milling 
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 Vertical milling 

 
To set machining wizard for rectangle pocket, check Vertical / Horizontal, and set the 
following parameters: 

 Length L 

 Width W 

 Start X / Y 

 Z Depth h 

 Cut Depth H 

 Tool Dia D: 

 Nose Space T 

3.5.6.5 Set Screw Compensation Wizard 
It is used to use laser interferometer to measure lead screw error. 

The schematic diagram is as follows: 

 

1. Check X / Y / Z, and set the following parameters: 
o Start P1 
o End Position P2 
o Measure N1~Nx 

2. Set parameter Cycle Times. 
3. To conveniently check machining effect, set parameter Pause. 
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4 Settings in NcStudio Software 
4.1 Overview 
Through this part, you can quickly know the machining operations of NcStudio software in 
WEIHONG NcStudio CNC System for Cutting Machines. 

4.2 Quick Start 

4.2.1 Overview 
Through this part, you can quickly know the basic machining process of WEIHONG 
NcStudio CNC System for Cutting Machines. 

The machining process is as follows: 

 

4.2.2 Execute Returning to the Machine Origin 
The origin of the machine coordinate system (inherent coordinate system of a machine 
tool), also called mechanical origin or home, is a fixed point assigned by designing, 
manufacturing and debugging before the machine tool leaves the factory. 

This operation is used to synchronize the machine coordinate system of the system and 
the machine tool. 

Before executing returning to the machine origin, make sure all servo alarms have been 
removed. 
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To execute returning to the machine origin, do the following: 

1. In the upper right corner of the main interface of NcStudio software, click the 

hamburger menu  → Homing. Homing dialog box pops up: 

 
If Dialog box pops up when cycle starts in the lower left corner is checked, this 
dialog box will automatically pop up when NcStudio software starts. 

2. Optional: If the switch position of the machine origin changes, click Clear Average, 
and click Clear in History Average dialog box. 
Otherwise, a prompt Compared to history average, distance between coarse 
positioning signal and fine positioning signal exceeds the allowable range. Failed to 
execute returning to machine origin pops up. 

3. Do one of the following: 
o To return all axes to the machine origin, click All Axis. Z-axis returns to the 

machine origin firstly, then X-axis, and Y-axis return in sequence. 
o To return a single axis to the machine origin, click the button for a single axis, 

the target axis returns to the machine origin. 
o If you make sure that the current position is the same with the machine 

coordinate, the machine tool has never been turned off and E-stop has never 
occurred, to set the current position as the machine origin, click Direct Set. 
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After executing returning to the machine origin, sign  appears in front of each axis in the 
axis coordinate display bar. 

4.2.3 Load a Program File 
It is used to load a program file for machining. 

In the operation button bar, click , and select the target program file. The 
system automatically loads the program file and shows its track in Tool Path&Trace 
window. 

To unload the program file, click . Track in Tool Path&Trace window 
disappears. 

4.2.4 Set the Workpiece Origin 
The zero point of X-axis / Y-axis / Z-axis / A-axis in the program file is the workpiece origin. 
It is used to define the actual position of the workpiece origin in the board. 

It is used to clear the current workpiece coordinate of each axis and set the machine 
coordinate of each axis to the workpiece offset. 

To set the workpiece origin, do the following: 

1. Move the machine tool to the position where is the target workpiece origin. 
2. In the operation button bar, select a clearing type in the dropdown box of 

. 

3. Click . A prompt Are you sure to set the current machine coordinate to 
the workpiece origin pops up. 

4. Click Yes. 
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4.2.5 Execute MDI 
It is used to input and execute at most 8 simple commands, so as to make machine tools 
move quickly or execute simple operations. 

To execute MDI, do the following: 

1. In the operation button bar, click . MDI dialog box pops up: 

 
2. Enter the target commands. 
3. Click Execute. The system starts to execute the input commands. 

4.2.6 Set a Machining Task 
It is used to start machining for all program files in a machining task. And you can set 
different machining interval, workpiece coordinate system, and machining times for each 
program file, and freely choose whether the target program file is involved in machining. 

Before setting a machining task, make sure the following: 

 Names of program files in the machining task are unique. 

 The format of program file is NC. 
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To set a machining task, do the following: 

1. To switch to Multi-task Manage window, in the function window area, click Multi-
task Manage: 

 
2. Change Multi-task Processing switch to ON status. 

3. To add the target program file to the machining task, click , and select the target 
program file. 
You can at most add 60 program files to the machining task. And the status of 
added program files is waiting for machining. 
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4. To edit the machining task, do the following: 

o To enable all added program files, click . 

o To disable all added program files, click . 
o The status of added program files is cancellation of machining. 

o To adjust the machining order of the selected program files, click  or . 

o To delete a program file, select the target program file, and click . 
If you need to delete all program files, please click Delete All. 

o Click . If a front / back identifier exists, the system firstly machines the 
program file with a back identifier and then the program file with a front 
identifier. 
See Sort Program Files in a Machining Task for details. 

5. Optional: To replace the target program file with another one, double click the 
name of the target program file and select another program file. 

6. To set the machining times for the target program file, double click the table cell in 
Times column, and set a value. 

7. Optional: To set sorting rules, click Permutation setup, see Sort Program Files in 
a Machining Task for details. 

8. Optional: To reset the status of station 1 or 2 to waiting for machining and clear 
machined time, click Reset area 1 / 2 file. 

9. To save the current machining task to TSK format, click Save&Load. 
If the modification is not saved, sign * shows in Current task name in the upper 
right corner of Multi-task Manage window. 

4.2.7 Start Machining 
It is used to start automatic machining from the first program file to the last program file in 
the machining task. 

Before start machining, make sure no alarms like E-stop alarm occur. 

To start machining, do one of the following: 

 In the operation button bar, click . The system automatically starts 
machining the loaded program file. 
During automatic machining, you can also do the following: 

o To pause machining, click . 

o To stop machining, click . To resume machining from the exact 
interrupted position when power interruption or E-stop occurs, click 

. 
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 In the idle status, in the operation button bar, click , set the machining 
range by setting the start line and end line, and click OK. The system automatically 
starts machining from the start line to the end line. 

 With the handwheel, in Auto mode, in the operation button bar, click . 
The system is controlled by the handwheel. 

4.3 System Operations 

4.3.1 Set Tool Compensation 
Tool compensation includes tool length compensation and tool radius compensation. 

The cutting part actually involved is the tool nose or the cutting edge which has 
dimensional variation with the tool center or the related point of the tool rest, so the CNC 
system has to compute the corresponding coordinates of the tool center or the related 
point of the tool rest according to the actual coordinate position of the tool rest or the 
cutting edge (namely the actual coordinate position of the part profile), which is called tool 
compensation. 

Note: Please set tool compensation in the help of the technician. 

Before setting tool compensation, set the following parameters to Yes: 

 Enable Tool Length Compensation 

 Enable Tool Radius Compensation 
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To set tool compensation, do the following: 

1. In the upper right corner of the main interface of NcStudio software, click the 

hamburger menu  → Tool Parameter. Tool Parameter dialog box pops up: 

 
2. Set the following parameters for the target tool: 

o Tool Diameter: the diameter of the current tool. 
o Diameter Wear: the diameter wear of the current tool. 
o Tool Length: the length of the current tool. 
o Length Wear: the length wear of the current tool. 
o X / Y / Z Offset: the offset of X-axis / Y-axis / Z-axis. 
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4.3.2 Set Parameters for the Tool Magazine 
Before setting parameters for the tool magazine, make sure multi-cylinder configuration is 
not enabled. 

Note: Please execute this operation in the help of the technician. 

To set parameters for the tool magazine, do the following: 

1. In the upper right corner of the main interface of NcStudio software, click the 

hamburger menu  → Tool Magazine Parameter. Tool Param dialog box pops 
up: 

 
2. In Magazine Common Parameter area, set the following parameters: 

o Magazine capacity: the total number of tools in tool magazine. 
o Tool change upper position: the upper position of Z-axis to change a tool. 
o Speed in tool change: the spindle speed during tool change. 
o Speed of Z-axis: the speed for Z-axis moving to the upper / lower position 

during tool change. 
o Magazine cylinder delay: the delay time to turn on the magazine cylinder. 
o Spindle tool clamp delay: the delay time to clamp / unclamp tool. 
o Dustcover cylinder delay: the delay time for the dustcover up and down. 
o Open spindle after tool change: whether to turn the spindle on after tool 

change. 
o X safe position: it is used to judge if the current machine coordinate of X-

axis is less than this parameter. 
3. To set the current position to the position of the tool magazine, modify the value of 

parameter ToolLibPos(X/Z), and click the corresponding button of 
SetToolPos(X/Z). 
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4.3.3 Set Parameters for Loading and Unloading 
It is used to set parameters for loading and unloading, so as to improve machining 
accuracy and efficiency. 

Note: Please execute this operation in the help of the technician. 

Before setting parameters for loading and unloading, make sure loading and unloading is 
enabled in NcConfig software. 

To set parameters for loading and unloading, do the following: 

1. In the upper right corner of the main interface of NcStudio software, click the 

hamburger menu  → Load Unload Param. Load Unload Param dialog box 
pops up: 

 
2. Double click 板材类型, and input the name for the plate type. 

3. Set the following parameters according to your needs: 
o Load start / end position: the start / end position for loading material. 
o Side push position: the fixed position for side pushing. 
o Unload start / end position: the start / end position for unloading material. 
o Vacuum adsorption / destroy delay: the delay time for vacuum adsorption / 

destroy. 
o Loading adsorption delay: the delay time for loading adsorption. 
o Front / Left / Right / Back position delay: the delay time to turn on front / 

left / right / back positioning cylinder. 
o Back / Left / Right / push delay: the delay time to turn on back / left / right 

pushing cylinder. 
o Load / unload delay: the delay time to turn on loading / unloading cylinder. 
o Load / unload speed: the speed for loading and unloading. 
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4.3.4 Set a Printer 
During machining, the system automatically recognizes pictures that are put in the same 
path with program files and whose naming rule is the same with program files and print 
them. 

Before setting a printer, in NcConfig software, in Other area of Component page, check 
LabelPrint. 

To set a printer, do the following: 

1. In the upper right corner of the main interface of NcStudio software, click the 

hamburger menu  → Printer Setting. Printer dialog box pops up: 

 
2. In Printer Setting area, do the following: 

a. To select the target printer, click the dropdown box of Printer and select the 
target printer. 
If you need to select the target printer to the default printer, please click 
Select Printer. 

b. Optional: To make the system automatically print pictures without editing, 
check Enable Printer. 

c. In the dropdown box of Format, select the picture format. 
The supported formats include BMP, JPG, PNG, GIF and TIF. 

d. To select the storage path for printed pictures, click Select and select the 
target path. 

3. In Picture Setting area, do the following: 
a. Optional: To make the printed pictures adapt to the paper size, check 

Adaptive. 
b. To set X-axis coordinate of the upper left corner of the picture corresponding 

to the label paper, click input box Offset(X), and set a value. 
Default value: 0. 

c. To set X-axis coordinate of the upper left corner of the picture corresponding 
to the label paper, click input box Offset(Y), and set a value. 
Default value: 0. 

4. Click Print: 
o When a program file is loaded, if a picture exists in the same path with the 

program file, the system prints these pictures. Otherwise, printing action will 
not occur. 

o When no program file is loaded, the system prints the selected picture. 
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4.3.5 Sort Program Files in a Machining Task 
It is used to sort program files in the same machining task before start machining the task. 

The naming rule of program files in the same machining task is as follows: 

 

1. Board type: any characters, texts without limitation of the number of words. 
2. Number: the digits should be the same and continuous. 
3. Front/Back identifier: any characters, numbers, texts without limitation of the 

number of words. 
o If a front identifier shows in the file name, the front of the board will be 

machined. 
o If a back identifier shows in the file name, the back of the board will be 

machined. 
Note: Please set the front/back identifier in the prefix or suffix of the file name. 

To sort program files in a machining task, do the following: 

1. To switch to Multi-task Manage window, in the function window area, click Multi-
task Manage: 

2. Change Multi-task Processing switch to ON status. 
3. Click Permutation Setup. Permutation Setup dialog box pops up: 
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4. To set the front / back identifier of the file name, set parameters Front Flag and 
Verso Flag. 
The system will firstly machine the program file with a back identifier, then the 
program file with a front identifier, and lastly the program file with no identifier. 

5. To set the position of the identifier in the file name, set parameter Flag Place: 
o 1: the identifier is in the suffix of the file name. 
o 2: the identifier is in the prefix of the file name. 

6. Optional: To enable double stations for machining, set parameter Station 
Permutation Type to 2. 
The system uses single station for machining by default. 

7. Modify the value of parameter Auto Sort: 
o When a program file is added into the machining task: 

 When the parameter is set to Yes, the system firstly machines the 
program file with a back identifier, then the program file with a front 
identifier and lastly the program file with no identifier. 

 When the parameter is set to No, the system lastly machines the 
added file. 

o When a program file is deleted in the machining task: 
 When the parameter is set to Yes, the system lastly machines the 

other file (002_F in the following example) that is in the same group 
with the deleted file. 
Example 
When the machining order is 001_B(back identifier) → 001_F(front 
identifier) → 002_B(back identifier) → 002_F(front identifier) → 
003_F(front identifier) → 006, and 002_B is deleted, the machining 
order turns into 001_B → 001_F → 003_F → 006 → 002_F. 

 When the parameter is set to No, the machining order remains 
unchanged. 



上海维宏电子科技股份有限公司 

SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

70 / 74 

4.3.6 Manage Offsets 
Offsets include the following: 

 Workpiece offset: the distance between the workpiece origin and the machine 
origin. 

 Public offset: the distance of the X-axis, Y-axis and Z-axis relative to the machine 
origin for all workpiece coordinate systems. 

 Tool offset: the distance between the tool and standard tool. The relationship 
between workpiece coordinate and offsets is as follows: 

Workpiece coordinate  = Machine coordinate - Workpiece offset - Public offset - Tool offset 
To manage offsets, do the following: 

1. To switch to Offset Manage window, in the function window area, click Offset 
Manage 

 
2. To set the workpiece offset, do the following: 

a. In Workpiece Offset area, select the target workpiece coordinate system 
from G54 to G56, and click Modify. 

b. To set the current position to the workpiece offset, input the workpiece offset 
of each axis, and click Set. 

3. To set the public offset, in Public Offset area, input the public offset of each axis. 
4. Optional: To adjust Z-axis public offset, do one of the following: 

o To lift Z-axis 0.01mm / 0.1mm / 1mm, click 0.01 / 0.1 / 1 after L to. 
o To deepen Z-axis 0.01mm / 0.1mm / 1mm, click 0.01 / 0.1 / 1 after D. 

4.3.7 Set Technics 
It is used to set parameters for different technic types, so as to improve machining 
accuracy and efficiency. 
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Technic types include the following: 

 Cutting: used to cut boards. 

 Wood: Carve patterns in the boards. 
To set technics, do the following: 

1. To switch to Craftsmanship window, in the function window area, click 
Craftsmanship: 

 
2. To modify technic parameters, change Turn on switch to ON status. 

Otherwise, you are not allowed to modify technic parameters. 
3. Select the technic type, and click Setting. 

If you need to cancel this operation, please click Cancel. 
4. In the Value column, double click the table cell, and modify values of the following 

parameters: 
o Gxx Acc Up: the acceleration in accelerating phrase during machining. 
o Gxx Acc Down: the deceleration in decelerating phrase during machining. 
o Jerk: the change rate of acceleration. 
o Max Corner Acc: the maximum feedrate at corners. It is suggested to set it 

1~2 times of acceleration of a single axis. 
o Max Speed of Ref Circle: the maximum feedrate when machining 10mm-

diameter reference circle. 
o Path Smoothing Time: the longer the time, the smoother the surface of the 

workpiece. But some of the details may be weakened. 
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5 FAQs 
It is used to clear alarms so as to establish good communication between WEIHONG 
NcStudio CNC System for Cutting Machines and the servo drive. 

The types of alarms that need to be cleared include the following: 

 Alarm of terminal board disconnection 

 E-stop alarm 

 Limit alarm 

 Servo driver alarm 

 Alarm of port polarity error 

5.1 Clear the Alarm of Terminal Board Disconnection 
To clear the alarm of terminal board disconnection, do the following: 

1. Make sure the wiring of terminal boards is connected correctly and securely. 
If it is not connected correctly and securely, correct and tighten the wiring. 

2. Make sure the drive program is correctly installed. 
If it is not correctly installed, install the drive program again. 

3. Make sure the terminal boards are not damaged. 
If it is damaged, replace the terminal board. 

5.2 Clear the E-stop Alarm 
To clear the E-stop alarm, check if E-stop button on the panel is pressed: 

 If it is, release the button. 

 If it is not, modify the polarity of E-stop port in NcTune software. 

5.3 Clear the Limit Alarm 
When the machine tool triggers the limit switch, the system will send a positive / negative 
limit alarm. 

To clear the limit alarm, move the machine tool towards the opposite direction of limit 
switch. 

5.4 Clear the Servo Drive Alarm 
Before clearing the servo drive alarm, make sure no alarm in the servo drive. 

To clear the servo drive alarm, do the following: 

1. Make sure the wiring of the servo drive is connected correctly and securely. 
If it is not connected correctly and securely, correct and tighten the wiring. 

2. Make sure the polarity of Servo Alarm port is NC. 
If it is not, modify the port polarity to NC. 

3. Optional: Make sure the setting of parameter Drive Station Address matches with 
the drive station address of the machine tool. 
If it does not, modify the parameter setting according to the drive station address of 
the machine tool and restart the software to make modification effective. 

5.5 Clear the Alarm of Port Polarity Error 
When the switch type of port polarity does not match with that of the machine tool, related 
ports will send alarms. 

To clear the alarm of port polarity error, modify the polarity of related ports in NcTune 
software. 
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6 Legal Notices 
The term “Software Product” includes all copies of the licensed software and its 
documentation. This license agreement is a legal agreement between You (either an 
individual, a legal entity or any affiliated companies or other entities) and Weihong 
Electronic Technology Co., Ltd. (hereinafter referred to as Weihong Company). By 
installing, copying, or otherwise using the Software Product, you agree to be bound by the 
terms and conditions of this license. Unless otherwise stated in this agreement, you shall 
not use, copy, revise, rent, or transfer the Software Product or any part of the Software 
Product for any other purposes. 

6.1 Requirements of Use 
1. You may install for use one copy of the Software Product on a single machine; 
2. You may make a copy of the Software Product for archive or backup purposes and 

the copy is to be used on this machine only; 
3. You may transfer the Software Product and the license agreement to a third party, 

provided that the third party accepts the terms and conditions stated in this 
agreement, with prior express permission from Weihong Company; 

4. When transfer confirmed, you shall transfer all the copies of the original documents 
and the supplementary documents to the third party or destroy all the copies un-
transferred; 

5. You can use the Software Product on a network server or intranet server only if it is 
stipulated in explicit terms that you are allowed to use the Software Product on a 
network server or intranet server, or you have purchased license for each node and 
terminal using the Software Product; 

6. You may NOT sublicense, assign or transfer the license agreement; 
7. You may NOT or direct any third party to reverse engineer, decompile or 

disassemble the Software Product; 
8. You may NOT copy or transfer the Software Product or any part of the Software 

Product unless otherwise expressly stated in this agreement; 
9. The license agreement shall be terminated automatically upon you transfer the 

Software Product or copies of all or part of the Software Product to a third party. 

6.2 Intellectual Property Rights Notice: 
The Software Product and all intellectual property rights therein (including but not limited to 
any all copyrights, patents, trademarks, and publicity rights) are owned by Weihong 
Company. The Software Product is protected for Weihong Company on the basis of 
Chinese copyright law and international treaty provisions as well as on the basis of other 
laws and agreements regarding intellectual property. You are not allowed to remove the 
copyright statement made in the Software Product, and guarantee that you shall copy the 
copyright statement in all copies of the Software Product or of any part of the Software 
Product. You are obliged to stop any form of illegal copying of the Software Product and 
accompanying materials. 

Weihong Company can update the Software Product at any time. You can pay real-time 
attention to Weihong Company's official website. 
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6.3 Termination: 
This license may be terminated by Weihong Company at any time once you violate any 
terms or conditions made in this agreement. Once the license is terminated, you are 
obliged to destroy all the copies of the Software Product or return them to Weihong 
Company. 

Now, we affirm that you have already read through this agreement and understood it 
thoroughly and agreed to comply with all of the terms and conditions of this agreement 
strictly. 

Weihong Electronic Technology Co., Ltd. 



Shanghai Weihong Electronic Technology Co., Ltd.

Address: No. 1590, Huhang Rd., Fengxian, Shanghai, China, 201401

Hot-line: 400 882 9188 

Website: www.weihong.com.cn/en
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