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Preface 
Thank you for using the NcStudio Phoenix Stone Machining Center software. 

This manual will introduce details about the NcStudio Phoenix Stone Machining Center in 
aspects such as machine debugging, shape drawing, technique setting, machining 
operations, etc. 

Please read this manual carefully before installing and using this product. 

Our products are constantly being updated to provide better experience to our customers. 
Any document changes will not be informed separately. If you have any problems when 
using the product, or if you have any opinions or suggestions for our products and services, 
please contact us directly. 

Contact Us 

Shanghai Weihong Electronic Technology Co., Ltd. 

Headquarters Address: 1590 Huhang Rd., Fengxian, Shanghai, China 

Post Code: 201401 

Telephone: 400-882-9188 

Fax: 021-33587519 

Email: weihong@weihong.com.cn 

Official website: http://www.weihong.com.cn 

mailto:weihong@weihong.com.cn
http://www.weihong.com.cn/
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1 Safety Precautions 
Please read this manual, including the safety precautions, carefully and take necessary 
safety protection measures before using this product. If you have other requests, please 
contact us. 

1.1 Precautions 
Failure to obey the precautions may cause damage to human body, equipment or other 
properties. 

Equipment running and debugging precautions 

 Before running the equipment, ensure that the parameters are set correctly. 
Otherwise, the equipment may have unintentional movements. 

 The value of the parameters must be within the range allowed by the machine and 
servo drive. If a parameter value is out of the limit, the system may have unstable 
performance or cause equipment damage. 

1.2 Warning, Cautions, and Notes 
Three types of prompts are used in this manual: 

 

Warnings: Hazards or unsafe practices which could result in severe personal injury. 

 

 

Cautions: Hazards or unsafe practices which may result in equipment damage, data loss, 
lowered equipment performance or other unpredicted consequences. 

 

 

Notes: Used to highlight suggestions that need your extra attention and supplementary 
information and notes to the text body. 
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2 About the Product 
2.1 Overview 
The WEIHONG NcStudio Phoenix Stone Machining Center software is mainly used in 
machining of all types of high-class tabletop plates, wash basin plates and cupboard 
plates, engraving of man-made cupboard stones, quartzite tabletop and wash basins, and 
edging, independent drilling, sanding and chamfering for Western-style designs. 

2.2 Functions 
The NcStudio Phoenix Stone Machining Center software mainly supports the following 
functions: 

 Shapes 
o Loading .ncex, .g code, .nc, .dxf, .dwg, .plt, and .eng files. 
o Drawing and editing shapes, and shape gallery. 
o Pre-processing shapes: single-item pre-processing and one-key pre-

processing. 

 Machining techniques 
o 7 types of techniques: Pot hole, Front water, Back water, Outline, Hole 

opener, DrainTrough, and Custom 
o At most 10 grinding steps: You can specify the tool No., machining speed, 

spindle rotational speed, plunging depth, and other parameters for each step. 
o The machining sequence, direction, lead line, deceleration point can be set 

to improve machining accuracy and efficiency. 

 Tool magazine and tools 
o Support single linear tool magazine, dual linear tool magazine, and manual 

tool change. 
o Support tool and wear compensation based on the compensation settings. 
o Support 3 methods for setting the tool offset: direct input, manual setting of 

the Z-axis offset, and tool calibration. 

 Edge finding and centering 
o Support automatic edge finding and centering for rectangular and oval 

shapes. 
o Support manual edge finding and centering for rectangular and oval shapes. 

 Machining methods 
o Support multiple machining methods: machining wizard, machining for 

different layers, array and mirror machining, machining simulation, selective 
machining, and running machining commands. 

o Support machining statistics. 

2.3 Features 
 Easy use 

Simple UI design with integrated CAD, CAM, and CNC functions and shape gallery, 
drawing and parameter setting functions. User-friendly interface. 

 Stable performance 
Advanced speed pre-processing, self-adaptive look-ahead, and track pre-
processing algorithms to make the equipment move more rapid and stable. 

 High control accuracy 
Professional algorithms are used to ensure machining efficiency, accuracy and 
flexibility. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 3 / 97 
 

3 Software Interface 
This chapter will introduce the main interface of the NcStudio Phoenix Stone Machining 
Center software.  

The software interface is shown below. 

 
 
1. File button bar 2. Menu bar 3. Status bar 4. Drawing area 5. Tech Set button 6. Layers 
bar 7. Coordinate area 8. Machine control area 9. Operation button area 10. Port button 
area 11. Machining operation area 12. Information bar 13. Drawing tool bar 

3.1 Status Bar 
Shows the machine status and log. 

The following figure shows an example during emergency stop: 

 
 
The four types of equipment status and descriptions are shown below: 
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Status Description 

Emergency 
stop 

In this status, machining is stopped because events that prevent 
the machine from running normally or may damage the machine or 
operator have occurred. 

Idle In this status, there is no control input. 

Running 
In this status, the machine is running the commands sent from the 
software. 

Paused In this status, the machining is paused. 

 

Click the log area, the log dialog box is displayed, which shows log details. 

 
 
The system shows three types of logs. Their descriptions are shown below. 

Log Description 

: Common 
information 

Shows software actions. 

: Warning 
Suggesting potential errors. The equipment may still work in 
short time. 

: Error 
Suggesting operation errors. Machine needs to be stopped 
and the errors cleared before continuing machining. 
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3.2 Coordinate Area 
Shows the mechanical coordinate system and workpiece coordinate system. 

After executing homing of an axis, the  icon will be shown before the axis. 

 
 

3.3 Machine Control Area 
For manual control of machine movement and movement multiplier. 

 
 
1. Feed mode 2. Multiplier area 3. Current tool number 4. Axis direction buttons 

 Feed mode 
The system supports three feed modes: 
 

Feed 
Mode 

Description 

Jog 
In this mode, the target axis continues to move in the target 
direction until you release the axis direction button. 

Step In this mode, the target axis moves in the target direction by the 
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Feed 
Mode 

Description 

step you selected (0.01/0.1/1) every time you click the axis 

direction button. Custom step: Click  and enter the 
desired step in the box. Default value: 5. Maximum value: 1000 

Handwheel 
(HW) 

In this mode, you control the movement with the handwheel. 

 

 Multiplier/Override control area 
Used to adjust the actual machining speed. 
There are three override slides to control the G00 override, feed override, and 
spindle override. 
Actual feed rate = Feed rate setting * feed override 
Actual spindle rate = Spindle rate setting * spindle override 

You can use the following methods to adjust the override values: 
o Drag the corresponding slider. 
o Click the target value position on the bar. 
o Select the target bar and press the PgUp / PgDn key to increase/decrease 

the value. 
o Select the target bar and press the ↑ / ↓ / ← / → key to increase/decrease 

the value. 

 Axis direction buttons 
Use the following methods to control the axes to move in the positive or negative 
direction: 

o Click an axis direction button to make the axis move at a default speed of 
1800 mm/min. 

o Press down the Rapid button and then click an axis direction button, or press 
and hold the 5 key and click an axis direction button to make the axis move 
at a default speed of 2400 mm/min. 

3.4 Operation Button Area 
Convenient operation buttons for quick access. 

Button Description 

: Unload 
Unload the current loaded program. 

: Go to mechanical 
origin 

Make all axes go to the mechanical origin. For details, 
see Go to Mechanical Origin. 

: Go to workpiece 
origin 

Make all axes go to the workpiece origin. For details, 
see Set Workpiece Origin. 

: Go to the fixed point 

Make all axes go to the fixed point (fixed mechanical 
coordinates). 
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Button Description 

: Handwheel guide 
Enter HW mode. 

: Clear 
Clear all coordinates. 

: MDI 

At most 8 user commands can be entered and 
executed. 

: Simulation 
Enter simulation mode. 

 

3.5 Port Button Area 
Shortcuts for controlling the opening/closing of some I/O ports. 

 
 

If a button is highlighted green, the port is open. Click  to start current 
machining task. 

3.6 Machining Operation Area 
Buttons for starting or stopping machining. 

Button Description 

: Start 

Start the current machining task. If you have drawn path in 
the software, or edited an opened/imported file, the system 
will start machining based on the technique and parameter 
settings. If a file is loaded by clicking Open and Load in the 
menu bar, the system will start machining based on the 
loaded file. 

: Pause 
Makes the machine movement pause. 

: Stop 
Stops the current machining task. 

: Resume 

Resumes machining from the point stopped last time 
(prerequisite: the mechanical coordinates are correct). 
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Save any changes before starting machining. 

 

3.7 Tech Set button 

Click the Tech Set button  to open the Technics Parameter window and set the 
technic type and other parameters. 

For details about technic parameters, see Set Technic Parameters. For details about 
machining sequence, see Set Machining Direction. 

The default technic type is Custom. 

3.8 Layers bar 
Used to select or modify a layer. 

For details, see Layers. 

If there are multiple shapes in the file, you can set them to be on different layers so that 
they can use different machining technics and shapes on the same layer can be machined 
separately. 

 
Only after a layer is selected for a shape, the layer technic parameters can be set. 

 

3.9 Information Bar 
Shows the currently loaded file name and the system time. 

3.10 Drawing Tool Bar 
Supports the following operations: 

 Shape-related functions 

 Setting technic parameters 

 Setting edging finding and centering parameters 

3.11 File Button Bar 
Shows common file-related buttons. 

Button Description 

: New 

Create a new file. After clicking this button, a prompt will be 
displayed, asking if you want to keep the current technic 
parameter settings: If you select Yes, the technic parameter 
settings on all layers will remain. If you select No, the technic 
parameter settings on all layers will be cleared. 

: Import 
.g code, .nc, .dxf, .plt, .dwg files can be imported. 
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Button Description 

: Open 

.ncex files can be opened and loaded in the software. The 
shapes and parameter settings will be loaded in the software 
together. 

: Save 
Click this button to generate an .ncex file on the desktop and 
load it in the software. Note: Machining cannot be started until 
the created, imported, or opened file is saved. 

: Save as 
Click this button to save the opened/imported file as an .ncex file 
and set the file name and storage path. 

: Undo 
Undo the last step. Undo the last step to correct any shape 
drawing errors. 

: Redo Redo the last step to resume the state before undoing. 

: Clear 
Track 

Clear the machining tracks. 

: Catch 
Automatically catches feature points during drawing. For details, 
see Catch. 

: Catch 
Option 

Set the catch parameters. 
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4 Machine Debugging 
After connecting the hardware and installing the software, you need to debug the system. 
The basic debugging flowchart is shown below: 

 
 

 Make Origin and Position Limit Share One Port 

 View and Alter Port Polarity 

 Set Drive Parameters 

 Set and Check Pulse Equivalent 

 Check Axis Direction 

 Set Workbench Travel Limits 

 Manage Tool Magazine 

 
If the password is required during debugging, please contact the manufacturer. 

 

4.1 Make Origin and Position Limit Share One Port 
The origin switch and position limit switch need to share the same port based on the 
machine. 
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This section takes the case of the X-axis mechanical origin and X-axis positive limit 
sharing the same port as an example to introduce related steps: 

Prerequisite: 

The NcStudio Phoenix Stone Machining Center software is closed. 

Follow the steps below to make the two switches share the same port: 

1. Open this path: C:\Program Files\Weihong\NcStudio\NcConfig\Bin. Find and 
double-click NcConfig.exe to open the NcConfig window. 

2. Go to View > Configuration. In the left configuration menu, click Port Mapping to 
open the Port Mapping page: 

 
 

3. On the Port Mapping screen, find the Phoenix.G.Home.CoarseOn and 
Phoenix.G.Limit.PLimitOn logical ports. Double-click their physical ports to show 
the selection box: 

 
 

4. Click the Controller or Port drop-down menu and select corresponding options to 
make the physical ports of Phoenix.G.Home.CoarseOn and 
Phoenix.G.Limit.PLimitOn consistent. 
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5. Click  to save the setting. 
6. To check the setting result: Open NcStudio. Go to Operation > Port to check the 

port list. In the figure below, the X-axis origin and X-axis positive limit share the 
same port: 

 
 

4.2 View and Alter Port Polarity 
After the software is started normally, modify the port polarity based on the detection 
switch and limit switch type: 

 Set the port polarity of normally closed switches to NC. 

 Set the port polarity of normally open switches to NO. 
The mapping between the port state and icons are shown below: 

 Input port:  No signal detected;  Signal detected 

 Output port:  No signal detected;  Signal detected 
Follow the steps below to view and alter the port polarity: 

1. In the menu bar, go to Operation > Port. 

 
 

2. In the Port dialog box, select the target port and click the Convert button to set its 
polarity to NC/NO. 

3. After the polarity of a port is modified, you can use the following functions based on 
your requirements: 

o To test if a port has output signals, click Test On/Test Off. Port icon  or  
indicates that the port is under test. 
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o To cancel a port test, click Cancel Test. 
o To cancel all port tests, click Cancel All. 
o To set sampling interval, click Filter. In the Sampling Setting dialog box, 

drag the Interval slider. If the box before Filter is ticked, the system will rule 
out signals whose duration is shorter than the interval. 

4.3 Set Drive Parameters 
Basic drive parameters need to be set by referring to the user manual for that drive brand. 

If you choose to use a drive brand other than those mentioned in this section, 
please note that: 

 Check the servo drive SON signal type and ensure that it is active low (ON when 
connected to GND of a 24V power supply). 

 Check the electrical level of the X/Y/Z-axis servo alarm output ports when there is 
no alarm: 

o Low level when there is no alarm: Set their polarity to NC (in the menu bar, 
go to Operation > Port). 

o Low level when there is alarm: Set their polarity to NO. 
For details about altering the port polarity, see View and Alter Port Polarity. 

 Ensure that the servo drive is set to receive pulses + direction signals. 

 Check to see if there is external emergency stop signal input among the servo drive 
input ports and check the input signal logic. 

 The drive requires a 24V power, which flows to it via the terminal board. Before 
drive trial-run, connect the terminal board to a 24V power supply. 
If the drive does not work, check to see if the drive parameter CW/CCW Input 
Inhibition is set to No. 

WEIHONG tested the following drive parameters in position loop control mode. The test 
results are as follows: 

 WISE series drive 

 Yaskawa Σ-Ⅱ Series Drive 

 Yaskawa Σ-Ⅴ/Σ-7 Series Drive` 

 Panasonic MINAS A4 Series Drive 

 Panasonic MINAS A5 Series Drive 

 Fuji FALDIC-β Series Drive 

 Fuji ALPHA 5 Series Drive 

 Delta ASDA-A Series Drive 

 Delta ASDA-A2 Series Drive 

 Delta ASDA-B Series Drive 

 Delta ASDA-B2 Series Drive 

4.3.1 WISE Series Drive 
Pr001 Control mode selection 

1: Position loop control mode 

2: Speed loop control mode 

Value: 1 

Pr528 LED initial state 

Used to monitor if the number of pulses sent and received are correct. 
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In a WEIHONG control system, pulse monitor can be used to check if the communication 
card has sent pulses correctly and determine if there is electrical interference. 

Value: 6 

Pr008 Number of command pulses per turn 

If Pr008 is set to 0, Pr009 and Pr010 are effective. 

If Pr008 value is not 0, Pr008 = screw pitch/(pulse equivalent × mechanical reduction 
ratio) 

Value: 0 

Pr009 1st command division and multiplication numeratorPr010 command division 
and multiplication denominator 

Range: 0–230 

Typical value: When screw pitch = 5 mm, encoder resolution = 10000, axis coupling joint is 

used, and pulse equivalent = 0.001 mm: Pr009＝10000, Pr010＝Screw pitch/pulse 

equivalent＝5 mm/0.001 mm = 5000, which means that Pr009/Pr010=10000/5000=2/1。 

Value: manual calculation 

Pr011 Number of pulse output by one motor turn 

Typical value: When pulse equivalent = 0.001, there is no reducer, and screw pitch = 10 
mm: Pr011=2500; when screw pitch = 5 mm: Pr011=1250. 

Value: 2500 (by default) 

Pr100 1st position loop gain 

Unit: 0.1/s 

Value: 480 (by default). May need adjustment based on machine condition. 

Pr101 1st velocity loop gain 

Unit: 0.1Hz 

Value: 270 (by default). May need adjustment based on machine condition. 

Pr102 1st velocity loop integral time constant 

Unit: 0.1ms 

Value: 210 (by default). May need adjustment based on machine condition. 

Relation between Pr008, Pr009, and Pr010 values 

Pr008 Pr009 Pr010 Description 

1–220 Invalid Invalid 

Pr009 and Pr010 values are not valid. System 
processing is based on the Pr008 value. 
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Pr008 Pr009 Pr010 Description 

0 0 1–230 
 

If Pr008 and Pr009 are 0, system processing is based 
on the Pr010 value. 

0 1–230 1–230 
 

If Pr008 is 0 but Pr009 is not 0, system processing is 
based on the Pr009 and Pr010 values. 

 

4.3.2 Yaskawa Σ-Ⅱ Series Drive 

Fn010 Password setting (preventing random parameter modification) 

If Fn010 is set to 0000, modification of user parameters (PnXXX) and some auxiliary 
function parameters (FnXXX) is allowed. 

If Fn010 is set to 0001, modification of user parameters (PnXXX) and some auxiliary 
function parameters (FnXXX) is not allowed. 

Value: 0000 

Un00C Input command pulse counter 

Used to monitor if the number of pulses sent and received are correct. 

In a WEIHONG control system, pulse monitor can be used to check if the communication 
card has sent pulses correctly and determine if there is electrical interference. 

Value: In hexadecimal, low-order (L) 4 digits 

Pn000 Rotation direction and control mode selection 

Digit 0: If digit 0 is set to 0, the motor rotates CW (anti-clockwise when observing from the 
load/lead screw side). If digit 0 is set to 1, the motor rotates CCW. 

Digit 1: If digit 1 is set to 1, the control mode is position control. Always calculates pulse 
commands. 

Value: 0010 

Pn200 Pulse command format selection 

Digit 0: If digit 0 is set to 5, the command is pulse + direction, negative logic. 

Digit 3: If digit 3 is set to 0, the differential signal goes into the filter. 

Value: 0005 

Pn50A Function selection 

Digit 1: If digit 1 is set to 0, the /S-ON signal is enabled and its input pin is No.40. If digit 1 
is set to 7, the /S-ON signal is always ON. 
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Digit 3: If digit 3 is set to 8, the CW input inhibition signal P-OT will not be used. 

Value: 8100 

Pn50B Function selection 

Digit 0: If digit 0 is set to 8, the CCW input inhibition signal N-OT will not be used. 

Value: 6548 

Pn50F Function selection 

Applicable when the servo motor has a brake. 

Digit 2: If digit 2 is set to 3, CN1-29 and 30 output brake interlocking signal/BK to control 
the 24V relay for brake. 

Value: 0300 

Pn50E Function selection 

Applicable when the servo motor has a brake. 

None of the four digits can be set to 3 in case that CN1-29 and CN1-30 are used for other 
functions, causing braking failure. 

Value: 0211 

Pn506 Brake delay when servo motor is off 

Unit: 10ms 

Applicable when the servo motor has a brake. 

Value: Subject to actual situation. 

Pn201 PG division ratio setting 

Range: 16–214 

Typical value: When pulse equivalent = 0.001, there is no reducer, and screw pitch = 10 
mm, Pn201 = 2500; when screw pitch = 5 mm, Pn201 = 1250 

Value: Based on the PG division ratio (WEIHONG systems) 

Pn202 Electronic gear ratio numerator, Pn203 Electronic gear ratio denominator 

Equation: 

Pn202 = Pulse number per encoder turn × 4 × Mechanical deceleration rate 

Pn203 = Screw pitch/ Pulse equivalent 
 

Typical value: When screw pitch = 5 mm, the encoder is 17 digits, axis coupling joint is 

used, pulse equivalent = 0.001 mm: Pn202＝16384 and Pn203＝625 When screw pitch = 

5 mm, the encoder is 17 digits, axis coupling joint is used, pulse equivalent = 0.0005 mm: 

Pn202＝8192 and Pn203＝625 

Value: Manual calculation 

4.3.3 Yaskawa Σ-Ⅴ/Σ-7 Series Drive 

Fn010 Parameter input inhibition setting 

If Fn010 is set to 0000, modification of user parameters (PnXXX) and some auxiliary 
function parameters (FnXXX) is allowed. 
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If Fn010 is set to 0001, modification of user parameters (PnXXX) and some auxiliary 
function parameters (FnXXX) is not allowed. 

Value: 0000 

Pn000 Function selection basic switch 0 

Digit 0: If digit 0 is set to 0, the motor rotates CW after receiving CW commands. 

Digit 1: If digit 1 is set to 1, the control mode is position control (pulse sequence 
commands). 

Value: 0010 

Pn200 Position control command format selection switch 

Digit 0: If digit 0 is set to 5, the command format is pulse + direction, negative logic. 

Value: 0005 

Pn50A Input signal selection 1 

Digit 1: If digit 1 is set to 0, /S-ON signal is enabled and its input pin is No.40. If digit 1 is 
set to 7, the servo drive is always ON. 

Digit 3: If digit 3 is set to 8, the CW input inhibition signal P-OT will not be used. 

Value: 8100 

Pn50B Input signal selection 2 

Digit 0: If digit 0 is set to 8, the CCW input inhibition signal N-OT will not be used. 

Value: 6548 

Pn50F Output signal selection 2 

Applicable when the servo motor has a brake. 

Digit 2: If digit 2 is set to 3, CN1-29 and 30 output brake interlocking signal/BK to control 
the 24V relay for brake. 

Value: 0300 

Pn50E Output signal selection 1 

Applicable when the servo motor has a brake. 

None of the four digits can be set to 3 in case that CN1-29 and CN1-30 are used for other 
functions, causing braking failure. 

Value: 0211 

Pn506 Brake command: Servo OFF delay 

Applicable when the servo motor has a brake. 

Unit: ms 

Value: Subject to actual situation. 

Pn20E Electronic gear ratio numerator, Pn210 Electronic gear ratio denominator 

Equation: Pn20E/Pn210 = (Encoder resolution × pulse equivalent × mechanical 
reduction ratio)/screw pitch 

Value: Manual calculation 
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Pn212 Encoder allocated pulse number 

Range: 16–230 

Typical value: When pulse equivalent = 0.001, there is no reducer, and screw pitch = 10 
mm, Pn212 = 2500; when screw pitch = 5 mm, Pn212 = 1250 

Value: Based on the PG division ratio (WEIHONG systems) 

4.3.4 Panasonic MINAS A4 Series Drive 
Pr01 LED initial state 

Used to monitor if the number of pulses sent and received are correct. 

In a WEIHONG control system, pulse monitor can be used to check if the communication 
card has sent pulses correctly and determine if there is electrical interference. 

Value: 12 

Pr02 Control mode selection 

0: Position control 

1: Speed control 

2: Torque control 

Value: 0 

Pr40 Command pulse input selection 

1: Input via dedicated differential circuit. 

Value: 1 

Pr42 Command pulse input format selection 

3: The command pulse input format is pulse + direction, negative logic 

Value: 3 

Pr44 Feedback pulse division and multiplication numerator 

Range: 1–32767 

Typical value: When pulse equivalent = 0.001, there is no reducer, and screw pitch = 10 
mm, Pr44 = 2500; when screw pitch = 5 mm, Pr44 = 1250 

Value: Based on the PG division ratio (WEIHONG systems) 

Pr48 Command pulse division and multiplication 1st numerator, Pr4B Command 
pulse division and multiplication denominator 

Range: 1–10000 

Typical value: When screw pitch = 5 mm, the encoder resolution is 10000, axis coupling 

joint is used, and pulse equivalent = 0.001 mm: Pr48= 10000, Pr4B＝ screw pitch/pulse 

equivalent = 5/0.001=5000. Pr48/Pr4B=10000/5000=2/1. 

Value: Manual calculation 

4.3.5 Panasonic MINAS A5 Series Drive 
Pr5.28 LED initial state 

Used to monitor if the number of pulses sent and received are correct. 
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In a WEIHONG control system, pulse monitor can be used to check if the communication 
card has sent pulses correctly and determine if there is electrical interference. 

Value: 6 

Pr0.01 Control mode setting 

0: Position control 

1: Speed control 

2: Torque control 

Value: 0 

Pr0.05 Command pulse input selection 

0: Opto-electronic coupler input (PULS1, PULS2, SIGN1, SIGN2) 

1: Dedicated line drive input (PULSH1, PULSH2, SIGNH1, SIGNH2) 

Value: 1 (in common cases) 

Pr0.07 Command pulse input format selection 

3: The command pulse input format is pulse + direction, negative logic 

Value: 3 

Pr0.08 Number of command pulses per turn 

If Pr0.08 is set to 0, Pr0.09 and Pr0.10 are valid. 

If Pr0.08 is not 0, Pr0.08 = screw pitch/(pulse equivalent × mechanical reduction ratio) 

Value: 0 

Pr0.09 1st command division and multiplication numerator, Pr0.10 Command pulse 
division and multiplication denominator 

Range: 0–230 

Typical value: When screw pitch = 5 mm, the encoder resolution is 10000, axis coupling 

joint is used, and pulse equivalent = 0.001 mm: Pr0.09＝10000 and Pr0.10＝screw 

pitch/pulse equivalent=5/0.001＝5000. Pr0.09/Pr0.10=10000/5000=2/1. 

Value: Manual calculation 

Pr0.11 Number of pulse output by one motor turn 

Range: 1–262144 

Typical value: When pulse equivalent = 0.001, there is no reducer, and screw pitch = 10 
mm, Pr0.11 = 2500; when screw pitch = 5 mm, Pr0.11 = 1250 

Value: Based on the PG division ratio (WEIHONG systems) 

Relation between Pr0.08, Pr0.09, and Pr0.10 values 

 

Pr0.08 Pr0.09 Pr0.10 Description 
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Pr0.08 Pr0.09 Pr0.10 Description 

1–220 Invalid Invalid 

 

Pr0.09 and Pr0.10 values are not valid. System 
processing is based on the Pr0.08 value. 

0 0 1–230 

 

If Pr0.08 and Pr0.09 are 0, system processing is based 
on the Pr0.10 value. 

0 1–230 1–230 

 

If Pr0.08 is 0 but Pr0.09 is not 0, system processing is 
based on the Pr0.09 and Pr0.10 values. 

 

4.3.6 Fuji FALDIC-β Series Drive 
01 Command pulse numerator α, 02 Command pulse denominator β 

Stand for electronic gear ratio numerator and denominator. 

Range: 1–32767 

Equation: α/β = (encoder resolution × pulse equivalent × mechanical reduction 
ratio)/screw pitch 

Typical value: When encoder resolution = 65536, pulse equivalent = 0.001, screw pitch = 5 
mm, and mechanical reduction ratio = 1: α/β=65536×0.001/5=8192/625, which means 
α=8192 and β=625. 

Value: Manual calculation 

03 Pulse train input format 

0: The pulse train input format is pulse + direction (symbol). 

Value: 0 

04 Rotation direction 

0: Rotates CW (anti-clockwise when observing from the load side) 

1: Rotates CCW (clockwise when observing from the load side) 

Value: 0 or 1 
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10 CONT1 signal distribution 

1: CONT1 is distributed to RUN (SON). If CONT1 is not distributed, it becomes ON if there 
is no alarm after power-on. 

Value: 1 

11 CONT2 signal distribution 

2: CONT2 is distributed to RST (CLR: servo alarm clearing). Parameter 12, 13, and 14 are 
0, which means that CONT3, CONT4, and CONT5 cannot be distributed to OT (overtravel) 
or EMG (external emergency stop). 

Value: 2 

15 OUT1 signal distribution 

1: OUT1 is distributed to alarm output contact a, which is normally open. 

2: OUT1 is distributed to alarm output contact b, which is normally closed. 

Value: 1 

27 Parameter modification inhibition 

0: Drive parameter values can be modified. 

1: Drive parameter values cannot be modified. 

Value: 0 or 1 

74 CONT 1 constant validity 1 

1: Valid upon servo motor start (RUN). 

Value: 1 

4.3.7 Fuji ALPHA 5 Series Drive 
PA1_01 Control mode selection 

0: Position control 

1: Speed control 

Value: 0 

PA1_06 Electronic gear ratio numerator 0, PA1_07 Electronic gear ratio denominator 

Range: 1–32767 

Equation: PA1_06/PA1_07 =(Encoder resolution × pulse equivalent × mechanical 
reduction ratio)/screw pitch 

Typical value: When encoder resolution = 65536, pulse equivalent = 0.001, screw pitch = 5 
mm, and mechanical reduction ratio = 1: PA1_06/PA1_07 =65536×0.001/5=8192/625. 
Therefore, PA1_06 = 8192 and PA1_07 = 625. 

Value: Manual calculation 

PA1_03 Command pulse format 

0: The pulse train input format is pulse + direction (symbol). 

Value: 0 

PA1_04 Rotation direction 
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0: Rotates CW (anti-clockwise when observing from the load side) 

1: Rotates CCW (clockwise when observing from the load side) 

Value: 0 or 1 

PA3_01 CONT1 signal distribution 

1: CONT1 is distributed to RUN (SON). If CONT1 is not distributed, it becomes ON if there 
is no alarm after power-on. 

Value: 1 

PA3_02 CONT2 signal distribution 

2: CONT2 is distributed to RST (CLR: servo alarm clearing). Parameter 12, 13, and 14 are 
0, which means that CONT3, CONT4, and CONT5 cannot be distributed to OT (overtravel) 
or EMG (external emergency stop). 

Value: 2 

PA3_51 OUT1 signal distribution 

1: OUT1 is distributed to alarm output contact a, which is normally open. 

2: OUT1 is distributed to alarm output contact b, which is normally closed. 

Value: 1 

PA3_26 CONT 1 constant validity 1 

1: Valid upon servo motor start (RUN). 

Value: 1 

PA1_08 Number of pulse output by one motor turn 

Range: 16–214 

Typical value: When pulse equivalent = 0.001, there is no reducer, and screw pitch = 10 
mm, PA1_08 = 2500; when screw pitch = 5 mm, PA1_08 = 1250 

Value: Based on the PG division ratio (WEIHONG systems) 

4.3.8 Delta ASDA-A Series Drive 
P0-02 Drive status display 

Used to monitor if the number of pulses sent and received are correct. 

In a WEIHONG control system, pulse monitor can be used to check if the communication 
card has sent pulses correctly and determine if there is electrical interference. 

Value: 02 

P1-00 External pulse input format 

Format: ZYX 

X=2: The external pulse input format is pulse + direction 

Z=1: negative logic 

Value: 102 

P1-01 Control mode setting 

Format: ZYX1X0 
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Z=0: DIO value does not change when the control mode is switched. Control mode was 
not switched; therefore, Z=0. 

Y=0: Rotates CW (anti-clockwise when observing from the load side). Y=1: Rotates CCW. 

X1X0=00: The control mode is position control. 

Value: 0000 

P1-32 Motor stopping mode 

Format: YX 

Y=0: When the servo motor is disabled, dynamic braking is used. Y=1: When the servo 
motor is disabled, the motor moves freely. 

X=0: The motor is stopped instantly. X=1: The motor decelerates before stops completely. 

Value: 00 

P1-44 Electronic gear ratio numerator N1, P1-45 Electronic gear ratio denominator M 

Range: 1–32767 

Equation: N1/M =(Encoder pulse number × 4 × pulse equivalent × mechanical 
reduction ratio)/screw pitch. 

Typical value: When the encoder pulse number = 2500, pulse equivalent = 0.001, screw 
pitch = 5 mm, and mechanical reduction ratio = 1, N1/M=2500×4×0.001/5=2/1. Therefore, 
N1=2 and M=1. 

Multi-segment electronic gear ratio was not used. Therefore, there was no need to set P2-
60–P2-62. 

Value: Manual calculation 

P2-10 Digital input pin DI1 function setting 

Format: X2X1X0 

X1X0=01: Set digital input DI1 to SON, matching pin No.9 of CN1. 

X2=1: Set input DI1 to the normally open contact a. 

Value: 101 

P2-15 Digital input pin DI6 function setting, P2-16 Digital input pin DI7 function 
setting 

DI6 are DI7 are NC position limit signal input by default. The drive cannot work before the 
CN1 pin No.32 and pin No.31 are connected. 

Format: P2-15=P2-16=X2X1X0 

X2=1: Set DI6 and DI7 input to the NO contact a. 

X1X0=00: Drive position limit input was not used. 

Value: P2-15=P2-16=100 

P2-17 Digital input pin DI8 function setting 

Format: X2X1X0 

X2X1X0=100: External EMG (emergency stop input) was not used. 
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Value: 100 

P2-21 Digital output pin DO4 function setting 

DO4 pins are pin No.1 and No.26, which are used for Z-axis clamping position braking 
signals. 

Format: X2X1X0 

X2=1: Set DO4 output to the NO contact a. X2=1: Set DO4 output to the NC contact b. 

X1X0=08: Set pin No.1 and No.26 to BK+ and BK- respectively. 

Value: 108 

P2-22 Digital output pin DO5 function setting 

DO5 pins are pin No.28 and No.27, which are used for servo alarm signals. 

Format: X2X1X0 

X2=0: Set DO5 output to the NC contact b. 

X1X0=07: Set pin No.28 and No.27 to ALRM+ and ALRM- respectively. 

Value: 007 

P2-51 Servo enablement SON setting 

0: Servo motor enablement must be triggered by digital signals. 

1: Servo motor is automatically enabled after powered on if there is no alarm. 

Value: 0 (1 when SON signal cables are unavailable) 

4.3.9 Delta ASDA-A2 Series Drive 
P0-02 Drive status display 

Used to monitor if the number of pulses sent and received are correct. 

In a WEIHONG control system, pulse monitor can be used to check if the communication 
card has sent pulses correctly and determine if there is electrical interference. 

Value: 02 

P1-00 External pulse input format 

Format: ZYX 

X=2: The external pulse input format is pulse + direction 

Z=1: negative logic 

Value: 102 

P1-01 Control mode setting 

Format: ZYX1X0 

Z=0: DIO value does not change when the control mode is switched. Control mode was 
not switched; therefore, Z=0. 

Y=0: Rotates CW (anti-clockwise when observing from the load side). Y=1: Rotates CCW. 

X1X0=00: The control mode is position control. 

Value: 0000 
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P1-44 Electronic gear ratio numerator N1, P1-45 Electronic gear ratio denominator M 

Range: 1–32767 

Equation: P1-44/P1-45 = (Encoder resolution × pulse equivalent × mechanical 
reduction ratio)/screw pitch. 

Typical value: When the encoder pulse number = 2500, pulse equivalent = 0.001, screw 
pitch = 5 mm, and mechanical reduction ratio = 1, N1/M=2500×4×0.001/5=2/1. Therefore, 
N1=2 and M=1. Multi-segment electronic gear ratio was not used. Therefore, there was no 
need to set P2-60–P2-62. 

Value: Manual calculation 

P1-46 Detector pulse output number setting 

Setting of the revolving single-direction pulse number. 

Range: 20–320000 

Typical value: When pulse equivalent = 0.001, there is no reducer, and screw pitch = 10 
mm, P1-46 = 10000; when screw pitch = 5 mm, P1-46 = 5000 

Value: Based on the PG division ratio (WEIHONG systems) 

P2-10 Digital input pin DI1 function setting 

Format: X2X1X0 

X1X0=01: Set digital input DI1 to SON, matching pin No.9 of CN1. 

X2=1: Set input DI1 to the normally open contact a. 

Value: 101 

P2-15 Digital input pin DI6 function setting 

DI6 are DI7 are NC position limit signal input by default. The drive cannot work before the 
CN1 pin No.32 and pin No.31 are connected. 

Format: X2X1X0 

X2=1: Set DI6 and DI7 input to the NO contact a. 

X1X0=00: Drive position limit input was not used. 

Value: 100 

P2-16 Digital input pin DI7 function setting 

Format: X2X1X0 

Value: 100 

P2-17 Digital input pin DI8 function setting 

Format: X2X1X0 

X2X1X0=100: External EMG (emergency stop input) was not used. 

Value: 100 

P2-21 Digital output pin DO4 function setting 

DO4 pins are pin No.1 and No.26, which are used for Z-axis clamping position braking 
signals. 
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Format: X2X1X0 

X2=1: Set DO4 output to the NO contact a. X2=1: Set DO4 output to the NC contact b. 

X1X0=08: Set pin No.1 and No.26 to BK+ and BK- respectively. 

Value: 108 

P2-22 Digital output pin DO5 function setting 

DO5 pins are pin No.28 and No.27, which are used for servo alarm signals. 

Format: X2X1X0 

X2=0: Set DO5 output to the NC contact b. 

X1X0=07: Set pin No.28 and No.27 to ALRM+ and ALRM- respectively. 

Value: 007 

4.3.10 Delta ASDA-B Series Drive 
P0-02 Drive status display 

Used to monitor if the number of pulses sent and received are correct. 

In a WEIHONG control system, pulse monitor can be used to check if the communication 
card has sent pulses correctly and determine if there is electrical interference. 

Value: 02 

P1-00 External pulse train input format 

Format: ZYX 

X=2: The external pulse input format is pulse + direction 

Z=1: negative logic 

Value: 102 

P1-01 Control mode setting 

Format: YX1X0 

Y=0: Rotates CW (anti-clockwise when observing from the load side). Y=1: Rotates CCW. 

X1X0=00: The control mode is position control. 

Value: 000 

P1-32 Motor stopping mode 

Format: YX 

Y=0: When the servo motor is disabled, dynamic braking is used. Y=1: When the servo 
motor is disabled, the motor moves freely. 

X=0: The motor is stopped instantly. X=1: The motor decelerates before stops completely. 

Value: 00 

P1-44 Electronic gear ratio numerator N1, P1-45 Electronic gear ratio denominator M 

Range: 1–32767 

Equation: P1-44/P1-45 = (Encoder resolution × pulse equivalent × mechanical 
reduction ratio)/screw pitch. 
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Typical value: When the encoder pulse number = 2500, pulse equivalent = 0.001, screw 
pitch = 5 mm, and mechanical reduction ratio = 1, N1/M=2500×4×0.001/5=2/1. Therefore, 
N1=2 and M=1. 

Multi-segment electronic gear ratio was not used. Therefore, there was no need to set P2-
60–P2-62. 

Value: Manual calculation 

P2-10 Digital input pin DI1 function setting 

Format: X2X1X0X1X0=01: Set digital input DI1 to SON, matching pin No.17 of CN1.X2=1: 
Set input DI1 to the normally open contact a. 

Value: 101 

P2-15 Digital input pin DI6 function setting 

DI6 is NC position limit signal input by default. The drive cannot work before the CN1 pin 
No.32 and pin No.31 are connected. 

Format: X2X1X0 

X2=1: Set input DI6 to the normally open contact a. 

X1X0=00: Drive position limit input was not used. 

Value: 100 

P2-18 Digital output pin DO1 function setting 

DO1 pin is pin No.16, which is used for Z-axis clamping position braking signals. 

Format: X2X1X0 

X2=1: Set DO1 output to the NO contact a. X2=1: Set DO4 output to the NC contact b. 

X1X0=08: Set pin No.16 to BK+. 

Value: 108 

P2-20 Digital output pin DO3 function setting 

DO3 pin is pin No.1, which is used for servo alarm signals. 

Format: 2X1X0 

X2=0: Set DO3 output to the NC contact b. 

X1X0=07: Set pin No.1 to ALRM+. 

Value: 007 

4.3.11 Delta ASDA-B2 Series Drive 
P0-02 Drive status display 

Used to monitor if the number of pulses sent and received are correct. 

In a WEIHONG control system, pulse monitor can be used to check if the communication 
card has sent pulses correctly and determine if there is electrical interference. 

Value: 02 

P1-00 External pulse train input format 

Format: ZYX 
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X=2: The external pulse input format is pulse + direction 

Z=1: negative logic 

Value: 102 

P1-01 Control mode setting 

Format: ZYX1X0 

Z=0: DIO value does not change when the control mode is switched. Control mode was 
not switched; therefore, Z=0. 

Y=0: Rotates CW (anti-clockwise when observing from the load side). Y=1: Rotates CCW. 

X1X0=00: The control mode is position control. 

Value: 0000 

P1-44 Electronic gear ratio numerator N1, P1-45 Electronic gear ratio denominator M 

Range: 1–32767 

Equation: P1-44/P1-45 = (Encoder resolution × pulse equivalent × mechanical 
reduction ratio)/screw pitch. 

Typical value: When the encoder pulse number = 2500, pulse equivalent = 0.001, screw 
pitch = 5 mm, and mechanical reduction ratio = 1, N1/M=2500×4×0.001/5=2/1. Therefore, 
N1=2 and M=1. 

Multi-segment electronic gear ratio was not used. Therefore, there was no need to set P2-
60–P2-62. 

Value: Manual calculation 

P1-46 Detector pulse output number setting 

Setting of the revolving single-direction pulse number. 

Range: 20–40000 

Typical value: When pulse equivalent = 0.001, there is no reducer, and screw pitch = 10 
mm, P1-46 = 10000; when screw pitch = 5 mm, P1-46 = 5000 

Value: Based on the PG division ratio (WEIHONG systems) 

P2-10 Digital input pin DI1 function setting 

Format: X2X1X0 

X1X0=01: Set digital input DI1 to SON, matching pin No.9 of CN1. 

X2=1: Set input DI1 to the normally open contact a. 

Value: 101 

P2-15 Digital input pin DI6 function setting 

DI6 are DI7 are NC position limit signal input by default. The drive cannot work before the 
CN1 pin No.32 and pin No.31 are connected. 

Format: X2X1X0 

X2=0: Set DI6 and DI7 input to the NC contact b. 

X1X0=00: Drive position limit input was not used. 
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Value: 000 

P2-16 Digital input pin DI7 function setting 

Format: X2X1X0 

Value: 000 

P2-17 Digital input pin DI8 function setting 

Format: X2X1X0 

X2X1X0=000: External EMG (emergency stop input) was not used. 

Value: 000 

P2-18 Digital output pin DO1 function setting 

DO1 pins are pin No.6 and No.7, which are used for Z-axis clamping position braking 
signals. 

Format: X2X1X0 

X2=1: Set DO1 output to the NO contact a. X2=1: Set DO4 output to the NC contact b. 

X1X0=08: Set pin No.6 and No.7 to BK- and BK+ respectively. 

Value: 108 

P2-22 Digital output pin DO5 function setting 

DO5 pins are pin No.28 and No.27, which are used for servo alarm signals. 

Format: X2X1X0 

X2=0: Set DO5 output to the NC contact b. 

X1X0=07: Set pin No.28 and No.27 to ALRM+ and ALRM- respectively. 

Value: 007 

4.4 Set and Check Pulse Equivalent 
Pulse equivalent is the linear distance that the lead screw travels or the angle that the 
rotary axis rotates when one pulse from the system is received. It is the minimum 
movement unit that the system can control. The smaller the pulse equivalent, the better 
the machining accuracy. The bigger the pulse equivalent, the larger the machine maximum 
feed rate. 

This section introduces the steps for setting and checking pulse equivalent. 

Related Information 

Concepts related to pulse equivalent are shown below: 

 Electronic gear ratio Determines whether the servo motor amplifies or reduces the 
pulse frequency received from the upper computer. Electronic gear ratio larger than 
1 indicates amplification while that smaller than 1 indicates attenuation. 

 Screw pitch: The distance traveled per motor turn. 

 Mechanical reduction ratio: Mechanical reduction ratio = Speed reducer input 
rotation speed / Speed reducer output rotation speed or Teeth number of 
driven wheel / Teeth number of driving wheel or Motor axis rotation speed / 
lead screw rotation speed. 
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 Encoder resolution: The number of pulses required to make the servo motor 
rotate by one turn. Check the servo motor nameplate or drive user manual to find 
the encoder resolution. 

 Stepping angle: The angle that the motor rotates per step pulse. 

 Subdivision: The ratio of the motor real stepping angle to the fixed stepping angle 
(whole step). 

Equation for calculating the pulse equivalent varies based on the motor type: 

 Stepping motor 
o Linear axis 

Pulse Equivalent = Screw Pitch / (360 / Stepping Angle * Subdivision * Mechanical Decelerat
ion Ratio) 

o Rotary axis 
Pulse Equivalent = 360 / (360/Stepping Angle * Subdivision * Mechanical Deceleration Ratio) 

Follow the steps below the set pulse equivalent: 

1. In the menu bar, go to System > Global Parameters. 

 
 

2. In the Param window, click the Operator drop-down menu in the lower left corner 
and select Manufacturer. 

3. In the parameters list, find the pulse equivalent related parameters (electronic gear 
ratio numerator, screw pitch, mechanical reduction ratio, etc.). Double-click a 
parameter to open the entry dialog box: 
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4. Enter values in the dialog box and click OK. 
After setting the parameters related to pulse equivalent, you need to check to see if they 
are set correctly. 

Follow the steps below to check to see if the pulse equivalent is correct: 

1. Use the handwheel or manually move an axis to any point and set the point to be 
the workpiece origin. 
For details, see Set Workpiece Origin. 

2. Control the axis to travel a certain distance. 
For details, see the feed method description in section Machine Control Area. 

3. Use a vernier caliper to measure if the actual distance and the distance shown by 
the coordinate system are consistent. 

o Yes: The pulse equivalent is correct. 
o No: The pulse equivalent is wrong. You need to adjust the parameter 

settings. 

4.5 Check Axis Direction 
Determine the positive direction for each axis with the right hand rule. The purpose is to 
avoid machine damage caused by axis moving in the wrong direction. 

Operations for checking each axis direction are similar and this section takes those for the 
X axis as an example. 

Follow the steps below to check the X axis direction: 

1. Determine the X-axis positive direction based on the right hand rule. 
2. In the software, click the X+/X- button in the machine control area to control the 

spindle to travel a certain distance. 
3. Check to see if the axis movement direction is consistent with that determined by 

the right hand rule. 
o Yes: The axis direction setting is correct. 
o No: In the menu bar, go to System > Global Parameters. Set the parameter 

Axis Direction(X) to the opposite of the current value. 
 1: Positive direction 
 -1: Negative direction 

Default value: 1 

4.6 Set Workbench Travel Limits 
After checking the axis movement direction and setting the mechanical origin, you need to 
set the axis travel limits based on the machine size to achieve soft limit functions. 
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Follow the steps below to set the workbench travel limits: 

1. In the menu bar, go to System > Global parameters. 

 
 

2. In the Param window, click the Operator drop-down menu in the lower left corner 
and select Manufacturer. 

3. Find the upper limit of worktable stroke, lower limit of worktable stroke, check 
worktable stroke parameters for each axis. 
Descriptions of the parameters are shown below: 

Parameter Description Allowed 
Range 

Default 
Value 

Check 
worktable 
stroke 

Indicates whether to enable the 
workbench stroke soft limits. 

Yes or 
No 

Yes 

Upper limit 
of 
worktable 
stroke 

When the parameter Check worktable 
stroke is set to Yes, this parameter 
indicates the mechanical coordinate of 
the stroke upper limit. 

[0, 
99999] 

400 

Lower limit 
of 
worktable 
stroke 

When the parameter Check worktable 
stroke is set to Yes, this parameter 
indicates the mechanical coordinate of 
the stroke lower limit. 

[-99999, 
0] 

400 

 
4. Double-click the target parameter and enter a value in the field. Click OK. 
5. After settings are finished, restart the software to make the settings take effect. 
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4.7 Manage Tool Magazine 
The system supports linear tool magazine and manual tool changing. 

Follow the steps below to manage the tool magazine: 

1. In the menu bar, go to Operation > Tool magazine. 

 
 

2. In the Tool magazine dialog box, click the Linear type drop-down menu and select 
one from the following options: 

o ManualTool 
Selected by default. 

o ParallelX 
Single linear tool magazine. 

o ParallelY 
Includes single-line linear tool magazine and dual-line linear tool magazine. 
The system automatically selects the single-line linear tool magazine or dual-
line linear tool magazine based on the number of tools on the left and right 
sides of the parallel Y axes. 

3. Enter values for the parameters in the Basic setting area. 
Fixed Point Position (when the linear type is set to ManualTool) 
Manually change the tool after the spindle moves to a fixed point. 
Current Tool No. 
Modifying this value will change the current tool o. and use corresponding tool offset. 
If this value is modified, the machine does not change the tool. 
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5 Machining Process 
The suggested machining process is shown below: 
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6 Shape-Related Functions 
This chapter introduces how to import machining files and how to use the shape-related 
functions in the following aspects: 

 Load Machining Files 

 Draw Shapes 

 Edit Shapes 

 Shape Editing Assistance 

 Pre-processing 

6.1 Load Machining Files 
The system supports .ncex, .g code, .nc, .dxf, .dwg, .plt, and .eng files. 

Machining files can be loaded in different ways. Their differences are shown below: 

Method Supported Format Description 

Drag and drop. 
.ncex, .dxf, .dwg, .plt, .g code, 
and .nc 

Convenient 

Click . 
.dxf, .dwg, .plt, .g code, and .nc 

File modification is allowed. 
Saving after modification is 
required. The loaded file 
will be saved in .ncex 
format. 

Click . 
.ncex 

File modification is allowed. 
Saving after modification is 
required. 

File > Open and Load 
(in the menu bar) 

.ncex, .dxf, .dwg, .plt, .g 
code, .nc 

File modification is not 
allowed. Shape parameters 
will be loaded in the 
software automatically. 

File > Load History 
File (in the menu bar) 

.ncex, .dxf, .dwg, .plt, .g 
code, .nc 

Helps quickly locate 
previously loaded files. File 
modification is not allowed. 
Shape parameters will be 
loaded in the software 
automatically. 

 

Based on your requirements, follow the steps below to load a file: 

 Drag and drop: 
Click and hold a .ncex/.dxf/.dwg/.plt/.g code/.nc file and release the mouse pointer 
over the software drawing area. 

 To modify an existing file: Click  or  to open/import the file. 
Note: Saving is required after modification. 
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 No need to modify the file: In the menu bar, go to File > Open and Load, the shape 
parameters will be loaded in the software. 

 Import files by clicking : 

In the file button bar, click . In the displayed Open dialog box, select the 
target file. 

 Open files by clicking : 

In the file button bar, click . In the displayed Open dialog box, select the 
target file. 

 Open and Load: 
In the menu bar, go to File > Open and Load. In the displayed Open dialog box, 
select the target file. 

 Load history files: 
In the menu bar, go to File > Load History File. In the displayed History File 
dialog box, select the target file. 

Related task 

To unload the loaded file, go to File > Unload in the menu bar. 

6.2 Draw Shapes 
The system supports drawing of Polyline, Line, Arc, Ellipse arc, Circle, Ellipse, 
Rectangle, Polygon, and Text. The system also provides a shape gallery that stores 
common shapes for direct use. 

Shape Use Method 

Polyline 
For details, see Draw a Polyline. 

Line 
For details, see Draw a Line. 

Arc 
For details, see Draw an Arc. 

Ellipse 
arc 

For details, see Draw an Ellipse Arc. 

Circle 
For details, see Draw a Circle. 

Ellipse 
For details, see Draw an Ellipse. 

Rectangle 
For details, see Draw a Rectangle. 

Polygon 
For details, see Draw a Polygon. 

Text 
For details, see Add Text. 
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Shape Use Method 

Gallery For details, see Use Gallery Shapes. 

 

The following section introduces how to select a shape tool and how to adjust the size of a 
shape. 

Use one of the following methods to select a shape tool: 

 In the drawing tool bar, click the icon of the target shape tool. 

 In the menu bar, click Draw and then select the name of the target shape tool. 
After selecting the target shape, follow the steps below to adjust the shape size or position: 

 Alter the X, Y, Z, W, and L values above the drawing area. 

 Move the mouse pointer over a corner point while pressing and holding the Shift 
key (the pointer becomes a double-sided arrow) and drag to adjust the shape size: 

 
 

6.2.1 Draw a Polyline 
A polyline is a single object composed of multiple straight lines or arcs. You can switch 
between straight lines and arcs. 

Follow the steps below to draw a polyline: 

1. In the drawing area, click the left mouse button where you want to start the shape. 
2. Optional: To draw a polyline composed of arcs, click the right mouse button and 

select Tangent Arc. 

 
A polyline is composed of straight lines by default. 

 
3. Click the left mouse button to select the next point and so on. 
4. To finish a polyline, click the right mouse button and select an option in the context 

menu based on your requirements: 
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o Confirm: The current point becomes the end point of the polyline, which 
remains open. 

o Close: The current point becomes the polyline end point, which will be 
connected to the start point with a straight line automatically and the polyline 
becomes a closed shape. 

o Cancel: Cancel all lines drawn. 

6.2.2 Draw a Line 
Follow the steps below to draw a line: 

1. In the drawing area, click the left mouse button where you want to start the shape. 
2. Click the left mouse button where you want to end the shape. 

6.2.3 Draw an Arc 
Follow the steps below to draw an arc: 

1. In the drawing area, click the left mouse button where you want the circle center. 
2. Click the left mouse button where you want the arc start point. The distance 

between the circle center and the start point will be the circle radius. 
3. Click the left mouse button where you want the arc end point. The default 

machining direction is anti-clockwise. 

6.2.4 Draw an Ellipse Arc 
Follow the steps below to draw an ellipse arc: 

1. In the drawing area, click the left mouse button where you want the center. 
2. Click the left mouse button where you want the arc start point and end point. The 

default machining direction is anti-clockwise. 

6.2.5 Draw a Circle 
Follow the steps below to draw a circle: 

1. In the drawing area, click the left mouse button where you want the circle center. 
2. Click the left mouse button to select a point to determine the circle radius. 

6.2.6 Draw an Ellipse 
Follow the steps below to draw an ellipse: 

1. In the drawing area, click the left mouse button where you want the center. 
2. Click the left mouse button to select two points, the distance from which to the 

center will be the ellipse's longest diameter and shortest diameter. 

6.2.7 Draw a Rectangle 
Follow the steps below to draw a rectangle: 

1. In the drawing area, click the left mouse button where you want the start point. 
2. Click the left mouse button where you want the end point. 

6.2.8 Draw a Polygon 
Follow the steps below to draw a polygon: 

1. In the drawing area, click the left mouse button where you want the center. 
2. Click the left mouse button where you want the end point. 
3. To change the number of edges, select the shape and change the value of the 

Edges field above the drawing area. 
The default edge number is 6. 

6.2.9 Add Text 
Follow the steps below to add text: 

1. Drag the mouse to create a rectangle text box. 
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2. Enter text in the box. 
3. Optional: To create line breaks, press Ctrl + Enter at the same time. 
4. Press Enter to finish text entering. 

6.2.10 Use Gallery Shapes 
Follow the steps below to use shapes in the gallery: 

1. In the drawing tool bar, click  to open the Gallery window: 

 
 

2. After a shape in the gallery is selected, you can see its preview below and set the 
parameters by double-clicking the target value. 

3. In the Path Position area, you can set the shape position with one of the following 
methods: 

o Select Fixed Position and enter values in the X and Y fields on the right; or 

 
The X and Y coordinates are those of the red point in the preview. 

 
o Select Set by Mouse and click OK. Close the Gallery window and click the 

left mouse button where you want the shape. 

6.3 Edit Shapes 
You can edit a shape as shown below: 

 Translate 

 Rotate 

 Chamfer 

 Mirror 

 Scale 

 Group and Break 

 Merge 
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 Explode 

 Break 

 Layers 

6.3.1 Translate 
Translating a shape means to move it in a straight direction/change its location 
coordinates instead of changing its size. 

Follow the steps below to translate a shape: 

1. Select the target shape. 
2. Use one of the following methods to translate the shape: 

o Click . Click the left mouse button in the drawing area to select a base 
point. Click the left mouse button on a workspace edge to select a second 
point. In the field between the two points, enter a distance value to move the 
shape. 

o In the menu bar, go to Object > Translate. Click any point in the drawing 
area. Click the left mouse button to select a target position. 

o Move the mouse pointer over the shape. Click and hold the left mouse button 
and move the shape. 

o Enter the target distance in the Move field below the drawing area and press 
Enter. Press ← / ↑ / ↓ / → keys to move the shape in the corresponding 
direction. 

6.3.2 Rotate 
Rotating a shape means to rotate the shape around a selected center point by a certain 
angle. 

Follow the steps below to rotate a shape: 

1. Select the target shape. 
2. Use one of the following methods to rotate the shape: 

o Follow the steps below to rotate the shape around a specific point: 
A. In the menu bar, go to Object > Rotate. 
B. Click the left mouse button to select the rotation center point. 
C. Move the mouse pointer to adjust the rotation angle. 
D. Click the left mouse button to confirm the rotation. 

o While pressing and holding Ctrl, move the mouse pointer over any of the 
four corner small rectangles, press and hold the left mouse button to rotate 
the shape. 

6.3.3 Chamfer 
Chamfering means to chamfer all angles smaller than 180°. Two chamfering modes are 
available: 

 Automatic chamfering: 
The system chamfers shapes that are selected and meet the conditions. 

 Manual chamfering: 
Select chamfering positions manually. 

Follow the steps below to add chamfered angles: 

1. Select the target shape. 
2. Use one of the following methods to open the Chamfer dialog box: 

o In the menu bar, go to Object > Chamfer. 
o Click the right mouse button, and select Chamfer. 
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3. Follow corresponding steps based on whether you choose to use automatic 
chamfering or manual chamfering. 

o Automatic chamfering: 
A. Enter the range of angles which you want to be chamfered in the Angle 
fields. Valid range: [0,180°] 
B. Enter the chamfering radius in the Radius field. 
C. Optional: To chamfer angles based on the fill/unfill property of the 
selected closed shape, tick Create Chamfer by Fill or Unfill. 
D. Click OK. The system chamfers angles that meet the conditions. 

o Manual chamfering: 
i. Enter the chamfering radius in the Radius field. 
ii. Optional: To chamfer angles based on the fill/unfill property of the 

selected closed shape, tick Create Chamfer by Fill or Unfill. 

iii. Click Set by Mouse. The mouse pointer becomes . 
iv. Left-click on angles which you want to be chamfered. 
v. To exit chamfering mode, click the right mouse button. 

6.3.4 Mirror 
The system supports two types of mirroring: 

 Mirror H (horizontal): The system mirrors the shape left part and right part along the 
vertical axis. 

 Mirror V (vertical): The system mirrors the shape upper part and lower part along 
the horizontal axis. 

Follow the steps below to mirror a shape: 

1. Select the target shape. 
2. In the menu bar, go to Object > Mirror > Mirror H/Mirror V. 

Examples of mirrored images are shown below: 

 Mirror H 
o Before 
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o After 

 
 

 Mirror V 
o Before 
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o After 

 
 

6.3.5 Scale 
Shape scaling means to enlarge or shrink the shape without changing its proportion. 

Follow the steps below to scale a shape: 

1. Select the target shape. 
2. Use one of the following methods to scale the shape: 

o Enter the scaling factor in the Scale field above the drawing area. Press 
Enter to confirm. 

o Go to Object > Scale in the menu bar: 
A. Click the left mouse button to select the scale center point. 
B. Click the left mouse button to select the target point. 
C. Move the mouse pointer to adjust the scaling factor. 
D. Click the left mouse button to confirm. 

6.3.6 Group and Break 
Grouping means to make multiple shapes belong to the same group. 

Breaking means to release the shapes from the group. 

Follow the steps below to group shapes: 

1. Select the target shapes. 
2. Use one of the following methods to group the shapes: 

 In the menu bar, go to Object > Group/Break > Group. 

 Click the Group button above the drawing area. 
Follow the steps below to break a group: 

1. Select the target group. 
2. Use one of the following methods to break the group: 

 In the menu bar, go to Object > Group/Break > Ungroup. 

 Click the Break button above the drawing area. 

6.3.7 Merge 
Merging means to joining unconnected shapes into a single shape. 

Only applicable to open shapes, non-text objects, and groups. 

Before merging shapes, it is recommended that you enable the catch function. For details, 
see Catch. 
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Follow the steps below to merge shapes: 

1. Select the target shapes. 
2. Use one of the following methods to open the Join dialog box: 

o In the drawing tool bar, click . 
o In the menu bar, go to Object > Merge. 
o Click the right mouse button and select Combine. 

 
 

3. Enter the tolerance value in the Tolerance field. 
The tolerance value needs to be the maximum distance between the shapes to be 
merged. 
Default tolerance range: [0.01, 10] mm. 

4. Select a merging priority: distance first (Dis First), length first (Len First), or 
direction first (Dir First). 
The priority strategy indicates that the system whether to merge the two shapes 
whose distance are the closet, length the longest, or direction the same first when 
there are three or more than three points that meets the tolerance requirement. 
Examples of merged shapes are shown below: 

o Before 

 
 

o After 
 Dis First 
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 Len First 

 
 

 Dir First 

 
 

5. Optional: To merge shapes in different layers, tick Join among Different Layers. 

6.3.8 Explode 
Exploding means to delete unnecessary lines and is often used in polyline shapes. 

Exploding can be used together with shape merging to correct drawing errors and ensure 
machining quality. 
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 Exploding shape groups equals to breaking/ungrouping the groups. 

 Exploding text objects equals to translating text into shape. 
Follow the steps below to explode a shape: 

1. Select the target shape. 
2. Use one of the following methods to explode a shape: 

o In the drawing tool bar, click . 
o In the menu bar, go to Object > Explode. 
o Click the right mouse button and select Explode. 

Examples of an exploded shape are shown below: 

 Before 

 
 

 After 

 
 

6.3.9 Break 
Breaking means to cut a shape into multiple polylines. The system supports two breaking 
methods: 

 Automatic breaking: The system breaks the selected shape based on the settings. 

 Manual breaking: Select the breaking positions manually. This method supports 
breaking for one shape at a time. 

Follow the steps below to break a shape: 

1. Select the target shape. 
2. Use one of the following methods to open the Break dialog box: 
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o In the drawing tool bar, click . 
o In the menu bar, go to Object > Break. 

 
 

3. Follow corresponding steps based on whether you choose to use automatic 
breaking or manual breaking. 

o Automatic breaking: 
A. Select Automatically. Enter the desired number and length of broken 

segments in the Counts and Length fields. 
B. Click OK. 

Examples of an automatically broken shape are shown below: 
Before 

 
 
After 

 
 

o Manual breaking: 
A. Select Manually. Enter the desired length of broken segments in the 

Length field. 
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B. Click OK. The mouse pointer becomes . 
C. Click the left mouse button to select the breaking positions. 
D. Click the right mouse button to confirm breaking. 

 
Examples of a manually broken shape are shown below: 
 
Before 

 
 
After 

 
 

6.3.10 Layers 
Layers are mainly used to distinguish different technics. Each layer can use different 
technic settings. Objects on the same layer (with the same color) use the same technic 
settings. For details about setting technic parameters, see Set Technic Parameters. 

The system supports 7 layers. 

The default layer is layer 0, the color of the shapes on this layer is deep blue. 

Follow the steps below to change the layer of a shape/shapes: 

1. Select the target shape(s). 
2. In the layers bar, click a numbered color/layer, the selected shape becomes the 

selected color/on the selected layer. 

6.4 Shape Editing Assistance 
This section introduces the following auxiliary functions for shape editing: 

 Select a Shape 
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 Adjust View 

 Catch 

 Measure 

6.4.1 Select a Shape 
After a shape is selected, its node numbers, feature points, and center point are shown. 

Follow the steps below to select a shape: 

1. In the drawing tool bar, click . 
2. Use one of the following methods to select a shape/shapes: 

 Click the target shapes while pressing Ctrl. 

 Press and hold the left mouse button to draw a box and select shapes: 
o When drawing a box from the upper left corner to the lower right corner, 

the shapes entirely within the box will be selected. 
 Before 

 
 

 After 

 
 

o When drawing a box from the lower right corner to the upper left corner, 
the shapes partially or entirely within the box will be selected. 

 Before 
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 After 

 
 

6.4.2 Adjust View 
This function only applies to the view and does not change the actual shape size or 
coordinates. You can: 

 Move View 

 Best View 

6.4.2.1 Move View 
Redefine the location of the shape in the window for clearer observation of the shape's 
different parts. 

Follow the steps below to move the view: 

Use one of the following methods to move the view: 

 Press and hold the mouse scroll wheel and move the mouse to the target position. 

 Use the "view move" function: 
a. Use one of the following methods to select the "view move" tool: 

 In the drawing tool bar, click . 
 In the menu bar, go to View > View move. 

b. Press and hold the left mouse button where you want the base point and 
move the mouse. Release the button in the target position. 
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c. Click the right mouse button or press Esc to exit "view move" mode. 

6.4.2.2 Best View 
In best view, the shapes are fully displayed in a way that suits the window. 

Follow the steps below to switch to best view: 

Use one of the following methods to switch to best view: 

 In the drawing tool bar, click . 

 In the menu bar, go to View > Best view. 

 Press the * key. 

6.4.3 Catch 
This function allows the system to locate shape feature points more accurately during 
shape drawing. 

When the mouse pointer approaches a feature point, the system can easily recognize it to 
accurately connect shapes as required. 

Follow the steps below to use the catch function: 

1. Use one of the following methods to open the Catch Options window: 

o In the file button bar, click . 
o In the menu bar, go to Draw > Catch Option. 
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2. Tick the target feature points and adjust the catching sensitivity by dragging the 
Catch Sensitivity slider. 
The higher the catching sensitivity, the easier it is for the system to capture the 
feature points. 

3. Use one of the following methods to enable the catch function: 

o In the file button bar, click . 
o In the menu bar, go to Draw > Catch. 

6.4.4 Measure 
This function supports measuring of the distance between any two points, X/Y-axis 
deviation, and X-axis positive angle. 

Follow the steps below to use the measuring function: 

1. In the drawing tool bar, click . 
2. Click the left mouse button to select the start point. 
3. Move the mouse pointer to the end point. The measuring result is displayed below 

the mouse pointer. 

6.5 Pre-processing 
Pre-processing of shapes before formal machining helps with a better machining result. 

The system supports pre-processing of a single shape, such as smoothing curves and 
reducing polylines, and batch pre-processing of shapes, such as instant processing. 

6.5.1 Smoothing Curve 
This function smoothens multiple polylines for smoother machining. 

Follow the steps below to smooth curves: 

Select the target shape and use one of the following methods to smooth it: 

 In the menu bar, go to Object > Smooth curve. 

 Click the right mouse button and select Smooth Curve. 
A message indicating curve smoothing success will be displayed. 

6.5.2 Reduce Polyline 
A polyline is a single object composed of multiple straight lines and curves and whose 
shape is controlled by nodes. 

Reducing a polyline means that the system automatically reduce the number of nodes as 
allowed by the tolerance to improve shape operation response speed. 

Follow the steps below to reduce the number of polyline nodes: 

1. Select the target polyline and use one of the following methods to open the 
Simplify Curve dialog box: 

o In the menu bar, go to Object > Reduce polyline. 
o Click the right mouse button and select Simplify Curve. 

2. Enter the tolerance value in the Tolerance field and click OK. 
A message indicating polyline reduction success will be displayed. 

6.5.3 Translate Text 
This function converts text into polylines for subsequent technic setting. 

Use the following method to convert text into polyline: 

Select the target text. In the menu bar, go to Object > Translate text. 
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6.5.4 Polyline to Circle 
This function converts closed polylines that are similar to circles into circles. 

Follow the steps below to use the function: 

1. Select the target shape and use one of the following methods to open the Polyline 
to Circle dialog box: 

o In the menu bar, go to Object > Trans to circle. 
o Click the right mouse button and select Polyline to circle. 

 
 

2. Enter values in the Tolerance and Relative Error fields. 
After conversion, a prompt will be displayed as shown below: 

 
 
Examples of a converted shape are shown below: 

 Before 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 54 / 97 
 

 
 

 After 

 
 

6.5.5 Edit Polylines 
The system supports editing of polylines, such as enlarging/shrinking, modifying the 
position of polyline nodes and altering the line segment length. 

Follow the steps below to edit polylines: 

1. After a polyline is selected, a node editing red box and node numbers are displayed. 
The red box indicates the node currently selected. 
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2. To select other nodes, click the +/- buttons or enter the node No. in the 
ChooseNode field above the drawing area. 

 
3. Follow corresponding steps based on your needs: 

o To enlarge or shrink a polyline, select the target polyline, enter the 
enlarging/shrinking factor in the Scale field above the drawing area and 
press Enter. 

o To change the width or height of a polyline, select the target polyline, enter 
values in the W or H field above the drawing area, and press Enter. 

o To change the position of the selected node, enter values in the X or Y field 
above the draw area, and press Enter. 
If the entered X and Y coordinates for a node are the same as those of the 
adjacent nodes, the modification does not take effect. 

o To alter the distance between the current node and the previous node, enter 
a value in the Length field above the drawing area, and press Enter. 

 
If the selected node is the end point of an tangent arc, the Length value is 
the arc radius and cannot be modified. 

 
6.5.6 Instant Processing 
The instant processing function includes common shape processing items for your 
selection to achieve better machining results. 

The instant processing options include Simplify Curve, Delete Overlap Lines, Join, 
Delete Dots, Delete Mini-Circles, Delete Mini-Curves, Intersection Trim, Polyline to 
Circle, Auto Set Fill/Unfill, etc. 

Follow the steps below to use the instant processing function: 

1. Select the target shape. Use one of the following methods to open the Instant Pre-
process dialog box: 

o In the menu bar, go to Object > Instant Processing. 
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o Click the right mouse button and select Instant Pre-process. 

 
 

2. Tick target options and set the parameters. 
3. Optional: If Apply when Importing is ticked, the system automatically runs the 

selected processing items when a file is imported. 
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7 Set Technic Parameters 
 Set Technic Parameters 

 Technic Parameter Description 

 Set Other Technic Parameters 

7.1 Set Basic Technic Parameters 
You can set the layer color, machining sequence, allowance, plate information, cutting 
type, and grinding type parameters differently for each technic. 

The system supports seven technics, including a custom technic. 

Descriptions of the technics are shown below: 

Technic Description 

Pot hole 
Only applicable to closed shapes, such as circles, ellipses, rectangles, 
polygon, etc. 

Front water 
The lower part of the drawing area is the front water area by default. Only 
applicable to open shapes, such as lines, arcs, ellipse arcs, polylines. 

Back water 
The upper part of the drawing area is the back water area by default. 
Only applicable to open shapes, such as lines, arcs, ellipse arcs, 
polylines. 

Outline 
Only applicable to closed shapes, such as circles, ellipses, rectangles, 
polygon, etc. 

Hole opener 
Vertical machining at the circle center and not related to the tool radius. 
Only applicable to circles. 

DrainTrough Applicable to lines and closed areas with the same height. 

Custom Applicable to close and open shapes. 

 

7.1.1 Set Pot Hole Parameters 
Follow the steps below to set pot hole parameters: 

1. Click  to open the Technics Parameter window: 
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2. In the Tech area, select a colored layer for the technic. 
3. Click the Technics type drop-down menu and select Pot hole. 

 
After a colored layer is selected for the technic, shapes on the layer becomes the 
selected color. 
Because the layers are mainly used to distinguish different technics, it is 
recommended that you assign different layers to different technics. 

 
4. Click the Sequence drop-down menu to select machining by Graphics or by Tools. 
5. Set the parameters in the Parameter area. For details, see Technic Parameter 

Description. 
6. Click the Cut type drop-down menu, select a cutting type, and set related 

parameters. For details, see Technic Parameter Description. 
o No select 
o Layered cut: Cutting layer by layer 
o Hole cut: Cutting after drilling a hole at the lead-in line start point 
o Screw Cutting: Slow spiral cutting of closed shapes. The Z axis goes down 

by the screw pitch each turn. 
7. Set the parameters in the Grind area and tick the Steps numbers to increase or 

decrease grinding steps. At most 5 grinding steps can be added. For details, see 
Technic Parameter Description. 

8. Click OK. 

7.1.2 Set Front Water Parameters 
Follow the steps below to set front water parameters: 

1. Click  to open the Technics Parameter window: 
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2. In the Tech area, select a colored layer for the technic. 
3. Click the Technics type drop-down menu and select Front water. 

 
After a colored layer is selected for the technic, shapes on the layer becomes the 
selected color. 
Because the layers are mainly used to distinguish different technics, it is 
recommended that you assign different layers to different technics. 

 
4. Click the Sequence drop-down menu to select machining by Graphics or by Tools. 
5. Set the parameters in the Parameter area. For details, see Technic Parameter 

Description. 
6. Click the Cut type drop-down menu, select a cutting type, and set related 

parameters. For details, see Technic Parameter Description. 
o No select 
o Layered cut: Cutting layer by layer 

7. Set the parameters in the Grind area and tick the Steps numbers to increase or 
decrease grinding steps. At most 5 grinding steps can be added. For details, see 
Technic Parameter Description. 

8. Click OK. 

7.1.3 Set Back Water Parameters 
Follow the steps below to set back water parameters: 

1. Click  to open the Technics Parameter window: 
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2. In the Tech area, select a colored layer for the technic. 
3. Click the Technics type drop-down menu and select Back water. 

 
After a colored layer is selected for the technic, shapes on the layer becomes the 
selected color. 
Because the layers are mainly used to distinguish different technics, it is 
recommended that you assign different layers to different technics. 

 
4. Click the Sequence drop-down menu to select machining by Graphics or by Tools. 
5. Set the parameters in the Parameter area. For details, see Technic Parameter 

Description. 
6. Set the parameters in the Grind area and tick the Steps numbers to increase or 

decrease grinding steps. At most 5 grinding steps can be added. For details, see 
Technic Parameter Description. 

 
If water-retaining bars are used for the back water-retaining area, set Thickness in 
the Grind area. 

 
7. Click OK. 

7.1.4 Set Outline Parameters 
Follow the steps below to set outline parameters: 

1. Click  to open the Technics Parameter window: 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 61 / 97 
 

 
 

2. In the Tech area, select a colored layer for the technic. 
3. Click the Technics type drop-down menu and select Outline. 

 
After a colored layer is selected for the technic, shapes on the layer becomes the 
selected color. 
Because the layers are mainly used to distinguish different technics, it is 
recommended that you assign different layers to different technics. 

 
4. Click the Sequence drop-down menu to select machining by Graphics or by Tools. 
5. Set the parameters in the Parameter area. For details, see Technic Parameter 

Description. 
6. Click the Cut type drop-down menu, select a cutting type, and set related 

parameters. For details, see Technic Parameter Description. 
o No select 
o Layered cut: Cutting layer by layer 
o Screw Cutting: Slow spiral cutting of closed shapes. The Z axis goes down 

by the screw pitch each turn. 
7. Set the parameters in the Grind area and tick the Steps numbers to increase or 

decrease grinding steps. At most 5 grinding steps can be added. For details, see 
Technic Parameter Description. 

8. Click OK. 

7.1.5 Set Hole Opener Parameters 
Follow the steps below to set hole opener parameters: 

1. Click  to open the Technics Parameter window: 
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2. In the Tech area, select a colored layer for the technic. 
3. Click the Technics type drop-down menu and select Hole opener. 

 
After a colored layer is selected for the technic, shapes on the layer becomes the 
selected color. 
Because the layers are mainly used to distinguish different technics, it is 
recommended that you assign different layers to different technics. 

 
4. Click the Sequence drop-down menu to select machining by Graphics or by Tools. 
5. Set the parameters in the Parameter and Param areas. For details, see Technic 

Parameter Description. 
6. Click OK. 

7.1.6 Set Custom Parameters 
Follow the steps below to set custom parameters: 

1. Click  to open the Technics Parameter window: 
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2. In the Tech area, select a colored layer for the technic. 
3. Click the Technics type drop-down menu and select Custom. 

 
After a colored layer is selected for the technic, shapes on the layer becomes the 
selected color. 
Because the layers are mainly used to distinguish different technics, it is 
recommended that you assign different layers to different technics. 

 
4. Click the Sequence drop-down menu to select machining by Graphics or by Tools. 
5. Set the parameters in the Parameter area. For details, see Technic Parameter 

Description. 
6. Click the Cut type drop-down menu, select a cutting type, and set related 

parameters. For details, see Technic Parameter Description. 
o No select 
o Layered cut: Cutting layer by layer 
o Hole cut: Cutting after drilling a hole at the lead-in line start point 

7. Set the parameters in the Grind area and tick the Steps numbers to increase or 
decrease grinding steps. At most 5 grinding steps can be added. For details, see 
Technic Parameter Description. 

 
Click the Side drop-down menu in the Grind area to select a machining side (Left 
Crc or Right Crc) based on the shape machining direction. 

 
8. Click OK. 
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7.1.7 Set DrainTrough Parameters 
Follow the steps below to set draintrough parameters: 

1. Click  to open the Technics Parameter window: 

 
 

2. In the Tech area, select a colored layer for the technic. 
3. Click the Technics type drop-down menu and select DrainTrough. 

 
After a colored layer is selected for the technic, shapes on the layer becomes the 
selected color. 
Because the layers are mainly used to distinguish different technics, it is 
recommended that you assign different layers to different technics. 

 
4. Click the Sequence drop-down menu to select machining by Graphics or by Tools. 
5. Set the parameters in the Parameter area. For details, see Technic Parameter 

Description. 
6. Click the Cut type drop-down menu in the Cut area, select a cutting type, and set 

related parameters. For details, see Technic Parameter Description. 
o No select 
o Line: The tool moves along the shape lines. 
o Area: The machining method is normally horizontal milling. It is similar to 

pocketing and applicable to closed areas, including irregular shapes. 
7. Set the parameters in the Grind area and tick the Steps numbers to increase or 

decrease grinding steps. At most 5 grinding steps can be added. For details, see 
Technic Parameter Description. 

8. Click OK. 

7.2 Technic Parameter Description 
Allowance 
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Indicates X-axis and Y-axis radial feeding allowance. 

The system will reserve distances accordingly on the machining side. 

Plate size parameters 

Include Plate length(X), Plate lengh(Y), and Thickness. Plate size is immediately shown 
in the drawing area. 

Set the plate size parameters based on the actual size because they affect the positions of 
the shapes. 

Z down tool point height 

The distance between the tool and the workpiece surface before lowering the tool. 

The Z axis travels from its highest point to this height at the G00 speed and travels at the Z 
Cut Spd for each tool after traveling lower than this height. 

The cutting point is the green dot in each shape. If a lead line is added, the tool cuts from 
the lead line start point. 

Dec dist and Dec rate 

Set the distance before and after the deceleration point during which the tool decelerates 
at the set decelerating rate. 

Actual feed rate within decelerating distance = Feed rate setting * Dec rate 

 
 
Cut depth 

The cutting depth from the Z-axis workpiece origin. 

Z Cut Spd 

The cutting speed from the Z-axis workpiece origin. 

Cut speed 

The tool radius is in direct proportion to the machining speed. 

Speed 

Indicates the grinding speed. 
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Spindle 

Indicates the spindle rotational speed during grinding. 

Amount and Times 

Amount indicates the total feed amount. 

One-time feed amount = Total feed amount/Feed times 

Layer Num and Last incise 

Layer Num indicates the tool feeding times during layered cutting. 

Last incise indicates the amount of last tool feed during layered cutting. 

One-time cutting depth for layers other than the bottom layer = (Cut Depth - Last Incise)/(Layer Num - 1) 

Two way 

Only applicable to open shapes. 

If Two way is ticked, the system executes the machining path back and forth. 

Commonly used in Front water, Back water, and Custom technics. 

Thickness 

Indicates the back water bar thickness. 

Steps 

A machining process can include multiple steps. 

Within a step, the cutting amount and tool do not change. 

Diameter 

Indicates the diameter of the tool used in the current step. 

Pitch of screw 

Indicates the Z-axis feed amount per turn during screw cutting. 

7.3 Set Other Technic Parameters 
The following parameters can be set for a technic: 

 Unfill and Fill 

 Scalpel Line 

 Set Workpiece Origin 

 Set Slow Spot 

 Set Machining Sequence 

 Set Machining Direction 

7.3.1 Unfill and Fill 
Unfill is used when the material inside the closed shape needs to be removed. Fill is used 
when the material inside the closed shape needs to be reserved. 

Follow the steps below to set unfill/fill parameters: 

1. Select the target shape(s). 
2. Use one of the following methods to select unfill/fill: 

o In the menu bar, go to Object > Unfill/Fill > Fill/Unfill/Auto Set Fill. 
If Auto Set Fill is selected, the system automatically determines whether to use fill 
or unfill. 

o Click the right mouse button, select Unfill/Fill, and select Unfill or Fill. 
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7.3.2 Scalpel Line 
The scalpel line is used to avoid the tool staying at the machining start point for too long 
and causing errors or workpiece damage for better machining accuracy. 

If only closed shapes are selected, functions only applicable to open shapes will be 
disabled and vice versa. 

Scalpel lines include lead-in lines and lead-out lines. 

 Lead-in line types: Line, Arc, and Hook. Hook lead-in lines are composed of 
connected arcs and straight lines. 

 Lead-out line types: Line and Arc. 
Follow the steps below to set scalpel line parameters: 

1. Select the target shape(s). 
2. Use one of the following methods to open the LeadLine dialog box: 

o In the drawing tool bar, click . 
o In the menu bar, go to Object > Scalpel Line. 
o Click the right mouse button and go to Lead Line > Set. 
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3. Set the parameters in the Lead-In and Lead-Out areas. 

Parameter definition may vary based on the scalpel line type: 
o Line 

 Angle: Formed by the scalpel line and the tangent line at the scalpel 
line and the shape's crossing point. 

 Length: The line length. 
o Arc 

 Angle: The central angle 
 Length: The arc length. 

o Hook 
 Radius: The arc radius 
 Length: Sum of the arc radius and straight line length. 

4. In the Seal area, tick Gap/Over to set the scalpel line seal. 
o Gap: Open lead lines. 
o Over: Closing lead lines. 

5. Use one of the following methods to set the scalpel line position: 
o Select Automatic Lead Position and tick Corner First or Edge First. 

 Corner First: Add a scalpel line at corners. 
 Edge First: Add a scalpel line on the longest edge. 

o Select Set by Universal(0~100) param and enter a percentage value in the 
field. 

o Click the Set by Mouse button. The mouse pointer becomes . Click on 
the shape edges to select the scalpel line position. Click the right mouse 
button or press Esc to exit. 

6. Optional: In the Options area, you can tick Retain Position, Change Leads Type 
or Retain Leads Type, Change Position. 

7. Click OK. 
Related tasks 

 To delete a scalpel line, select the target shape, click the right mouse button, and 
go to Clear > Lead Line. 

 To modify a scalpel line, select the target shape, click the right mouse button, and 
go to Lead Line > Start Point. Follow corresponding steps based on your needs: 

o To modify the position of the scalpel line but not its angle or length, click the 
left mouse button on the target position. 

o To re-draw a straight lead-in line, click the left mouse button outside the 
shape and then click the left mouse button on a shape edge. 

7.3.3 Set Workpiece Origin 
The workpiece origin is the zero point of the workpiece coordinate system. It is selected 
normally under considerations of programming and size conversion convenience, and 
small machining errors. The position of the workpiece origin can be changed. 

Before starting machining, ensure that the workpiece origin is located on the workpiece. 

Follow the steps below to set the workpiece origin: 

1. Use one of the following methods to determine the position of the drawing origin: 
o Left-click and hold on the intersection of the horizontal and vertical rulers. 

Drag it to the target position. 
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o In the drawing tool bar, click  to open the Set Drawing Origin dialog box: 

 
 
Use one of the following methods to set the position of the drawing origin: 

 Select from the system options: 
A. Select one from Top Left, Top Center, Top Right, etc. 
B. Click OK. 

 Select a position by mouse: 
A. Click the Set by Mouse button. The mouse pointer becomes 

. 
It is recommended that you enable the capture function first 
before setting the drawing origin position by mouse. 

B. Click the left mouse button on the target position. 
C. Click the right mouse button to exit. 

2. In the machine control area, click X+/X-/Y+/Y- to move the X axis or Y axis to the 
target position. 

3. In the operation button area, click  to open the Clear Setting dialog box: 

 
 

4. Click X Clear/Y Clear/XY Clear to set the X-axis, Y-axis, or both X-axis and Y-axis 
coordinates of the current position to 0. 

5. Click Close. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 70 / 97 
 

7.3.4 Set Slow Spot 
This function is used to add slow spots/deceleration points before and after the target 
position to make the system execute machining at the deceleration rate. 

Only applicable to the back water technic. 

Follow the steps below to set slow spots: 

1. Select the target shape. Use one of the following methods to use the slow spot tool: 

o In the drawing tool bar, click . 
o In the menu bar, go to Object > Slow Spot. 

2. Click the left mouse button at the target position to add a slow spot. 
If  is displayed, a slow spot has been added in the position. 

7.3.5 Set Machining Sequence 
This function is used to assign the machining sequence for the shapes in the file. 

Click  or go to View > Show Order in the menu bar to show the machining sequence of 
all the shapes in the file. 

You can set the machining sequence with the following two methods: 

 By tool No.: A tool is changed after it has finished all its path to save tool change 
time and improve machining efficiency. 

o Ascending by the cutting tool No.: Generates all cutting paths (including the 
hole opener technic). 

o Ascending by the grinding tool No.: Generates all grinding paths. 
For details, see description about the parameters in the Cut area and Grind area in 
Set Technic Parameters. 

 By shape: The system supports the following methods of setting custom machining 
sequence: 

o Auto Set Order 
o Manual Set Order 
o Specify Order 
o Order List 
o Manual Draw 
o Sort to Top or Sort to Bottom 
o Group Set Order 

7.3.5.1 Auto Set Order 
The system sets the machining sequence based on the parameter setting. 

Follow the steps below to use the auto set function: 

1. Select the target shapes. 
2. Use one of the following methods to open the Sort dialog box: 

o In the menu bar, go to Object > Mach Order > Auto Set Order. 
o Click the right mouse button and go to Mach Order > Auto Sorting. 
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3. Select a sort strategy. 
4. Optional: Set parameters in the Advanced Options area. 

o Divide Grid: A directional sequencing strategy. 
 AutoSet: The system automatically divides the shapes into grids 

based on the their distance and number. 
 Fixed Value: Shapes whose distance from each other is smaller than 

the Distance value will be divided into the same grid. 
o Color: The shapes are sequenced based on the layer sequence. Only 

applicable to nested shapes inside components. 
o Small Objects First: Puts shapes whose sizes are smaller than the set 

value first. Only applicable to nested shapes inside components. 
o Sort in Group: Shapes inside different groups may have different machining 

sequence based on the selected sort strategy. 
o Allow Reverse Direction: Allow the shape machining sequence to be 

reversed. 
5. Click OK. 

7.3.5.2 Manual Set Order 
Manually specify the machining sequence for the shapes. 

Follow the steps below to use the manual set function: 

1. Select the target shapes. Use one of the following methods to enable manual set: 
o In the menu bar, go to Object > Mach Order > Manual Set Order. 
o Click the right mouse button and go to Mach Order > Manual Sorting. 

The mouse pointer becomes  and the current machining sequence is displayed. 
2. Click the shape you want to be processed first. 
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The mouse pointer becomes  and the number beside the shape becomes 1. 
The numbers beside other shapes become 2, 3,... respectively in the original 
sequence. 
To reset a shape's sequence, click the right mouse button and select Previous 
Order. 

3. Click the rest of the shapes in the desired machining sequence. 
4. Use one of the following methods to exit manual sequencing: 

o Click the right mouse button and select Exit. 
o Press Esc. 

7.3.5.3 Specify Order 
Manually specify the machining sequence for the selected single shape. 

Follow the steps below to use the specifying order function: 

1. Select the target shape. 
2. Use one of the following methods to open the Specify Order Separately dialog box: 

o In the menu bar, go to Object > Mach Order > Specify Order. 
o Click the right mouse button and go to Mach Order > Specify Order 

Separately. 
3. Enter the sequence number in the Number [1,n] field. 

“N” represents the maximum sequence number in the current file. 
4. Click OK. 

7.3.5.4 Order List 
This function is used to set the machining sequence based on the shape number. 

Follow the steps below to use the order list function: 

1. Select the target shape(s). 
2. Use one of the following methods to open the Order List dialog box: 

o In the menu bar, go to Object > Mach Order > Order List. 
o Click the right mouse button and go to Mach Order > Order List. 

 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 73 / 97 
 

 
3. Tick one or multiple shape numbers and use one of the following methods to adjust 

their sequence: 
o Click Move Up/Move Down. 
o Double-click an unselected shape number to move it down. 

4. Click OK. 

7.3.5.5 Manual Draw 
This function is used to manually exchange the shape sequence numbers. 

Follow the steps below to use the manual draw function: 

1. Use one of the following methods to enable manual draw: 
o In the menu bar, go to Object > Mach Order > Manual Draw. 
o Click the right mouse button and go to Mach Order > Manual Draw Sort. 

The shapes are connected by green dotted lines. 
2. Move the mouse pointer to a shape edge. Click and hold the mouse left button and 

drag it to another shape's edge until a green highlight line between the two shapes 
is displayed. Release the mouse button to change their machining sequence (as 
indicated by the direction of the arrow on the connecting green dotted line). 

7.3.5.6 Sort to Top or Sort to Bottom 
This function is used to make the selected single shape be processed first or last. 

Follow the steps below to use the sort to top/bottom function: 

1. Select the target shape. 
2. Use one of the following methods to use the function: 

o In the menu bar, go to Object > Mach Order > Sort to Top/Sort to Bottom. 
o Click the right mouse button and go to Mach Order > Sort To the Top/Sort 

To the Bottom. 
The machining sequence of the selected shape becomes the first/last. 

7.3.5.7 Group Set Order 
This function is used to set the machining sequence for shapes inside a group. 

Prerequisite: 

The target shapes are in the same group. 

Follow the steps below to use the function: 

1. Select the target shapes. 
2. Use one of the following methods to open the Sort dialog box: 

o In the menu bar, go to Object > Mach Order > Group Set Order. 
o Click the right mouse button and go to Mach Order > Group Sort. 

For details, see operations in Auto Set Order. 

7.3.5.8 Set Machining Direction 
This function is used to display or change the machining direction of the path. Two 
methods are available: 

 Reverse: Reverses the current machining direction. 

 Set: Smart change of the machining direction of the closed shapes 
Follow the steps below to change the machining direction: 

1. Select the target shape(s). 
2. Use one of the following methods to show the machining direction: 
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o In the menu bar, go to View > Show Dir. 

o In the drawing tool bar, click . 
3. Use one of the following methods to change the machining direction: 

o To reverse the machining direction: 
 In the menu bar, go to Object > Mach Direction > Reverse, or 
 Click the right mouse button and go to Mach Direction > Reverse. 

o To select a machining direction: 
A. Use one of the following methods to open the Direction dialog box: 

 In the menu bar, go to Object > Mach Direction > Set. 
 Click the right mouse button and go to Mach Direction > Set. 

 
 

B. Select a machining direction among the system options. 
C. Optional: To keep the machining direction of the shapes inside groups 
unchanged, tick Skip Groups. 
D. Click OK. 
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8 Go to Mechanical Origin 
The mechanical origin is the origin of the mechanical coordinate system of the machine. 
The mechanical coordinate system of a piece of machine is fixed and determined before 
out of factory. 

The purpose of making the axes go to the mechanical origin is to synchronize the system 
mechanical coordinate system with the machine mechanical coordinate system. The axes 
must go to the mechanical origin first before machining. 

Prerequisite: 

There are no servo motor alarms. 

Follow the steps below to make an axis or all axes go to the mechanical origin: 

1. In the operation button area, click  to open the Homing dialog box: 
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This dialog box is opened by default when the software is started. Unselect Dialog 
box pops up when cycle starts to stop showing it automatically when the software 
is started. 

 
2. Use one of the following methods to make an axis or all axes go to the mechanical 

origin: 
o Click All Axes to make all the axes go to the mechanical origin in the 

sequence of Z axis, X axis, and Y axis. 
o Click X, Y, or Z to make the X axis, Y axis, or Z axis go to the mechanical 

origin. 

 
For safety considerations, it is recommended that you make the Z axis go to 
the mechanical origin first. 

 
o Click DirectSet to set the current point as the mechanical origin. 

 
Applicable when you are sure that the machine coordinates are correct (The 
mechanical coordinates of the current point are the same as the machine's 
actual mechanical coordinates, and the software was not closed nor does the 
machine have servo motor alarms or other exception that can cause 
machine position errors). 

 

After an axis has gone to the mechanical origin successfully,  will be displayed before it 
in the machine control area. 
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9 Set Tool Parameters 
You can use the software to manage the tools effectively to improve machining efficiency. 

Tool parameters include 

 Set Tool Compensation Parameters 

 Set Wear Compensation Parameters 

 Set Tool Offset Parameters 

9.1 Set Tool Compensation Parameters 
Used to compensate the difference between the actual tool position and the programmed 
tool position. 

After the tool compensation parameters are set, if a tool is replaced, you only need to 
change the tool compensation value instead of modifying the machining program. 

Follow the steps below to set tool compensation parameters: 

1. In the menu bar, go to System > Global Parameters. In the Param window, click 
the first drop-down menu in the lower-left corner and select Manufacturer. Set the 
parameters Enable Tool Length Compensation and Enable Tool Radius 
Compensation to Yes. 

2. In the menu bar, go to Operation > Tool setting. 
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3. In the Tool Compensation window, double-click the target field. Enter a value in 

the input box. Descriptions of the parameters are shown below: 

Parameter Description 

Tool No. 
The tool sequential number. At most 31 tools are 
supported. 

Diameter Used for radius compensation. 

Diameter Wear Used for worn diameter compensation. 

Wear Ratio 
Indicates the worn diameter amount every time the tool 
processes 1-meter materials. Applicable to real-time 
wear compensation. 

Offset(X)/(Y)/(Z) 
Indicates the tool offset value. Manually enter a value in 
the field or use a tool sensor. 

 
4. Click OK. 

9.2 Set Wear Compensation Parameters 
If the wear compensation function is enabled, the system makes real-time adjustment of 
the tool feed amount based on the wear amount. 

Wear compensation is not needed during cutting. 

If the wear compensation function is enabled, the tool radius will have a certain deviation. 
You need to check to see if such deviation causes any intervention. 

Follow the steps below to set wear compensation parameters: 

1. In the menu bar, go to System > Global Parameters. In the Param window, 
change the status of Enable Tool Radius Compensation and Enable wear 
compensation based on the description below: 

Enable Tool 
Radius 

Compensation 

Enable Wear 
Compensation 

Description 

No Yes 
Real-time tool wear compensation is 
disabled. 

Yes No 
Real-time tool wear compensation is 
disabled. Tool compensation for 
general cases is used. 

Yes Yes 

If tool diameter compensation 
commands G41/G42 is not included in 
the machining program, real-time tool 
wear compensation will not be 
enabled. 

 
If the wear compensation conditions are not met, a prompt indicating that the tool 
diameter is too short will be displayed. 

2. Set the parameter Enable Tool Length Compensation based on the actual 
situation. 
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3. Load programs with G41/G42/G40 tool diameter compensation commands. 

4. Click  to start machining. 
o After the G41/G42 commands are processed, real-time tool diameter wear 

compensation is enabled. 
o After the G40 command is processed, real-time tool wear compensation is 

disabled. 
5. Click  or  to save the file in the original path or another path. 

The system determines if wear compensation will be enabled based on the wear 
ratio. If the wear ratio is not 0, wear compensation will be enabled. 

9.3 Set Tool Offset Parameters 
Used to make sure that the tools are lowered to the correct height during machining. 

You can set the tool offset parameters with the following methods: 

 Enter the Z-axis offset value. 

 Use the current point Z-axis mechanical coordinate as the Z-axis offset. 

 Use the tool calibration result as the Z-axis offset. 
Follow the steps below to enter the offset value: 

1. In the menu bar, go to Operation > Tool setting to open the Tool Compensation 
window: 
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2. Double-click the Offset(Z) field of the target tool and enter the Z-axis offset value in 
the input box. 

3. Click OK. 
Follow the steps below to use the current Z-axis mechanical coordinate as the Z-axis 
offset: 

1. In the menu bar, go to Operation > Tool calibration setting to open the Tool 
calibration setting window: 

 
 

2. Click Set Offset Z in the Manual Set Offset area to set the Z-axis offset of the 
current tool to the current Z-axis mechanical coordinate. 

Follow the steps below to use the tool calibration result as the Z-axis offset: 

1. In the menu bar, go to Operation > Tool calibration setting to open the Tool 
calibration setting window: 
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2. Optional: If Decrease Movable Tool Sensor Thickness Or Not is ticked, the Z-
axis offset value will be the calibration result minus the tool sensor thickness. 

3. Execute tool calibration based on your needs: 
o To execute tool change and calibration for multiple tools: 

A. Tick the target tool numbers in the One-click calibrate area. 
B. Click OK. The system will write the calibration results of the selected tools 
into their Z-axis tool offset. 

o To execute tool calibration at a fixed point on the machine for a single tool: 
A. Control the X axis and Y axis to move above the tool sensor. Click XY 
Position. 
B. Enter a value in the Fixed calibrate Z field. 
C. Click Fixed calibrate. 
The system will write the calibration result of the selected tool into its Z-axis 
tool offset. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 82 / 97 
 

 

10 Set Edge Finding and Centering Parameters 
Used to calculate the plate angle relative to the mechanical coordinate system and rotate 
the workpiece coordinate system in the program to create a new one accordingly. The 
purpose is to avoid inaccurate positioning of the plate due to large plate size or weight and 
improve plate usage rate. 

Two methods are available: 

 Automatic Edge Finding and Centering 

 Manual Edge Finding and Centering 

10.1 Automatic Edge Finding and Centering 
The system supports automatic edge finding and centering for rectangles and ellipses. 

The sensor moves (along with the spindle) during automatic edge finding and 
centering as shown below: 

1. It moves down from the start point P to point A. 
2. It receives the edge finding signal, retreats for a certain distance, and moves 

horizontally to point B. 
3. It receives signal at point B and goes back to point P. The rotation angle can be 

determined. 
4. It moves left to point C and down to point A. 
5. It moves from point A to point A′. The Y-axis mechanical coordinate of point O′ Y 

can be determined. 
6. It moves from point A′ to point C, and then to point C′. The X-axis mechanical 

coordinate of point O′ X can be determined. After the edge finding process is 
complete, the system automatically starts machining. 

 

 

Follow the steps below to use the automatic edge finding and centering function: 

1. In the drawing tool bar, click  to open the Edge seeking and centering 
window: 
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2. Set the parameters in the Auto Rectangle and Auto Ellipse pages based on the 
shape. The description of the parameters is shown below: 

Parameter Description 

X The plate X-axis length. 

Y The plate Y-axis length. 

Speed The edge finding feed speed. 

AB 
Horizontal 
Dis 

Horizontal distance between point A and point B. The value 
should be smaller than the X field value 

Back 
Distance 

The retreating distance after receiving the edging finding 
signal at point A. 

Set Z-Height 
and Set Start 
Point P 

Click the axis direction buttons to move the axes. Move the 
Z axis to the safe height. It is recommended to set point P 
left to the center point at an angle smaller than 45 degrees. 

 
3. Click Edge Seeking to start edge finding simulation. 
4. Optional: To make the cutter return to point O′ after automatic edge finding, tick 

Back to O′ after seeking. 

5. Click  to close the Edge seeking and centering window. 
Related tasks: 

To start machining directly after automatic edge finding: 

1. In the port button area, click RectangleSeek/Ellipse Seek. 
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2. In the machining operation area, click . 

10.2 Manual Edge Finding and Centering 
The system supports manual edge finding and centering for rectangles and ellipses. 

The principle for manual edge finding and centering is shown below: 

Mark point A, B, C, D, and E on the work piece. Manually control the cutter to move to the 
five points to record their coordinates into the software. Click Calculate to make the 
system calculate the rotation angle and the mechanical coordinates of point O′. 

 

Follow the steps below to set manual edge finding and centering parameters: 

1. In the drawing tool bar, click  to open the Edge seeking and centering dialog 
box: 

 
 

2. Click the Manual Rectangle or Manual Ellipse tab based on the shape. The 
Manual Rectangle screen is shown below as an example: 
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3. Click the X or Y direction buttons (X+, X-, Y+, Y-) to move the  in the drawing 
area to the target position for point A/B/C/D/E. 

4. Click the corresponding Set Point A/Set Point B/Set Point C/Set Point D/Set 
Point E button. 

5. Click Calculate. The rotation angle and X-axis and Y-axis mechanical coordinates 
of point O′ are displayed in the window. 

6. Optional: To make the cutter go to the position of point O′, click Back to O′. 

7. Click  to close the Edge seeking and centering window. 
Related tasks: 

To start machining directly after manual edge finding: 

1. In the port button area, click Manual Seek. 

2. In the machining operation area, click . 
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11 Machining Methods and Statistics 
The system supports multiple machining methods and viewing of machining statistics: 

 Simulation 

 Machining Wizard 

 Selective Machining 

 Advanced Machining 

 Machining by Commands 

 View Machining Statistics 

11.1 Simulation 
Simulation is used to check to see if the machining area and tool path are proper before 
formal machining. 

Follow the steps below to use simulation: 

1. In the operation button area, click Simulation to make it highlighted in green. 

2. In the machining operation area, click  to start simulation. 

11.2 Machining Wizard 
The machining wizard is used to generate machining path automatically. The system 
supports different shapes in the Cir. Contour, Cir. Pocket, Rect. Contour, Rect. Pocket, 
and Screw Comp Wizard screen. 

Follow the steps below to use machining wizard: 

1. Follow corresponding steps based on the shape. 
o For circle edges, circle pockets, rectangle edges, rectangle pockets, and 

screws: 
A. In the menu bar, go to Program > Machining Wizard to open the Wizard 
window: 
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B. Click the Cir. Contour, Cir. Pocket, Rect. Contour, Rect. Pocket, or 
Screw Comp Wizard tab based on your needs. Set related parameters as 
indicated by the left figure. 
C. Click Execute. The system starts machining. 

o For rectangle basins and ellipse basins: 

A. In the drawing tool bar, click  to open the Processing Wizard window: 
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B. Click the Rectangle Basin or Ellipse Basin tab based on your needs. Set 
related parameters as indicated by the figure. Descriptions of the parameters 
are shown below: 

 Parameters in the Basin shape area: 

Parameter Description 

Long side a The length of the workpiece. 

Short side b The width of the workpiece. 

Thickness h 
The height/thickness of the 
workpiece. 

Chamfer r 
The radius of the workpiece corner 
(when r=0, the workpiece is a 
rectangle). 

 
 Lead line parameters: 

Parameter Description 

Line Straight lead lines. 

Arc Arc lead lines. 

Angle e and Length d The lead line angle and length. 

 
 Technic parameters 

 Tick desired technic items (Hole, Cutting, Coarse, etc.) 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 89 / 97 
 

 Set the tool number, tool feed, depth, cut speed, machining 
speed and spindle speed parameters. 

 The tool is fed by the PerToolFeed amount every time until it 
reaches the Depth value. 

 The PerToolFeed values for Coarse, Forming, Fine, and 
Polish technics are the tool horizontal feed amount, which are 
different from that for the Cutting technic. 

2. After the parameters are set, click Load to save the file to the local path. The 
machining path will be displayed in the drawing area. 

3. In the machining operation area, click  to start machining. 

 
Machining path: The cutter goes to the middle point of edge a from the lead-in line, goes 
along the machining path clockwise once and then goes out from the middle point of edge 
a along the lead-out line. 

 

11.3 Selective Machining 
This function is used to select the program lines you want to be executed. The system only 
executes the selected lines. 

Prerequisite: 

The target program file is loaded into the software. 

Follow the steps below to use the selective machining function: 

1. In the menu bar, go to Advanced > Selective Machining to open the Selective 
MC dialog box: 

 
 

2. Enter values in the Start Row and End Row fields. 
3. Optional: To change the starting row and ending row number, click Reset. The 

Start Row and End Row will be restored to their default values. 
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The default starting row is the first row and the default ending row is the last row. 

 
4. Click OK. 

5. In the machining operation area, click . A prompt will be displayed, as 
shown below: 

 
 

6. Click Yes. 

11.4 Advanced Machining 
This function is used to create shape array and rotate or mirror a shape. 

 A shape array is created by copying a shape along the rectangular matrix. 

 Rotating a shape is to rotate it around a certain point by a certain degree. 

 Mirroring a shape is to create its symmetrical shape over the X axis or Y axis. 
Follow the steps below to use the advanced machining functions: 

1. In the menu bar, go to Advanced > AdvAuto to open the AdvAuto window: 
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2. Follow corresponding steps based on your needs. 
o Array 

A. In the Array area, click the Array Mode drop-down menu. Select Rectangular 
Array. B. Set the Rows, Columns, Row Space R, and Column Space C 
parameters. 

o Rotation 
A. In the Mirror & Rotate area, click the Machining Mode drop-down menu. Select 
CW 90°, CW 180°, or CCW 90°. B. Enter the X and Y coordinates of the rotation 
center in the Rotate Center X and Rotate Center Y fields. 

o Mirroring 
A. In the Mirror & Rotate area, click the Machining Mode drop-down menu. Select 
Mirroring by X or Mirroring by Y. B. Tick Mirror. C. Optional: To adjust the 
position of the mirrored shape, adjust the Eccentricity L value. 

 
The default array mode or machining mode is Convention, which means no array, 
rotation, or mirroring. 
Array settings and rotation/mirroring settings can be applied at the same time. 

 
3. Click OK. 
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4. In the machining operation area, click . A prompt will be displayed, as 
shown below: 

 
 

5. Click Yes to start machining. 

11.5 Machining by Commands 
The system supports entry and execution of at most 8 simple commands to achieve quick 
movement or simple machining tasks. 

Follow the steps below to enter and execute machining commands: 

1. In the operation button area, click  to open the MDI dialog box: 
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2. Enter commands in the fields. Use ";" for line switching. 
3. Click Execute behind the command box. The system executes the commands in 

the box. 

11.6 Machining Statistics 
You can check the machining statistics automatically collected to create better machining 
plans and avoid machine collision. 

Follow the steps below to check machining statistics: 

1. In the menu bar, go to Program > Machining Statistics. 

 
 

2. In the Statistics window, you can check the machining file name, machining 
duration, cutting duration, cycle number, machining progress, movement range, 
machining range, and tool travel length. 



上海维宏电子科技股份有限公司 
SHANGHAI WEIHONG ELECTRONIC TECHNOLOGY CO., LTD. 

 

 94 / 97 
 

 

12 Case Example 
12.1 Quick Start 
Follow the steps below to start machining with the NcStudio Phoenix Stone Machining 
Center software: 

1. Load the machining program. 
2. Make the axes go to the mechanical origin. 
3. Run machining simulation. 

4. In the machining operation area, click  to start machining. 

12.2 Cutting Workpiece Outline 
Follow the steps below to cut the outline of a workpiece: 

1. Load a program file or draw the shape in the software drawing area. For details, see 
Load Machining Files or Draw Shapes. 
The default layer is layer 0. The color of shapes on it is deep blue. 
The following figure shows an example of a loaded program: 

 
 

2. Select the shape. Click TechSet in the layers bar. In the Technics Parameter 
window, click the Technics type drop-down menu and select Outline. Set the other 
parameters for the outline technic. For details, see Set Outline Parameters. 

3. Optional: Set other technic parameters based on your needs: 
o Scalpel Line 
o Set Workpiece Origin 
o Set Slow Spot 
o Set Machining Sequence 
o Set Machining Direction 

4. Go to Mechanical Origin 
5. Set tool compensation and offset parameters based on your needs: 

o Set Tool Compensation Parameters 
o Set Wear Compensation Parameters 
o Set Tool Offset Parameters 
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6. Optional: Set edge seeking and centering parameters. For details, see Set Edge 
Finding and Centering Parameters. After setting edge seeking and centering 
parameters, click the corresponding button (RectangleSeek, Ellipse Seek, or 
Manual Seek) in the port button area. 

7. Execute machining simulation to inspect the axis movement. 

8. In the machining operation area, click  to start machining. 
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Legal Notices 
The term “Software Product” includes all copies of the licensed software and its 
documentation. This license agreement is a legal agreement between You (either an 
individual, a legal entity or any affiliated companies or other entities) and Weihong 
Electronic Technology Co., Ltd. (hereinafter referred to as Weihong Company). By 
installing, copying, or otherwise using the Software Product, you agree to be bound by the 
terms and conditions of this license. Unless otherwise stated in this agreement, you shall 
not use, copy, revise, rent, or transfer the Software Product or any part of the Software 
Product for any other purposes. 

Requirements of Use 
1. You may install for use one copy of the Software Product on a single machine; 
2. You may make a copy of the Software Product for archive or backup purposes and 

the copy is to be used on this machine only; 
3. You may transfer the Software Product and the license agreement to a third party, 

provided that the third party accepts the terms and conditions stated in this 
agreement, with prior express permission from Weihong Company; 

4. When transfer confirmed, you shall transfer all the copies of the original documents 
and the supplementary documents to the third party or destroy all the copies un-
transferred; 

5. You can use the Software Product on a network server or intranet server only if it is 
stipulated in explicit terms that you are allowed to use the Software Product on a 
network server or intranet server, or you have purchased license for each node and 
terminal using the Software Product; 

6. You may NOT sublicense, assign or transfer the license agreement; 
7. You may NOT or direct any third party to reverse engineer, decompile or 

disassemble the Software Product; 
8. You may NOT copy or transfer the Software Product or any part of the Software 

Product unless otherwise expressly stated in this agreement; 
9. The license agreement shall be terminated automatically upon you transfer the 

Software Product or copies of all or part of the Software Product to a third party. 

Intellectual Property Rights Notice 
The Software Product and all intellectual property rights therein (including but not limited to 
any all copyrights, patents, trademarks, and publicity rights) are owned by Weihong 
Company. The Software Product is protected for Weihong Company on the basis of 
Chinese copyright law and international treaty provisions as well as on the basis of other 
laws and agreements regarding intellectual property. You are not allowed to remove the 
copyright statement made in the Software Product, and guarantee that you shall copy the 
copyright statement in all copies of the Software Product or of any part of the Software 
Product. You are obliged to stop any form of illegal copying of the Software Product and 
accompanying materials. 

Weihong Company can update the Software Product at any time. You can pay real-time 
attention to Weihong Company's official website. 

Termination 
This license may be terminated by Weihong Company at any time once you violate any 
terms or conditions made in this agreement. Once the license is terminated, you are 
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obliged to destroy all the copies of the Software Product or return them to Weihong 
Company. 

Now, we affirm that you have already read through this agreement and understood it 
thoroughly and agreed to comply with all of the terms and conditions of this agreement 
strictly. 

Weihong Electronic Technology Co., Ltd. 
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